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Chapter 1 
Welcome to Lavenir CAM Software 

Lavenir produces a complete line of accurate, high-speed CAM software for PCB data. This CAM 
Software User’s Guide documents the features of the entire Lavenir CAM software product line. 

Lavenir CAM Software Feature Comparison 
Whatever your requirements, Lavenir has a CAM package to meet your needs. This chart compares the 
features of ViewMate, ViewMaster, ViewMaster PRO, and CAMMaster. 

 ViewMate ViewMaster ViewMaster PRO CAMMaster 

PCB Data Import üü üü üü üü 

PCB Data Export — üü üü üü 

PCB Data Viewing üü üü üü üü 

PCB Data Editing üü üü üü üü 

Aperture File Conversion Wizard üü üü üü üü 

Printing üü üü üü üü 

Vector DRC — üü üü üü 

Raster DRC — — — üü 

Fill Polygons  — — üü üü 

Add Venting Patterns  — — üü üü 

Calculate Copper Area  — — üü üü 

Delete Non-Functional Pads  — — üü üü 

Snap Data to Padmaster  — — üü üü 

Clip Silkscreen Traces  — — üü üü 

Generate Soldermask Data  — — üü üü 

Generate Filleting  — — üü üü 

Generate Outlines  — — üü üü 

Generate Polygon Contours  — — üü üü 

Generate Centroid Data  — — üü üü 

Compare Layers  — — üü üü 

Correct Trace/Pad Overlap  — — üü üü 

Convert Drawn Pads to Flashed — — üü üü 

Vector Netlist Extraction — — üü üü 

Raster Netlist Extraction — — — üü 

Netlist Conversion — — — üü 

Netlist Comparison — — — üü 

Sax Basic Scripting — — — üü 

Automatic Panelization — — — üü 
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ViewMate 
ViewMate is Lavenir’s free Gerber viewer. ViewMate allows you to import, view and print PCB and 
aperture data. ViewMate also allows you to experiment with editing features. ViewMate does not save 
or export data, but it is an excellent viewer, and the printing feature is useful. You are welcome to keep 
and use ViewMate as you wish. Make as many copies as you want, spread it around to others in your 
company, and give it to the people you do business with. You can download free copies of ViewMate 
from the Lavenir Web Site at http://www.lavenir.com.   

ViewMaster 
ViewMaster is Lavenir’s basic PCB editing program. With ViewMaster, you can import, export, view, 
and edit PCB and aperture data. You can also print a plot and run a Vector Design Rule Check. 

Importing PCB Files 
You set language and format options for importing data:  

• Gerber data of multiple formats. 

• NC Drill data specified as Excellon, Wessel, or Sieb & Meyer. 

• HPGL 

Once the format is specified, you can import up to 99 layers of incoming data. 

Importing Aperture and Tool Code Information 
You can import an aperture list from over 100 CAD/CAM systems, or you can manually set up a new 
aperture list.  

The Aperture File Wizard allows you to show ViewMaster how to interpret and import a previously 
unsupported aperture list type and save a method for importing that same type in the future.  

ViewMaster supports up to 2000 D Code definitions within the range of D10 to D9999 and supports 
255 Tool Code definitions. You can design and use custom apertures, combine aperture lists 
automatically and save D Code and Tool Code information in Lavenir environment files. 

Exporting Data 
ViewMaster exports PCB files in several formats: 

• Basic Gerber 

• Gerber Extended 

• MDA Autoplot 

• NC Drill 

Visible layers can be output as individual files or combined into one. 

The program can also export a text Report file with statistical information about the loaded files. 
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Viewing and Inspecting Data 
ViewMaster presents a graphical view of any combination of the 99 layers for your inspection.  

• Control which layers are visible to work with at any given time. Layers can be positive or 
negative, paint, or scratch. You control the colors and visibility. 

• Traces and pads can be shown true to width and filled or as zero-width or outlined. Turn pad 
or trace visibility on or off. Show pads and traces in contrasting colors or the same color.  

• The zoom range, 0.001 to 7000, lets you inspect the data as closely as you wish.  

• Automatic inspection features allow you to go directly to each element of a specified class. 

• The Design Rule Checking operation highlights design rules violations on screen. 

• Reporting functions provide statistical information about the loaded files. 

Controlling Layers of Data 
ViewMaster can load up to 99 layers of plot data. Using the Layers Table, the Layers Toolbar, and the 
Current Element Toolbar you can control: 

• Active Layer(s)  

• Layer Number  

• Board Layer  

• Layer Name  

• Layer Type  

• Layer Element Counts  

• Layer Color  

• Layer Visibility  

• Positive and Negative Layers  

• Paint and Scratch Layers  

You can also edit entire Layers: 

• Delete Layers  

• Swap Layers  

• Transfer Layers  

• Replicate Layers  
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Editing Data 
You can correct design rule violations and prepare data for output with the editing features in 
ViewMaster.  

• Insert pads, traces, elbows, rectangles, circles, and arcs.  

• Select individual traces and pads, or groups of elements of specific types on single or multiple 
layers, or whole layers. The selection for editing can be as complex or as simple as you wish. 

• Selected elements can be deleted, moved, copied, transferred, replicated, scaled, mirrored, 
rotated, transcoded, and step/repeated.  

• Entire layers can easily be deleted, moved, aligned, transferred, replicated, swapped, rotated, 
mirrored, scaled, and step/repeated.  

• Insert text at any size and angle.  

• Change shape, size, and D Code of elements. ViewMaster can transcode, rotate, swell, and 
scale D Codes, individually or as a group. Design and use custom apertures.  

Automatic Editing Features 
In addition to its manual editing features, ViewMaster has several automatic editing features. 

• Convert 360-degree Arcs to Quadrant Arcs 

• Convert Arcs to Chords 

• Sort Data into Optimized Order 

Printing 
ViewMaster can print a file on a color or black and white printer. You have a choice of print ranges, 
color schemes, and scale factors. 

Running a Vector Design Rule Check 
ViewMaster can run a Vector Design Rule Check to verify the accuracy and manufacturability of plot 
data using Lavenir’s established Vector DRC routine. 

The Vector DRC routine examines individual layers, layer sets, portions of layers selected with the 
reference frame, or the entire database, depending on how you set it up. The program reports design 
rule violations in a text file and flags the errors in the Viewing Area for easy identification. You can 
check for the following design rule violations: 

• Air Gap Violations: Trace-to-Trace Air Gap, Trace-to-Pad Air Gap, Pad-to-Pad Air Gap. 

• Soldermask Gap Violations: Pad-to-Mask Clearance, Trace-to-Mask Clearance. 

• Annular Ring Violations: Drill-to-Outer Layers, Drill-to-Other Layers, Drill-to-Plane Layers, 
Drill-to-Thermal. 

• Pad-to-Pad Contact Violations.  

• Centerline Disconnection Violations.  

• Unterminated Trace Violations.  
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• Trace Intersection Violations.  

• Outline-to-Copper Area Violations.  

Generating a Distance Histogram 
ViewMaster can generate a Distance Histogram report to verify the manufacturability of plot data and 
aid in the quoting process. The Distance Histogram report is a text file that includes the number of 
times each particular clearance occurs in the plot. 

ViewMaster PRO 
With ViewMaster PRO, you have all of the importing, exporting, viewing, editing, printing and DRC 
features of ViewMaster. And in addition, you can perform many automated CAM operations and 
extract netlists with a Vector Netlist Extraction routine. 

Using Specialized CAM Tools 
ViewMaster PRO contains specialized CAM tools that automate the most frequently demanded CAM 
operations.  

• Fill Polygons  

• Add Venting Patterns  

• Calculate Copper Area  

• Delete Non-Functional Pads  

• Snap Data to Padmaster  

• Clip Silkscreen Traces  

• Generate Soldermask Data  

• Generate Filleting  

• Generate Outlines  

• Generate Polygon Contours  

• Generate Centroid Data  

• Compare Layers  

• Correct Trace/Pad Overlap  

• Convert Drawn Pads to Flashed 

Extracting Vector Netlists 
ViewMaster PRO can extract a variety of netlist data from multiple layers of Gerber and NC drill data 
using Lavenir’s established Vector Netlist Extraction. 

In addition to extracting netlist data, the program can import netlist data into the current job and has 
features for viewing and inspecting netlist data. 
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CAMMaster 
With CAMMaster, you have all of the importing, exporting, viewing, editing, printing and Vector 
DRC features of ViewMaster. And you have all of the automated CAM operations and Vector Netlist 
Extraction features of ViewMaster PRO. In addition, you can extract netlists with a Raster Netlist 
Extraction Routine, convert foreign netlist formats to Lavenir netlist formats with a Netlist Conversion 
Routine, and compare two netlists with a Netlist Comparison feature. You can also run DRC checks 
with a Raster DCR Routine, and you can automate your operations with powerful Scripting 
capabilities.  

Running a Raster Design Rule Check 
CAMMaster can run a Design Rule Check to verify the accuracy and manufacturability of plot data 
using the new Raster DRC.  

Both the Vector and Raster DRC routines examine individual layers, layer sets, portions of layers 
selected with the reference frame, or the entire database, depending on how you set it up. The program 
reports design rule violations in a text file and flags the errors in the Viewing Area for easy 
identification. You can check for the following design rule violations: 

• Air Gap Violations: Trace-to-Trace Air Gap, Trace-to-Pad Air Gap, Pad-to-Pad Air Gap. 

• Soldermask Gap Violations: Pad-to-Mask Clearance, Trace-to-Mask Clearance. 

• Annular Ring Violations: Drill-to-Outer Layers, Drill-to-Other Layers, Drill-to-Plane Layers, 
Drill-to-Thermal. 

• Outline-to-Copper Area Violations.  

• Silkscreen on Pad Violations. 

Extracting Raster Netlists 
CAMMaster can extract a variety of netlist data from multiple layers of Gerber and NC drill data using 
the new Raster Netlist Extraction.  

In addition to extracting netlist data, the program can import netlist data into the current job and has 
features for viewing and inspecting netlist data. 

Converting Netlist Data Formats 
CAMMaster can convert a variety of netlist data formats into Lavenir Format 2 or Format 4 (.F02 or 
.F04) files so that the files can be imported into CAMMaster and other Lavenir programs such as 
FixMaster and ProbeMaster.  

Comparing Netlist Files 
CAMMaster can compare two netlist files and display the differences graphically. You designate a 
Reference Net and a Net Under Test, and CAMMaster finds the differences. This allows you to make 
comparisons between CAD generated netlists and Gerber extracted netlists, or between pre- and post-
editing Gerber extracted netlists.  
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Scripting Automatic Functions 
CAMMaster incorporates the Sax Basic Editor and Sax Basic Language, a full-featured development 
environment and programming language. Using this system, the Lavenir Macro Recorder and the 
CAMMaster Automation object library of properties and methods, you can: 

• Capture macros and record them as Sax Basic scripts which you can save, edit and execute. 

• Program using variables, math, and flow control.  

• Use CAMMaster functions in your scripts and have your scripts get and use values from the 
currently loaded job file.  

• Use the functions of other programs whose methods and properties are available to you as 
automation object libraries. 
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Download Software Updates 
Lavenir will be making updated versions of the software and Help files available to customers who 
have a current maintenance agreement or warranty. You can download the current software updates 
from the Lavenir Premier Support Web site.  

To Download Software Updates: 
1. Have your User Name and Password ready before logging on to the Lavenir Premier Web 

Site. Your User Name and Password are printed on your User Password Letter. If you do not 
know your User Name and Password, call Lavenir at (925) 680-7400. 

2. Go to the Lavenir Web Site at http://www.lavenir.com. 

3. On the Site Map, click on Premier Support. 

4. On the User Name and Password dialog, enter your User Name and Password. 

5. Click on Software Library. 

6. Follow the instructions to download the <Program Name> SETUP.EXE update file to your 
system. 

7. Double-click on the downloaded the <Program Name>  SETUP.EXE file on your system 
and follow the setup instructions. 

Send Us Your Comments 
Lavenir is committed to continuous improvement. Your constructive comments on the software will 
help us to correct problems and improve features.  

• Please e-mail your comments and suggestions regarding Lavenir Software to  
feedback@lavenir.com.  

• Visit the Lavenir Web Site at  
http://www.lavenir.com.  

• You can reach Lavenir between the hours of 8am and 5pm Pacific Time at  
(925) 680-7400  

• Lavenir is located at 
2440 Estand Way 
Pleasant Hill, CA 94523 
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Lavenir Technical Support 
Contact Lavenir Customer support with questions about Lavenir hardware and software or to arrange 
for training or maintenance. 

You can reach Lavenir Technical Support by: 

• Telephone: (925) 680-7400 between the hours of 8 AM and 5 PM Pacific Standard Time. 

• E-Mail: support@lavenir.com.  

• Web Site: http://www.lavenir.com  

• Lavenir Technology is located at: 
2440 Estand Way 
Pleasant Hill, CA 94523 



Lavenir CAM Software User’s Guide 

20 

About this User’s Guide 
This Lavenir CAM Software User’s Guide provides information about how to use ViewMate, 
ViewMaster, ViewMaster PRO and CAMMaster. 

To indicate which documented features are available in which programs, the User’s Guide uses the 
following system of icons: 

 
A feature that has the icons above is available in all four products. 

 
A feature that has the icons above is available in CAMMaster, ViewMaster PRO, and ViewMaster, but 
the feature is not available in ViewMate. 

 
A feature that has the icons above is available in CAMMaster, and ViewMaster PRO, but the feature is 
not available in ViewMaster or ViewMate. 

 
A feature that has the icons above is available in CAMMaster, but the feature is not available in 
ViewMaster PRO, ViewMaster or ViewMate. 

Other icons are used to indicate supplemental information: 

  This icon indicates a hotkey that can be used instead of a menu command.  

  This icon indicates a toolbar button that can be used instead of a menu command. 

  This icon indicates a special note or warning about a feature.  

  This icon indicates a tip on how to handle an operation more efficiently. 

Menu commands are in bold, and cascading menus are separated by a hyphen (-). For instance, an 
instruction that says to click on File-Import-Gerber means to click on the File menu, then go to the 
Import cascade menu, and then to click on the Gerber cascade menu. 

Key commands can be unmodified by the Shift or Ctrl keys. For instance, to align the cursor to an 
element, you would be instructed to press A, which means to press the A key on the keyboard without 
pressing Ctrl or Shift.  

And key commands can also be modified by the Shift or Ctrl keys. For instance, to align the cursor to 
an element and query the element’s properties, you would be instructed to press Shift+A, which means 
to hold down the Shift key and press the A key. 
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Chapter 2 
File Operations 

The program Opens and Saves native format Job Files (.BIN) and can Import other file types into the 
open Job File and Export other file types from the Job File. 

Job File (.BIN) 
The Job File (.BIN) is the native file format for the Lavenir View Series of PCB editors and contains 
all information regarding the current state of the database and program settings. The Job File is a 
binary file that stores plot data for all loaded layers, layer configuration, aperture information, shape 
data, and menu parameters. Instead of reloading aperture and plot data files, and resetting menu 
configurations, you save work in progress in a Job File and then later open the Job File to restore the 
entire job and resume work. The Job File is the only file type that the program opens and saves with 
the Open and Save commands. However the program can Import other file types into the open Job File 
and Export other file types from the Job File. 

Many of the commands for handling job files can be accessed using the Main Toolbar.  

 

Main Toolbar 

To Display the Main Toolbar: 
Ø On the View menu, look at Toolbars-Main. 

• If Main has a checkmark next to it, then the Main Toolbar is displayed. 

• If Main does not have a checkmark next to it, then the Main Toolbar is not displayed. 

To change the display of the Main Toolbar, click Main. 
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Start a New Job 

 
The New command creates a new Job File that has nothing in it and is ready to have other files 
imported into it or to have data inserted into it. The program can only have one Job File open at a time; 
so, if a different Job File is already open when you start a new Job File, then the program prompts you 
to save and close the existing Job File before starting the new Job File. 

To Start a New Job File: 
Ø On to the File menu, click New.  

 Ctrl+N 

  

 When you first start the program, the program opens with a new, empty Job File. 

Open a Job File 

 
The Open command opens a previously saved Job File. The program can only have one Job File open 
at a time; so, if a different Job File is already open when you open another Job File, then the program 
prompts you to save and close the existing Job File before opening the new Job File. 

To Open a Job File: 
1. On the File menu, click Open.  

2. In the Look in box, click the drive, folder, or network location that contains the Job File. 

3. In the folder list, double-click folders until you open the folder that contains the Job File you 
want. 

4. Double-click the Job File. 

 Ctrl+O 

  

 To open a Job File you've used recently, click the file name on the Recent Files List at the 
bottom of the File menu. 

 You can also Drag and Drop Job Files into the program. 
You can also Import a Job File, which is different than Opening a Job File. 
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Save the Job File 

 
Saving a Job File stores all information regarding the current state of the database and program settings 
in a Job File (.BIN) so that the information can be restored later when you open the file. As new 
capabilities have been added to the software, new versions of the Job File have been created to save 
information not previously used by the software (i.e., netlist information and step and repeat blocks).  

To Save a New, Unnamed Job File: 
1. If you want to include netlist information that was extracted with the Raster Netlist routine in 

the saved file, go to File-Save Options-Include Net Info. If the menu shows a check mark 
next to Include Net Info, then netlist information will be saved. If the menu does not show a 
check mark, then the netlist information will not be saved in the file. Clicking the menu 
switches the feature on and off. 

 The Job File only saves netlist information equivalent to a Lavenir Format 2 (.F02) file. 
It does not save the trace information or internal layer information that is present in a 
Lavenir Format 4 (.F04) file. So if you extract a netlist using Raster Netlist Extraction 
and want to export an .F04 file, do it before saving and closing the Job File. 

 Job Files that include netlist information cannot be opened by Lavenir DOS software or 
by Lavenir Windows software older than version 5.0. 

2. If you want to include coded step and repeat blocks in the saved file, go to File-Save 
Options-Step and Repeat Blocks. If the menu shows a check mark next to Step and Repeat 
Blocks, then coded step and repeat blocks present in the database will be saved as coded step 
and repeat blocks. If the menu does not show a check mark, then coded step and repeat blocks 
present in the database will be converted to copied elements. Clicking the menu switches the 
feature on and off. 

 Job Files that include coded step and repeat blocks cannot be opened by Lavenir DOS 
software or by Lavenir Windows CAM software older than version 6.0 or by Pulsar 
firmware older than version 3.4. 

3. If you want to save the file at high resolution (.001 mil English or .01 micron metric), go to 
File-Save Options-High Resolution. If the menu shows a check mark next to High 
resolution, then the file will be saved with a resolution of  .001 mil English or .01 micron 
metric. If the menu does not show a check mark, then the file will be saved with a resolution 
of  .1 mil English or 1micron metric. Clicking the menu switches the feature on and off. 

 Job Files saved at high resolution cannot be opened by Lavenir DOS software or by 
Lavenir Windows CAM software older than version 6.0.28 or by Pulsar firmware older 
than version 3.8. 

4. On the File menu, click Save.  
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5. To save the Job File in a different folder, click a different drive in the Save in box, or double-
click a different folder in the folder list. 

To save the Job File in a new folder, click Create New Folder. 

6. In the File name box, type a name for the Job File. 

 Ctrl+S 

  

To Save Work in Progress: 
When you have work in progress that you want to save in case of power failure or because you need to 
shut down the program, you can save it under the current file name and overwrite the original Job File. 

Ø To save the open Job File under the current file name, go to the File menu, and click Save.  

As long as the Job File already has a name and location, the program saves the file without further 
prompts. 

 Ctrl+S 

  

 The Save command uses the same settings as those used the last time the file was saved. You 
can check the options for including netlist information and coded step and repeat blocks on 
the File menu under Save Options. 

 If you want to save a temporary version of the file you are working on so that you have the 
option to undo large edits, use a Milestone file.  
If you want to discard all changes to a Job File and restore to the last saved version of the 
file, use the Revert To Saved command. 
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To Save a Copy of a Job File: 
1. If you want to include netlist information that was extracted with the Raster Netlist routine in 

the saved file, go to File-Save Options-Include Net Info. If there is a check mark next to 
Include Net Info, then netlist information will be saved. If there is no check mark, then the 
netlist information will not be saved. Clicking the menu switches the feature on and off. 

 The Job File only saves netlist information equivalent to a Lavenir Format 2 (.F02) file. 
It does not save the trace information or internal layer information that is present in a 
Lavenir Format 4 (.F04) file. So if you extract a netlist using Raster Netlist Extraction 
and want to export an .F04 file, do it before saving and closing the Job File. 

 Job Files that include netlist information cannot be opened by Lavenir DOS software or 
by Lavenir Windows CAM software older than version 5.0. 

2. If you want to include coded step and repeat blocks in the saved file, go to File-Save 
Options-Step and Repeat Blocks. If the menu shows a check mark next to Step and Repeat 
Blocks, then coded step and repeat blocks present in the database will be saved as coded step 
and repeat blocks. If the menu does not show a check mark, then coded step and repeat blocks 
present in the database will be converted to copied elements. Clicking the menu switches the 
feature on and off. 

 Job Files that include coded step and repeat blocks cannot be opened by Lavenir DOS 
software or by Lavenir Windows CAM software older than version 6.0 or by Pulsar 
firmware older than version 3.4. 

3. If you want to save the file at high resolution (.001 mil English or .01 micron metric), go to 
File-Save Options-High Resolution. If the menu shows a check mark next to High 
resolution, then the file will be saved with a resolution of  .001 mil English or .01 micron 
metric. If the menu does not show a check mark, then the file will be saved with a resolution 
of  .1 mil English or 1micron metric. Clicking the menu switches the feature on and off. 

 Job Files saved at high resolution cannot be opened by Lavenir DOS software or by 
Lavenir Windows CAM software older than version 6.0.28 or by Pulsar firmware older 
than version 3.8. 

4. On the File menu, click Save As.  

5. To save the copy in a different folder, click a different drive in the Save in box, or double-
click a different folder in the folder list. 

To save the copy in a new folder, click Create New Folder. 

6. In the File name box, type a name for the copy. 
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Close a Job File 

 
The program can have one and only one Job File open at a time; so, closing the current Job File 
without opening another one is the same as exiting the program. The Open and New commands 
automatically close the current Job File; so, if a different Job File is already open when you open 
another Job File, then the program prompts you to save and close the existing Job File before opening 
the new Job File. 

To Close a Job File: 
1. On the File menu, click Exit.  

Closing a Job File does not save the Job File. If you have changed the file since the last time it was 
saved, the program prompts if you want to save the changes before closing. 

2. If prompted whether to save the file, click Yes or No. 

 If you have made a bad mistake in your editing since the last time you saved and you 
want to go back to your saved version, you can close the file without saving and then 
open the saved version. Or you can use the Revert to Saved command, which does the 
same thing automatically. 

Revert to a Saved Job File 

 
The Revert To Saved command allows you to discard all changes to a Job File and restore to the last 
saved version of the file. 

To Revert to a Saved Job File: 
Ø To revert to a saved Job File, go to the File menu, and click Revert to Saved.  

 If you want to save a temporary version of the file you are working on so that you have the 
option to undo large edits, use a Milestone file.  
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Import a Job File 

 
Importing a Job File is different than Opening a Job File in several ways: 

• An Imported Job File is merged into the current Job File. It is not opened on its own, under its 
own file name, and with no other data present the way an Opened file is. 

• An Imported job can be offset in the layer stack from the original way it was saved. If there is 
already data present in the layers of the Job File database when the new job is imported, the 
data in overlapping layers is merged into the existing layers, and the existing layer settings are 
maintained. Data imported into empty layers retains the layer settings of the imported job 
(i.e., layer name, color, etc.). 

• An imported job can be offset in the X and Y dimensions from the original way it was saved. 

To Import a Job File: 
1. On the File menu, click Import-Job.  

2. In the Look in box, click the drive, folder, or network location that contains the Job File. 

3. In the folder list, double-click folders until you open the folder that contains the Job File you 
want. 

4. Click the Job File so that it is selected. 

5. Click Options. 

6. If you want to offset the imported Job File in the layer stack from the original way it was 
saved, enter the first layer where you want the imported Job File to begin merging into the 
database in the Layers Start At field. 

7. Select where you want the imported Job File’s origin to be located. 

• Absolute (0,0): The imported Job File’s absolute origin is located at the open file’s 
absolute origin. 

• At X, Y: The imported Job File’s absolute origin is offset by the X and Y amount from 
the open file’s absolute origin. 

8. On the Import Job Options dialog, click OK. 

9. On the Import Job File dialog, click Open. 

 You can also Drag and Drop files into the program. 
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Import Files into the Job 
Imported files are merged into the current Job File. To get Gerber, Drill, HPGL, aperture or netlist files 
into the job, use the Import commands, not the Open command. You can also import another Job File 
into the current Job File. 

Drag-and-Drop File Import 

 
The simplest method for importing files into a Job File or for opening a Job File is to drag and drop the 
file into the program. The program attempts to guess the format of the file and import it.  

To Drag and Drop Files into the Program: 
1. Open the Lavenir program and a file browser such as Windows Explorer or My Computer 

so that they are side by side on the desktop. 

2. In the file browser, select the files that you want to drag into the Lavenir program: 

• Click on a file to select a single file. 

• Shift+Click to add files to the selection. 

• Ctrl+Click to remove files from the selection. 

• Drag across a range of files to select the whole range of files. 

3. Click on the selected files(s), hold down the mouse, and drag the selected file(s) over to the 
Lavenir program. 

4. Release the mouse button where you want to drop the files: 

• Job (.BIN) Files: To import a job, drop it on the Layers Toolbar on the layer where you 
want it imported. To open the job, drop it on the viewing area. 

• Gerber Files: Drop Gerber files on the Layers Toolbar on the layer where you want them 
imported. 

• Drill Files: Drop Drill files on the Layers Toolbar on the layer where you want them 
imported. 

• Aperture Files: Drop Aperture files on the Layers Toolbar. It does not matter which 
layer. 

• Netlist Files: Drop Netlist files on the Layers Toolbar. It does not matter which layer; the 
netlist file has its own layer definitions. 

• HPGL Files: Drop HPGL files on the Layers Toolbar on the layer where you want them 
imported. 

The program attempts to guess the format of the files and import them. If there is not format 
information in the files themselves, the program uses the data format, file interpretation, auto 
features, and other options that were used the last time a file of the given format was imported. 
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Import Basic Gerber 
The program imports several formats of Gerber data, including Basic Gerber, Gerber Extended and 
MDA Autoplot. Each format has format options and may have additional import options. In addition 
there are several options for simultaneously importing and merging associated aperture data along with 
the imported Gerber. 

Gerber Data Format Options 

 

Gerber Data Format Tab 

The following are Gerber Data Format options on the Data Format tab of the Gerber Import and Export 
dialogs: 

Left of Decimal: The number of digits in the data file to the left of the implied decimal point. 

Right of Decimal: The number of digits in the data file to the right of the implied decimal point. 

Omit Zeros 

• Trailing: Trailing zeros are omitted.  

• Leading: Leading zeros are omitted. 
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Position Coordinates 

• Incremental: Position coordinates are incremental (coordinates are relative to the last 
position). 

• Absolute: Position coordinates are absolute (coordinates are relative to the absolute 
origin). 

Data Units 

• English: Units are in inches.  

• Metric: Units are in metric. 

Data Code 

• ASCII: The file is an ASCII text file. 

• EBCDIC: The file is in EBCDIC 

• EIA: The file is in EIA. 

Arc Interpretation 

• Quadrant: Arcs are Quadrant arcs. 

• 360-degree: Arcs are 360-degree arcs. 
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Gerber File Interpretation Options 

 

Gerber File Interpretation Tab 

The following are Gerber File Interpretation options on the File Interpretation tab of the Gerber Import 
dialog. Different systems that use Gerber data interpret the following commands and situations 
differently, so this is where you tell the program how you want these commands handled when 
importing your files: 

D03 Commands 

• Modal: D03 Commands are modal.  

• Non-Modal: D03 Commands are non-modal. 

D04 – D09 Apertures: The Gerber specification reserves D04 – D09 as unused and begins 
aperture definitions with D10. This option tells the program what to do if the file contains D04 – 
D09. 

• Illegal: D04 – D09 apertures are illegal. This option complies with the specification. If 
the system encounters D04 – D09 apertures on import, the apertures are not imported into 
the Job File. 
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• Allowed: D04 – D09 apertures are allowed. Some systems output apertures for D04 – 
D09 even thought this violates the Gerber specification, and this option allows the 
program to read those files as they were output. 

Isolated D01 (no X, Y, I or J in block): D01 commands should have a coordinate position to 
indicate where the draw ends. This option tells the program what to do if the file contains D01 
commands without coordinates. 

• Treat as Zero-Length: Isolated D01 commands are considered to be zero-length draws.  

• Ignore: Isolated D01 commands are ignored. 

Zero-Length Draws: D01 commands should have a different ending coordinate position the 
beginning coordinate position. This option tells the program what to do if the file contains D01 
commands with the same beginning and ending coordinates. 

• Make Pads: Zero-Length Draws are made into pads. 

• Ignore: Zero-Length Draws are ignored.  

End of Block Characters 

• * or $: The end of a block is indicated by * or $. 

• CR or LF: The end of a block is indicated by CR or LF. 

RS274X AM Positive Rotation: The Gerber Extended specifications for the positive rotation 
direction for the Aperture Macro (AM) command have changed from clockwise to 
counterclockwise, so there is some ambiguity in what to do with an AM rotation command. This 
option tells the program what direction is indicated by a positive AM rotation command. 

• Counterclockwise: RS274X AM Positive Rotation is Counterclockwise. This matches 
the most recent specification. 

• Clockwise: RS274X AM Positive Rotation is Clockwise. This matches previous 
specifications. 
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Gerber Auto Feature Options 

 

Gerber Auto Feature Tab 

The following are automatic file-loading options on the Auto Features tab of the Gerber Import 
dialogs. 

• Autoload Apertures: When you use the Autoload Apertures option while importing Gerber 
files, the program searches the directory for aperture files that have the same prefix and 
attempts to load the aperture information simultaneously. If the option is not used, then the 
Gerber files are imported and the aperture files need to be imported separately.  

The option is only relevant for Basic Gerber files that have a separate aperture file for each Gerber 
file, not for Gerber Extended and MDA Autoplot, which contain aperture information in the 
Gerber file itself. 

In addition to being convenient, it is important that you use the Autoload Apertures feature if you 
are using the Autotranscode D Code Conflicts option below to merge aperture information for 
Basic Gerber files. 
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A similar command on the Import Apertures dialog is Autoload Gerber, which is set during the 
Import Apertures procedure. 

• All Aperture Files Use the Same Units: This option tells the system that all aperture files 
have the same units as the first aperture file. This is useful if you are using the Autoload 
Apertures option above to load multiple aperture files and you want to avoid being prompted 
for units for each file. 

• Gerber Units Same as Aperture File: This feature automatically sets the units of the Gerber 
file to the units specified in the associated aperture file imported with the Autoload Apertures 
option above and converts the aperture units to match, if needed. For instance, if an aperture 
file included information that the Gerber file was in English units, and the apertures were in 
metric units, then the aperture list would be translated into English units, and the Gerber 
would be imported in English units. 

• Autotranscode D Codes: When you use the Autotranscode D Code Conflicts option while 
importing Gerber files, then as the files are imported, the program automatically transcodes 
elements with D Codes that have conflicting definitions in different files. If the Autotranscode 
D Code Conflicts option is not used, the last loaded conflicting D Code overwrites the 
previous conflicting definition.  

In order for Autotranscode to work, the Gerber file must be imported with the aperture 
information. This means that the option is relevant when importing Gerber Extended and MDA 
Autoplot, which contain aperture information, or when importing Basic Gerber using the 
Autoload Apertures option above. 
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Import Basic Gerber Files into the Job Using the Import Command 

 
The Import command allows you to pick multiple Gerber files simultaneously and import them into the 
current Job File. 

To Import Basic Gerber Files into the Job Using the Import Command: 
1. Set the first active, visible layer to which you want to read in Gerber Data. See Select from the 

Active Layers on page 152. 

2. On the Files Menu, click Import-Gerber. 

 

Import Gerber Dialog 

3. In the Look in box, click the drive, folder, or network location that contains the Gerber Files. 

4. In the folder list, double-click folders until you open the folder that contains the Gerber Files 
you want. 

5. Click on the files that you want. You can select as many as you want using Shift+Click and 
Ctrl+Click to add or remove from the selection. 

6. Click Options. 

7. On the Data Format tab, set the Data Format options. See Gerber Data Format Options on 
page 29. 
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8. On the File Interpretation tab, set the File Interpretation options. See Gerber File 
Interpretation Options on page 31. 

9. On the Auto Features Tab, set the Automatic File Loading options. See Gerber Auto Feature 
Options on page 33. 

10. On the Options dialog, click OK. 

11. Click Open. 

The program imports the specified Basic Gerber Files and loads them into the Job File beginning 
with the first active, visible layer. 

 F2 = Opens the Import Gerber dialog 
F3 = Set the Gerber Import options only, without importing 

 You can also Drag and Drop files into the program. 

Import Basic Gerber into the Job Using a .ENV File 

 
Basic Gerber Files that were exported from the program (or saved from the DOS Lavenir VIEW 
Editor) along with a .ENV Environment file can be imported into the program using the .ENV file. 
This system requires less setup than the usual system for importing Basic Gerber because the Gerber 
format settings and options are saved in the .ENV file and do not have to be configured manually. 

To Import Basic Gerber into the Job Using a .ENV File: 
1. On the Files Menu, click Import-Gerber. 

2. In the Look in box, click the drive, folder, or network location that contains the .ENV File 
and the Gerber Files. 

3. In the folder list, double-click folders until you open the folder that contains the Files you 
want. 

4. Double-click on the .ENV File. 

The program imports the specified .ENV file and the associated Basic Gerber Files and loads them 
into the Job File. 

 F2 = Opens the Import Gerber dialog 

 You can also Drag and Drop files into the program. 
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Import Gerber Directly into the Layers Table 

 
Rather than going through the File-Import-Gerber menu, it is sometimes more convenient to import 
Gerber directly into the Layers Table. This technique gives you control over exactly which file gets 
imported into which layer. 

To Import Gerber Directly into the Layers Table: 
1. To display the Layers Table, go to the Setup menu, and click Layers. 

2. For each layer that you want to import data into, enter the file name into Name field. See 
Layer Name on Layers Table on page 352. You can use one of the following methods: 

• Enter a New Layer Name.  

• Rename Multiple Files Using Wildcards  

• Browse the Directories for File Names  

3. If the files are not in the current directory, be sure to toggle the display of the path portion of 
the layer name so that the path is shown. 

4. Make all layers that you want to import visible. 

5. On the Layers Table, click Gerber Options. 

6. On the Data Format tab, set the Data Format options. See Gerber Data Format Options on 
page 29. 

7. On the File Interpretation tab, set the File Interpretation options. See Gerber File 
Interpretation Options on page 31. 

8. On the Auto Features Tab, set the Automatic File Loading options. See Gerber Auto Feature 
Options on page 33. 

9. On the Options dialog, click OK. 

10. On the Layers Table, click Import Layer Files. 

 F10 = Display the Layers Table. 
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Set the Gerber Import Options without Importing 

 
You may want to set the Gerber Import Options without actually importing the data at the same time. 
One reason for doing this would be if you intend to Drag and Drop files into the job or Import from 
Layers at a later time. 

To Set the Gerber Import Options without Importing: 
1. Press F3. 

2. On the Data Format tab, set the Data Format options. See Gerber Data Format Options on 
page 29. 

3. On the File Interpretation tab, set the File Interpretation options. See Gerber File 
Interpretation Options on page 31. 

4. On the Auto Features Tab, set the Automatic File Loading options. See Gerber Auto Feature 
Options on page 33. 

5. On the Options dialog, click OK. 
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Import Gerber Extended and MDA Autoplot 

 

To Import Gerber Extended and MDA Autoplot into the Job 
1. Set the first active, visible layer to which you want to read in Gerber Data. See Select from the 

Active Layers on page 152. 

2. On the Files Menu, click Import-Gerber. 

3. In the Look in box, click the drive, folder, or network location that contains the Gerber Files. 

4. In the folder list, double-click folders until you open the folder that contains the Gerber Files 
you want. 

5. Click on the files that you want. You can select as many as you want using Shift+Click and 
Ctrl+Click to add or remove from the selection. 

6. Click Options. 

7. If the file header does not contain this information, set the Data Format options on the Data 
Format tab. See Gerber Data Format Options on page 29. If the file header does contain this 
information, it will override the option settings on this dialog. 

8. On the File Interpretation tab, set the File Interpretation options. See Gerber File 
Interpretation Options on page 31. 

9. On the Auto Features Tab, set the Automatic File Loading options. See Gerber Auto Feature 
Options on page 33. 

 Only the Autotranscode D Codes option on the Auto Features tab is relevant to Gerber 
Extended or MDA Autoplot files. The Apertures options are irrelevant for Gerber 
Extended or MDA Autoplot files because they contain the aperture information in the 
same file as the Gerber. 

10. Click Open. 

The program imports the specified Gerber Extended or MDA Autoplot Files and loads them into 
the Job File beginning with the first active, visible layer.  

The program also imports all aperture information included in the Gerber Extended or MDA 
Autoplot Files.  

 F2 = Opens the Import Gerber dialog 

 You can also Drag and Drop files into the program. 
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Import Drill Data 

 
Drill data is translated into Gerber on import and is translated back to Drill on export. As Drill data is 
imported into the current Job File, drill data Tool Codes are mapped to N-type D Codes used to 
represent the drill data on screen.  

To Import Drill Data into the Job: 
1. Set the first active, visible layer to which you want to read in Drill Data. See Select from the 

Active Layers on page 152. 

2. On the Files Menu, click Import-Drill. 

 

Import Drill Dialog 

3. In the Look in box, click the drive, folder, or network location that contains the Drill Files. 

4. In the folder list, double-click folders until you open the folder that contains the Drill Files 
you want. 

5. Click on the files that you want. You can select as many as you want using Shift+Click and 
Ctrl+Click to add or remove from the selection. 

6. Click Options. 

7. On the Data Format tab, set the Data Format options. 
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Drill Data Format Tab 

Language 

• Excellon: The file is in Excellon. 

• Wessel: The file is in Wessel 

• Sieb and Meyer: The file is in Sieb and Meyer. 

Left of Decimal: The number of digits in the data file to the left of the implied decimal point. 

Right of Decimal: The number of digits in the data file to the right of the implied decimal point. 

Zeros 

• Omit Trailing Zeros: Trailing zeros are omitted.  

• Omit Leading Zeros: Leading zeros are omitted. 

• All Digits Present: All digits are present and there are no zeros omitted.  
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• Explicit Decimal Point: The file has explicit decimal points, and the omitted zeros and 
number of digits to the right and left of the decimal are moot. 

Position Coordinates 

• Incremental: Position coordinates are incremental (coordinates are relative to the last 
position). 

• Absolute: Position coordinates are absolute (coordinates are relative to the absolute 
origin). 

Data Units 

• English: Units are in inches.  

• Metric: Units are in metric. 

Data Code 

• ASCII: The file is an ASCII text file. 

• EBCDIC: The file is in EBCDIC 

• EIA: The file is in EIA. 

8. On the Options tab, set the First D Code to be used as the system automatically maps 
incoming D Codes to Tool Codes. 

9. On the options dialog, click OK. 

10. Click Open. 

The program imports the specified Drill Files and loads them into the Job File beginning with the 
first active, visible layer. 

The program also imports all Tool Code information included in the Drill Files and automatically 
maps the Tool Codes to new N-type D Codes.  

 You can also Drag and Drop files into the program. 
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Import Aperture Lists 
There are several ways that aperture information can be brought into the open Job File. 

• Import an aperture list using the Import command. 

• Convert and import an aperture list using the Aperture File Wizard. 

• Merge aperture information contained in Gerber Extended or MDA Autoplot file or by using 
the Autoload Apertures option on the Auto Features tab of the Gerber Import dialog. 

• Insert D Code information manually using the D Code Table Editing commands. 

Import an Aperture List Using the Import Command 

 
The program can import many formats of aperture list. The basic procedure, which follows, imports 
D Code definitions and overwrites conflicting D Code information already loaded into the open Job 
File.  

To Import an Aperture List: 
1. On the Files Menu, click Import-Apertures. 

 

Import Apertures Dialog 

2. In the Look in box, click the drive, folder, or network location that contains the Aperture File. 
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3. In the folder list, double-click folders until you open the folder that contains the Aperture File 
you want. 

4. Click on the file that you want so that it is highlighted. 

5. If you want to automatically load Gerber data with the aperture files, click the Autoload 
Gerber option so that it has a checkmark. 

When you use the Autoload Gerber option while importing aperture files, the program searches 
the directory for Gerber files that are referenced by the aperture file and attempts to load the 
Gerber information simultaneously. If the option is not used, then the aperture files are imported 
and the Gerber files need to be imported separately.  

A similar command on the Import Gerber Options dialog is Autoload Apertures, which is set in 
the Import Gerber procedure. 

6. Pick the aperture list type on the Type drop down list, or click Guess Type. 

If the file is not on the Type drop down list, or the program is unable to guess the type, or the 
program is unable to import the file correctly once the type has been identified, then you may be 
able to import the file with the Aperture File Wizard. See Use the Aperture File Wizard on page 
45. 

7. Click Open. 

Depending on the aperture list type, the program may prompt for some additional information or 
files. If the program encounters aperture definitions that it cannot recognize it may prompt 
whether or not you want to import the shapes as Custom Apertures. 

8. On the Setup menu, click D Codes.  

9. On the D Code Table, compare your original aperture file to the D Code definitions that were 
imported to ensure that all definitions were imported correctly. Especially be sure to check 
any shapes that were converted to Custom Apertures on import. 

For information on merging aperture lists see Gerber Auto Feature Options on page 33. 

 You can also Drag and Drop files into the program. 
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Use the Aperture File Wizard 

 
The Aperture File Wizard allows you to convert and import a foreign aperture list and save a method 
for converting the same type of aperture list in the future. 

To Use the Aperture File Wizard: 
1. On the Files Menu, click Import-Apertures. 

2. In the Look in box, click the drive, folder, or network location that contains the Aperture File. 

3. In the folder list, double-click folders until you open the folder that contains the Aperture File 
you want. 

4. Click on the file that you want so that it is highlighted. 

5. On the Import Apertures dialog, click Wizard. 

The system displays the Aperture File Wizard, which takes you sequentially through the 
following five steps. 

Aperture File Wizard Step 1: 

 

Aperture File Wizard Step 1 

1. In the box labeled Fields in Aperture File Are, indicate how the fields are separated: 

• Separated by characters: A file that is separated by characters has a specific character, 
such as a space or tab, separating the different fields. Also, files that have a character-to-
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digit change or digit-to-character change indicating separate fields are considered to be 
separated by characters. 

• Aligned in Columns: A file that is aligned in columns has each field type in the same 
column for every record. (A column is the character position in the line, so the second 
character in the line is the character in column 2 for that record, and the third character is 
in column 3). For example, a file in which the D Code always starts in column two 
(second character), the shape name always starts in column six (sixth character), and the 
X dimension always starts in column twenty (twentieth character) is a file whose fields 
are aligned in columns. 

2. In the Units list box, click on the units used in the file so that the line is highlighted. 

3. Click the Next button. 

Depending on what you selected in Step 1, the system displays one of two Step 2 dialogs: 

• See Aperture File Wizard Step 2 for Files Separated by Characters: below.  

Or 

• See Aperture File Wizard Step 2 for Files Aligned in Columns on page 48.  

Aperture File Wizard Step 2 for Files Separated by Characters: 

 

Aperture File Wizard Step 2 for Files Separated by Characters 

The goal in Step 2 is to break your file up into fields, one for each data type.  

As you add to your list of separators, the list box at the bottom of the dialog shows you how the file 
separates into fields. 

1. In the Field Separators group box, click the check box(es) next to the characters that separate 
the fields in your file so that each one used in your file has a check mark. For example, if your 
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file always has a space between the D Code, shape, and X dimension, check the Space check 
box.  

2. If your file is such that a change in field is indicated when the text in the file changes from a 
character to a digit, or vice versa, click the check boxes next to Character to Digit Change 
and/or Digit to Character Change. For example, if the fields for shape and dimension run 
together like C00100, where C is the shape and 00100 is the diameter, then the change from 
shape field to diameter field is indicated by a character to digit change. 

3. If your file uses a separator character that is not listed, you can add it to the Others list:: 

• Click on the + button. 

• Type the character you want to add. 

• Click OK.  

This adds the character to the Others list.  

If you want to remove a character from the Others list: 

• Click on the character so that it is highlighted. 

• Click the – button. 

4. If your file sometimes contains multiple consecutive separator characters and you want them 
to be treated as one separator, click the Treat Consecutive Separators as One check box so 
that it has a check mark. When this option is checked, the program treats consecutive 
separators as one separator so that only one new field will be created for each group of 
consecutive separators. For instance, if you check the Space check box and your file contains 
5 spaces between each field and the Treat Consecutive Separators as One check box is 
checked, then the 5 spaces are treated as one separator. In the same example, if the Treat 
Consecutive Separators as One check box is not checked, then 5 new fields will be created, 
one for each space. 

5. If your file contains text enclosed in quotes or single quotes and you do not want this text 
broken up into different fields, select a Text Qualifier from the Text Qualifier combo box. 

As you add to your list of separators, the list box at the bottom of the dialog shows you how the 
file separates into fields. Add and remove separators until you have all the fields separated from 
each other. 

6. When all the fields are separated from each other, click the Next button to go to Step 3. See 
Aperture File Wizard Step 3: on page 49. 
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Aperture File Wizard Step 2 for Files Aligned in Columns: 

 

Aperture File Wizard Step 2 for Files Aligned in Columns 

The goal in Step 2 is to break your file up into fields, one for each data type. 

1. In the box where the file is displayed, click between each field to draw a line separating the 
fields.  

2. To remove a line double-click on it. 

3. Scroll through the file to make sure you have placed all the lines correctly.  

4. When all the lines are placed to properly separate all the fields, click the Next button to go to 
Step 3. See Aperture File Wizard Step 3: on page 49. 
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Aperture File Wizard Step 3: 

 

Aperture File Wizard Step 3 

The goal of this step is to tell the Aperture File Wizard what each field in the file represents. 

 When setting up this dialog, it is possible that a single field in the file may be used for one 
thing in one record and another thing in another record. For example, Field 4 might 
represent the Y dimension if the shape is a Rectangle and represent a Hole if the shape is a 
Circle. This is OK. In this example you would enter 4 in the Y edit box and also enter 4 in the 
Hole/Radius edit box. 
Also, if the file does not contain data for a particular field label, enter zero for that field label. 

1. If your file contains D Codes, select the D Code radio button, and put the number of the field 
that contains the D Code numbers in the D Code edit box. 
If your file contains aperture position numbers and not D Codes, select the Aperture Position 
radio button, and put the number of the field that contains the aperture position numbers in the 
Aperture Position edit box. 

2. Put the number of the field that contains the shape names in the Shape edit box. 

3. Put the number of the field that contains the X dimensions in the X edit box. 

4. If any of the apertures in the file have a Y dimension, put the number of the field that contains 
the Y dimensions in the Y edit box. 

5. If the file contains custom apertures and gives the path of the custom aperture file, put the 
number of the field that contains the custom aperture file paths in the Custom Aperture File 
edit box. 
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6. If the file has hole size or rounded rectangle radius data, put the number of that field in the 
Hole/Radius edit box. 

7. If the file contains rotation data, put the field number in the Rotation edit box. 

8. If the file contains thermal apertures: 

• Click the Thermal Fields button.  

• In the Thermals dialog, put the field number of each data type in the corresponding edit 
box.  

• If the file doesn’t contain a data type, leave the field number 0, and the program will use 
a default value. 

The Inner Diameter Default is outer diameter minus 2 times the cut width. 

The Cut Width Default is 0.015 in.  

The Number of Cuts Default is 4.  

The Angle Default is 45.  

If the only thermal data in the file is the outer diameter and inner diameter, and the outer 
diameter field number is the same as the X dimension field number, and the inner diameter 
field number is the same as the Y dimension field number or undefined, then there is no need 
to fill in the thermal field numbers. 

9. Click the Next button to go to Step 4. 
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Aperture File Wizard Step 4: 

 

Aperture File Wizard Step 4 

The goal of this step is to tell the Aperture File Wizard what each shape in the file corresponds to in a 
Lavenir format aperture list. 

1. For each shape listed, select the Lavenir shape that it corresponds to. If the shape is not in the 
list of Lavenir shapes or if it is not actually a shape (garbage data), select Undefined. 

2. When all the listed shapes that are true shapes have been mapped to a corresponding Lavenir 
shape, click the Next button to go to Step 5. 
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Aperture File Wizard Step 5: 

 

Aperture File Wizard Step 5 

The goals of Step 5 are to verify the accuracy of the file conversion, to save a method for converting 
this type of file in the future, and to import the converted file into the program. 

The Original File box contains the text of the original file, and the D Code Mapping contains the end 
result of the conversion process. 

1. Click on a line in the Original File list box or on a D Code in the D Code Mapping list box 
to select that line and the corresponding line in the other box. 

2. Compare each line in the Original File to the D Code Mapping and make sure the D Code 
Mapping matches what you think it should be. 

3. If the data in the D Code Mapping box does not match what you think it should be, you can 
click the Back button to go back through the steps of the Aperture File Wizard and change 
settings and options. Or you can edit the D Code mapping: 

• To bring up a context menu where you can change the shape, dimensions and D Code 
number of the selected D Code, Right-Click on a D Code in the D Code Mapping box. 

• To change the dimensions of the selected D Code, Double-Click or press I. 

• To change the D Code number of the selected D Code, press A.  

• To change the shape of the selected D Code, press the letter of a Lavenir shape code. 
This also brings up the dimension dialog for the new shape. 

• If there is a line that you don’t want translated, enter a ? for the D Code or Shape. You 
can do this by selecting the D Code and pressing U, or do it by pressing A and entering ? 
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for the D Code number. The program does not import any line in which the D Code or 
Shape is a ?. 

4. To check the file for errors that will prevent the converted file from importing into the job, 
such as invalid D Code numbers and dimensions greater than 10 inches: 

• Click the Check For Errors button.  

• If any errors are found, an Errors Found dialog box is shown listing the errors.  

• To select the D Code that corresponds to the error, click on the error. 

• Edit the D Code Mapping to correct the errors.  

• When finished editing, click the Check For Errors button again to update the list of 
errors. 

5. If you have other aperture lists of this type and you want to save the Aperture File Wizard 
settings so that you can import the same format in the future: 

• Click the Save Aperture List Type button.  

• Enter a file name prefix.  

• Select a folder to store all your Aperture Wizard files in.  

 You are only prompted for the folder the first time you save an Aperture Wizard file 
because all the Aperture Wizard files need to be saved in the same place. If you want to 
change where you save Aperture Wizard files, the folder name is stored in your registry 
under the key HKEY_LOCAL_MACHINE-Software-Lavenir Technology, Inc. in the 
string value Aperture Wizard Directory.  

The next time you go into the Import Apertures dialog box, you will be able to select this file from 
the Type combo box and use the information you gave in Steps 1 through 4 to skip right to Step 5. 

6. When the file is free of errors and ready to import, click the Finish button. 

If an Errors Found dialog box pops up, you must correct these errors before you can import your 
aperture list. See the discussion above. 

If there are no errors, the file is imported into the job and the aperture information is added to the 
D Code Table. 

7. On the Setup menu, click D Codes and check the D Code Table to make sure your aperture 
list was imported properly. 
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Import HPGL 

 
The program translates HPGL data into Gerber on import. HPGL Pen widths are mapped to D Codes 
on Import. 

To Import HPGL into the Job 
1. Set the first active, visible layer to which you want to read in HPGL Data. See Select from the 

Active Layers on page 152. 

2. On the Files Menu, click Import-HPGL. 

3. In the Look in box, click the drive, folder, or network location that contains the HPGL Files. 

4. In the folder list, double-click folders until you open the folder that contains the HPGL Files 
you want. 

5. Click on the files that you want. You can select as many as you want using Shift+Click and 
Ctrl+Click to add or remove from the selection. 

6. Click Options. 

7. Set the HPGL Import options. 

Zero-Length Draws 

• Make Pads: Draw commands with no end coordinate are made into pads. 

• Ignore: Draw commands with no end coordinate are ignored. 

First New D Code: Enter the number of the first new D Code you want the program to generate 
when translating pen widths to D Codes. 

Ignore IP Commands:  

Isotropic Scaling: 

Auto Select Text D Code:  

Ignore Polygon Fills:  

8. On the options dialog, click OK. 

9. Click Open. 

The program imports the specified HPGL Files and loads them into the Job File beginning with 
the first active, visible layer. 

 You can also Drag and Drop files into the program. 
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Import Netlist Data 
The program can import Lavenir Format 2, Format 4, and IPC-D-356 netlists into the job. If you have 
a netlist of another format, it may be possible to convert it into a Lavenir format using the Netlist 
Conversion feature. See Convert Netlist Files to Lavenir Format on page 57.  

The program can import netlist information in two different ways. The program can import all netlist 
information in the netlist file and generate pads and traces to represent the netlist in the layers of the 
current job. Or the program can import the netlist information and match it to existing pads and traces 
already in the current job. 

Import Netlist File into the Job and Generate Plot Data  

 

To Import a Netlist File into the Job and Generate Plot Data: 
1. On the File menu, click Import-Netlist.  

 

Import Netlist Dialog 

2. In the Look in box, click the drive, folder, or network location that contains the Netlist File. 

3. In the folder list, double-click folders until you open the folder that contains the Netlist File 
you want. 

4. Click the Netlist File so that it is highlighted and the name appears in the File Name field. 

5. If you want the netlist file and representative plot data to begin in a specific layer, click 
Options, and select the layer in the layer dialog. 

6. Click OK. 
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Import Netlist Data into the Job and Match to Existing Plot 

 

To Import a Netlist File into the Job and Match to Existing Plot: 
1. On the File menu, click Import-Net Info.  

 

Import Netlist Dialog 

2. In the Look in box, click the drive, folder, or network location that contains the Netlist File. 

3. In the folder list, double-click folders until you open the folder that contains the Netlist File 
you want. 

4. Double-click the Netlist File. 
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Convert Netlist Files to Lavenir Format 

 
The program can convert many formats of netlist file into Lavenir Format 2 or Format 4 netlists. When 
the netlist is converted into a Lavenir format netlist, you can import the netlist into the job. 

To Convert a Netlist File: 
1. On the Tools Menu, click Netlist-Convert Netlist. 

 

Convert Netlist Dialog 

2. In the Look in box, click the drive, folder, or network location that contains the netlist file. 

3. In the folder list, double-click folders until you open the folder that contains the netlist file 
you want. 

4. Click on the file that you want so that it is highlighted. 

5. Pick the netlist type on the Type drop down list, or click Guess Type. 
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6. If the file contains N/C records for non-connected points and you want those points to have 
unique identifiers, click on Add Numbers to N/C’s so that the option has a check mark. If 
there is no check mark, then those points will have the N/C identifier with no unique net 
number. 

7. If you want to automatically import the converted netlist after conversion, click on Import 
Netlist so that the option has a check mark. If there is no check mark, then the netlist will be 
converted and saved under a name you specify later, but it will not be imported. 

8. Click Open. 

Depending on the netlist type, the program may prompt for some additional information or files. 

The program prompts for a name for the converted netlist file. 

9. If you want to accept the default name, click Accept Default. 
If you want to change the name or directory, click Change Name, and enter a new name or 
location for the converted netlist file. Then click OK. 
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Export Files from the Job 
Exported files are files of a specific data format that are derived from the current Job File. To get Basic 
Gerber, Gerber Extended, MDA Autoplot, Drill, aperture or netlist files out of the Job File for use by 
other software or hardware, use the Export commands, not the Save command.  

Export Basic Gerber 

 
The program exports several formats of Gerber data, including Basic Gerber, Gerber Extended and 
MDA Autoplot. Each format has field and data format options and may have additional special export 
options.  

Gerber Export Fields Options 

 

Gerber Export Fields Tab 



Lavenir CAM Software User’s Guide 

60 

The following are Gerber Export options on the Fields tab of the Gerber Export dialog. Different 
systems that use Gerber data interpret commands and situations differently, so this is where you tell the 
program how to export the file so that your other systems can use the file: 

G54 Before Tool Select: Inserts a G54 command before every tool select command. 

2-Digit D and G Fields: Exports 2-digit D and G fields (D02 and D03 instead of D2 or D3). 

D Field in Each Block: Exports a D field in each block (required for non-modal systems); 
otherwise the system will not output a D field in each block if the D field command has not 
changed since the previous D field (appropriate for modal systems).  

Each Block in New Line: Exports each block in a new line. Some systems require this, but it 
makes the file larger. 

Flash: There are several options for how to export a flash: 

• D3* : This is the standard. 

• D2*D3* : Some systems require a move before the flash. 

• G55D3* : Some systems require a G55 before the flash. 

• D3*D3* : This is an odd format required by some Allegro systems. 
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Gerber Data Format Options 

 

Gerber Data Format Tab 

The following are Gerber Data Format options on the Data Format tab of the Gerber Import and Export 
dialogs: 

Left of Decimal: The number of digits in the data file to the left of the implied decimal point. 

Right of Decimal: The number of digits in the data file to the right of the implied decimal point. 

Omit Zeros 

• Trailing: Trailing zeros are omitted.  

• Leading: Leading zeros are omitted. 

Position Coordinates 

• Incremental: Position coordinates are incremental (coordinates are relative to the last 
position). 

• Absolute: Position coordinates are absolute (coordinates are relative to the absolute 
origin). 
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Data Units 

• English: Units are in inches.  

• Metric: Units are in metric. 

Data Code 

• ASCII: The file is an ASCII text file. 

• EBCDIC: The file is in EBCDIC 

• EIA: The file is in EIA. 

Arc Interpretation 

• Quadrant: Arcs are Quadrant arcs. 

• 360-degree: Arcs are 360-degree arcs. 
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Export Basic Gerber 
The following steps outline the basic procedure for exporting Basic Gerber. You may have special 
considerations when photoplotting multiple layers on a single piece of film. See Photoplot Multiple 
Layers on a Single Piece of Film on page 72. 

To Export Basic Gerber: 
1. Check your visibility settings for: 

• Visible Layers  

• The program only exports visible elements, so make sure all pads, traces, selected, 
unselected elements and blanked D Codes to be exported are visible. See Element 
Visibility on page 84. 

2. On the Files Menu, click Export-Basic Gerber. 

 

Export Basic Gerber Dialog 

3. In the Look in box, click the drive, folder, or network location where you want the Basic 
Gerber Files. 
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4. In the folder list, double-click folders until you open the folder where you want the Basic 
Gerber Files. 

5. On the Layers to Export list, click to select the layers that you want to export. Only visible 
layers appear on the list. 

6. Click Options. 

7. On the Data Format tab, set the Data Format options. See Gerber Data Format Options on 
page 61.  

8. On the Origin Tab, set the export file origin.  

• Absolute origin (0,0): Select this option if you want the origin of the export file to be the 
same as the origin of the loaded Job File database. 

• Present Cursor Location: Select this option if you want the origin of the export file to 
be the current cursor position instead of the origin of the loaded Job File database. 

9. On the Fields tab, set the Gerber Field options. See Gerber Export Fields Options on page 59. 

10. On the Options dialog, click OK. 

11. Select whether to export the layers as Individual Layer-by-Layer files or as a Combined file.  

• Layer-by-Layer: When you use the Layer-by-Layer option to Export files, all files 
selected in the Layers to Export list are exported in separate files. 

• Export Combined Files: When you use the Combined option to Export files, all files 
selected in the Layers to Export list are exported in a single file. This means that the 
plot data for separate layers is merged into a single layer. 

12. Depending on whether you selected Layer-by-Layer or Combined, you may need to enter a 
file name. 

• If exporting the layers Combined, enter a file name. 

• If exporting the layers Layer-by-Layer, the system uses the layer names in the Layers 
Table. 

13. Click Export. 

Because Basic Gerber does not contain aperture information you will probably want to export an 
aperture list. See Export Aperture Data on page 79. 

Export Gerber Extended 

 
The following steps outline the basic procedure for exporting Gerber Extended. In addition to the basic 
procedure you may have some special considerations:  

• See Photoplot Multiple Layers on a Single Piece of Film on page 72. 

• See Combine Paint, Scratch, Positive & Negative Layers in Extended Gerber on page 67. 

• See Append Additional Files to Gerber Extended Headers on page 68. 
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To Export Gerber Extended: 
1. Check your visibility settings for: 

• Visible Layers  

• The operation only exports visible elements, so make sure all pads, traces, selected, 
unselected elements, and blank D Codes to be exported are visible. See Element Visibility 
on page 84. 

2. On the Files Menu, click Export-Gerber Extended. 

 

Export Gerber Extended Dialog 

3. In the Look in box, click the drive, folder, or network location where you want the Gerber 
Extended Files. 

4. In the folder list, double-click folders until you open the folder where you want the Gerber 
Extended Files. 

5. On the Layers to Export list, click to select the layers that you want to export. Only visible 
layers appear on the list. 

6. Click Options. 
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7. On the Data Format tab, set the Data Format options. See Gerber Data Format Options on 
page 61.  

8. On the Origin Tab, set the export file origin.  

• Absolute origin (0,0): Select this option if you want the origin of the export file to be the 
same as the origin of the loaded Job File database. 

• Present Cursor Location: Select this option if you want the origin of the export file to 
be the current cursor position instead of the origin of the loaded Job File database. 

9. On the Fields tab, set the Gerber Field options. See Gerber Export Fields Options on page 59. 

10. On the Gerber Extended Options tab, set the Gerber Extended Export Options.  

 

Gerber Extended Export Options Tab 

The following are Gerber Extended Export options on the Gerber Extended Options tab of the 
Gerber Extended Export dialog. 

• Output G36 and G37 Commands for F-type D Codes: Exports G36 and G37 
commands for polygon boundary D Codes (type F).  
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• Generate Scratch Layers for “Inside” Polygons: Generates scratch layers for G36 and 
G37 polygons that are inside other polygons. 

• Output Thermal Primitive (7): Outputs H-type Thermal D Codes using the Gerber 
Extended thermal macro #7. 

• Output Dark/Clear Knockout Polarity: Adds Knockout Polarity commands that allow 
some Crescent photoplotters to plot paint and scratch layers simultaneously on a single 
piece of film.  

• Knockout Dimension: Size of the knockout block to be added before the scratch layers. 

• Output LTIenv Comments: Adds a header to the Gerber Extended file that can be read 
by other Lavenir software and hardware. The header contains information that allows the 
Lavenir software to identify certain macros in the Gerber Extended file as Heat Reliefs, 
Rounded Rectangles, Octagons, etc. Without this information the software would import 
these macros as Custom Apertures (Type-M D Codes). 

• Output Step and Repeat Codes (SR): Exports coded step and repeat blocks in the Job 
File database using the Gerber Extended SR command. Otherwise the coded step and 
repeats are converted into copied data on export. 

11. On the Options dialog, click OK. 

12. Select whether to export the layers as Individual Layer-by-Layer files or as a Combined file.  

• Layer-by-Layer: When you use the Layer-by-Layer option to Export files, all files 
selected in the Layers to Export list are exported in separate files. 

• Export Combined Files: When you use the Combined option to Export files, all files 
selected in the Layers to Export list are exported in a single file. This means that the 
plot data for separate layers is merged into a single layer. 

13. Depending on whether you selected Layer-by-Layer or Combined, you may need to enter a 
file name. 

• If exporting the layers Combined, enter a file name. 

• If exporting the layers Layer-by-Layer, the system uses the layer names in the Layers 
Table. 

14. Click Export. 

Combine Paint, Scratch, Positive & Negative Layers in Extended Gerber 
Most photoplotters that accept Gerber Extended can plot a particular sequence of paint, scratch, 
positive, and negative layers on a single piece of film. Gerber Extended headers can appear anywhere 
inside a plot file. Because of this, paint, scratch, positive, and negative data can appear inside the same 
file.  

To output this data properly, integrate the following steps into the Export Gerber Extended procedure. 

To Combine Paint, Scratch, Positive & Negative Layers in Extended Gerber: 
1. Give all layers exactly the same name, prefix and extension.  

2. Export the data Layer-by-Layer. 
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Append Additional Files to Gerber Extended Headers 
You can set up custom entries for Gerber Extended headers in files that will be inserted by the program 
in the generated header. The name of the Gerber Extended file is GBX_HDR.ADD. If this file does not 
exist when the Gerber Extended files are output, no action is taken. If it does exist, it is inserted "as is" 
(i.e. no parsing of the contents is attempted). 

Export MDA Autoplot 

 
The following steps outline the basic procedure for exporting MDA Autoplot. In addition to the basic 
procedure you may have some special considerations:  

• See Photoplot Multiple Layers on a Single Piece of Film on page 72. 

• See Combine Paint, Scratch, Positive & Negative Layers in MDA Autoplot on page 71. 

• See Append Additional Files to MDA Autoplot Headers on page 72. 

To Export MDA Autoplot: 
1. Check your visibility settings for: 

• Visible Layers  

• The operation only exports visible elements, so make sure all pads, traces, selected, 
unselected elements, and blank D Codes to be exported are visible. See Element Visibility 
on page 84. 

2. On the Files Menu, click Export-MDA Autoplot. 
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Export MDA Autoplot Dialog 

3. In the Look in box, click the drive, folder, or network location where you want the MDA 
Autoplot Files. 

4. In the folder list, double-click folders until you open the folder where you want the MDA 
Autoplot Files. 

5. On the Layers to Export list, click to select the layers that you want to export. Only visible 
layers appear on the list. 

6. Click Options. 

7. On the Data Format tab, set the Data Format options. See Gerber Data Format Options on 
page 61.  

8. On the Origin Tab, set the export file origin.  

• Absolute origin (0,0): Select this option if you want the origin of the export file to be the 
same as the origin of the loaded Job File database. 

• Present Cursor Location: Select this option if you want the origin of the export file to 
be the current cursor position instead of the origin of the loaded Job File database. 

9. On the Fields tab, set the Gerber Field options. See Gerber Export Fields Options on page 59. 
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10. On the MDA Options tab, set the MDA Export Options. 

 

MDA Export Options Tab 

The following are MDA Export options on the MDA Options tab of the MDA Export dialog. 

Aperture Units 

• Mils: Aperture units are converted to mils from the database units on export. 

• Database Units: Aperture units exported in the database units. 

Output Carriage Return/Line Feed: Adds a carriage return or line feed to separate each block. 

Output Cursor Position as X, Y Offset: Exports the cursor position in the X, Y Offset field. 

Output Frame Dimensions as Film Size: Exports the reference frame dimension in the Film Size 
field. 

Merge Paint and Scratch: Adds a Merge command to combine two or more paint and scratch 
composite layers. 

F-Type Polygon Output 
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• Nest Inside/Outside Fill Polygons: The program determines which polygons are inside 
other polygons and exports them as nested. 

• Output All Polygons as Outside Fill: The program exports all polygons as outside fill 
polygons regardless of which polygons are inside other polygons. 

Output LTIenv Comments: Adds a header to the MDA file that can be read by other Lavenir 
software and hardware. The header contains information that allows the Lavenir software to 
identify certain macros in the MDA file as Heat Reliefs, Rounded Rectangles, Octagons, etc. 
Without this information the software would import these macros as Custom Apertures (Type-M 
D Codes). 

11. On the Options dialog, click OK. 

12. Select whether to export the layers as Individual Layer-by-Layer files or as a Combined file.  

• Layer-by-Layer: When you use the Layer-by-Layer option to Export files, all files 
selected in the Layers to Export list are exported in separate files. 

• Export Combined Files: When you use the Combined option to Export files, all files 
selected in the Layers to Export list are exported in a single file. This means that the 
plot data for separate layers is merged into a single layer. 

13. Depending on whether you selected Layer-by-Layer or Combined, you may need to enter a 
file name. 

• If exporting the layers Combined, enter a file name. 

• If exporting the layers Layer-by-Layer, the system uses the layer names in the Layers 
Table. 

14. Click Export. 

Combine Paint, Scratch, Positive & Negative Layers in MDA Autoplot 
Most photoplotters that accept MDA Autoplot data can plot a particular sequence of paint, scratch, 
positive, and negative layers on a single piece of film. MDA Autoplot headers can appear only at the 
beginning of a plot file. Therefore a new file is required each time the data changes polarity.  

To output a merged sequence of MDA Autoplot layers, integrate the following steps into the Export 
MDA Autoplot procedure. 

To Combine Paint, Scratch, Positive & Negative Layers in MDA Autoplot: 
1. Give each layer a unique name.  

2. On the MDA Autoplot Export Options tab, put a check mark in the Merge Paint and Scratch 
option. 

3. Export the data Layer-by-Layer.  

The MDA headers in each file chain to the next via the NEXT command.
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Append Additional Files to MDA Autoplot Headers 
You can set up custom entries for MDA Autoplot headers in files that will be inserted by the program 
in the generated header. The name of MDA Autoplot file is MDA_HDR.ADD. If this file does not 
exist when MDA Autoplot files are output, no action is taken. If it does exist, it is inserted "as is" (i.e. 
no parsing of the contents is attempted). 

Photoplot Multiple Layers on a Single Piece of Film 
When photoplotting multiple layers on a single piece of film, some photoplotters plot the offset for 
you; most don’t.  

To be safe when photoplotting multiple layers on a single piece of film, integrate the following steps 
into the Export procedure. 

To Photoplot Multiple Layers on a Single Piece of Film: 
1. Arrange the data so that no layer overlaps another. 

2. Export the file Combined. 
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Export Drill Data 

 
The program can export Gerber data as Drill Data in the Excellon, Wessel, or Sieb & Meyer formats.  

There are two ways to export Drill data: 

• Use the following basic Export Drill Data procedure. 

• Designate the Layer Type as Drill (DRI), in the Type column on the Layers Table and export 
the data Layer-by-Layer using the Export Basic Gerber, Export Gerber Extended, or Export 
MDA Autoplot procedures.  

In addition to the basic procedure, you may have some special considerations if you are exporting an 
Excellon drilled slot pattern. See Excellon Drilled Slot Pattern on page 78. 

Prepare the Plot Data for Drill Data Export: 
Ø The program exports only N-Type D Codes as Drill Data. Before exporting drill data go to the 

D Code Table and verify that everything you want to export as drill data is mapped to Type N. 
Then go back and export the Drill Data. 

To Export Drill Data from the Job: 
1. Check your visibility settings for: 

• Visible Layers  

• The operation only exports visible elements, so make sure all pads, traces, selected, 
unselected elements, and blank D Codes to be exported are visible. See Element Visibility 
on page 84. 

2. On the Files Menu, click Export-Drill. 
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Export Drill Dialog 

3. In the Look in box, click the drive, folder, or network location where you want the Drill Files. 

4. In the folder list, double-click folders until you open the folder where you want the Drill Files. 

5. On the Layers to Export list, click to select the layers that you want to export. Only visible 
layers appear on the list. 

6. Click Options. 

7. On the Data Format tab, set the Data Format settings. 
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Drill Data Format Tab 

Language 

• Excellon: The file is in Excellon. 

• Wessel: The file is in Wessel 

• Sieb and Meyer: The file is in Sieb and Meyer. 

Left of Decimal: The number of digits in the data file to the left of the implied decimal point. 

Right of Decimal: The number of digits in the data file to the right of the implied decimal point. 

Zeros 

• Omit Trailing Zeros: Trailing zeros are omitted.  

• Omit Leading Zeros: Leading zeros are omitted. 

• All Digits Present: All digits are present and there are no zeros omitted.  
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• Explicit Decimal Point: The file has explicit decimal points, and the omitted zeros and 
number of digits to the right and left of the decimal are moot. 

Position Coordinates 

• Incremental: Position coordinates are incremental (coordinates are relative to the last 
position). 

• Absolute: Position coordinates are absolute (coordinates are relative to the absolute 
origin). 

Data Units 

• English: Units are in inches.  

• Metric: Units are in metric. 

Data Code 

• ASCII: The file is an ASCII text file. 

• EBCDIC: The file is in EBCDIC 

• EIA: The file is in EIA. 

8. On the Origin Tab, set the export file origin.  

• Absolute origin (0,0): Select this option if you want the origin of the export file to be the 
same as the origin of the loaded Job File database. 

• Present Cursor Location: Select this option if you want the origin of the export file to 
be the current cursor position instead of the origin of the loaded Job File database. 

9. On the Options tab, set the special Drill Export Options.  
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Drill Export Options Tab 

The following are Drill Export options on the Options tab of the Drill Export dialog. 

Output Both X and Y in Each Block: Always exports both an X and Y field in each block. 
Otherwise the program only exports the coordinate that changed from the previous block. 

Output Tool Specification Header/Trailer: Exports a tool specification header or trailer, 
depending on the drill language selected. Otherwise the header is not included in the exported file. 

Output Step and Repeat Codes: Exports coded step and repeat blocks in the Job File database 
using the drill language step and repeat command. Otherwise the coded step and repeats are 
converted into copied data on export. 

10. On the Options dialog, click OK. 

11. Select whether to export the layers as Individual Layer-by-Layer files or as a Combined file.  

• Layer-by-Layer: When you use the Layer-by-Layer option to Export files, all files 
selected in the Layers to Export list are exported in separate files. 



Lavenir CAM Software User’s Guide 

78 

• Export Combined Files: When you use the Combined option to Export files, all files 
selected in the Layers to Export list are exported in a single file. This means that the 
plot data for separate layers is merged into a single layer. 

12. Depending on whether you selected Layer-by-Layer or Combined, you may need to enter a 
file name. 

• If exporting the layers Combined, enter a file name. 

• If exporting the layers Layer-by-Layer, the system uses the layer names in the Layers 
Table. 

13. Click Export. 

Excellon Drilled Slot Pattern 
The Excellon G85 command, Drill Slot Pattern, defines a slot cut by drilling closely spaced holes 
between two endpoints. The syntax for this command is X#Y#G85X#Y#. If you select Excellon as 
your output language, then on export, any trace with a D Code of type N will be exported as a G85 
block. 
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Export Aperture Data 

 
The program exports aperture information in Lavenir VIEW Environment Files (.ENV).  

To Export a VIEW Environment File: 
1. On the Files Menu, click Export-Apertures. 

2. In the Look in box, click the drive, folder, or network location where you want the Aperture 
Files. 

3. In the folder list, double-click folders until you open the folder where you want the Aperture 
Files. 

4. Click Options. 

5. Select the Environment File Format. 

6. On the Options dialog, click OK. 

7. Click Export. 

VIEW Environment Files (.ENV) 
The VIEW environment file is more than an aperture list. It contains D Code and Tool Code tables 
plus layer file names, program configuration, menu settings, and the like.  

The VIEW environment file has changed over time as the Lavenir VIEW Editor capabilities have 
increased. Currently, there are Versions 1, 2, 3 and 4. Since older versions of software and RPG 
firmware cannot read the newest version environment files, the program allows you to set the version 
to export.  

Version 1 is appropriate for use with software earlier than the Lavenir VIEW Editor version 2.0. 

Both Versions 2 and 3 are currently used. Version 3 is more compact than Version 2 and it saves 
additional and enhanced D Code shapes: type H, Heat Relief; M, Custom Aperture; and N, NC Drill 
Hole. 

The Version 4 environment file allows you to save the Tool Code Table, layer types, as well as the Q 
shape D Code, Rounded Rectangle, and the E shape, Octagon.
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Export Netlist Data 

 
The program can export netlist data extracted using the Raster Netlist Extraction routine. Netlist data 
extracted using the Vector Netlist Extraction routine is automatically exported at the time of extraction. 

To Export Netlist Files: 
1. On the File menu, click Export-Netlist.  

 

Export Netlist Dialog 

2. On the Netlist Export Options dialog, select the type(s) of netlist file(s) you wish to export: 

Format 2: The Format 2 Netlist contains all IPC-D-356 data. The program exports the file using 
the Base Output File Name set during the Running the Raster Netlist Extraction procedure and the 
extension .F02. 

Format 4: The Format 4 Netlist contains all IPC-D-356 data, plus addition trace data. The 
program exports the file using the Base Output File Name set during the Running the Raster 
Netlist Extraction procedure and the extension .F04. 

3. Select whether you wish to export only the additional test point information or to export the 
standard IPC data plus the additional test point information.  

 No additional test point information will be exported unless your SPU and/or SPL layers 
were visible during the netlist extraction operation. 

4. Click OK. 
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Milestone Files 

 
A Milestone file is a temporary Job File that saves a copy of work in progress. The program 
automatically erases the temporary Milestone file when the current Job File is closed. You can use a 
Milestone file whenever you need to do a large edit that you might want to undo but that might exceed 
that amount of memory allocated for the undo feature. Save a Milestone file before the edit, do the 
edit, and then if you need to, restore the Milestone file. The Milestone file is convenient because the 
system manages it, and you do not need to keep track of multiple file names and directories the way 
you would if you wanted to do the same thing manually. 

To Save a Milestone file: 
Ø On the File menu, click Milestone-Save Milestone.  

The system saves all the current job information in a temporary file without prompting for a file 
name or directory. 

To Revert to a Saved Milestone file: 
Ø On the File menu, click Milestone-Revert to Milestone.  

 Most of the automated editing tools available in CAMMaster and ViewMaster PRO, such as 
Venting and Fill Polygons, have a feature to save a milestone file on the operation dialog. 
This means that you don’t have to save the Milestone yourself; just select the option for the 
operation to save a Milestone, then if the automated editing tool does not give you the results 
you want, you can revert to the Milestone file. 

Set Current Directory 

 
Most file import and export operations use dialogs that allow you to select the file names and 
directories. The program also has a way to set a target directory to use as a default directory without 
going to an import or export dialog. 

To Set the Current Directory:  
1. On the Setup menu, click Set Current Directory. 

2. On the Browse for Folder dialog, click on folders until you highlight the directory that you 
want. 

3. Click OK. 
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Chapter 3 
View Plot Data 

The program has many ways for you to control what you see on screen and how you see it. You can 
change the view of different kinds of elements and layers. You can control what part of the data is 
displayed and at what zoom level it is displayed. You can measure distance and go to specific locations 
in the data. You can also control how certain aspects of the interface, such as the screen grid and 
cursor, are displayed. And you can also display the properties of certain elements. 

Many of the commands for controlling the visibility of elements on screen are available on the 
Visibility Toolbar.  

 

Visibility Toolbar 

To Display the Visibility Toolbar: 
Ø On the View menu, look at Toolbars-Visibility. 

• If Visibility has a checkmark next to it, then the Visibility Toolbar is displayed. 

• If Visibility does not have a checkmark next to it, then the Visibility Toolbar is not 
displayed. 

To change the display of the Visibility Toolbar, click Visibility. 

  Visibility Toolbar button on Main Toolbar. Down = Displayed, Up = Not Displayed 

Many of the commands for controlling what the screen is looking at and where the cursor is are 
available on the Screen View Toolbar.  

 

Screen View Toolbar 

To Display the Screen View Toolbar: 
Ø On the View menu, look at Toolbars-Screen. 

• If Screen has a checkmark next to it, then the Screen View Toolbar is displayed. 

• If Screen does not have a checkmark next to it, then the Screen View Toolbar is not 
displayed. 

To change the display of the Screen View Toolbar, click Screen. 
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Element Visibility 
The element visibility command control whether certain types of elements, such as pads or traces and 
selected or unselected elements, are displayed and how they are displayed. 

Pads Visible 

 
Pads can be made visible or not visible. 

To Toggle Pad Visibility: 
1. On the View menu, go to Visibility-Element-Pads. 

• If Pads is checked, pads are visible. 

• If Pads is not checked, pads are not visible. 

2. To change the visibility, click Pads. 

 Shift+P 

  

Traces Visible 

 
Traces can be made visible or not visible. 

To Toggle Trace Visibility: 
1. On the View menu, go to Visibility-Element-Traces. 

• If Traces is checked, traces are visible. 

• If Traces is not checked, traces are not visible. 

2. To change the visibility, click Traces. 

 Shift+T 
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Selected Elements Visible 

 
Selected elements can be made visible or not visible. 

To Toggle Selected Element Visibility: 
1. On the View menu, go to Visibility-Element-Selected Elements. 

• If Selected Elements is checked, selected elements are visible. 

• If Selected Elements is not checked, selected elements are not visible. 

2. To change the visibility, click Selected Elements. 

 Shift+S 

  

Unselected Elements Visible 

 
Unselected elements can be made visible or not visible. 

To Toggle Unselected Element Visibility: 
1. On the View menu, go to Visibility-Element-Unselected Elements. 

• If Unselected Elements is checked, unselected elements are visible. 

• If Unselected Elements is not checked, unselected elements are not visible. 

2. To change the visibility, click Unselected Elements. 

 Shift+U 
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Selected Elements Shown in White or Contrasting Color 

 
Selected Elements can be displayed in white or in contrasting color. 

To Display Selected Elements in White or Contrasting Color: 
1. On the View Menu, go to Visibility-Selected. 

The position of the bullet indicates how selected elements are displayed: 

• If there is a bullet on Display in White, then selected elements are White. 

• If there is a bullet on Display in Contrasting Color, then selected elements are shown in 
Contrasting Color. 

2. To switch between the two, click Display in White or Display in Contrasting Color. 

Blank D Codes 

 
Control the visibility of elements of specific D Codes by “blanking” the D Codes. Elements with blank 
D Codes are not displayed on screen or exported, but the original shape is remembered by the system 
and can be restored by “unblanking” the D Code. One way to handle blank D Codes is to map the 
D Code to Shape B on the D Code Table. But you can also quickly blank and unblank D Codes 
without going to the D Code table. 

To Toggle D Codes between Blank and Original Shape: 
1. On the View Menu, click Visibility-Element-Blank D Codes. 

2. Select elements in the Visible D Codes list or in the Blank D Codes list, and click the 
appropriate arrow to move them to the opposite list. 

 Shift+H 
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Pad and Trace Contrast 

 
Pads and traces can be displayed in the same color or can be displayed at a contrasting color or 
intensity. 

To Set Pad-Trace Contrast: 
1. On the View Menu, click Visibility-Element-Options. 

2. Click the Pad-Trace Contrast checkbox to turn off or on Pad-Trace Contrast. 

3. Click the option to select Contrasting Color or Contrasting Intensity. 

4. Click OK. 

 V 

  

Zero-Width Elements 

 
Traces can be displayed filled at actual width or at zero width. And when traces are zero width, pads 
can be displayed filled or outlined. 

To Set the Element Display Mode: 
1. On the View Menu, click Visibility-Element-Options. 

2. Click the Trace Width option to Zero Width or Filled. 

3. Click the Pad Width option so that when traces are zero width pads are shown Outlined or 
still Filled. 

4. Click OK. 

 O (For Traces) 
Shift+O (For pads)  

  For Traces and  for Pads 
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Layer Visibility 
The visibility status of a layer indicates whether the layer is visible or not in the Viewing Area. There 
are several ways you can find out and control the Layer Visibility: 

• See Layer Visibility on Layers Table on page 364.   

• See Layer Visibility on Layer Toolbar on page 365.   

• Use the layer visibility commands that follow. 

Next Layer Visible 

 

To Make the Next Layer Visible: 
Ø On the View Menu, click Visibility-Layer-Next Layer Visible. 

 Shift+Equals 

Previous Layer Visible 

 

To Make the Previous Layer Visible: 
Ø On the View Menu, click Visibility-Layer-Previous Layer Visible. 

 Shift+Backspace 

Make Any Single Layer Visible 

 
You can make a single layer visible and shut off visibility for all other layers. 

To Make a Single Layer Visible: 
1. On the Setup Menu, click Layer-Only Visible and Active.  

2. Enter a single layer number. 

 Ctrl+L 
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Make a Range of Layers the Only Visible Layers 

 
You can make a range of layers visible and shut off visibility for all other layers. 

To Make a Range of Layers Visible and Shut off Visibility for All Other Layers: 
1. On the Setup Menu, click Layer-Only Visible.  

2. Enter a single layer number or a range of layers separated by a dash and/or a series of layers 
separated by commas (i.e., 1-4 or 5,7,9 or 1-4,5,7,9). 

Layer Visibility Quick Keys 

 
The Layer Visibility Quick Keys toggle the visibility of the layer with the corresponding Layer 
Number. This is the quickest way to toggle the visibility for layers 1 through 9. 

 1 through 9 

All Layers Visible 

 

To Make all Layers Visible: 
Ø On the View Menu, click Visibility-Layer-All Layers Visible. 

 Ctrl+0 (Zero)  

  

Toggle Layer Visibility 

 
You can toggle layer visibility so that visible layers are turned off and vice versa. 

To Toggle Layer Visibility: 
Ø On the View Menu, click Visibility-Layer-Toggle Layer Visibility. 

 Shift+0 (Zero)  
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Zoom Level 
The program can display data at zoom levels that range from .0001 to 7000. The Zoom Tool is most 
versatile manual method for controlling zoom level, but there are also zoom commands, which are 
sometimes faster. 

Zoom Tool 

 
The zoom tool combines the Zoom Up, Zoom Down, and Zoom on Area commands into one mouse-
driven tool. 

To Use the Zoom Tool: 
1. On the View Menu, click Zoom-Tool. 

 

Zoom Up Tool 

 

Zoom Down Tool 

2. Now you can zoom up, down and on an area: 

• To zoom up, Click where you want to zoom to. 

• To zoom down, Shift+Click where you want to zoom from. 

• To zoom on an area, Drag the mouse across that area you want to zoom on.  

3. To release the zoom tool, click another tool or press Esc. 

 Z 
Enter = Zoom Up 
Shift+Enter = Zoom Up 
Tab = Start drag area and Tab again to end 
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Zoom Up, Down 

 
The Zoom Up and Zoom Down commands, zoom up or down on the crosshair position by a fixed 
factor of 1.39. 

To Zoom Up or Down: 
1. Position the crosshair where you want to zoom up. 

2. Separate the crosshair and the cursor. See Separate the Crosshair and Mouse Cursor on page 
112.  

3. On the View Menu, click Zoom-Up/Down. 

 Page Up = Zoom up 
Page Down = Zoom Down 

 It is usually preferable to run this operation using the key commands, because they do not 
require you to separate the cursor. Or you can use the Zoom Tool, which does not require you 
to separate the cursor. 

 

Zoom To Show All Data 

 
The Zoom to Show All Data command, zooms so that all visible data fits on the screen at the highest 
possible zoom. 

To Show All Data: 
Ø On the View Menu, click Zoom-To Show All. 

 Home 
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Zoom On Reference Frame 

 
The Zoom on Reference Frame command zooms so that the Reference Frame fits on the screen at the 
highest possible zoom. 

To Zoom on the Reference Frame: 
1. Position the Reference Frame where you want it. See Reference Frame on page 177. 

2. On the View Menu, click Zoom-On Frame. 

 Shift+Home 

 There is an easier way to zoom on a specific area using the Zoom Tool. 

Zoom To Exact Zoom Level 

 

To Zoom to an Exact Zoom Level: 
1. Position the crosshair where you want to zoom to. 

2. Separate the crosshair and the cursor. See Separate the Crosshair and Mouse Cursor on page 
112. 

3. On the View Menu, click Zoom-Set Level. 

4. Enter the Zoom Level. 

 Shift+Z 

  Type the Zoom Level in the Screen View Toolbar 

 It is usually preferable to run this operation using the key command, because it does not 
require you to separate the cursor.  
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Distance Measurement and Coordinate System 
The cursor position is displayed in the Screen View Toolbar. The cursor position can be displayed in 
Rectangular Coordinates (X, Y) or Polar Coordinates (Distance, Angle). And the cursor position can 
be displayed relative to the Absolute Origin (0,0) or a Relative Origin that you can set that is offset 
from the absolute origin. The cursor position display is also where distance is displayed when in 
Distance Measurement mode. The program has commands to go to a coordinate location. 

Distance Measurement 

 
You can measure distance from a fixed point, or you can measure distance from the edge of an 
element. When the distance measurement feature is active, the distance and angle from the start point 
to the cursor is shown in the Screen View Toolbar, and it is as if the cursor position was displayed with 
Polar Coordinates from a Relative Origin.  

To Measure Distance from a Point: 
1. On the View menu, click Distance-From Point. 

2. Position the cursor at the point where you want to measure from. 

3. Click the mouse or press Enter. 

4. Move the cursor to the position where you want to measure to. 

The distance and angle from the start point to the cursor is shown in the Screen View Toolbar. 

The Distance Measurement tool remains active so you can move the cursor to new locations where 
you want to measure to, or you can click the mouse again to set a new location to measure from. 

5. To stop measuring distance, select another tool or press Esc. 

 D = Measure Distance from Point 
Enter = Select start point or element 

 For precision, use the Align command when measuring from the exact centerpoint of an 
element. 

To Measure Distance from the Edge of an Element: 
1. On the View menu, click Distance-From Edge. 

2. Position the cursor on the element where you want to measure from. 

3. Click the mouse or press Enter. 

The cursor snaps to the element and the “rubber band” extends from the closest point on the edge 
of the element to the cursor. 

4. Move the cursor to the position where you want to measure to. 

5. The distance and angle from the edge of the element to the cursor is shown in the Screen 
View Toolbar. 
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The Distance Measurement tool remains active so you can move the cursor to new locations where 
you want to measure to, or you can click the mouse again to select a new element to measure 
from. 

To stop measuring distance, select another tool or press Esc. 

 For precision, use the Align command when measuring from the exact centerpoint of an 
element. 

Polar Coordinates 

 
When the program displays Polar Coordinates the coordinates are given as the Distance (or Radius) 
and Angle to the cursor from the origin. The coordinate buttons on the Screen View Toolbar indicate 
R, for Radius, and A, for Angle, the Polar Coordinate button is down, and the program shows a line 
connecting the cursor to the origin. The alternative to viewing Polar Coordinates is to view (X, Y). Just 
like Rectangular Coordinates, Polar Coordinates can be displayed relative to the Absolute Origin or the 
Relative Origin . 

To View Polar Coordinates: 
Ø On the View menu, click Coordinate Origin-Polar. 

  

Rectangular Coordinates 

 
When the program displays Rectangular Coordinates the coordinates are given as the X and Y distance 
to the cursor from the origin. The coordinate buttons on the Screen View Toolbar indicate X and Y, the 
Polar Coordinate button is up, and the program does not show a line connecting the cursor to the 
origin. Rectangular Coordinates can be displayed relative to the Absolute Origin or the Relative 
Origin. The alternative to viewing Rectangular Coordinates is to view Polar Coordinates.  

To View Rectangular Coordinates: 
Ø On the View menu and click Coordinate Origin-(X, Y). 
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Absolute Origin 

 
The Absolute Origin is the (0, 0) origin of the database. Coordinates are displayed relative to the 
Absolute Origin when the Coordinate buttons display capital letters, for instance (X, Y) or (R, A), and 
the relative origin button is up. The Absolute Origin cannot be moved, but data can be repositioned 
relative to it. The alternative to the Absolute Origin is to display relative to a Relative Origin, which 
can be moved. 

To View Coordinates Relative to the Absolute Origin: 
Ø On the View menu, click Coordinate Origin-Absolute. 

 R = Toggle between Relative and Absolute origin 

  

 When you switch to display relative to the Absolute Origin, the default method for positioning 
with the Go To Coordinates command also switches to Absolute.  

Relative Origin 

 
The Relative Origin is a coordinate position that you can set and measure relative to. Coordinates are 
displayed relative to the Relative Origin when the coordinate buttons display lower case letters 
preceded by the letter “d”, for instance (dx, dy) or (dr, da), and the Relative Origin button is down. The 
Relative Origin can be moved using the Set Relative Origin command so that you can measure 
coordinates relative to a new position. The alternative to the Relative Origin is to display relative to the 
Absolute Origin, which cannot be moved. 

To View Coordinates Relative to the Relative Origin: 
Ø On the View menu, click Coordinate Origin-Relative. 

 R = Toggle between Relative and Absolute origin 

  

 When you switch to display relative to the Relative Origin, the default method for positioning 
with the Go To Coordinates command also switches to Incremental.  
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Set Relative Origin 

 
The Relative Origin is a coordinate position that you can set and measure relative to. 

To Set the Relative Origin: 
1. On the View menu, click Coordinate Origin-Set Relative Origin. 

 

Set Relative Origin Tool 

2. Position the cursor where you want the Relative Origin. 

3. Click the mouse or press Enter. 

The Set Relative Origin tool remains selected, so you can position the Relative Origin at one point 
after another. 

4. To release the Set Relative Origin tool, click a different editing tool or press Esc. 

 Shift+R = Set Relative Origin Tool 
Enter = Activate Tool 
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Pan the Screen 
Scroll the Screen 

 
The program has scrollbars for navigating the viewing area. 

To Turn On and Off the Display of Scrollbars: 
Ø On the View menu, click Scrollbars. A check mark indicates that scrollbars are being 

displayed. 

To Use the Scrollbars: 
Ø To scroll by a small step, click the scroll arrows. 

Ø To scroll by one screen, click the scroll bar above or below the scroll box. 

Ø To scroll to a specific location, drag the scroll box. 

The area that can be scrolled to using the scroll bars is called the Workspace.  

To Set the Workspace Dimensions: 
1. On the Setup menu, click Workspace. 

2. On the Workspace dialog you can set the dimensions of the workspace several ways: 

• Enter the locations of the corners manually. 

• Click Around all Data to automatically set the corners to contain all data. 

• Click Around Frame to make the corners match the dimensions of the current Reference 
Frame. See Reference Frame on page 177. 

• Click Default to set the dimensions to the default film size for the Pulsar 8000 
Photoplotter (26” x 20”). 

3. When the corner values are set, click OK. 
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Automatically Pan Screen at Viewing Area Edges 

 
You have the option to have the screen pan automatically when you move the cursor to the edge of the 
Viewing Area with the arrow keys. 

To Set the Screen to Automatically Pan: 
1. On the View Menu, and look at Pan at View Margins. 

• If there is a checkmark on Pan at View Margins, then the screen will pan when you 
move the cursor to the edge of the Viewing Area with the arrow keys. 

• If there is no checkmark on Pan at View Margins, then the screen will not pan 
automatically. 

2. To turn automatic panning on or off click Pan at View Margins. 

Pan Screen Up, Down, Left, Right 

 
Panning the screen using the following commands moves the view by one full screen. To scroll the 
view more smoothly, use the Scrollbars. 

To Pan the Screen Up, Down, Left, Right: 
Ø On the View Menu, click 

Pan View-Up or 
Pan View-Down or 
Pan View-Left or 
Pan View-Right  

 Ctrl+Up Arrow 
Ctrl+Down Arrow 
Ctrl+Left Arrow 
Ctrl+Right Arrow 
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Pan Screen to Origin 

 

To Pan the Screen to the Origin: 
Ø On the Go menu, click Origin. 

 Ctrl+Home 

  

Pan Screen to Center 

 

To Pan the Screen to the Center of the Visible Data: 
Ø On the Go menu, click Center. 

 C 

  

Pan Screen to First Screenful 

 
The first screenful of data is the lower left corner of the visible data that will fit on the screen at the 
current zoom level. Using this command and the Pan View to Next Screenful command you can be 
sure to view all data by sequential screens. 

To Pan the Screen to the First Screenful of Data: 
Ø On the View Menu, click Pan View-First Screenful. 

 Shift+F 
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Pan Screen to Next Screenful 

 
You can step sequentially through each screen of data. The sequence of screens moves from the lower 
left corner of the visible data that will fit on the screen at the current zoom level, and moves to the right 
until there is nothing left to view. Then it moves back to the left and up one screen. Using this 
command and the Pan View to First Screenful command you can be sure to view all data by sequential 
screens. 

To Pan the Screen to the Next Screenful of Data: 
Ø On the View Menu, click Pan View-Next Screenful. 

 Shift+N 

  

Center View on Cursor 

 
The Center View on Cursor command pans the screen so that the cursor location moves to the center of 
the Viewing Area. 

To Pan the Cursor Location to the Center of the View: 
1. Position the crosshair at the point you want centered in the viewing area. 

2. Separate the crosshair and the cursor. See Separate the Crosshair and Mouse Cursor on page 
112. 

3. On the View Menu, click Center Display at Cursor. 

 Shift+End 

 It may be preferable to run this command using its keyboard equivalent rather than the menu 
command. The key command does not require you to separate the cursor.  
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Go To Location 
The program has many commands for making the cursor go to a specific location. You can go to 
specific coordinates. You can align to an element and also query an element for its layer, D Code and 
net. You can go to positions relative to other elements, such as the other end of a trace or the center of 
an arc. And you can go to positions relative to other interface features, such as a marker or the corners 
of the reference frame. 

Go To Coordinates 

 

To Position the Crosshair at a Precise Coordinate Location: 
1. On the Go menu, click Coordinates. 

2. Enter the coordinates that you want to go to. 

3. Select whether you want to move to a position relative to the origin (Absolute), or relative to 
the current cursor position (Incremental). 

4. Click OK. 

 X or Y 

  Click on X or Y button on Screen View Toolbar 

 For precision it is better to accept the values in the Coordinates dialog by pressing Enter 
rather than clicking OK. When you click on the mouse, you are likely to jiggle it and move the 
cursor out of alignment. The safest method is to separate the crosshair cursor from the 
pointer and run the operation from the keyboard. See Separate the Crosshair and Mouse 
Cursor on page 112. 
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Align to Element 

 
The Align command aligns the crosshair to an element without selecting the element or querying the 
element’s properties. The Align command will only align to elements that meet all the active Selection 
Criteria, if any: 

• Current Layer  

• Current D Code  

• Current Net  

• Special Element Class  

Use this command when you want to precisely align the crosshair for an editing function. 

To Align to an Element: 
1. Position the crosshair near the element you want to align to. 

2. Separate the crosshair and the cursor. See Separate the Crosshair and Mouse Cursor on page 
112. 

3. On the Go menu, click Closest-Align. 

 A 

 It may be preferable to run this command using its keyboard equivalent rather than the menu 
command. The key command does not require you to separate the cursor. However, the safest 
method is to separate the crosshair cursor from the pointer and run the operation from the 
keyboard.  
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Query Element 

 
The Query command snaps the crosshair to an element and updates the Current Element Toolbar with 
the element’s properties: 

• Layer of the Element 

• D Code of The Element 

• Net of the Element 

• Coordinates of the Element 

The Query command will only query elements that meet all the active Selection Criteria, if any: 

• Current Layer  

• Current D Code  

• Current Net  

• Special Element Class  

To Query an Element Using the Properties Tool: 
1. On the Go menu, click Closest-Properties Tool. 

 

Query Properties Tool 

2. Click near the element you want to query. 

To Query an Element Near the Cursor: 
1. Position the crosshair near the element you want to query. 

2. Separate the crosshair and the cursor. See Separate the Crosshair and Mouse Cursor on page 
112. 

3. On the Go menu, click Closest-Properties. 

 Shift+A 

 It may be preferable to run this command using the keyboard rather than the menu command. 
The key command does not require you to separate the cursor. However, the safest method is 
to separate the crosshair cursor from the pointer and run the operation from the keyboard. 
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Go To Other Endpoint of Trace 

 
This command moves the cursor to the other end of a queried trace or to the center of a queried pad. 

To Position the Cursor at the Other End of a Trace: 
1. Query the trace. See Query Element on page 103.  

2. Separate the crosshair from the cursor. See Separate the Crosshair and Mouse Cursor on page 
112. 

3. On the Go menu, click Other Endpoint of Trace. 

 E 

 It may be preferable to run this command using its keyboard equivalent rather than the menu 
command. The key command does not require you to separate the cursor. However, the safest 
method is to separate the crosshair cursor from the pointer and run the operation from the 
keyboard. 

Go To Arc Center 

 
This command moves the cursor to the center of a queried arc. 

To Position the Cursor at the Center of an Arc: 
1. Query the arc. See Query Element on page 103. 

2. Separate the crosshair from the cursor. See Separate the Crosshair and Mouse Cursor on page 
112. 

3. On the Go menu, click Arc Center. 

 Shift+E 

 It may be preferable to run this command using its keyboard equivalent rather than the menu 
command. The key command does not require you to separate the cursor. However, the safest 
method is to separate the crosshair cursor from the pointer and run the operation from the 
keyboard. 
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Go To Reference Frame Corners 

 
You can make the cursor go to the corners of the Reference Frame. This operation can be set to have 
the cursor go to only the upper right and lower left corners of the Reference Frame, or it can be set to 
go to all four corners. For more information about the reference frame, see Reference Frame on page 
177. 

To Go To Reference Frame Corners: 
1. Separate the crosshair from the cursor. See Separate the Crosshair and Mouse Cursor on page 

112. 

2. On the Go menu, click Frame Corner. 

 Ctrl+E 

 It may be preferable to run this command using its keyboard equivalent rather than the menu 
command. The key command does not require you to separate the cursor. However, the safest 
method is to separate the crosshair cursor from the pointer and run the operation from the 
keyboard. 

To Select 2-Corner or 4-Corner Mode: 
1. On the View Menu, look at the Go To-4 Corners Mode menu item. 

• If there is a check mark next to 4 Corners Mode, then the cursor will go to all four 
corners of the Reference Frame. 

• If there is no check mark next to 4 Corners Mode, then the cursor will only go to the 
upper right and lower left corners of the Reference Frame. 

2. To switch the mode, click on 4 Corners Mode. 
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Go To Last Marked Position 

 
The program allows you to mark a position and return to the mark later. 

To Return to a Marked Location: 
1. Separate the crosshair from the cursor. See Separate the Crosshair and Mouse Cursor on page 

112. 

2. On the Go menu, click Last Marked Position. 

 H 

 It may be preferable to run this command using its keyboard equivalent rather than the menu 
command. The key command does not require you to separate the cursor. However, the safest 
method is to separate the crosshair cursor from the pointer and run the operation from the 
keyboard. 

Mark a Location 

 
The program allows you to mark a location and return to the location later. 

To Mark a Location: 
1. Position the crosshair where you want the mark. 

2. Separate the crosshair and the cursor. See Separate the Crosshair and Mouse Cursor on page 
112. 

3. On the View Menu, click Mark. 

 M 

 It may be preferable to run this command using its keyboard equivalent rather than the menu 
command. The key command does not require you to separate the cursor.  
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Screen Grid 
The program has a screen grid that can be used for precisely positioning the cursor. The grid can be 
turned on and off as needed. 

When the grid is off, the cursor can be moved freely to any position using the Arrow Keys or the 
mouse. 

When the grid is on: 

• The cursor moves only on the grid points when moved with the Arrow Keys. 

• The cursor snaps to the closest grid point when you activate an editing command such as 
insert, copy or move. 

• The cursor can be moved off the grid using the mouse or by Aligning to or Querying an 
element. 

Some settings affect the behavior of the grid: 

• The grid unit determines the spacing of grid points. 

• The space between grid points can be Fixed at one interval or can be set to be Variable 
depending on the Zoom level. 

• The grid can be Anchored so that it does not move, or it can be Dragged by the cursor.  

Turn the Screen Grid On and Off 

 

To Turn the Screen Grid On and Off: 
1. On the View Menu, go to Grid-Display Grid. 

• If there is a checkmark on Display Grid, the grid is On.  

• If there is no checkmark on Display Grid, the grid is Off.  

2. To turn the grid on or off click Display Grid 

 G 

  Up = Off, Down = On 
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Anchored or Dragged Grid 

 
You can toggle between a Grid that is Anchored and one that can be moved or Dragged with the 
cursor: 

To Toggle between an Anchored and Dragged Grid: 
1. On the View Menu, go to Grid. 

The position of the bullet indicates the status of the grid: 

• If there is a bullet on Anchored, the grid is stationary, and the cursor hops from one grid 
point to the next. 

• If there is a bullet on Dragged, the grid is moveable, and the cursor drags the grid. 

2. To switch between the two states, click Anchored or Dragged. 

 Shift+G 

  Up = Dragged, Down = Anchored 
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Fixed or Variable Grid 

 
The grid can be set to Variable and Fixed Grid Mode. The difference between these two modes is the 
interval displayed between grid dots.  

• Variable Grid: The program changes the displayed grid interval so that a comfortable 
number of grid dots appears on screen at any zoom level. The displayed grid interval will be 
equal to a multiple of the grid unit. The possible grid intervals are grid unit times a power of 
ten or any such value divided by two. As you increase the zoom level, the grid interval 
becomes smaller to the point of the finest resolution until it reaches the grid unit. It will never 
be smaller than the grid unit.  

• Fixed Grid: The interval displayed between grid dots is always equal to the grid unit, at any 
zoom level. The grid interval does not change until the screen is almost filled with grid dots. 
When there are too many dots to display, the grid becomes invisible, but it is still on. 

To Toggle between a Fixed Interval and Variable Interval Grid: 
1. On the View Menu, go to Grid. 

The position of the bullet indicates the status of the grid: 

• If there is a bullet on Variable, the grid interval is variable depending on zoom level. 

• If there is a bullet on Fixed, the grid interval is fixed regardless of zoom level. 

2. To switch between the two states, click Variable or Fixed. 

 Ctrl+G 

  Up = Fixed, Down = Variable 

Grid Units 

 
The grid unit is the basis of the grid interval, the space between grid points. 

To Set the Grid Units: 
1. On the View menu, click, Grid-Units. 

2. Set the grid unit. 
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Properties 
You can display the properties of selected elements, properties such as a general property breakdown 
of the selection, a D Code breakdown of the selection, or a Tool code breakdown of the selection. 

Selected Element Properties 

 
The system can show you the properties of the selected elements, including: 

• Total Number of Elements Selected 

• Number of Pads Selected 

• Number of Traces Selected 

• Number of Arcs Selected 

• D Codes of Selected Elements 

• Layers of Selected Elements 

• Nets of Selected Elements 

• Dimensions of Selection 

To See Properties of the Selected Elements: 
Ø On the View menu, click Selection-Properties. 

Selected Element D Code Properties 

 
The system can show you the D Code properties of the selected elements, including: 

• All D Codes in the selection, sorted by size 

• The shape and dimensions of each D Code 

To See the D Code Properties of the Selected Elements: 
Ø On the View menu, click Selection-D Codes. 
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Selected Element Drill Properties 

 
The system can show you the properties of all elements in the selection that represent drill data 
(D Code Type N). The properties include: 

• D Codes of NC drill data in the selection, sorted by size 

• The diameter and Tool Code of each NC drill D Code 

To See the NC Drill D Code Properties of the Selected Elements: 
Ø On the View menu, click Selection-NC Tools. 
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Cursor Options 
There are several options for how the crosshair cursor is displayed and how it is controlled by the 
mouse pointer. 

Full-Screen Cursor 

 
The crosshair cursor can be displayed at a small size (an inch or so), or it can be displayed at full-
screen size. 

To Toggle the Crosshair between Full-Screen Size and Small Size: 
1. On the View menu, go to Full Screen Cursor. 

• If there is a checkmark next to Full Screen Cursor, then the cursor is displayed at full-
screen size. 

• If there is a no checkmark next to Full Screen Cursor, then the cursor is displayed at 
small size. 

2. To change the size, click Full Screen Cursor. 

  Up = Small Cursor, Down = Full Screen 

Separate the Crosshair and Mouse Cursor 

 
The program allows you to separate the crosshair cursor and the arrow-shaped mouse pointer cursor. 
Do this when you need to leave the crosshair at a specific location on screen but you need to use the 
mouse to activate a command.  

To Separate the Crosshair and the Mouse Cursor: 
Ø Press Spacebar. 
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Refresh Screen 

 
The Refresh command redraws the screen. Use this command if you ever abort a lengthy operation and 
leave the screen partially drawn.  

To Refresh the Screen: 
Ø On the View menu, click Refresh. 

 End 
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Chapter 4 
Edit Plot Data 

The program has many features for inserting data, selecting data for editing, editing selected data, and 
editing entire layers of data. In addition, there are few special commands that edit existing data but do 
not use selection.  

Insert New Plot Data 
You can insert all types of data: pads and traces; special classes of traces and trace combinations such 
as orthogonals, 90-degree pairs, rectangular polygons, elbows; several types of arcs such as circles, 3-
points arcs, chord and tangent arcs, chord and point arcs, center and chord arcs; and text. 

Many of the commands for inserting new data are available on the Insert Toolbar.  

 

Insert Toolbar 

To Display the Insert Toolbar: 
Ø On the View menu, look at Toolbars-Insert. 

• If Insert has a checkmark next to it, then the Insert Toolbar is displayed. 

• If Insert does not have a checkmark next to it, then the Insert Toolbar is not displayed. 

To change the display of the Insert Toolbar, click Insert. 

  Insert Toolbar button on Main Toolbar. Down = Displayed, Up = Not Displayed 
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Insert Pad 

 
The Insert Pad feature inserts pads of the current D Code on the active, visible layers. 

To Insert Pads: 
1. Set the Current D Code. See Current D Code on page 314.  

2. Set the Active Layers, and the Visible Layers. See Select from the Active Layers on page 152. 

3. On the Edit Menu, click Insert-Pad. 

 

Insert Pad Tool 

4. Position the cursor where you want the pad. 

5. Click the mouse or press Enter. 

The Pad Insertion tool remains selected, so you can insert one pad after another. 

6. To stop inserting pads, click a different editing tool or press Esc. 

 Insert Key = Pops up list of insert tool types. 
Enter = Inserts selected type. 
Esc = Releases insert tool. 
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Insert Trace 

 
The Insert Trace feature inserts traces of the current D Code on the active, visible layers. 

To Insert Traces: 
1. Set the Current D Code. See Current D Code on page 314. 

2. Set the Active Layers, and the Visible Layers. See Select from the Active Layers on page 152. 

3. On the Edit Menu, click Insert-Trace. 

 

Insert Trace Tool 

4. Position the cursor where you want the trace to start. 

5. Click the mouse or press Enter. 

6. Position the cursor where you want the trace to end. 

7. Click the mouse or press Enter. 

The end of the last trace becomes the beginning of the next, so you can chain one trace to another. 

• To end a trace without chaining, Double-Click or double-press Enter. 

• To stop inserting traces, click a different editing tool or press Esc. 

 Insert Key = Pops up list of insert tool types. 
Enter = Inserts selected type. 
Esc = Releases insert tool. 
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Insert Orthogonal Trace 

 
Orthogonal traces are traces that are exactly horizontal, vertical or at 45 degrees. The Insert Orthogonal 
Traces feature inserts orthogonal traces of the current D Code on the active, visible layers. 

To Insert Orthogonal Traces: 
1. Set the Current D Code. See Current D Code on page 314. 

2. Set the Active Layers, and the Visible Layers. See Select from the Active Layers on page 152. 

3. On the Edit Menu, click Insert-Orthogonal Trace. 

 

Insert Orthogonal Trace Tool 

4. Position the cursor where you want the orthogonal trace to start. 

5. Click the mouse or press Enter. 

6. Position the cursor where you want the orthogonal trace to end. 

7. Click the mouse or press Enter. 

The end of the last orthogonal trace becomes the beginning of the next, so you can chain one 
orthogonal trace to another. 

• To end an orthogonal trace without chaining, Double-Click or double-press Enter. 

• To stop inserting orthogonal traces, click a different editing tool or press Esc. 

 Insert Key = Pops up list of insert tool types. 
Enter = Inserts selected type. 
Esc = Releases insert tool. 
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Insert 90-Degree Trace Pair 

 
The 90-degree trace pair joins a starting point to an ending point using a horizontal trace chained to a 
vertical. The 90-degree trace pair is inserted using the current D Code on the active, visible layers. 

To Insert a 90-Degree Trace Pair: 
1. Set the Current D Code. See Current D Code on page 314. 

2. Set the Active Layers, and the Visible Layers. See Select from the Active Layers on page 152. 

3. On the Edit Menu, click Insert-90-Degree Trace Pair. 

 

Insert 90-Degree Trace Pair Tool 

4. Position the cursor where you want the first trace to start. 

5. Click the mouse or press Enter. 

6. Position the cursor where you want the second trace to end. 

7. Click the mouse or press Enter. 

The end of the last 90-degree trace pair becomes the beginning of the next, so you can chain one 
90-degree trace pair to another. 

• To end a 90-degree trace pair without chaining, Double-Click or double-press Enter. 

• To stop inserting 90-degree trace pairs, click a different editing tool or press Esc. 

 Insert Key = Pops up list of insert tool types. 
Enter = Inserts selected type. 
Esc = Releases insert tool. 
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Insert Elbow in Existing Trace 

 
Inserting an elbow in a trace creates two chained traces that connect the same endpoints as the original 
trace but meet in an offset vertex. 

To Insert an Elbow in an Existing Trace: 
1. Set the Active Layers, and the Visible Layers so that the existing trace is on an active visible 

layer. See Select from the Active Layers on page 152. 

2. On the Edit Menu, click Insert-Elbow. 

 

Insert Elbow Tool 

3. Position the cursor near the trace in which you want to insert an elbow. 

4. Click the mouse or press Enter. 

5. Position the cursor where you want the elbow vertex. 

6. Click the mouse or press Enter. 

The Elbow Insertion tool remains selected, so you can insert elbows in one trace after another. 

• To cancel inserting an elbow before setting the vertex point, press Esc. 

• To stop inserting elbows, click a different editing tool or press Esc. 

 Insert Key = Pops up list of insert tool types. 
Enter = Inserts selected type. 
Esc = Releases insert tool. 
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Insert 90-Degree Elbow in Existing Trace 

 
Inserting a 90-degree elbow in a trace creates a series of chained horizontal and vertical traces that 
connect the same endpoints as the original trace but pass through an offset cursor position. 

To Insert a 90-Degree Elbow in an Existing Trace: 
1. Set the Active Layers and the Visible Layers so that the existing trace is on an active visible 

layer. See Select from the Active Layers on page 152. 

2. On the Edit Menu, click Insert-90-Degree Elbow. 

 

Insert 90-Degree Elbow Tool 

3. Position the cursor near the trace in which you want to insert a 90-degree elbow. 

4. Click the mouse or press Enter. 

5. Position the cursor where you want the new trace path to pass through. 

To create a two-trace elbow with only one horizontal and one vertical trace, use the Align 
command to align the cursor to one end of the original trace. 

6. Click the mouse or press Enter. 

The 90-Degree Elbow Insertion tool remains selected, so you can insert 90-degree elbows in one 
trace after another. 

• To cancel inserting a 90-degree elbow before setting the pass through point, press Esc. 

• To stop inserting 90-degree elbows, click a different editing tool or press Esc. 

 Insert Key = Pops up list of insert tool types. 
Enter = Inserts selected type.  
Esc = Releases insert tool. 
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Insert Drawn Rectangle 

 
The drawn rectangle is a rectangular polygon of chained vertical and horizontal traces. The drawn 
rectangle is inserted using the current D Code on the active, visible layers. 

To Insert a Drawn Rectangle: 
1. Set the Current D Code. See Current D Code on page 314. 

2. Set the Active Layers, and the Visible Layers. See Select from the Active Layers on page 152. 

3. On the Edit Menu, click Insert-Rectangle-Drawn. 

 

Insert Drawn Rectangle Tool 

4. Position the cursor where you want one corner of the drawn rectangle. 

5. Click the mouse or press Enter. 

6. Position the cursor where you want the opposite corner of the drawn rectangle. 

7. Click the mouse or press Enter. 

The Drawn Rectangle Insertion tool remains selected, so you can insert one drawn rectangle after 
another. 

• To cancel inserting a drawn rectangle before setting the second corner, press Esc. 

• To stop inserting drawn rectangles, click a different editing tool or press Esc. 

 Insert Key = Pops up list of insert tool types. 
Enter = Inserts selected type.  
Esc = Releases insert tool. 
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Insert Frame-Sized Rectangular Polygon 

 
The Insert Frame-Sized Rectangular Polygon command inserts a rectangular polygon at the same size 
as the Reference Frame using the current D Code on the active, visible layers. 

To Insert a Reference Frame-Sized Rectangular Polygon: 
1. Set the Active Layers, and the Visible Layers. See Select from the Active Layers on page 152. 

2. Position the Reference Frame at the size and location that you want the new pad. See 
Reference Frame on page 177. 

3. Set the Current D Code. See Current D Code on page 314. 

4. On the Edit Menu, click Insert-Rectangle-Frame Sized 

 Shift+B 

Insert Frame-Sized Pad 

 
The Insert Frame-Sized Pad command inserts a pad inside the Reference Frame at the same size as the 
Reference Frame. If needed, a new D Code is created. The frame-sized pad is inserted on the active, 
visible layers. 

To Insert a Reference Frame-Sized Pad: 
1. Set the Active Layers, and the Visible Layers. See Select from the Active Layers on page 152. 

2. Position the Reference Frame at the size and location that you want the new pad. See 
Reference Frame on page 177. 

3. On the Edit Menu, click Insert-Frame Sized Pad 

4. If prompted, enter the D Code for the new pad. 

5. Click the mouse or press Enter. 

 Insert Key = Pops up list of insert commands 

 This key command does not select an insert tool like most of the other insert commands; the 
pad is inserted as soon as the command is selected from the pop up list. 
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Insert Circle 

 
A circle is an arc that forms a complete, joined, circular loop around a centerpoint. The circle is 
inserted using the current D Code on the active, visible layers. 

To Insert a Circle: 
1. Set the Current D Code. See Current D Code on page 314. 

2. Set the Active Layers, and the Visible Layers. See Select from the Active Layers on page 152. 

3. Set the Arc Insertion Direction. 

4. On the Edit Menu, click Insert-Circle. 

 

Insert Circle Tool 

5. Position the cursor where you want the center of the circle. 

6. Click the mouse or press Enter. 

7. Position the cursor at any point on the circle. 

8. Click the mouse or press Enter. 

The Circle Insertion tool remains selected, so you can insert one circle after another. 

• To cancel inserting a circle before setting the outside point, press Esc. 

• To stop inserting circles, click a different editing tool or press Esc. 

 Insert Key = Pops up list of insert tool types. 
Enter = Inserts selected type.  
Esc = Releases insert tool. 
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Insert 3-Point Arc 

 
A 3-point arc is an arc that is defined by three points located on the arc. The 3-point arc is inserted 
using the current D Code on the active, visible layers. 

To Insert a 3-Point Arc: 
1. Set the Current D Code. See Current D Code on page 314. 

2. Set the Active Layers, and the Visible Layers. See Select from the Active Layers on page 152. 

3. Set the Arc Insertion Direction. 

4. On the Edit Menu, click Insert-3-Point Arc. 

 

Insert 3-Point Arc Tool 

5. Position the cursor where you want the 3-point arc to start. 

6. Click the mouse or press Enter. 

7. Position the cursor at a point on the 3-point arc that is between the endpoints.  

8. Click the mouse or press Enter. 

9. Position the cursor where you want the 3-point arc to end. 

10. Click the mouse or press Enter. 

The 3-Point Arc Insertion tool remains selected, so you can insert one 3-point arc after another. 

• To cancel inserting a 3-point arc before setting the endpoint, press Esc. 

• To stop inserting 3-point arcs, click a different editing tool or press Esc. 

 Insert Key = Pops up list of insert tool types. 
Enter = Inserts selected type.  
Esc = Releases insert tool. 
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Insert Chord and Tangent Arc 

 
A chord and tangent arc is an arc that is defined by an endpoint chord and an endpoint tangent. The 
chord and tangent arc is inserted using the current D Code on the active, visible layers. 

To Insert a Chord and Tangent Arc: 
1. Set the Current D Code. See Current D Code on page 314. 

2. Set the Active Layers, and the Visible Layers. See Select from the Active Layers on page 152. 

3. Set the Arc Insertion Direction. 

4. On the Edit Menu, click Insert-Chord and Tangent Arc. 

 

Insert Chord and Tangent Arc Tool 

5. Position the cursor where you want the chord and tangent arc to start. 

6. Click the mouse or press Enter. 

7. Position the cursor where you want the chord and tangent arc to end. 

8. Click the mouse or press Enter. 

9. Position the cursor on a tangent to the endpoint that you just entered. This sets the curvature 
of the arc.  

10. Click the mouse or press Enter. 

The Chord and Tangent Arc Insertion tool remains selected, so you can insert one chord and 
tangent arc after another. 

• To cancel inserting a chord and tangent arc before setting the tangent point, press Esc. 

• To stop inserting chord and tangent arcs, click a different editing tool or press Esc. 

 Insert Key = Pops up list of insert tool types. 
Enter = Inserts selected type.  
Esc = Releases insert tool. 
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Insert Chord and Point Arc 

 
A chord and point arc is an arc that is defined by an endpoint chord and a point on the curve of the arc. 
The chord and point arc is inserted using the current D Code on the active, visible layers. 

To Insert a Chord and Point Arc: 
1. Set the Current D Code. See Current D Code on page 314. 

2. Set the Active Layers, and the Visible Layers. See Select from the Active Layers on page 152. 

3. Set the Arc Insertion Direction. 

4. On the Edit Menu, click Insert-Chord and Point Arc. 

 

Insert Chord and Point Arc Tool 

5. Position the cursor where you want the chord and point arc to start. 

6. Click the mouse or press Enter. 

7. Position the cursor where you want the chord and point arc to end. 

8. Click the mouse or press Enter. 

9. Position the cursor at a point on the curve of the chord and point arc. This sets the curvature 
of the arc.  

10. Click the mouse or press Enter. 

The Chord and Point Arc Insertion tool remains selected, so you can insert one chord and point arc 
after another. 

• To cancel inserting a chord and point arc before setting the point on the curve, press Esc. 

• To stop inserting chord and point arcs, click a different editing tool or press Esc. 

 Insert Key = Pops up list of insert tool types. 
Enter = Inserts selected type.  
Esc = Releases insert tool. 
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Insert Center and Chord Arc 

 
A center and chord arc is an arc that is defined by a centerpoint, a starting point and a point that 
establishes the chord angle. The center and chord arc is inserted using the current D Code on the 
active, visible layers. 

To Insert a Center and Chord Arc: 
1. Set the Current D Code. See Current D Code on page 314. 

2. Set the Active Layers, and the Visible Layers. See Select from the Active Layers on page 152. 

3. Set the Arc Insertion Direction. 

4. On the Edit Menu, click Insert-Center and Chord Arc. 

 

Insert Center and Chord Arc Tool 

5. Position the cursor where you want the center of the center and chord arc. 

6. Click the mouse or press Enter. 

7. Position the cursor where you want the chord and point arc to start. This establishes the start 
point and the radius. 

8. Click the mouse or press Enter. 

9. Position the cursor at a point that is at the desired angle from the starting point. 

10. Click the mouse or press Enter. 

The Center and Chord Arc Insertion tool remains selected, so you can insert one center and chord 
arc after another. 

• To cancel inserting a center and chord arc before setting the final angle, press Esc. 

• To stop inserting center and chord arcs, click a different editing tool or press Esc. 

 Insert Key = Pops up list of insert tool types. 
Enter = Inserts selected type. 
Esc = Releases insert tool. 
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Set Arc Direction - Clockwise/Counterclockwise 

 
Arcs can be inserted in the clockwise or counterclockwise direction. When you insert an arc, this 
determines which direction the arc will be drawn between the points you designate as the start point 
and the end point. Arc direction may also be important if you export data to a router. 

 When you change the arc insertion direction, existing arcs are not changed. 

To Set the Arc Direction Before You Insert an Arc: 
Ø On the Edit menu, look at the Insert-Clockwise Arc Mode menu command. 

This menu command indicates the current arc insertion direction and can switch between 
clockwise and counterclockwise.  

• A check mark indicates clockwise arc insertion. 

• No check mark indicates counterclockwise arc insertion. 

• To change insertion direction, Click on the command. 
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Insert Text 

 
The program can insert text at any size and orientation. The text is inserted with all traces selected so 
you can re-scale it or move it as you wish. The text is inserted using the current D Code on the active, 
visible layers. 

To Insert Text: 
1. Set the Current D Code. See Current D Code on page 314. 

2. Set the Active Layers, and the Visible Layers. See Select from the Active Layers on page 152. 

3. Clear the current selection, by going to the Edit Menu and clicking Select-Clear Selection. 

4. Position the crosshair where you want the text to start. 

5. Separate the crosshair and the cursor. See Separate the Crosshair and Mouse Cursor on page 
112. 

6. On the Edit Menu, click Insert-Text. 

 

Insert Text Dialog 

7. Set the Size of the text. 
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8. Set the Orientation of the text. 

9. Set the Font of the text. 

10. The dialog shows the Current D Code that will be used to form the text traces, and you can 
change the D Code here if you want to.  

11. Type the text. 

12. Click the mouse or press Enter. 

13. The program inserts the text into the plot and selects it. If the size, position or orientation is 
not what you need, use Scale, Move, Mirror, or Rotate to edit the selected traces. 

 Insert Key = Pops up list of insert tool types. 
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Edit Selected Plot Data 
The program has many commands for editing selected elements. Selected elements can be deleted, 
moved, copied, centered, transferred, replicated, mirrored, rotated, scaled, transcoded, snapped to grid 
and stepped and repeated. For information on how to select elements for these types of editing 
operations, see Select Elements for Editing on page 150. 

Many of the commands for editing selected data are available on the Edit Toolbar.  

 

Edit Toolbar 

To Display the Edit Toolbar: 
Ø On the View menu, look at Toolbars-Edit. 

• If Edit has a checkmark next to it, then the Edit Toolbar is displayed. 

• If Edit does not have a checkmark next to it, then the Edit Toolbar is not displayed. 

To change the display of the Edit Toolbar, click Edit. 

  Edit Toolbar button on Main Toolbar. Down = Displayed, Up = Not Displayed 
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Delete Selected Elements 

 

To Delete Selected Elements: 
1. Select the elements. See Select Elements for Editing on page 150.  

2. On the Edit Menu, click Edit Selection-Delete. 

 Delete Key 

  

 Instead of using the Delete command, you may want to use the Transfer command to transfer 
unwanted elements to an unused layer. The commands that delete groups of elements can’t be 
undone. Elements transferred to an unused layer can be recovered later if necessary. 

Move Selected Elements 

 

To Move Selected Elements: 
1. Select the elements. See Select Elements for Editing on page 150. 

2. On the Edit Menu, click Edit Selection-Move. 

 

Move Tool 

3. Position the cursor at a reference point. 

4. Click the mouse or press Enter. 

5. Position the cursor where you want the reference point and selected elements to move to. 

6. Click the mouse or press Enter. 

The selected elements move to the new cursor position. 

 Shift+M 
Enter = Activate move tool. 

  

 For precision, use the Align and Go To Coordinate commands when setting the reference and 
move-to points. 
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Copy Selected Elements 

 

To Copy Selected Elements: 
1. Select the elements. See Select Elements for Editing on page 150. 

2. On the Edit Menu, click Edit Selection-Copy. 

 

Copy Tool 

3. Position the cursor at a reference point. 

4. Click the mouse or press Enter. 

5. Position the cursor where you want the new elements to be copied to. 

6. Click the mouse or press Enter. 

 K 

  

 For precision, use the Align and Go To Coordinate commands when setting the reference and 
copy-to points. 

Center Selected Elements to the Reference Frame 

 

To Center Selected Elements to the Reference Frame: 
1. Position the Reference Frame where you want the selected elements to be centered. See 

Reference Frame on page 177. 

2. Select the elements. See Select Elements for Editing on page 150. 

3. On the Edit Menu, click Edit Selection-Center to Frame. 

The selected elements move to the center of the Reference Frame. 
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Transfer Selected Elements 

 
The transfer command removes elements from one layer and transfers them to another layer. 

To Transfer Selected Elements: 
1. Select the elements. See Select Elements for Editing on page 150. 

2. On the Edit Menu, click Edit Selection-Transfer. 

 

Transfer Elements Dialog 

3. Enter the destination layer.  

 If elements are selected from more than one layer, the destination layer is the first layer that 
elements will be transferred to. 

 J 
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Replicate Selected Elements 

 
The replicate command copies elements to another layer without removing them from their original 
layer. 

To Replicate Selected Elements: 
1. Select the elements. See Select Elements for Editing on page 150. 

2. On the Edit Menu, click Edit Selection-Replicate. 

 

Replicate Elements Dialog 

3. Enter the destination layer. 

 If elements are selected from more than one layer, the destination layer is the first layer that 
elements will be transferred to. 

 Ctrl+J 
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Mirror Selected Elements 

 
The mirror commands flip the image composed of the selected elements. The elements are flipped in 
the X or Y direction, and are flipped to the opposite side of a reference point. The program reassigns 
shapes H, T and M to existing D Codes of the correct size or new D Codes defined to match the 
aperture. Other shapes are not affected by mirroring.  

To Mirror Selected Elements: 
1. Select the elements. See Select Elements for Editing on page 150. 

2. On the Edit Menu, click Edit Selection-Mirror X or Mirror Y. 

 

Mirror Elements Dialog 

3. Select whether to mirror around a cursor position that you can set, or around the center of the 
group of selected elements.  

 

Mirror Tool 

4. If you are mirroring around the cursor position, then position the cursor and click the mouse 
or press Enter. 
If you are mirroring around the center of the selection, click anywhere or press Enter.  

The elements flip and stay selected.  

 Shift+X 
Shift+Y 

  for Mirror X, and  for Mirror Y 
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Rotate Selected Elements 

 
The rotate command rotates the image composed of the selected elements. The selected elements are 
rotated counterclockwise around a reference point.  

If the angle of rotation is a multiple of 90 degrees, the program transcodes the X, Y asymmetrical 
shapes (shape codes R, O, X, H, T and M) to existing D Codes of the correct size or new D Codes 
defined to match the aperture. Generally these shapes will have the same shape code, but new, rotated 
dimensions. 

 If the angle is not a multiple of 90 degrees, the program transcodes shapes to new or existing D Codes 
to match the rotated aperture. For some shape codes, such as circles, no transcoding is necessary. For 
other shapes codes, such as heat reliefs (H) or customs (M), the shape code remains the same but the 
parameters or dimensions change to accommodate the new angle. For most shapes (types S, R, O, X, 
etc.), the shapes are transcoded to new Custom Aperture D Codes (type M) defined to match the 
rotated aperture. Targets (type T) are not rotated, by non-90-degree increments. 

To Rotate Selected Elements: 
1. Select the elements. See Select Elements for Editing on page 150. 

2. On the Edit Menu, click Edit Selection-Rotate. 

 

Rotate Elements Dialog 

3. Select whether to rotate around a Cursor Position that you can set, or around the Center of 
the group of selected elements.  
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Rotation Angle Dialog 

4. Set the Rotation Angle. 

 

Rotate Tool 

5. If you are rotating around the cursor position, then position the cursor and click the mouse or 
press Enter. 

 Ctrl+R 
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Scale Selected Elements 

 
The scale command scales the image of the selected elements. If the X and Y scale factors are the 
same, the program can also scale the D Codes of the selected elements. 

 The Scale command does not transcode selected elements as their D Codes are scaled. So 
non-selected elements of the same D Code will also have their D Codes scaled. 

To Scale Selected Elements: 
1. Select the elements. See Select Elements for Editing on page 150. 

2. On the Edit Menu, click Edit Selection-Scale. 

 

Scale Elements Dialog 

3. Set the X and Y Scale Factors. 

4. If the X and Y factors are the same, set whether to also scale the D Codes of the selected 
elements. 

5. Set whether to scale around a cursor position that you can set, or around the center of the 
group of selected elements.  

6. If you are scaling around the cursor position, then position the cursor and click the mouse or 
press Enter. 
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Transcode Selected Elements 

 
The Transcode command changes the D Code assignment of selected elements. 

To Transcode Selected Elements to a New D Code: 
1. Select the elements. See Select Elements for Editing on page 150. 

2. On the Edit Menu, click Edit Selection-Trasnscode. 

 

Transcode Elements 

3. Set the new D Code. 

 Ctrl+T 
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Snap Selected Elements to the Grid 

 
The Snap to Grid command moves selected elements to the nearest Grid points. This command should 
only be used to fine tune data that was designed for a grid. If you use too large a grid unit or a large 
tolerance, you may get elements stacked. For information about the Grid, see Screen Grid on page 107. 

To Snap Selected Elements to the Grid: 
1. Set the Grid Unit. 

2. Turn the Grid On. 

3. Make sure the Grid is Anchored where you want it. 

4. Make sure the Grid is Fixed. 

5. Select the elements you want to snap to the Grid. See Select Elements for Editing on page 
150. 

6. On the Edit menu, click Edit Selection-Snap to Grid. 

 

Snap to Grid Tolerance Dialog 

7. On the Tolerance dialog, set a tolerance distance: 

If the tolerance is any value other than zero, selected elements within the tolerance distance of the 
nearest grid point will be snapped to the grid point, while elements that are not within tolerance 
distance will not be snapped. If the tolerance is zero, the elements are snapped to the nearest grid 
point regardless of distance. 

8. Click OK. 

 Ctrl+M 

 The program can also snap data to a Padmaster Layer. 
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Step and Repeat Selected Data 
The Step and Repeat command makes multiple copies of selected elements and positions the copies in 
an array as specified.  

Differences between a Coded SR Block and Copied Step and Repeat 

 
The program can handle stepped and repeated data in two ways.  

Copy the Stepped and Repeated Data 
The original image can be stepped and repeated by copying the original data to the new locations in the 
step and repeat array. After being stepped and repeated in this way, the elements in the array have no 
special relationship to each other in the database; they are ungrouped elements like any other and can 
be selected and edited in the normal way. When you step and repeat selected elements this way, it 
makes the database proportionately larger because the process makes multiple copies of the design 
data, and all the copies have to be stored in the file. 

Use Coded SR Blocks for the Stepped and Repeated Data 
The original image can be stepped and repeated by adding a step and repeat code block into the 
database. The step and repeat code block indicates that the data of the original image is part of a step 
and repeat array. This process does not make a physical copy of the original data for each image in the 
array. Instead it groups the original data into a block and adds a code that tells the system to display or 
output an array whenever the data is displayed, printed or plotted. In this system, the elements of the 
array are not individual elements like any other. They are grouped elements that must be selected and 
edited as a group. When you step and repeat selected elements this way, it makes the database only 
slightly larger than it was before the step and repeat operation because the process does not make 
multiple copies of the design data. Files that use coded step and repeat can be much smaller than files 
in which the step and repeat arrays are made with copied data. 

The program can generate coded step and repeat blocks during a step and repeat operation. But it can 
also import coded step and repeat blocks Extended Gerber, MDA Autoplot,, and Drill Files. 
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Step and Repeat Selected Elements 

 
The Step and Repeat command makes multiple copies of selected elements and positions the copies in 
an array as specified.  

To Step and Repeat Selected Elements: 
1. Select the elements. See Select Elements for Editing on page 150. 

2. On the Edit Menu, click Edit Selection-Step and Repeat-New. 

 

Step and Repeat Dialog 
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3. On the Step and Repeat Selected Elements dialog: 

• Enter the number of images you want in the X and Y dimensions. This includes the 
original image. 

• Enter the distance you want between each image in the Step Distance boxes. 

• Click on the method you want for calculating the distance between each image. 

To Corresponding Elements: This options places the stepped images so that they have the 
step distance between corresponding elements in adjacent images. 

To Edges of Images: This option places the stepped images so that they have the step 
distance between the edges of adjacent images. 

To Centers of Edge Elements: This option places the stepped images so that they have the 
step distance between the centerpoints of elements at the edges of adjacent images. 

• Select whether to use step and repeat blocks.  

Copy the data: The image can be stepped and repeated by copying the original data to the 
new locations. To copy the data to new locations, be sure the Use Step and Repeat Blocks 
option does not have a checkmark.  

Use Step and Repeat Blocks: Or the image can be stepped and repeated by adding a step and 
repeat code block into the database which indicates that the data of the original image is part 
of a step and repeat array. To use coded step and repeat blocks, click the Use Step and Repeat 
Blocks option so that it has a checkmark. 

 The choice to use step and repeat blocks does not make a difference in how the image is 
displayed. But it does make a difference in how the data can be selected, edited and saved 
later. 

4. Click OK. 

 Shift+K 
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Convert Coded SR Blocks to Copied Step and Repeat Data 

 
Data that is in a coded step and repeat block is said to be “grouped.” This means that it can only be 
selected and edited as a group and not as individual elements. If you want to edit individual elements 
of a coded step and repeat block while not affecting other elements in the array, you must convert the 
coded step and repeat block into individual copied elements using the Ungroup command. 

To Ungroup Elements of a Single Coded SR Block: 
1. Select the coded step and repeat block that you want to convert. See Select Elements for 

Editing on page 150. 

2. On the Edit menu, click Edit Selection-Step and Repeat-Ungroup. 

You can also ungroup all step and repeat blocks in the entire database simultaneously. 

To Ungroup All Coded Step and Repeat Blocks: 
Ø On the Edit menu, click All Step and Repeats-Ungroup. 
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Change Step and Repeat Parameters of a Coded SR Block 

 
Data that is in a coded step and repeat block is said to be “grouped.” This means that it can only be 
selected and edited as a group and not as individual elements. If you want to change the step and repeat 
parameters of a coded step and repeat block (i.e., change the number of copies in the array or change 
the step distance), use the Change command. 

To Change Step and Repeat Parameters of a Coded SR Block: 
1. Select the coded step and repeat block that you want to convert. See Select Elements for 

Editing on page 150. 

2. On the Edit menu, click Edit Selection-Step and Repeat-Change. 

 

Step and Repeat 
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3. On the Step and Repeat Selected Elements dialog: 

• Enter the number of images you want in the X and Y dimensions. This includes the 
original image. 

• Enter the distance you want between each image in the Step Distance boxes. 

• Click on the method you want for calculating the distance between each image. 

To Corresponding Elements: This options places the stepped images so that they have the 
step distance between corresponding elements in adjacent images. 

To Edges of Images: This option places the stepped images so that they have the step 
distance between the edges of adjacent images. 

To Centers of Edge Elements: This option places the stepped images so that they have the 
step distance between the centerpoints of elements at the edges of adjacent images. 

• Select whether to use step and repeat blocks.  

Copy the data: The image can be stepped and repeated by copying the original data to the 
new locations. To copy the data to new locations, be sure the Use Step and Repeat Blocks 
option does not have a checkmark.  

Use Step and Repeat Blocks: Or the image can be stepped and repeated by adding a step and 
repeat code block into the database which indicates that the data of the original image is part 
of a step and repeat array. To use coded step and repeat blocks, click the Use Step and Repeat 
Blocks option so that it has a checkmark. 

 The choice to use step and repeat blocks does not make a difference in how the image is 
displayed. But it does make a difference in how the data can be selected and edited later. 

4. Click OK. 
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Select and Edit One-Up Image of a Coded SR Block 

 
Data that is in a coded step and repeat block is said to be “grouped.” This means that it can only be 
selected and edited as a group and not as individual elements. If you want to edit individual elements 
in the one up image of a coded step and repeat block, you must convert the coded step and repeat block 
back into the individual elements of the one-up image using the One-Up command. 

To Convert Elements of a Single Coded SR Block Back into a One-Up Image: 
1. Select the coded step and repeat block that you want to convert. See Select Elements for 

Editing on page 150. 

2. On the Edit menu, click Edit Selection-Step and Repeat-One Up. 

The stepped and repeated images of the array are replaced by the single one-up image. 

You can also convert all step and repeat blocks in the entire database back to their one-up images 
simultaneously. 

To Convert All Coded SR Blocks to One-Up Images: 
Ø On the Edit menu, click All Step and Repeats-One Up. 
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Select Elements for Editing 
Many of the editing commands act on Selected Elements. Selected elements are shown highlighted in 
white or in contrasting color. So, when you activate an editing commend such as Delete or Copy, the 
command will affect the selected elements highlighted in white or in contrasting color. 

To make group editing of specific classes of elements easier, there are several selection criteria to limit 
what can be selected for editing. You can limit your selections to: 

• Only a single layer or all visible layers  

• Only the current D Code or any D Code  

• Only the current net or any net  

• Any class of element or only a specified class of element such as pads, traces, arcs, orthogonal 
traces, vertical traces, horizontal traces, 45-degree traces, non-orthogonal traces, chains of 
traces, polygons of traces, drawn pads, or a specified shape code 

The selection criteria affect what can be selected when you select anything, regardless of whether it is 
a command to select a single element, a group of elements, a global selection from the entire database, 
or a chain of traces. The selection criteria do not affect what can be selected when you select all data. 

When you have a selection in place, you can also add to the current selection, remove from the current 
selection, invert the selection, and clear the selection. 

Selected elements can be made visible or not visible and they can be displayed in white or in 
contrasting color. For information on how to adjust the view of selected items, see Element Visibility 
on page 84. 

Many of the commands for selecting data are available on the Selection Toolbar.  

 

Selection Toolbar 

To Display the Selection Toolbar: 
Ø On the View menu, look at Toolbars-Selection. 

• If Selection has a checkmark next to it, then the Selection Toolbar is displayed. 

• If Selection does not have a checkmark next to it, then the Selection Toolbar is not 
displayed. 

To change the display of the Selection Toolbar, click Selection. 

  Selection Toolbar button on Main Toolbar. Down = Displayed, Up = Not Displayed 
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Some of the features for controlling selection criteria are available on the Current Element Toolbar.  

 

Current Element Toolbar 

To Display the Current Element Toolbar: 
Ø On the View menu, look at Toolbars-Current Element. 

• If Current Element has a checkmark next to it, then the Current Element Toolbar is 
displayed. 

• If Current Element does not have a checkmark next to it, then the Current Element 
Toolbar is not displayed. 

To change the display of the Current Element Toolbar, click Current Element. 
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Selection Criteria 
Selection criteria limit what can be selected for editing. 

Select from the Active Layers 

 
In order for elements in a layer to be selected or for elements to be inserted into a layer, the layer must 
be Active and Visible. Visible layers are indicated in the Layers Toolbar and in the Layers Table. If 
more than one layer is visible, you can designate one single layer to be active or all visible layers as 
active.  

The single active layer is indicated in the drop down layers list on the Current Element Toolbar and 
when the “Only” button next to the list is down.  

To Set a Single Active Layer: 
1. Double-click on the layer in the Layers Toolbar to make the layer visible. 

2. On the Current Element Toolbar pick the Active Layer from the drop down list. 

3. On the Current Element Toolbar click the “Only” button next the drop down layers list so 
that the button is down. 

  Active layer controls n the Current Element Toolbar. 
“Only” button up = All visible layers active, Down = Only the single layer is active.  

 0 (Zero) = Toggle between all layers active and single layer active (Changes the “Only” 
setting). 

Related Key Commands: 
The following key commands set the active layer but do not affect visibility or the “Only” 
button setting: 
 
1 through 9 = Quick Set Active Layer  
L = Set Active Layer  
Plus Key = Set Next Sequential Layer as Active Layer  
Backspace Key = Set Previous Sequential Layer as Active Layer  
 
The following key commands make a single layer the active visible layer in an alternative 
way. They shut off visibility to all other layers, turn on visibility to the single layer, and make 
it active: 
 
Ctrl+1 through 9 = Quick Set Single Active Visible Layer  
Ctrl+L = Set Single Active Visible Layer  
Ctrl+Plus Key = Set Next Sequential Layer as Single Active Visible Layer  
Ctrl+Backspace Key = Set Previous Sequential Layer as Single Active Visible Layer  

All visible layers are active when the “Only” button next to the drop down list is up. 
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To Make All Visible Layers Active: 
1. Double-click on the layers you want to edit in the Layers Toolbar to make them visible. 

2. On the Current Element Toolbar click the “Only” button next the drop down layers list so 
that the button is up. 

 0 (Zero) = Toggle between all layers active and single layer active (Changes the “Only” 
setting). 

  Active layer controls n the Current Element Toolbar. 
“Only” button up = All visible layers active, Down = Only the single layer is active.  

Select by Current D Code 

 
The Current D Code is the D Code indicated on the Current Element Toolbar. All newly inserted 
elements will be of the current D Code. You can also limit selection to only elements of the current 
D Code or allow elements of any D Code to be selected.  

To Limit Selection to Only the Current D Code: 
1. Set the current D Code in the Current Element Toolbar. 

2. Click the “Only” button next to the Current D Code in the Current Element Toolbar so 
the button is down. 

  Current D Code controls on Current Element Toolbar. 
“Only” button up = All D Codes active, Down = Only the single D Code is active.  

To Allow Elements of Any D Code to be Selected: 
Ø Click the “Only” button next to the Current D Code in the Current Element Toolbar so the 

button is up. 

 Shift+D = Set Current D Code 
Ctrl+D = Toggle Select Only Current D Code and Select Any D Code 

  Current D Code controls on Current Element Toolbar. 
“Only” button up = All D Codes active, Down = Only the single D Code is active.  
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Select by Current Net  
The Current Net is the Net indicated on the Current Element Toolbar. You can limit selection to only 
elements of the Current Net or allow elements of any Net to be selected.  

To Limit Selection to Only the Current Net: 
1. Set the Current Net in the Current Element Toolbar. 

2. Click the “Only” button next to the Current Net in the Current Element Toolbar so the 
button is down. 

  Current Net controls on the Current Element Toolbar. 
“Only” button up = All nets active, Down = Only the single net is active.  

To Allow Elements of Any Net to be Selected: 
Ø Click the “Only” button next to the Current Net in the Current Element Toolbar so the button 

is up. 

 Ctrl+Shift+N = Set the Current Net in the Current Element Toolbar. 
Ctrl+F = Toggle Between Select Only Current Net and Select Any Net 

  Current Net controls on the Current Element Toolbar. 
“Only” button up = All nets active, Down = Only the single net is active.  

 Some netlist databases, such as those extracted using the CAMMaster Raster Netlist 
Extraction routine flag single-point nets as “N/C” and flag elements which cause short 
circuits between different types of plane layers as “S/C.” For these types of netlist databases, 
you may also select single point nets elements or short circuit elements by entering a net 
number of “N/C” or “S/C”, respectively, into the Current Net field. 
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Select a Special Class of Element 

 
You can limit selection to specialized classes of elements, or allow any class of element to be selected. 
The class of element is indicated on the drop down list on the Selection Toolbar. The types of element 
classes that you can select are: 

• Any: No limitations, all types of elements can be selected. 

• Pads 

• Traces 

• Arcs 

• Orthogonal Traces 

• Vertical Traces 

• Horizontal Traces 

• 45-Degree Traces 

• Non-Orthogonal Traces 

• Chains of Traces 

• Polygons of Traces 

• Drawn Pads 

• Shape Code (C, S, R, O, D, H, T, E, N, M, F, ?) 

To Limit Selection to Only a Special Element Class: 
Ø On the drop down list on the Selection Toolbar, click the type of special element class you 

want to select so the special element class is displayed. 

 P = Select Pads Only 
T = Select Traces Only 

  Special Element Class Control on Selection Toolbar. 

To Allow Elements of Any Class to be Selected: 
Ø On the drop down list on the Selection Toolbar, click “Any” so that “Any” is displayed. 

 U = Unrestricted, select Any Element 

  Special Element Class Control on Selection Toolbar. 
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Select a Single Element 

 

To Select a Single Element: 
1. Set the selection criteria that you want to use, if any: 

• Active Layer  

• Current D Code  

• Current Net  

• Special Element Class  

2. On the Edit menu, click Select-Selection Tool. 

 

Selection Tool 

3. Click near the element you want to select. 

The closest element that meets the selection criteria will be selected and highlighted. 

 S = Selection Tool 
Enter = Select Element Near Tool 

  On Editing Toolbar 

To Select a Single Element Using the Double-Click Shortcut: 
1. Set the selection criteria that you want to use, if any: 

• Active Layer  

• Current D Code  

• Current Net  

• Special Element Class  

 

Selection Tool 

2. Without any tool selected (i.e., insert pad tool, draw frame tool, zoom tool etc.), double-click 
near the element you want to select. 

The closest element that meets the selection criteria will be selected and highlighted. 
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Select a Group of Elements 

 
You can select a group of elements from inside or outside of an area. 

To Select a Group of Elements: 
1. Set the selection criteria that you want to use, if any: 

• Active Layer  

• Current D Code  

• Current Net  

• Special Element Class  

2. On the Edit menu, click Select-Options. 

3. Pick whether to select inside or outside the selection frame. 

4. On the Edit menu, click Select-Selection Tool. 

 

Selection Tool 

5. Drag the mouse across the group of elements you want to select. Or for accuracy, press Tab 
at one corner of the area you want to select and press Tab again at the other corner. 

All elements defined by the drag area that meet the selection criteria will be selected and 
highlighted. 

 I = Toggle between Inside and Outside Frame 
S = Selection Tool 
Tab = Start selection area. Press again to end selection area. 

  = Selection Tool 
 

 = Toggle between Inside and Outside Frame 
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Select All Data 

 
The Select All Data command selects all data in the database. It is not limited by the selection criteria. 
The Select All Data command is different than the Global Select command because the Global Select 
command uses the selection criteria, while the Select All command does not. 

To Select All Data in the Loaded Database: 

Ø On the Edit menu, click Select-Select All. 

 Ctrl+A 

  

Select Globally from the Entire Database 

 
The Global Select command selects all data in the database that meet the selection criteria. The Global 
Select command is different than the Select All command because the Global Select command uses the 
selection criteria, while the Select All command does not. 

To Select Globally from the Entire Database: 
1. Set the selection criteria that you want to use, if any: 

• Active Layer  

• Current D Code  

• Current Net  

• Special Element Class  

2. On the Edit menu, click Select-Global-New. 

All elements in the loaded database that meet the selection criteria will be selected and 
highlighted. 

 Shift+V 

  

To Add and Remove Global Selections:  
Ø To add a Global selection to an existing selection, use Edit-Select-Global-Add. 

Ø To remove a Global selection from an existing selection, use Edit-Select-Global-Remove. 
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Select a Chain of Traces 

 
You can select a chain of traces. A chain of traces is a series of traces in which the endpoint of one 
trace is the exact start point of another trace. There are no limits on how many traces can be in a chain. 

To Select a Chain of Traces: 
1. Set the selection criteria that you want to use, if any: 

• Active Layer  

• Current D Code  

• Current Net  

• Special Element Class  

2. On the Edit menu, go to Select-Chain- 

• If you want the chain to be able to branch when more than two traces intersect at the 
same endpoint, click Branching. 

• If you want the chain to end when more than two traces intersect at the same endpoint, 
click No Branching. 

 

Chain Selection Tool 

3. Click near the first trace in the chain you want to select. 

To Add and Removing Chain Selections:  
Ø To add a chain of traces to an existing selection, Shift+Click after selecting the chain 

selection tool with Edit-Select-Chain-Branching/No Branching. 

Ø To remove a chain of traces from an existing selection, Ctrl+Click after selecting the chain 
selection tool with Edit-Select-Chain-Branching/No Branching. 
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Select and Edit Entire Array of a Coded SR Block 

 
Data that is in a coded step and repeat block is said to be “grouped.” This means that it can only be 
selected and edited as a group and not as individual elements.  

To Select a Single Coded Step and Repeat Block: 
1. Set the selection criteria that you want to use, if any: 

• Active Layer  

• Current D Code  

• Current Net  

• Special Element Class  

2. On the Edit menu, click Select-Selection Tool. 

 

Selection Tool 

3. Click near the coded step and repeat block you want to select. 

The entire step and repeat array is selected and highlighted. 

4. Edit the entire block together as one entity using any of the editing commands. 

 S = Selection tool 
Enter = Select array near tool 

  = Selection Tool 
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Add to a Selection 

 
You can add elements to a current selection by pressing the Shift key and selecting the elements you 
want to add. 

To Add to a Selection: 
1. Set the selection criteria that you want to use, if any: 

• Active Layer  

• Current D Code  

• Current Net  

• Special Element Class  

2. On the Edit menu, click Select-Selection Tool. 

 

Add to Selection Tool 

• Press the Shift key and Click near the single element you want to add. 

• Press the Shift key and drag across the elements you want to add. 

 S = Selection Tool 
Shift+Enter = Add a single element. 
Shift+Tab = Add elements in a selection area. Press again to end area. 

  = Selection Tool 

To Add a Global Selection:  
Ø To add a Global selection to an existing selection, use Edit-Select-Global-Add. 

To Add a Chain Selection:  
Ø To add a chain of traces to an existing selection, Shift+Click after selecting the chain 

selection tool with Edit-Select-Chain-Branching/No Branching. 



Lavenir CAM Software User’s Guide 

162 

Remove from a Selection 

 
You can remove elements from a current selection by pressing the Ctrl key and selecting the elements 
you want to remove. 

To Remove from a Selection: 
1. Set the selection criteria, if any, for the elements you want to remove from selection: 

• Active Layer  

• Current D Code  

• Current Net  

• Special Element Class  

2. On the Edit menu, click Select-Selection Tool. 

 

Remove from Selection Tool 

• Press the Ctrl key and Click near the element you want to remove. 

• Press the Ctrl key and drag across the elements you want to remove. 

 S = Selection Tool 
Ctrl+Enter = Remove a single element. 
Ctrl+Tab = Remove elements in a selection area. Press again to end area. 

  = Selection Tool 

To Remove a Global Selection:  
Ø To remove a Global selection from an existing selection, use Edit-Select-Global-Remove. 

To Remove a Chain Selection:  
Ø To remove a chain of traces from an existing selection, Ctrl+Click after selecting the chain 

selection tool with Edit-Select-Chain-Branching/No Branching. 
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Invert the Selection 

 
When you invert a selection, all selected data becomes unselected and all unselected data becomes 
selected. 

To Invert the Selection: 
Ø On the Edit menu, click Select-Invert Selection. 

 Ctrl+I 

  

Clear the Selection 

 
The Clear Selection command completely clears a selection so that no elements are currently selected. 

To Clear the Selection:  
Ø On the Edit menu, click Select-Clear Selection. 

 Ctrl+U 
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Edit Entire Layers of Data 
The program has features that allow you to edit entire layers of data without first selecting data. Layers 
can be moved, aligned, centered, transferred, replicated, swapped, and deleted.   

Move Layers 

 
The Move Layers command moves the active layer(s) in the X, Y plane by moving a starting reference 
point to an ending reference point. To move a list of layers, instead of the active layers, see Move 
Chosen Layers on page 165. To move a layer by an exact displacement, see Move Layers by 
Displacement on page 166. Moving a layer is different than transferring a layer because moving a layer 
displaces the data in the X, Y plane while transferring a layer moves it to another layer. 

To Move the Active, Visible Layers: 
1. Set the Active Layers, and the Visible Layers that you want to move. See Select from the 

Active Layers on page 152. 

2. On the Edit Menu, click Layers Move-Move. 

 

Move Layers Tool 

3. Position the cursor at a reference point. 

4. Click the mouse or press Enter. 

5. Position the cursor where you want the reference point and active, visible layers to move to. 

6. Click the mouse or press Enter. 

The active, visible layers move to the new cursor position. 

 Q 

 For precision, use the Align to Element and Go To Coordinate commands when setting the 
reference and move-to points. 
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Move Chosen Layers 

 
The Move Chosen Layers command moves a list of layer in the X, Y plane by moving a starting 
reference point to an ending reference point. To move active layers, instead of a list of layers, see Move 
Layers on page 164. To move a layer by an exact displacement, see Move Layers by Displacement on 
page 166. Moving a layer is different than transferring a layer because moving a layer displaces the 
data in the X, Y plane while transferring a layer moves it to another layer. 

To Move the Chosen Layers: 
1. On the Edit Menu, click Layers Move-Move Chosen. 

2. On the layers dialog, enter a single layer number or a range of layers separated by a dash 
and/or a series of layers separated by commas (i.e., 1-4 or 5,7,9 or 1-4,5,7,9). Or click the 
button to the right, and pick the layers off a list. 

3. Click OK. 

 

Move Layers Tool 

4. Position the cursor at a reference point. 

5. Click the mouse or press Enter. 

6. Position the cursor where you want the reference point and active, visible layers to move to. 

7. Click the mouse or press Enter. 

The active, visible layers move to the new cursor position. 

 For precision, use the Align to Element and Go To Coordinate commands when setting the 
reference and move-to points. 
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Move Layers by Displacement 

 
The Move Layers by Displacement command moves a layer in the X, Y plane by an exact 
displacement. To move a layer by moving a starting reference point to an ending reference point, see 
Move Layers on page 164. Moving a layer is different than transferring a layer because moving a layer 
displaces the data in the X, Y plane while transferring a layer moves it to another layer. 

To Move the Active, Visible Layers by Displacement: 
1. Set the Active Layers, and the Visible Layers that you want to move. See Select from the 

Active Layers on page 152. 

2. On the Edit Menu, click Layers Move-Move by Displacement. 

 

Move Layers by Displacement Dialog 

3. Enter the distance you want the layers to move in the X and Y directions. 

4. Click OK. 

The active, visible layers move by the displacement distance. 
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Align Layers 

 
The program can align active, visible layers by using a reference pad in common to each of the layers. 
The reference pad must be of the same D Code in each of the layers you want to align. The program 
will move the layers so that all the reference pads are aligned. 

To Align the Active, Visible Layers: 
1. Set the Active Layers, and the Visible Layers that you want to move. See Select from the 

Active Layers on page 152. 

2. Select the single pad that you want the other layers to align to. 

3. On the Edit Menu, click Layers Move-Align. 

If the active, visible layers have a pad of the same D Code as the selected reference pad, those 
layers move so that those pads align to the reference pad. 

 Ctrl+Q 

Center Layer to Layers 

 
The Center to Layers command centers the active layer to the combined centerpoint of the other visible 
layers.  

To Center the Active Layer to the Other Visible Layers: 
1. Set the Active Layer to be centered. See Select from the Active Layers on page 152. 

2. Set the visible layers that the active layer will be centered to. 

3. On the Edit Menu, click Layers Move-Center to Layers. 

 Shift+Q 
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Center Layers to Frame 

 
The Center to Frame command moves all active, visible layers to the center of the Reference Frame. 
There are two options with this operation: 

• Move all the active, visible layers as a unit, which preserves their alignment to each other. 

• Or move them all independently so that if individual layers have different centerpoints, they 
move by different amounts and in different directions. 

To Center the Active, Visible Layers to the Reference Frame: 
1. Set the active, visible layers to be centered. See Select from the Active Layers on page 152. 

2. Position the Reference Frame to which the layers will be centered. See Reference Frame on 
page 177. 

3. On the Edit Menu, click Layers Move-Center to Frame. 

4. Select whether to move the layers together as a single unit, or to independently center each 
layer to the Reference Frame. 

 Shift+C 
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Transfer Layers 

 
The Transfer Layers command takes all the data of the source layer and moves it to the destination 
layer. The original data is removed from the source layer. 

To Transfer a Layer: 
1. On the Edit menu, click Layers Move-Transfer. 

 

Transfer Layers Dialog 

2. On the Transfer dialog, select the source layer you want to transfer in the Current Layer 
field. 

3. On the Transfer dialog, select the layer you want the data to be transfer to in the Destination 
Layer field. 

4. If the Destination layer already has data, then the transferred data will be merged into that 
layer’s existing data. 

5. Click OK. 
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Replicate Layers 

 
The Replicate Layers command takes all the data of the source layer and copies it to the destination 
layer. The original data remains in the source layer. 

To Replicate a Layer: 
1. On the Edit menu, click Layers Move-Replicate. 

 

Replicate Layers Dialog 

2. On the Replicate dialog, select the source layer you want to replicate in the Current Layer 
field. 

3. On the Replicate dialog, select the layer you want the data to be replicated to in the 
Destination Layer field. 

4. If the Destination layer already has data, then the replicated data will be merged into that 
layer’s existing data. 

5. Click OK. 
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Swap Layers 

 

To Swap Two Layers: 
1. On the Edit Menu, click Layers Move-Swap. 

 

Swap Layers Dialog 

2. On the Swap dialog, select the two layers you want to swap. 

3. Click OK. 

 Shift+J 

Delete Layers 

 
You can delete data from a layer. You have options to delete all the data, or only the pads, or only the 
traces. 

To Delete Data from a Layer: 
1. Set the Active, Visible Layer from which you want to delete data. See Select from the Active 

Layers on page 152. 

2. On the Edit menu, go to Layers Delete- 

• To delete all the data from the layer, click All. 

• To delete all pads from the layer, click Pads. 

• To delete all traces from the layer, click Traces. 

You can also delete a layer in the Layers Table or delete a layer on the Layers Toolbar. 
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Special Editing Commands 
Some types of editing commands alter existing elements but do not work on selection or on layers. 

Break or Clip Traces 

 
The Break Trace command has two modes of operation, one which breaks a single trace into two 
chained traces, and the other which breaks all traces that cross a region and is usually used for clipping 
data from a region. This command is different than most other editing commands in that it does not use 
selection.  

To Break a Single Trace: 
1. Set the Active Layers, and the Visible Layers. See Select from the Active Layers on page 152. 

2. On the Edit Menu, click Break Traces. 

 

Break Trace Tool 

3. Position the crosshair at the point on the trace where you want the break. 

4. Click the mouse or press Enter. 

The cursor snaps to the trace at the point closest to the cursor. The trace is broken at the cursor 
location and half of the broken trace is selected.  

5. To delete the selected portion of the trace use the Delete Selected Data command 

 Ctrl+B = Select the Break Traces tool 
Enter = Break a Single trace 
Esc = Release the Break Traces tool 

To Clip Data from a Region: 
1. Set the Active Layers, and the Visible Layers. See Select from the Active Layers on page 152. 

2. On the Edit Menu, click Break Traces. 

 

Clip Traces Tool 

3. Position the crosshair at one corner of the area that you want to clip. 
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4. Drag the mouse across the group of elements you want to clip. Or for accuracy, press Tab at 
one corner of the area you want to clip and press Tab again at the other corner. 

All traces that cross the drag frame are broken and the data inside the drag area, including the 
pads, is selected.  

5. To delete the selected data use the Delete Selected Data command 

 Ctrl+B = Select the Break Traces tool  
Tab = Start a clip area and tab again to finish the clip area  
Esc = Release the Break Traces tool 

Break Traces and Replace with Pad 

 
The Break Trace and Replace with Pad command is like a combination of the Break Traces command 
and the Insert Frame-Sized Pad command. The command clips traces that cross a drag frame, deletes 
all data inside the drag frame, and inserts one large pad at the size of the drag frame. The main use of 
the command is to replace drawn fill areas with one pad to reduce file sizes and speed plotting. 

 Not all photoplotters will accept a pad of arbitrarily large size. The Lavenir Pulsar series of 
photoplotters can plot any size of rectangular pad. 

To Break Traces and Replace with a Pad: 
1. Set the Active Layers, and the Visible Layers. See Select from the Active Layers on page 152. 

2. On the Edit Menu, click Break Traces and Replace. 

3. On the D Code for Pad dialog, enter the unused D Code that you want to use to generate the 
replacement pad. 

 

Break  Traces and Replace Tool 

4. Position the crosshair at one corner of the area that you want to clip and replace. 

5. Drag the mouse across the group of elements you want to clip and replace. Or for accuracy, 
press Tab at one corner of the area you want to clip and press Tab again at the other corner. 

All traces that cross the drag frame are broken and the data inside the drag area, including the 
pads, is selected.  

 When the Break Traces and Replace tool is selected: 
Tab = Start a clip area and tab again to finish the clip area  
Esc = Release the Break Traces and Replace tool 
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Stretch Traces 

 
The Stretch Trace command has two modes of operation, one which selects the endpoint of a single 
trace and moves it to a new endpoint, and the other which selects all trace endpoints and pads that lie 
inside a region and move them as a group to a new location. The second is generally used to move a 
group of elements that make up a component while maintaining the same trace connectivity to the rest 
of the board. In both cases, the non-selected endpoints of the traces remain at their old locations and 
the traces are stretched to the new endpoint locations. This command is different than most other 
editing commands in that it does not use selection.  

To Stretch a Single Trace: 
1. Set the Active Layers, and the Visible Layers. See Select from the Active Layers on page 152. 

2. On the Edit Menu, click Stretch Trace. 

 

Stretch Traces Tool 

3. Position the crosshair at the endpoint of the trace you want to stretch. 

4. Click the mouse or press Enter. 

The cursor snaps to the trace at the endpoint closest to the cursor. The system displays a “rubber 
band” stretching from the non-selected endpoint to the cursor. 

5. Position the crosshair at the new location where you want the trace endpoint to be. 

6. Click the mouse or press Enter. 

The selected endpoint moves to the new location, while the non-selected endpoint remains at its 
old location. 

The Stretch Traces tool remains selected, so you can stretch one trace after another. 

7. To stop stretching traces, click a different editing tool or press Esc. 

 Ctrl+Shift+M = Select the Stretch Traces command 
Enter = Stretch a Single trace  
Esc = Release the Stretch Traces tool 
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To Stretch a Group of Traces: 
1. Set the Active Layers, and the Visible Layers. See Select from the Active Layers on page 152. 

2. On the Edit Menu, click Stretch Trace. 

 

Stretch Traces Tool 

3. Position the crosshair at one corner of the area of data that you want to move. 

4. Drag the mouse across the group of elements you want to move. Or for accuracy, press Tab 
at one corner of the area you want to move and press Tab again at the other corner. 

All traces that cross the drag frame are selected as well as all pads and traces inside the drag area. 
The system prompts for the start point of the move. 

5. Position the cursor at a reference point. 

6. Click the mouse or press Enter. 

7. Position the cursor where you want the reference point and selected elements to move to. 

8. Click the mouse or press Enter. 

All selected trace endpoints and pad centerpoints move as a group so that the reference position 
moves to the cursor location. While the non-selected endpoints remains at their old locations. 

The Stretch Traces tool remains selected, so you can stretch more traces. 

9. To stop stretching traces, click a different editing tool or press Esc. 

 Ctrl+Shift+M = Select the Stretch Traces command  
Tab = Start a selection area and Tab again to finish the selection area  
Enter = First reference point and Enter again for the second reference point 
Esc = Release the Stretch Traces tool 
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Undo an Editing Action 

 
The Undo command can undo previous editing actions. The number of previous editing actions that 
can be undone and the size of the editing actions in terms of memory involved is limited by the amount 
of memory allocated for the undo feature. To save work in progress and undo edits regardless of 
memory allocation, see Milestone Files on page 81 and Revert to a Saved Job File on page 26. 

To Undo a Previous Edit: 
Ø On the Edit menu, click Undo. And to undo the next previous edit, click Edit-Undo again. 

 Ctrl+Z 

  

If the edit can not be undone, it may mean there was not enough memory allocated for the undo 
feature. The system will be able to undo all previous edits that do not exceed the amount of memory 
allocated. For instance, the system may be able to undo hundreds of single-element edits, or it may be 
able to undo only a single multiple-element edit, or it may not be able to undo any edits at all if the 
edits are larger than the amount of memory allocated. 

To Set the Amount of Memory Allocated for the Undo Feature  : 
1. On the Setup menu, click Max Undo Memory. 

 

Undo Memory Dialog 

2. On the Undo Memory dialog, enter the number of Kbytes of memory you want devoted to 
the Undo function in the Limits field. 

The Current field is the amount of the memory that is already in use to store edits for Undo. 

3. If you want the program to prompt you when an editing function will exceed the allocated 
undo memory, click Prompt When Operation Exceeds Limit so that the option has a 
checkmark. If there is no checkmark, the system will not prompt. 

 If you select this option, and the system later prompts you that an edit has exceeded the 
Undo Memory Limit, you can allocate more memory by entering a new Limit value in the 
warning dialog and then continue the operation, by clicking OK. Clicking Cancel does 
not cancel the edit, it cancels changes in the Limit value. 

4. Click OK. 
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Reference Frame 
Some features of the program make use of the Reference Frame. The Reference Frame appears in the 
Viewing Area as a rectangle outlined in white. In Lavenir DOS software, the Reference Frame was 
called the “Window” and was used to select elements for editing and as a reference location for 
operations like centering data. In Lavenir software for Windows there is a different method for 
selecting elements, and the Reference Frame is used mostly as a reference location. 

Draw a New Reference Frame 

 

To Draw a New Reference Frame: 
1. On the Setup Menu, click Frame-Draw New Frame. 

 

Draw New Reference Frame Tool 

2. Position the cursor where you want the first corner of the Reference Frame. 

3. Click the mouse or press Enter. 

4. Position the cursor where you want the opposite corner of the Reference Frame. 

5. Click the mouse or press Enter. 

The frame-drawing tool remains selected so you can redraw the Reference Frame it you want to. 

6. To deselect the frame-drawing tool, select a new tool or press Esc. 

 Shift+W = Frame-Drawing Tool  
Enter = Set first corner and Enter again to set second corner 

  = Frame-Drawing Tool 

 For precision, you can run the operation from the keyboard and use the Go To Coordinate 
command, or you can use the Set Exact Reference Frame Corners command.  
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Set Exact Reference Frame Corners 

 

To Set Exact Reference Frame Corners: 
1. On the Setup menu, click Frame-Corners. 

 

Set Reference Frame Corners Dialog 

2. Enter the coordinates for the lower left corner and the upper right corner of the Reference 
Frame. 

3. Click OK. 
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Automatically Insert a Reference Frame Around Workspace 

 

To Insert a Reference Frame around Workspace: 
1. On the Setup menu, click Frame-Corners. 

 

Set Reference Frame Corners Dialog 

2. Click Around Workspace. 

3. Click OK. 

For more information about the Workspace, see Set the Workspace Dimensions. 
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Automatically Insert a Reference Frame Around All Data 

 

To Insert a Reference Frame around All Data: 
1. On the Setup menu, click Frame-Surround All Data. 

 

Reference Frame Margin Dialog 

2. If you want a margin around the data, enter the distance you want between the Reference 
Frame and the data on the Margin dialog. If you don’t want a margin, enter zero for margins. 

3. Click OK. 

 Ctrl+W 
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Move a Reference Frame 

 
You can move a Reference Frame to a new location while still maintaining its size by grabbing and 
moving its lower left corner. 

To Move a Reference Frame: 
1. Separate the crosshair and the mouse cursor. See Separate the Crosshair and Mouse Cursor 

on page 112. 

2. On the Setup Menu, click Frame-Grab LL Corner. 

The lower left corner of the Reference Frame hops to the crosshair. 

3. Position the crosshair where you want the lower left corner of the Reference Frame. 

4. On the Setup Menu, click Frame-Grab LL Corner a second time. 

The lower left corner of the Reference Frame is released from the crosshair. 

 W = Grab lower left corner of Reference Frame, and press W again to release corner. 

 It may be preferable to run this command using its keyboard equivalent rather than the menu 
command. The key command does not require you to separate the cursor.  

Resize a Reference Frame 

 
You can resize a Reference Frame while still maintaining its lower left corner position by grabbing and 
moving its upper right corner. 

To Resize a Reference Frame: 
1. Separate the crosshair and the mouse cursor. See Separate the Crosshair and Mouse Cursor 

on page 112. 

2. On the Setup Menu, click Frame-Grab UR Corner. 

The upper right corner of the Reference Frame hops to the crosshair, while the lower left corner 
remains anchored. 

3. Position the crosshair where you want the upper right corner of the Reference Frame. 

4. On the Setup Menu, click Frame-Grab UR Corner a second time. 

The upper right corner of the Reference Frame is released from the crosshair. 

 Ctrl+Shift+W = Grab upper right corner of Reference frame, and press  
Ctrl+Shift+W again to release corner. 

 It may be preferable to run this command using its keyboard equivalent rather than the menu 
command. The key command does not require you to separate the cursor.  
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Chapter 5 
Use Automatic Editing Tools 

The program has many automatic editing tools to perform complex operations. These features include 
some fairly basic operations such as converting arcs to quadrants or chords, and sorting the database by 
proximity. In addition the program includes some very complex labor-saving operations such as 
polygon filling, adding venting patterns, converting drawn pads to flashed, calculating copper area, 
deleting non-functional pads, snapping data to the padmaster layer, clipping silkscreen traces for 
padmaster clearance, generating soldermask data from a padmaster layer, generating outline data, 
generating pad filleting, generating centroid data, comparing layers, correcting trace/pad overlap 
problems, generating polygons from circuit element contours, and consolidating soldermask data into 
flashed pads. 

Approximate Arcs with Chords 

 
The program can approximate the curve of an arc by replacing it with chord segments. An arc 
converted to chords cannot be converted back. 

 This is one operation that does not use the normal selection system. The program converts 
arcs that are entirely surrounded by the reference frame regardless of their selection status.  

To Approximate Arcs with Chords: 
1. Position the reference frame around the arcs you want to convert to chords and set the 

Inside/Outside frame selection switch. See Reference Frame on page 177. 

2. On the Tools menu, click Convert Arcs-Approximate by Chords. 
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Convert Arcs to Chords Dialog 

3. On the Convert Arcs to Chords dialog, select the conversion method: 

Chord Length: Converts the arc into a series of chords of the specified length. 

Angle: Converts the arc into a series of chords that intersect at the specified angle. 

Bounded Angle: Converts the arc into a series of chords that intersect at the specified angle, 
unless that generates chords smaller than the specified length. In that case, it converts the arc into 
a series of chords of the specified length.  

4. Click OK. 

The program converts the arcs into chords, selects the chords, and reports the operation in the 
message line 
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Break 360-Degree Arcs into Quadrants 

 
The program can convert 360-degree arcs to quadrant arcs. A 360-degree arc converted to a quadrant 
arc cannot be converted back. 

 This is one operation that does not use the normal selection system. The program converts 
arcs that are entirely surrounded by the reference frame regardless of their selection status.  

To Convert 360-Degree Arcs to Quadrant Arcs: 
1. Position the reference frame around the arcs you want to convert to quadrants and set the 

Inside/Outside frame selection switch. See Reference Frame on page 177. 

2. On the Tools menu, click Convert Arcs-Break Into Quadrants. 

The program converts the arcs into quadrants, selects the converted arcs, and reports the operation 
in the message line 

Sort by Proximity 

 
The program can sort pads and traces by calculating the distance to neighboring elements and placing 
the closest element next in the database. There are two algorithms for the sort: 

• Distance: This algorithm uses the straight-line distance between two points. 

• Max (x, y): The Max (x, y) algorithm calculates the distance as the longest of the X and X 
displacements between the two points. 

While the Distance option gives the real distance between two points, the Max (x, y) option can 
minimize travel time on devices, such as some NC drilling machines, that can move both axes at 
maximum speed independently. 

To Sort the Database: 
Ø On the Tools menu, click  

Sort by Proximity-Using Distance or  
Sort by Proximity-Using Max (x, y). 

 Sorting data reduces plot file size, reduces processing time, and organizes data for output. 
Any size file can benefit from sorting, but it is especially important for outline files, fab 
drawings, and drill files destined for routing or drilling later. 
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Polygon Filling 

 
The program can fill polygon areas, around and between pads and traces, with hatched, crosshatched, 
and solid fills.  

You have an option to just outline the polygons and the circuit elements without filling, and another 
option to fill inside the circuit elements. 

Among many other uses, polygon filling operations can be used to: 

• Shield traces from unwanted interference due to impedance or noise from surrounding 
circuits. 

• Generate thief patterns around component and solder sides of the board for equalization of 
copper. 

• Fill line drawings such as custom apertures, extra large apertures not available on some 
photoplotters, or outlines of liquid crystal displays. 

These operations are similar to the venting operations, so if you do not see the type of fill pattern you 
want described in this section, see Venting Patterns on page 204. 

Nested Polygons for Fill Operations 
Polygons form the boundaries inside which the operation adds the fill patterns. A set of polygons 
drawn with F-type D Codes having the same ID that are completely nested, one inside the other, form a 
group. Nested groups tell the program where to fill and where to keep out. 

To define polygon boundaries for filling, you can use polygons drawn with traces mapped to an F-type 
D Code, or you can use the reference frame, and often you will use a combination of both. 

Use the Reference Frame as a Boundary 
In addition to telling the system where to find the polygons to fill, the reference frame itself can be 
used as a polygon. With the Use Reference Frame as Additional Polygon option on the Polygon 
Selection tab, the system sees the reference frame as it does an F-type polygon. You can use the 
reference frame in combination with other drawn polygons to form a nested group with fill and keep 
out areas. 

To Set Up the Reference Frame as a Fill Boundary: 
1. Set the Inside/Outside Reference Frame selection mode. 

The Inside/Outside Reference Frame selection mode tells the system whether to consider polygons 
on the inside or outside in a filling operation. 

2. Position the Reference Frame. See Reference Frame on page 177. 

The Reference Frame may be used solely to direct the filling to the right polygons (inside or 
outside as appropriate). Or it may also be used as the first or last polygon in a nested group, as 
indicated by the Use Reference Frame as Additional Polygon option on the Polygon Selection tab 
of the Fill Polygons dialog. 
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Draw Fill Boundary Polygons with Traces 
In addition to using the reference frame you can also draw the polygonal areas yourself using traces of 
F-Type D Codes. 

To Draw Fill Boundary Polygons with Traces: 
1. Set the active, visible layers you want to put the polygon on. See Select from the Active 

Layers on page 152. 

• To fill around pads and traces, put the polygon on the same layer as the pads and traces. 

• To use the same boundary on more than one layer, make only those layers visible, and 
draw the outline with all layers active. 

2. On the D Code Table define an F-type D Code for drawing polygons. If you plan to draw 
different groups of nested polygons, set up more than one F-type D Code, each with a unique 
ID. 

3. Use one of the trace insertion commands to draw a polygon area with the F-type D Code you 
defined. 

• Rectangles and circles automatically form closed polygons. Other trace types must be 
chained together to avoid open sides. 

• Traces, Orthogonal Traces and 90-Degree Traces chain successive traces. To close the 
last side of the polygon, move the cursor close to the first point of the first trace and snap 
to it using the Align command. Then insert the final trace.  

• Arcs can be chained similarly. Align to points on previous traces for both the first and 
last points of the new arc.  

• Elbow trace insertion can be used to change the shape of a closed polygon without 
creating open sides. 

4. Continue creating polygons as desired. 

• To add nested polygons, draw another polygon on the same layer entirely inside or 
entirely surrounding the previous polygon, using the same boundary D Code or another 
F-type D Code with the same ID. 

• To add a non-nested polygon entirely inside or surrounding an existing polygon, use an 
F-type D Code with a different ID.  

• To use an existing polygon from a Gerber file, make sure it is drawn correctly, and then 
change the boundary traces to an F-type D Code. 
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Standard Polygon Fill Options 
There are a few options that have to be set for most fill patterns regardless of what specific type of 
polygon fill you are adding. The following sections describe these standard options. To do a specific 
type of fill, skip down and read the procedure for that type of fill. The specific procedure will refer you 
to these sections to set some of the options. 

Set the Polygon Options for the Operation 

 

Fill Polygons Polygon Selection Tab 

On the Polygon Selection tab, set the options identifying the polygons for the operation. 

Use Reference Frame as Additional Polygon: The Reference Frame may be used solely to direct 
the operation to the correct polygons (inside or outside as indicated by the Inside/Outside switch). 
Or it may also be used as the first or last polygon in a nested group. To use the Reference Frame 
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as a polygon, click this option so that it has a check mark. To use the Reference Frame only to 
identify where the drawn polygons are located, click this option so that there is no check mark.  

Select Polygons: To have the system select the polygons during the operation so that they show 
up selected and highlighted after the operation, click this option so that it has a check mark. 
Otherwise do not check this option. 

Polygon Gaps: Ideally polygons should be drawn so that there are no gaps between traces in the 
loop. In the case that the polygons are not drawn closed, there are several options for whether and 
how to close gaps in polygons.  

• Do not Close Gaps: Select this option if you do not want to close polygons that have 
gaps. All other options provide a method to close the polygon gaps. 

• Close to First Point in Polygon: This option connects the first trace in a polygon to the 
last trace. 

• Close to Nearest Point in Polygon: This option connects the first trace in a polygon to 
the nearest point in the polygon. 

• Close to Maximum Tolerance: This option connects the first trace in a polygon to the 
nearest point in the polygon that is within a tolerance distance. Set the maximum gap that 
the system may close. 

Polygon Nesting: There are several options for whether and how to determine if polygons form 
nested polygon groups. 

• Do Not Nest: This option does not check to see if polygons are nested. It treats all 
polygons the same. 

• Use Quick Algorithm: This option uses a quick algorithm to see if polygons are nested. 
It is faster than the exact algorithm, but it is not appropriate for complex nested polygons, 
especially polygons that have concave contours. This algorithm may incorrectly see a 
polygon inside another polygon’s concave contour as being inside the other polygon. 

• Use Exact Algorithm: This option uses an exact algorithm to see if polygons are nested 
and always correctly determines the nesting order of polygon groups. It is not as fast as 
the exact algorithm, but it is always correct.  

Ignore Duplicate Edges: This option eliminates repetitive draws of polygon borders prior to the 
operation. 

Save Milestone Before Operation: This option saves a Milestone file before running the 
operation, so in case the results are not what you want, you can easily revert to the Milestone file. 
To have the system save a Milestone file before running the operation, click this option so that it 
has a check mark. Otherwise do not check this option. 
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Select the Layers for the Fill Operation 

 

Fill Polygons Layer Selection Tab 

On the Layer Selection tab, select the layers for the fill operation. 

Source Layers: Select the layers where the fill polygons are located. 

Fill Layer: Select the first layer where you want the fill to be generated. By selecting Same, you 
can fill multiple layers with the fill traces being added to the same layer where the corresponding 
polygons are located. 

Clear Destination Layers First: This option clears all data out of the fill layers before generating 
the fill. To have the system clear the fill layers before running the operation, click this option so 
that it has a check mark. Otherwise do not check this option. Do not use this option if there is any 
data on the fill layers that you want to keep, and especially if you are having the fill generated 
directly on the source layers. 
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Set the General Fill Options 

 

Fill Polygons General Tab 

On the General Tab, define the parameters for the fill. 

Angle: Enter the angle for the fill traces. For a solid fill this is the angle of all the traces, and for a 
hatched or crosshatched fill this is the angle of the hatch traces. Set the angle to zero or 90 when 
filling around pads and traces in order to have an accurate element clearance. 

Polygon Clearance: Enter the distance between fill and the polygons. 

Fill with Two D Codes: This option allows you to fill with two D Codes, one larger than the 
other. The narrower one is used when the wider one would leave gaps or rounded corners. If you 
use this option, the two D Codes must be sequential in number. Enter the first of the two as the 
D Code on the D Code tab. Either of these can be the narrower one. You must still make sure that 
the wider one fits through any neckdowns that may exist in the polygons. 
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Shortest Fill Trace: Enter the length of the shortest trace that the system may generate as fill. 
Traces that would be shorter than this length are not generated. 

Outline Polygons: This option outlines the fill to create a smooth fill shape. 

Round to Decimal: Enter the accuracy of the fill. The system can calculate the exact positioning 
of the fill based on the position of the polygons, the width of the traces, and the overlap. Set the 
decimal you want this positioning to be rounded to.  
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Fill Around Pads and Traces 

 

Fill Polygons Circuit Tab 

On the Circuit Tab, set the options for filling around and between pads and traces. 

Fill Over Elements: This option ignores the pads and traces present within the polygons. It fills 
the polygons so that the fill would cover the circuit elements. 

Fill Around Elements: This option fills around and between the pads and traces within the 
polygons. If you select this option, enter an Element Clearance. 

Element Clearance: Enter the distance between fill and the circuit elements. 



Lavenir CAM Software User’s Guide 

194 

Generate a Solid Fill 

 

To Generate a Solid Fill: 
1. Define the Polygon Areas for Filling. See Nested Polygons on page 186.   

2. On the Tools menu, click Fill Polygons-Solid Fill. 

3. On the Polygon Selection tab, set the options identifying the polygons for the fill operation. 
See Set the Polygon Options for the Operation on page 188. 

4. On the Layer Selection tab, select the layers for the fill operation. See Select the Layers for 
the Fill Operation on page 190. 

5. On the General tab, define the general parameters for the fill. See Set the General Fill 
Options on page 191. 

6. On the Circuit tab, set the options for filling around pads and traces. See Fill Around Pads 
and Traces on page 193. 

7. On the D Code tab, select the fill D Code: 

• D Code: Select a C-type D Code for the fill trace, or if you are filling with two D Codes, 
select the first of two consecutive C-type D Codes. These D Codes do not have to be 
unused; however, when you use them as fill traces, the system forces them to type C, 
Circle. 

• Size: If you want to set the size of the fill D Code, enter it here; otherwise the system will 
use the existing size for the selected D Code. 

8. On the Overlap Tab, set the solid fill overlap: 
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Fill Polygons Overlap Tab 

• Variable Overlap: This option allows the system to use a variable overlap in order to 
squeeze traces into narrow neckdown areas. 

• Set Overlap: This option allows you to set the overlap to a specific value. Enter an 
overlap large enough to eliminate banding due to plotter resolution and database 
rounding. Typically .5 to 1 mil is enough.  

9. On the main Fill Polygons dialog, click OK. 
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Generate a Hatched Fill 

 

To Generate a Hatched Fill: 
1. Define the Polygon Areas for Filling. See Nested Polygons on page 186. 

2. On the Tools menu, click Fill Polygons-Hatched Fill. 

3. On the Polygon Selection tab, set the options identifying the polygons for the fill operation. 
See Set the Polygon Options for the Operation on page 188. 

4. On the Layer Selection tab, select the layers for the fill operation. See Select the Layers for 
the Fill Operation on page 190. 

5. On the General tab, define the general parameters for the fill. See Set the General Fill 
Options on page 191. 

6. On the Circuit tab, set the options for filling around pads and traces. See Fill Around Pads 
and Traces on page 193. 

7. On the D Code Tab, select the fill D Code: 

• D Code: Select a C-type D Code for the fill trace, or if you are filling with two D Codes, 
select the first of two consecutive C-type D Codes. These D Codes do not have to be 
unused; however, when you use them as fill traces, the system forces them to type C, 
Circle. 

• Size: If you want to set the size of the fill D Code, enter it here; otherwise the system will 
use the existing size for the selected D Code. 

8. On the Hatch Tab, set the Hatch Spacing. The Hatch Spacing is the distance between hatch 
traces. 
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Fill Polygons Hatch Tab 

9. On the main Fill Polygons dialog, click OK. 
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Generate a Crosshatched Fill 

 

To Generate a Crosshatched Fill: 
1. Define the Polygon Areas for Filling. See Nested Polygons on page 186. 

2. On the Tools menu, click Fill Polygons-Crosshatched Fill. 

3. On the Polygon Selection tab, set the options identifying the polygons for the fill operation. 
See Set the Polygon Options for the Operation on page 188. 

4. On the Layer Selection tab, select the layers for the fill operation. See Select the Layers for 
the Fill Operation on page 190. 

5. On the General tab, define the general parameters for the fill. See Set the General Fill 
Options on page 191. 

6. On the Circuit tab, set the options for filling around pads and traces. See Fill Around Pads 
and Traces on page 193. 

7. On the D Code Tab, select the fill D Code: 

• D Code: Select a C-type D Code for the fill trace, or if you are filling with two D Codes, 
select the first of two consecutive C-type D Codes. These D Codes do not have to be 
unused; however, when you use them as fill traces, the system forces them to type C, 
Circle. 

• Size: If you want to set the size of the fill D Code, enter it here; otherwise the system will 
use the existing size for the selected D Code. 

8. On the Hatch Tab, define the remaining crosshatch parameters: 
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Fill Polygons Crosshatch Tab 

• Hatch Spacing: Enter the distance between fill traces. 

• Crosshatch Angle: Enter the angle of the crosshatch traces relative to the hatch traces. 
The angle of the hatch traces is set in the Angle field on the General Tab. In order to have 
an accurate element clearance when filling around pads and traces, set the Angle field on 
the General Tab to zero or 90, and set the Crosshatch Angle here to 90. 

9. On the main Fill Polygons dialog, click OK. 
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Generate Outlines Only 

 

To Generate Outlines Only: 
1. Define the Polygon Areas for Filling. See Nested Polygons on page 186. 

2. On the Tools menu, click Fill Polygons-Outlines Only. 

3. On the Polygon Selection tab, set the options identifying the polygons for the fill operation. 
See Set the Polygon Options for the Operation on page 188. 

4. On the Layer Selection tab, select the layers for the fill operation. See Select the Layers for 
the Fill Operation on page 190. 

5. On the D Code Tab, select the fill D Code: 

• D Code: Select a C-type D Code for the fill trace. These D Codes do not have to be 
unused; however, when you use them as fill traces, the system forces them to type C, 
Circle. 

• Size: If you want to set the size of the fill D Code, enter it here; otherwise the system will 
use the existing size for the selected D Code. 

6. On the Outline Polygons tab, set the outline parameters. 
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Fill Polygons Outline Polygons Tab 

• Outline Polygons Only: This option outlines only the polygons and does not outline the 
pads and traces within the polygons. If you select this option, enter a Polygon Clearance. 

• Outline Polygons and Elements: This option outlines both the polygons and the pads 
and traces within the polygons. If you select this option, enter a Polygon Clearance and 
an Element Clearance. 

• Polygon Clearance: Enter the distance between outlines and the polygons. 

• Element Clearance: Enter the distance between outlines and the circuit elements. 

7. On the main Fill Polygons dialog, click OK. 
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Fill Inside Elements 

 

To Fill Inside Elements: 
1. Define the Polygon Areas for Filling. See Nested Polygons on page 186. 

2. On the Tools menu, click Fill Polygons-Fill Inside Elements. 

3. On the Polygon Selection tab, set the options identifying the polygons for the fill operation. 
See Set the Polygon Options for the Operation on page 188. 

4. On the Layer Selection tab, select the layers for the fill operation. See Select the Layers for 
the Fill Operation on page 190. 

5. On the General tab, define the general parameters for the fill. See Set the General Fill 
Options on page 191. 

6. On the D Code Tab, select the fill D Code: 

• D Code: Select a C-type D Code for the fill trace, or if you are filling with two D Codes, 
select the first of two consecutive C-type D Codes. These D Codes do not have to be 
unused; however, when you use them as fill traces, the system forces them to type C, 
Circle. 

• Size: If you want to set the size of the fill D Code, enter it here; otherwise the system will 
use the existing size for the selected D Code. 

7. On the Overlap Tab, set the solid fill overlap: 
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Fill Polygons Overlap Tab 

• Variable Overlap: This option allows the system to use a variable overlap in order to 
squeeze traces into narrow neckdown areas. 

• Set Overlap: This option allows you to set the overlap to a specific value. Enter an 
overlap large enough to eliminate banding due to plotter resolution and database 
rounding. Typically .5 to 1 mil is enough.  

8. On the main Fill Polygons dialog, click OK. 
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Venting Patterns 

 
The program can fill polygon areas, around and between pads and traces, with venting and thieving 
patterns such as pads, positive VPI, negative VPI, starburst, solid, hatch, and crosshatch patterns.  

These operations are similar to the Polygon Filling operations, so if you don’t see the pattern you want 
described in this section, then see Polygon Filling on page 186. 

Nested Polygons for Venting Operations 
  Polygons form the boundaries inside which the operation adds the venting patterns. A set of polygons 
drawn with F-type D Codes having the same ID that are completely nested, one inside the other, form a 
group. Nested groups tell the program where to add venting and where to keep out. 

  To define polygon boundaries for venting, you can use polygons drawn with traces mapped to an F-
type D Code, or you can use the reference frame, and often you will use a combination of both. 

Use the Reference Frame as a Boundary 
  In addition to telling the system where to find the polygons to fill, the reference frame itself can be 
used as a polygon. With the Use Reference Frame as Additional Polygon option on the Polygon 
Selection tab, the system sees the reference frame as it does an F-type polygon. You can use the 
reference frame in combination with other drawn polygons to form a nested group with vent and keep 
out areas. 

To Set Up the Reference Frame as a Venting Boundary: 
1. Set the Inside/Outside Reference Frame selection mode. 

The Inside/Outside Reference Frame selection mode tells the system whether to consider polygons 
on the inside or outside in a venting operation. 

2. Position the Reference Frame. See Reference Frame on page 177. 

The Reference Frame may be used solely to direct the venting to the right polygons (inside or 
outside as appropriate). Or it may also be used as the first or last polygon in a nested group, as 
indicated by the Use Reference Frame as Additional Polygon option on the Polygon Selection tab 
of the Venting dialog. 

Draw Venting Polygons with Traces 
In addition to using the reference frame you can also draw the polygonal areas yourself using traces of 
F-Type D Codes. 

To Draw Venting Polygons with Traces: 
1. Set the active, visible layers you want to put the polygon on. See Select from the Active 

Layers on page 152. 

• To fill around pads and traces, put the polygon on the same layer as the pads and traces.  

• If you want to fill around pads and traces on multiple layers, make all those layers active 
and draw the polygon on all layers. 
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• If you are not going to be filling around elements, and you want the same venting pattern 
on several layers, you can draw the polygons on one layer and then generate the same 
venting pattern in all the desired vent layers. 

2. On the D Code Table define an F-type D Code for drawing polygons. If you plan to draw 
different groups of nested polygons, set up more than one F-type D Code, each with a unique 
ID. 

3. Use one of the trace insertion commands to draw a polygon area with the F-type D Code you 
defined. 

• Rectangles and circles automatically form closed polygons. Other trace types must be 
chained together to avoid open sides. 

• Traces, Orthogonal Traces and 90-Degree Traces chain successive traces. To close the 
last side of the polygon, move the cursor close to the first point of the first trace and snap 
to it using the Align command. Then insert the final trace.  

• Arcs can be chained similarly. Align to points on previous traces for both the first and 
last points of the new arc.  

• Elbow trace insertion can be used to change the shape of a closed polygon without 
creating open sides. 

4. Continue creating polygons as desired. 

• To add nested polygons, draw another polygon on the same layer entirely inside or 
entirely surrounding the previous polygon, using the same boundary D Code or another 
F-type D Code with the same ID. 

• To add a non-nested polygon entirely inside or surrounding an existing polygon, use an 
F-type D Code with a different ID.  

• To use an existing polygon from a Gerber file, make sure it is drawn correctly, and then 
change the boundary traces to an F-type D Code. 
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Standard Venting Options 
There are a few options that have to be set for most venting patterns regardless of what specific type of 
venting pattern you are adding. The following sections describe these standard options. To do a 
specific type of venting pattern, skip down and read the procedure for that type of pattern. The specific 
procedure will refer you to these sections to set some of the options. 

Set the Polygon Options for the Operation 

 

Venting Polygon Selection Tab 

  On the Polygon Selection tab, set the options identifying the polygons for the operation. 

Use Reference Frame as Additional Polygon: The Reference Frame may be used solely to direct 
the operation to the correct polygons (inside or outside as indicated by the Inside/Outside switch). 
Or it may also be used as the first or last polygon in a nested group. To use the Reference Frame 
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as a polygon, click this option so that it has a check mark. To use the Reference Frame only to 
identify where the drawn polygons are located, click this option so that there is no check mark.  

Select Polygons: To have the system select the polygons during the operation so that they show 
up selected and highlighted after the operation, click this option so that it has a check mark. 
Otherwise do not check this option. 

Polygon Gaps: Ideally polygons should be drawn so that there are no gaps between traces in the 
loop. In the case that the polygons are not drawn closed, there are several options for whether and 
how to close gaps in polygons.  

• Do not Close Gaps: Select this option if you do not want to close polygons that have 
gaps. All other options provide a method to close the polygon gaps. 

• Close to First Point in Polygon: This option connects the first trace in a polygon to the 
last trace. 

• Close to Nearest Point in Polygon: This option connects the first trace in a polygon to 
the nearest point in the polygon. 

• Close to Maximum Tolerance: This option connects the first trace in a polygon to the 
nearest point in the polygon that is within a tolerance distance. Set the maximum gap that 
the system may close. 

Polygon Nesting: There are several options for whether and how to determine if polygons form 
nested polygon groups. 

• Do Not Nest: This option does not check to see if polygons are nested. It treats all 
polygons the same. 

• Use Quick Algorithm: This option uses a quick algorithm to see if polygons are nested. 
It is faster than the exact algorithm, but it is not appropriate for complex nested polygons, 
especially polygons that have concave contours. This algorithm may incorrectly see a 
polygon inside another polygon’s concave contour as being inside the other polygon. 

• Use Exact Algorithm: This option uses an exact algorithm to see if polygons are nested 
and always correctly determines the nesting order of polygon groups. It is not as fast as 
the exact algorithm, but it is always correct.  

Ignore Duplicate Edges: This option eliminates repetitive draws of polygon borders prior to the 
operation. 

Save Milestone Before Operation: This option saves a Milestone file before running the 
operation, so in case the results are not what you want, you can easily revert to the Milestone file. 
To have the system save a Milestone file before running the operation, click this option so that it 
has a check mark. Otherwise do not check this option. 
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Select the Layers for the Venting Operation 

 

Venting Layer Selection Tab 

On the Layer Selection tab, select the layers for the venting operation. 

Source Layers: Select the layers where the polygons are located. 

First Vent Layer: Select the first layer where you want the venting to be generated. Venting can 
be added to a range of layers by entering the first layer here and then entering the number of layers 
to vent below. 

Number of Vent Layers: Enter how many layers you want to add venting to. Venting can be 
added to a range of layers by entering the first layer above and then entering the number of layers 
to vent here. 

Clear Destination Layers First: This option clears all data out of the venting layers before 
generating the fill. To have the system clear the venting layers before running the operation, click 
this option so that it has a check mark. Otherwise do not check this option. Do not use this option 
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if there is any data on the venting layers that you want to keep, and especially if you are having the 
venting generated directly on the source layers. 

There are a few ways to set the layer options up. 

To Add Venting to a Range of Layers Using Polygons on a Single Layer: 
If you are not going to be filling around elements, and you want the same venting pattern on several 
layers, you can draw the polygons on one layer and then generate the same venting pattern in a 
consecutive range of desired vent layers. 

1. In the Source Layers field, select the single layer where the polygons are located. 

2. In the First Vent Layer field, select the first layer of the range of layers where you want the 
venting to be generated.  

3. In the Number of Vent Layers field, enter how many consecutive layers to which you want to 
add the same venting pattern.  

To Add Venting to Multiple Layers Using Polygons on Multiple Layers: 
If you are filling around elements, or you want to use a different polygon shape on several layers, you 
need to have polygons on every layer and select them all as Source Layers. 

1. In the Source Layers field, select the all the layers where the polygons are located. 

2. In the First Vent Layer field, select the first layer where you want the venting to be generated. 
This does not need to be a source layer or a layer with data, in fact you may want an unused 
layer to more easily check the results. 

3. In the Number of Vent Layers field, enter enough layers to accommodate the venting patterns 
being generated. 
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Venting Around Pads and Traces 

 

Venting Circuits Tab 

On the Circuit Tab, set the options for adding venting around and between pads and traces. 

Vent Over Elements: This option ignores the pads and traces present within the polygons. It adds 
venting so that the pattern would cover the circuit elements. 

Vent Around Elements: This adds venting around and between the pads and traces within the 
polygons. If you select this option, enter an Element Clearance. 

Element Clearance: Enter the distance between venting and the circuit elements. 
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Generate a Pad Venting Pattern  

 

To Generate a Pad Venting Pattern: 
1. Define the Polygon Areas for venting. See Nested Polygons for Venting Operations on page 

204.   

2. On the Tools menu, click Venting-Pads. 

3. On the Polygon Selection tab, set the options identifying the polygons for the venting 
operation. See Set the Polygon Options for the Operation on page 206. 

4. On the Layer Selection tab, select the layers for the venting operation. See Select the Layers 
for the Venting Operation on page 208. 

5. On the Circuit tab, set the options for venting around pads and traces. See Venting Around 
Pads and Traces on page 210. 

6. On the D Code tab, select the D Code: 

• D Code: Select a C-type D Code for the pads of the venting pattern. The D Codes does 
not have to be unused; however, when you use it for a venting pattern, the system forces 
it to type C, Circle. 

• Size: Enter the size of the D Code you selected for the pads of the venting pattern.  

7. On the Vent tab, set options to define the pad venting pattern. 

 

Venting Pad Pattern Vent Tab 
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• Polygon Clearance: Enter the distance between venting and the polygons. 

• Gap: Enter the edge-to-edge distance between pads in layer pairs. 

• Shortest Vent Trace: This is not used for a pads fill.  

• Outlines Outside: This is not used for a pads fill. 

• Outlines Inside: This is not used for a pads fill. 

• Offset Odd Rows: Select this option to offset odd rows within a single venting layer. 
When this option is selected odd rows of pads within a single venting layer are offset so 
that they form a diagonal pattern. Otherwise the rows are not offset and the within a 
single venting layer pads form a grid pattern.  

• Offset Layer Pairs: When generating a Pads venting pattern, the system generates the 
pattern in layer pairs. The first and second venting layers are generated such that the pads 
in the second layer are placed half way between the pads in the first layer. Similarly, the 
pattern in the second pair of layers is generated such that the pads in the fourth layer fall 
half way between the pads in the third layer. Check this option to set an offset between 
layer pairs. When this option is checked, each subsequent layer pair is offset from the 
previous layer pair by the distance entered in the Offset Distance below. If the option is 
not checked, then the pads in all odd number layers overlay, and the pads in all even 
layers overlay. 

• Offset Distance: If the Offset Layer pairs option is checked above, enter the distance to 
offset layer pairs here. 

8. On the main Venting dialog, click OK. 
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Generate a Positive VPI Venting Pattern 

 

To Generate a Positive VPI Venting Pattern: 
1. Define the Polygon Areas for venting. See Nested Polygons for Venting Operations on page 

204. 

2. On the Tools menu, click Venting-Positive VPI. 

3. On the Polygon Selection tab, set the options identifying the polygons for the venting 
operation. See Set the Polygon Options for the Operation on page 206. 

4. On the Layer Selection tab, select the layers for the venting operation. See Select the Layers 
for the Venting Operation on page 208. 

5. On the Circuit tab, set the options for venting around pads and traces. See Venting Around 
Pads and Traces on page 210. 

6. On the D Code tab, select the D Code: 

• D Code: Select a D Code for the triangular venting pads of the Positive VPI venting 
pattern. The D Code should be unused, because when you use it for Positive VPI venting, 
the system forces it to an unusual triangular custom aperture. 

• Size: Enter the size of the D Code you selected for the triangular venting pads of the 
Positive VPI venting pattern.  

7. On the Vent tab, set options to define the Positive VPI venting pattern. 
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Venting Positive VPI Pattern Vent Tab 

• Polygon Clearance: Enter the distance between venting and the polygons. 

• Gap: This is the size of the vent area between the triangular venting pads of the Positive 
VPI venting pattern. 

• Shortest Vent Trace: This is not used for a Positive VPI venting.  

• Outlines Outside: This is not used for a Positive VPI venting. 

• Outlines Inside: This is not used for a Positive VPI venting. 

• Offset Odd Rows: This is not used for a Positive VPI venting. 

• Offset Layer Pairs: When generating a Positive VPI venting pattern, the system 
generates the pattern in layer pairs. The first and second venting layers are generated such 
that the pads in the second layer are placed half way between the pads in the first layer. 
Similarly, the pattern in the second pair of layers is generated such that the pads in the 
fourth layer fall half way between the pads in the third layer. Check this option to set an 
offset between layer pairs. When this option is checked, each subsequent layer pair is 
offset from the previous layer pair by the distance entered in the Offset Distance below. If 
the option is not checked, then the pads in all odd number layers overlay, and the pads in 
all even layers overlay. 

• Offset Distance: If the Offset Layer pairs option is checked above, enter the distance to 
offset layer pairs here. 

8. On the main Venting dialog, click OK. 
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Generate a Negative VPI Venting Pattern 

 

To Generate a Negative VPI Venting Pattern: 
1. Define the Polygon Areas for venting. See Nested Polygons for Venting Operations on page 

204. 

2. On the Tools menu, click Venting-Negative VPI. 

3. On the Polygon Selection tab, set the options identifying the polygons for the venting 
operation. See Set the Polygon Options for the Operation on page 206. 

4. On the Layer Selection tab, select the layers for the venting operation. See Select the Layers 
for the Venting Operation on page 208. 

5. On the Circuit tab, set the options for venting around pads and traces. See Venting Around 
Pads and Traces on page 210. 

6. On the D Code tab, select the D Code: 

• D Code: Select a C-type D Code for the traces of the Negative VPI venting pattern. The 
D Codes does not have to be unused; however, when you use it as a venting trace, the 
system forces it to type C, Circle. 

• Size: Enter the size of the D Code you selected for the venting traces of the Negative VPI 
venting pattern. This is the width of the venting path. 

7. On the Vent tab, set options to define the Negative VPI venting pattern. 



Lavenir CAM Software User’s Guide 

216 

 

Venting Negative VPI Pattern Vent Tab 

• Polygon Clearance: Enter the distance between venting and the polygons. 

• Gap: This is the height of the diamond-shaped area left between the traces of the 
Negative VPI venting pattern. 

• Shortest Vent Trace: Enter the length of the shortest trace that the system may generate 
as a venting trace. Traces that would be shorter than this length are not generated. 

• Outlines Outside: Select this option to have the program draw the inside boundary of a 
polygon the Negative VPI venting pattern. 

• Outlines Inside: Select this option to have the program draw the outside boundary of a 
polygon the Negative VPI venting pattern. 

• Offset Odd Rows: This is not used for a Negative VPI venting pattern. 

• Offset Layer Pairs: This is not used for a Negative VPI venting pattern. 

• Offset Distance: This is not used for a Negative VPI venting pattern. 

8. On the main Venting dialog, click OK. 
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Generate a Starburst Venting Pattern 

 

To Generate a Starburst Venting Pattern: 
1. Define the Polygon Areas for venting. See Nested Polygons for Venting Operations on page 

204. 

2. On the Tools menu, click Venting- Starburst. 

3. On the Polygon Selection tab, set the options identifying the polygons for the venting 
operation. See Set the Polygon Options for the Operation on page 206. 

4. On the Layer Selection tab, select the layers for the venting operation. See Select the Layers 
for the Venting Operation on page 208. 

5. On the D Code tab, select the D Code: 

• D Code: Select a C-type D Code for the fill traces of the Starburst venting pattern. The 
D Code does not have to be unused; however, when you use it as a venting trace, the 
system forces it to type C, Circle. 

• Size: Enter the size of the D Code you selected for the venting traces of the Starburst 
venting pattern.  

6. On the Vent tab, set options to define the Starburst venting pattern. 

 

Venting Starburst Pattern Vent Tab 
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• Polygon Clearance: Enter the distance between venting and the polygons.  

• Gap: This is not used for a Starburst venting pattern. 

• Shortest Vent Trace: Enter the length of the shortest trace that the system may generate 
as a venting trace. Traces that would be shorter than this length are not generated. 

• Outlines Outside: This is not used for a Starburst venting pattern. The rays of the 
Starburst pattern are outlined automatically. 

• Outlines Inside: This is not used for a Starburst venting pattern. The rays of the Starburst 
pattern are outlined automatically. 

• Offset Odd Rows: This is not used for a Starburst venting pattern. 

• Offset Layer Pairs: This is not used for a Starburst venting pattern. 

• Offset Distance: This is not used for a Starburst venting pattern. 

7. On the Starburst tab, enter the Starburst Angle. The Starburst Angle is the angle between 
the starburst rays. 

8. On the main Venting dialog, click OK. 
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Generate a Solid Venting Pattern 

 

To Generate a Solid Venting Pattern: 
1. Define the Polygon Areas for venting. See Nested Polygons for Venting Operations on page 

204. 

2. On the Tools menu, click Venting-Solid. 

3. On the Polygon Selection tab, set the options identifying the polygons for the venting 
operation. See Set the Polygon Options for the Operation on page 206. 

4. On the Layer Selection tab, select the layers for the venting operation. See Select the Layers 
for the Venting Operation on page 208. 

5. On the Circuit tab, set the options for venting around pads and traces. See Venting Around 
Pads and Traces on page 210. 

6. On the D Code tab, select the D Code: 

• D Code: Select a C-type D Code for the venting traces of the solid venting pattern. The 
D Codes does not have to be unused; however, when you use it as a venting trace, the 
system forces it to type C, Circle. 

• Size: Enter the size of the D Code you selected for the venting traces of the solid venting 
pattern.  

7. On the Vent tab, set options to define the solid venting pattern. 
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Venting Solid Pattern Vent Tab 

• Polygon Clearance: Enter the distance between venting and the polygons. 

• Gap: This is not used for a solid venting pattern. 

• Shortest Vent Trace: Enter the length of the shortest trace that the system may generate 
as a venting trace. Traces that would be shorter than this length are not generated. 

• Outlines Outside: This is not used for a solid venting pattern. The solid venting pattern 
is outlined automatically. 

• Outlines Inside: This is not used for a solid venting pattern. The solid venting pattern is 
outlined automatically. 

• Offset Odd Rows: This is not used for a solid venting pattern. 

• Offset Layer Pairs: This is not used for a solid venting pattern. 

• Offset Distance: This is not used for a solid venting pattern. 

8. On the main Venting dialog, click OK. 
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Generate a Hatch Venting Pattern 

 

To Generate a Hatch Venting Pattern: 
1. Define the Polygon Areas for venting. See Nested Polygons for Venting Operations on page 

204. 

2. On the Tools menu, click Venting-Hatch. 

3. On the Polygon Selection tab, set the options identifying the polygons for the venting 
operation. See Set the Polygon Options for the Operation on page 206. 

4. On the Layer Selection tab, select the layers for the venting operation. See Select the Layers 
for the Venting Operation on page 208. 

5. On the Circuit tab, set the options for venting around pads and traces. See Venting Around 
Pads and Traces on page 210. 

6. On the D Code tab, select the D Code: 

• D Code: Select a C-type D Code for the venting traces of the Hatch venting pattern. The 
D Codes does not have to be unused; however, when you use it as a venting trace, the 
system forces it to type C, Circle. 

• Size: Enter the size of the D Code you selected for the venting traces of the Hatch 
venting pattern.  

7. On the Vent tab, set options to define the Hatch venting pattern. 
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Venting Hatch Pattern Vent Tab 

• Polygon Clearance: Enter the distance between venting and the polygons. 

• Gap: Enter the distance between the venting traces of the Hatch venting pattern 

• Shortest Vent Trace: Enter the length of the shortest trace that the system may generate 
as a venting trace. Traces that would be shorter than this length are not generated. 

• Outlines Outside: Select this option to have the program draw the inside boundary of a 
polygon for the Hatched venting pattern. 

• Outlines Inside: Select this option to have the program draw the outside boundary of a 
polygon for the Hatched venting pattern. 

• Offset Odd Rows: This is not used for Hatch venting pattern. 

• Offset Layer Pairs: This is not used for Hatch venting pattern. 
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• Offset Distance: This is not used for Hatch venting pattern. 

8. On the Hatch tab, set the special options for the Hatch venting pattern. 

 

Venting Hatch Pattern Hatch Tab 

• Hatch Angle: Enter the angle for the hatch traces. Set the angle to zero or 90 when 
venting around pads and traces in order to have an accurate element clearance. 

• Crosshatch Angle: This is not used for Hatch venting pattern. 

9. On the main Venting dialog, click OK. 
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Generate a Crosshatch Venting Pattern 

 

To Generate a Crosshatch Venting Pattern: 
1. Define the Polygon Areas for venting. See Nested Polygons for Venting Operations on page 

204. 

2. On the Tools menu, click Venting- Crosshatch. 

3. On the Polygon Selection tab, set the options identifying the polygons for the venting 
operation. See Set the Polygon Options for the Operation on page 206. 

4. On the Layer Selection tab, select the layers for the venting operation. See Select the Layers 
for the Venting Operation on page 208. 

5. On the Circuit tab, set the options for venting around pads and traces. See Venting Around 
Pads and Traces on page 210. 

6. On the D Code tab, select the D Code: 

• D Code: Select a C-type D Code for the venting traces of the Crosshatch venting pattern. 
The D Codes does not have to be unused; however, when you use it as a venting trace, 
the system forces it to type C, Circle. 

• Size: Enter the size of the D Code you selected for the venting traces of the Crosshatch 
venting pattern.  

7. On the Vent tab, set options to define the Crosshatch venting pattern. 
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Venting Crosshatch Pattern Vent Tab 

• Polygon Clearance: Enter the distance between venting and the polygons. 

• Gap: Enter the distance between the venting traces of the Crosshatch venting pattern 

• Shortest Vent Trace: Enter the length of the shortest trace that the system may generate 
as a venting trace. Traces that would be shorter than this length are not generated. 

• Outlines Outside: Select this option to have the program draw the inside boundary of a 
polygon for the Crosshatch venting pattern. 

• Outlines Inside: Select this option to have the program draw the outside boundary of a 
polygon for the Crosshatch venting pattern. 

• Offset Odd Rows: This is not used for Crosshatch venting pattern. 

• Offset Layer Pairs: This is not used for Crosshatch venting pattern. 
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• Offset Distance: This is not used for Crosshatch venting pattern. 

8. On the Hatch tab, set the special options for the Crosshatch venting pattern. 

 

Venting Crosshatch Pattern Hatch Tab 

• Hatch Angle: Enter the angle for the hatch traces. Set the angle to zero or 90 when 
venting around pads and traces in order to have an accurate element clearance. 

• Crosshatch Angle: Enter the angle of the crosshatch traces relative to the hatch traces. In 
order to have an accurate element clearance when filling around pads and traces, set the 
Hatch Angle to zero or 90, and set the Crosshatch Angle to 90. 

9. On the main Venting dialog, click OK. 
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Convert Drawn Pads 

 
The program can convert drawn shapes to flashed shapes and vice versa. The operation adds or 
substitutes a new flashed or drawn shape for an existing flashed or drawn shape in a plot file.  

Converting drawn pads to flashed pads is useful for operations such as drill point extraction, netlist 
extraction, design rule checking, generating fab drawings of drill data from padmasters, and generating 
fillets where traces enter pads.  

The are two main modes of operation: 

• Single Shape: This is a manual draw-to-flash operation in which you can select single shapes 
in the viewing area and convert all instances of that shape in a file into flashed pads of a 
specific D Code. The operation can be run using key commands. The single shape method is 
useful for situations in which the same shapes are not found in many different files and you 
only want to do draw-to-flash conversions. 

• Shape Library: This is an automatic shape-to-shape operation in which you can create and 
save shape files in a shape library and convert a list of shapes in multiple files to new flashed 
or drawn shapes. This is useful for situations in which the same drawn shapes are replaced in 
many different files and when you need to do shape-to-shape conversions, not just draw-to-
flash. 

Convert Single Shapes 

 
This operation uses the contents of the reference frame as a shape model and finds matching shapes. 
The system can select matching shapes for editing or convert them to flashed pads. 

To Convert Single Shapes: 
1. Make the layers where you want to convert shapes active, visible layers. See Select from the 

Active Layers on page 152. 

2. Set the Visibility settings. 

The operation only checks visible elements, so make sure all pads, traces, selected, and unselected 
elements to be checked are visible. See Element Visibility on page 84. 

3. Clear selection from all elements.  

Depending on your settings, the system can use selection to indicate shapes found by the 
operation. Clearing the selection first helps avoid confusion. 

4. Position the reference frame around the elements that you want to use as the shape model. 
See Reference Frame on page 177. 

5. On the Tools menu, click Convert Drawn Pads-Single Shape, or press Ctrl+Shift+P. 

6. On the Layers tab, select the layers for the operation. 
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Single Shapes Layers Tab 

Old Shapes Layers: Select the layer where the elements you want to convert are located. 

First New Shapes Layer: Select the first consecutive layer where you want the converted shapes 
to be inserted. 

Clear Destination Layers First: This option clears all data out of the new shapes layers before 
inserting the converted data. To have the system clear the destination layers before running the 
operation, click this option so that it has a check mark. Otherwise do not check this option. Do not 
use this option if there is any data on the destination layers that you want to keep. 

7. On the Old Shapes tab, select options for how to handle the old shapes that are found by the 
operation. 
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Single Shapes Old Shapes Tab 

Delete: This option deletes the old shape and replaces it with a pad of the D Code specified on the 
D Code tab. 

Transfer: This option transfers the old shape to the Old Shapes Transfer Layer which you 
specify and replaces it with a pad of the D Code specified on the D Code tab. 

Keep: This option keeps the old shape on the original layer and adds a pad of the D Code 
specified on the D Code tab. 

Highlight: This option selects the old shape and does not insert a new pad. 

8. On the Options tab, set the shape conversion options. 
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Single Shapes Options Tab 

Affect only Elements Inside the Reference Frame: This option is not used for Single Shape 
replacements because the reference frame is used to establish the shape model. 

Find Old Shapes in Rotated Orientations: A check mark indicates the program identifies shapes 
that are rotated versions of the shape model. See the Insert New Shape in Matching Orientation 
option below. 

Insert New Shape in Matching Orientation: A check mark indicates that, if the Find Old 
Shapes in Rotated Orientations option above is checked and the program does find rotated 
versions of the shape, then the program inserts new shapes oriented to match the rotated old 
shapes. 

Identify Old Shapes by Outlines Only: A check mark indicates the program recognizes the 
outline of the shape to be replaced, rather than the elements it is composed of. This helps to avoid 
creating padstacks that may occur if the module were to recognize shapes composed of concentric 
traces as more than one shape, and it also identifies shapes that have the same outlines but have 
different interior fills. 

Automatically Set the New D Code Dimensions: A check mark indicates the program 
automatically calculates the replacement D Code size and shape. 

Automatically Determine Shape Centers: A check mark indicates the program automatically 
calculates the center of the old shape and positions the new shape at the old center. 

Save Milestone Before Operation: This option saves a Milestone file before running the 
operation, so in case the results are not what you want, you can easily revert to the Milestone file. 
To have the system save a Milestone file before running the operation, click this option so that it 
has a check mark. Otherwise do not check this option. 
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Shape Size Tolerance: If you want to allow the program to identify shapes that are approximately 
the same as the model old shape, enter a tolerance value in the Tolerance field. A zero tolerance 
means the program only finds exactly matching shapes. A tolerance in the range of 1 or 2 mils 
should catch most size variations due to data conversion or other factors. 

9. On the Pad D Code tab, select the Pad D Code to use when inserting the flashed pad where 
the old shape is found and select a D Code to Use option:  

 

Single Shapes Pad D Code Tab 

This One: The operation uses the D Code you entered regardless of whether the D Code has 
already been used elsewhere in the job. 

First Unused One after this One: The operation uses the first D Code after the D Code you 
entered. This option is useful if you repeat the process for another shape or run the operation 
repeatedly from the key command because the system automatically increments the Pad D Code. 

10. On the main Single Shape dialog, click OK. 

 Ctrl+Shift+P = Opens the Convert Single Shapes dialog 

  = Opens the Convert Single Shapes dialog 
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Convert Libraries of Shapes 

 
This operation scans the job for a library of old shapes and finds all shapes in the file that match the 
old shapes in the library. The system can select the matching shapes for editing or convert them to new 
shapes. Both old shapes and new shapes can be either D Codes or stored shape files. 

To Convert Libraries of Shapes: 
1. Make the layers where you want to convert shapes active, visible layers. See Select from the 

Active Layers on page 152. 

2. Set the Visibility settings. 

The operation only checks visible elements, so make sure all pads, traces, selected, and unselected 
elements to be checked are visible. See Element Visibility on page 84. 

3. Clear selection from all elements.  

Depending on your settings, the system can use selection to indicate shapes found by the 
operation. Clearing the selection first helps avoid confusion. 

4. If you want to perform the operation on only part of the file, position the reference frame 
around the part you want to check. See Reference Frame on page 177.  

 If you want to check all data, it does not matter where the reference frame is positioned.  

5. On the Tools menu, click Convert Drawn Pads-Conversion Library. 

6. On the Layers tab, select the layers for the operation. 
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Drawn Pads Layers Selection Tab 

Old Shapes Layers: Select the layer where the shapes you want to convert are located. 

First New Shapes Layer: Select the first consecutive layer where you want the converted shapes 
to be inserted. 

Clear Destination Layers First: This option clears all data out of the new shapes layers before 
inserting the converted data. To have the system clear the destination layers before running the 
operation, click this option so that it has a check mark. Otherwise do not check this option. Do not 
use this option if there is any data on the destination layers that you want to keep. 

7. On the Old Shapes tab, select options for how to handle the old shapes that are found by the 
operation. 
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Drawn Pads Old Shapes Tab 

Delete: This option deletes the old shape and replaces it with the new shape. 

Transfer: This option transfers the old shape to the Old Shapes Transfer Layer which you 
specify and replaces it with the new shape. 

Keep: This option keeps the old shape on the original layer and adds the new shape. 

Highlight: This option selects the old shape and does not insert the new shape. 

8. On the Options tab, set the shape conversion options. 
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Drawn Pads Options Tab 

Affect only Elements Inside the Reference Frame: A check mark indicates that the program 
only checks the part of the file inside the reference frame. 

Find Old Shapes in Rotated Orientations: A check mark indicates the program identifies shapes 
that are rotated versions of the shape model. See the Insert New Shape in Matching Orientation 
option below. 

Insert New Shape in Matching Orientation: A check mark indicates that, if the Find Old 
Shapes in Rotated Orientations option above is checked and the program does find rotated 
versions of the shape, then the program inserts new shapes oriented to match the rotated old 
shapes. 

Identify Old Shapes by Outlines Only: A check mark indicates the program recognizes the 
outline of the shape to be replaced, rather than the elements it is composed of. This helps to avoid 
creating padstacks that may occur if the module were to recognize shapes composed of concentric 
traces as more than one shape, and it also identifies shapes that have the same outlines but have 
different interior fills. 

Automatically Set the New D Code Dimensions: A check mark indicates the program 
automatically calculates the replacement D Code size and shape. 
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Automatically Determine Shape Centers: A check mark indicates the program automatically 
calculates the center of the old shape and positions the new shape at the old center. 

Save Milestone Before Operation: This option saves a Milestone file before running the 
operation, so in case the results are not what you want, you can easily revert to the Milestone file. 
To have the system save a Milestone file before running the operation, click this option so that it 
has a check mark. Otherwise do not check this option. 

Shape Size Tolerance: If you want to allow the program to identify shapes that are approximately 
the same as the model old shape, enter a tolerance value in the Tolerance field. A zero tolerance 
means the program only finds exactly matching shapes. A tolerance in the range of 1 or 2 mils 
should catch most size variations due to data conversion or other factors. 

9. On the Library tab, set up the Old Shapes to New Shapes conversion table. Set up the table 
so that in each row that is Active there is an Old Shape or D Code that is to be converted to a 
New Shape or D Code. 

 

Drawn Pads Library Tab 

To select a row in the table to change: Click on the item in the Old Shape or D Code column so 
that it is highlighted. Shift+Click to select a range of rows, and Ctrl+Click to add or remove a row 
from the selection. All selected rows will be changed simultaneously in the same way. 
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To change the Old Shape of a selected row: Click on File or D Code under Old Shape and 
select a stored Shape File or a D Code from the dialog that appears. 

To change the New Shape of a selected row: Click on File or D Code under New Shape and 
select a stored Shape File or a D Code from the dialog that appears. 

To make a selected row Active for the conversion: Click the Active button. Only rows that say 
“On” in the Active column will have their conversions carried out. Click once to turn on and 
again to turn off. 

To delete a selected row: Click Delete. 

To add a new row to the table: Click Add. 

10. On the main Drawn Pads dialog, click OK. 
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Shape Files 
Shape files are symbols, drawn pads, or element groupings that are identified by filenames and saved 
in small Gerber files. You can use any Gerber Extended or MDA Autoplot file as a shape file. Also, 
you can use any Basic Gerber file as a shape file as long as it is in Leading, Absolute, English 2.4 or 
Metric 4.3 format.  

If you save a large number of shape files, you can assemble them into a library of shape files, which 
you can use to perform multiple conversions at once whenever you have a similar job. This is useful 
for situations in which the same drawn shapes are replaced in many different Job Files. To do this, add 
the shapes to the conversion table and save a Library Parameter File. When you have a similar Job File 
import the Library Parameter File and converting the library of shapes. 

Save Shape Files 

 
You can save shape files, which can then be substituted for other shapes or D Codes or imported into 
other jobs. 

To Save Shape Files: 
1. Make the layers where the model for the shape is active, visible layers. See Select from the 

Active Layers on page 152. 

2. Set the Visibility settings. 

The operation only checks visible elements, so make sure all pads, traces, selected, and unselected 
elements to be checked are visible. See Element Visibility on page 84. 

3. Clear selection from all elements.  

The system uses selection to indicate shapes found by the operation. Clearing the selection first 
helps avoid confusion. 

4. Position the reference frame around the elements that you want to use as the shape model. 
See Reference Frame on page 177.  

Your reference frame selection should contain only the elements that are part of the shape. If you 
can’t position the window without also selecting extraneous elements, select and replicate the 
elements of the shape to another unused layer, then select the shape with the reference frame. 

5. Position the cursor where you want the centerpoint of the shape file. 

6. Separate the cursor. See Separate the Crosshair and Mouse Cursor on page 112. 

7. On the Tools menu, go to Convert Drawn Pads-Shape File-. 

• If you want to select the name and directory of the stored file, then on the menu cascade, 
click Store. 

• If you want the file to be saved with a default name in the current directory, then on the 
menu cascade, click Autorecord. 

The system saves the data in the frame as a shape file. 
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Import Shape Files 

 
You can import a shape file into a current job and insert the design represented by the shape at the 
cursor location. 

To Import a Shape File: 
1. Make the layers where you want to insert the shape active, visible layers. See Select from the 

Active Layers on page 152. 

2. Position the cursor where you want the centerpoint of the shape file. 

3. Separate the cursor. See Separate the Crosshair and Mouse Cursor on page 112. 

4. On the Tools menu, go to Convert Drawn Pads-Shape File-Load. 

 

Drawn Pads Import Shape File Dialog 

5. In the Look in box, click the drive, folder, or network location that contains the shape file. 

6. In the folder list, double-click folders until you open the folder that contains the shape file you 
want. 

7. Double-click the shape file. 

The system inserts the shape file at the cursor. 
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Library Parameter Files 
In situations where the same drawn shapes need to be replaced in many different Job Files, it can be 
useful to save a Library Parameter File that can be imported again when there is a similar job.  

Save Library Parameter Files 

 
You can save a Library Parameter File, which can be imported later when you need to replace similar 
shapes in another job.  

To Save a Library Parameter File: 
1. Set up and convert the Library of Shapes for the current job. 

2. On the Tools menu, go to Convert Drawn Pads-Parameter File-Save. 

 

Drawn Pads Save Library Parameter File Dialog 

3. In the Look in box, click the drive, folder, or network location where you want to save the 
parameter file. 

4. In the folder list, double-click folders until you open the folder where you want to save the 
parameter file. 

5. In the File name box, type a name for the parameter file.  

6. Click Ok. 

The system saves the parameter file so that it can be imported again later. 
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Import Library Parameter Files 

 
You can import a Library Parameter File that was saved earlier when you replaced similar shapes in 
another job.  

To Import a Library Parameter File: 
1. On the Tools menu, go to Convert Drawn Pads-Parameter File-Import. 

 

Drawn Pads Import Library Parameter File Dialog 

2. In the Look in box, click the drive, folder, or network location that contains the parameter 
file. 

3. In the folder list, double-click folders until you open the folder that contains the parameter 
file. 

4. Double-click the parameter file. 

The system imports the saved the parameter file and restores all the settings of the Convert Drawn 
Shapes dialog. 
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Calculate Copper Area 

 
The program can compute the copper area of layers of Gerber data and produce a report file showing 
the copper area in units of area and in percent of the area. 

Copper area may be computed for each layer individually, for any combination of positive and 
negative layers, or for the CPU and CPL layers, including the copper of plated through-hole walls. 

Calculate Copper Area  

 

To Calculate Copper Area: 
1. On the D Code Table and the Tool Code Table, define all D Codes and Tool Codes. 

NC Drill Tool Codes must be defined as P-plated, N-non-plated, T-tooling, or V-via. 

2. On the Layers Table, identify layers by layer type and stack them in the proper order. 

3. If you want to calculate the copper of plated through-hole walls while calculating the CPU 
and CPL layers, set up a padmaster (PAD) or drill layer (DRI) as a Scratch layer. 

4. Position the reference frame around the part of the plot you want to compute. See Reference 
Frame on page 177. When the percentage of copper area is calculated, it is calculated as a 
percentage of the reference frame area. 

5. On the Tools Menu, click Calculate Copper Area. 
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Calculate Copper Area Dialog 

6. Select a calculation option: 

• Layer by Layer: Provides individual layer analysis for each selected layer. 

• All Layers Combined: Provides analysis for all selected layers combined, including any 
combination of positive and negative layers. 

• Upper/Lower: Provides analysis for CPU and CPL layers. If a scratch layer of type PAD 
or DRI is present, you can enter a value for the Board Thickness to compute the copper 
area of the layer’s plated hole walls. 

7. On the Layers to Calculate list, select the layers you want to include in the calculation. 

8. In the Raster Resolution box, enter the resolution for the rasterization. 

The default Raster Resolution is set for 2 mils. A more fine-pitch resolution, such as 1 mil yields a 
more accurate calculation, but takes longer to calculate; while a less fine-pitch resolution, such as 
4 mils is faster, but gives a less accurate calculation. As you go to finer resolutions, the difference 
in accuracy is not very significant, while the difference in time is dramatic.  

9. Click OK. 

After the system performs the calculations, it displays the copper area report file generated. 
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View a Copper Area Report 

 
This operation generates a report file of each calculation in a file called Report.txt in the current 
directory. If the file already exists, each successive calculation is added to this report. The report is 
automatically displayed after the calculation, but you can view it anytime. 

To View a Copper Area Report: 
1. On the Tools Menu, click Calculate Copper Area. 

2. Click the Browse Button. 

3. In the Look in box, click the drive, folder, or network location that contains the report. 

4. In the folder list, double-click folders until you open the folder that contains the report you 
want. 

5. Double-click the Report. 

 If you want to rename the file, then while you are viewing the file in the text editor, save it 
under a new name by using the Save As command. 
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Delete Non-Functional Pads 

 
The program can delete, transfer or select non-functional pads from the plot. 

Non-Functional pads can be defined as: 

• Unconnected pads 

• Padstacks of pads that have the same centerpoint 

• Pads within a defined center offset distance from each other 

To Delete Non-Functional Pads from a Plot: 
1. Make the layers you want to edit active, visible layers. See Select from the Active Layers on 

page 152. 

2. On the D Code Table and the Tool Code Table, define all D Codes and Tool Codes. 

• The program needs accurate dimensions in order to determine if pads are connected.  

• The program ignores pads defined as Blank (B) and Target (T).  

3. Set the Visibility settings. 

The operation only checks visible elements, so make sure all pads, traces, selected, and unselected 
elements to be checked are visible. See Element Visibility on page 84. 

4. If you want to remove pads from only part of the plot, position the reference frame around 
that part. See Reference Frame on page 177.  

 If you want to check all data, it does not matter where the reference frame is positioned. 

5. On the Tools menu, click Delete Pads. 

6. On the Layers tab, select the layers for the operation. 
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Delete Pads Layers Selection Tab 

Source Layers: Select the layers where the non-functional pads are located. 

First Destination Layer:  

• If you are going to transfer pads, select the first layer where you want the non-functional; 
pads to be transferred.  

• If you want to select pads rather than delete or transfer them, select Same. 

• If you want to delete pads, you don’t need to select destination layers.  

Clear Destination Layers First: This option clears all data out of the destination layers before 
transferring the pads. To have the system clear the destination layers before running the operation, 
click this option so that it has a check mark. Otherwise do not check this option. Do not use this 
option if there is any data on the destination layers that you want to keep. 

7. On the Options tab, set the standard Options. 
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Delete Pads Options Tab 

Affect only Elements Inside the Reference Frame: A check mark indicates the program will 
only affect pads that are inside the Reference Frame. No check mark means the system will check 
the entire plot. 

Current D Code Only: A check mark indicates the program will only affect elements of the 
current D Code. If you select this option, set the current D Code in the D Code edit field. No check 
mark means the system will check all elements regardless of D Code. 

Save Milestone Before Operation: This option saves a Milestone file before running the 
operation, so in case the results are not what you want, you can easily revert to the Milestone file. 
To have the system save a Milestone file before running the operation, click this option so that it 
has a check mark. Otherwise do not check this option. 

8. On the Removal Settings tab, set the options for what pads to remove: 
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Delete Pads Removal Settings Tab 

Unused Pads: This option removes every pad whose pad region does not touch a trace. The 
Unused Pads option should be used for inner layers only. The program does not remove pads that 
touch any part of a trace, not just pads that touch traces at the endpoints. That means that pads 
intended as feed-through holes are not removed. If you select the Unused Pads option, you can 
also enter a value for the Pad Gap. The size of the pad is extended by the Pad Gap in both the X 
and Y dimension to determine if it touches a trace. 

Padstacks: This option removes all but the largest pad in a stack. Pads that have the same X and 
Y centerpoint coordinates are considered to be stacked. This option is especially useful for 
removing duplicate holes (bit-breakers) in drill files, but do not use the Padstacks option on drill 
files that contain pads intentionally stacked as leader holes. 

Center Offset: This option removes all but the largest pad with a center-to-center distance smaller 
than the Center Offset Value. Do not use Center Offset on drill files that use holes to make slots. 

9. On the Removal Settings tab, set the options for how to remove the pads: 

Delete Pads: This option deletes pads from the plot. 

Transfer Pads: This option transfers pads to the Destination Layers set on the Layers Tab. If you 
want to select pads rather than transfer or delete them, select this option, and select Same as the 
Destination Layer on the Layers Tab. 

10. On the main Delete Pads dialog, click OK. 
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Snap Data to Padmaster 

 
The program can move all pads and traces in a set of source layers whose endpoints are within a user 
specified tolerance of a pad in the padmaster layer to the padmaster pad center. 

This operation should be used to precisely align elements to a padmaster, not to align grossly 
misaligned layers. For instance, after Deleting Non-Functional Pads with the Center Offset option, you 
could use Snap to Padmaster to insure that the remaining pads are precisely aligned. Or you could use 
this operation to align scanned artwork to a drill file. 

The program can also snap selected elements to the grid. See Snap Selected Elements to the Grid on 
page 142.  

To Snap Data to the Padmaster: 
1. Make the layers you want to edit are active, visible layers. See Select from the Active Layers 

on page 152. 

2. Set the Visibility settings. 

The operation only checks visible elements, so make sure all pads, traces, selected, and unselected 
elements to be checked are visible. See Element Visibility on page 84. 

3. If you want to snap only part of the plot, position the reference frame around that part. See 
Reference Frame on page 177.  

 If you want to check all data, it does not matter where the reference frame is positioned. 

4. On the Tools menu, click Snap to Padmaster. 

5. On the Layers tab, select the layers for the operation. 
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Snap to Padmaster Layers Selection Tab 

Source Layers: Select the layers that contain the elements you want to snap. 

Padmaster Layer: Select the padmaster layer that contains the pads you want the source layers to 
snap to. 

6. On the Options tab, set the standard Options. 
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Snap to Padmaster Options Tab 

Affect only Elements Inside the Reference Frame: A check mark indicates the program will 
only affect elements that are inside the Reference Frame. No check mark means the system will 
check the entire plot. 

Current D Code Only: A check mark indicates the program will only affect elements of the 
current D Code. If you select this option, set the current D Code in the D Code edit field. No check 
mark means the system will check all elements regardless of D Code. 

Save Milestone Before Operation: This option saves a Milestone file before running the 
operation, so in case the results are not what you want, you can easily revert to the Milestone file. 
To have the system save a Milestone file before running the operation, click this option so that it 
has a check mark. Otherwise do not check this option. 

7. On the Snap Settings tab, set the snap settings. 
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Snap to Padmaster Snap Settings Tab 

Tolerance: Enter the maximum distance from a Padmaster pad center within which the system 
may find a pad or trace endpoint to snap to that pad center. A tolerance of 0 is infinite tolerance, 
meaning there is no maximum distance that a trace endpoint or pad center may be snapped. 
Warning: Using infinite tolerance or a large, finite tolerance may result in adjacent elements 
being snapped to the same padmaster centerpoint. 

Snap Traces in Addition to Pads: A check mark indicates traces are snapped. No check mark 
indicates only pads are snapped. 

8. On the main Snap to Padmaster dialog, click OK. 

The program aligns the elements that are within tolerance to the pad centerpoints of the padmaster 
layer. The system reports how many elements were moved in the message line. 
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Clip Silkscreen Traces for Padmaster Clearance 

 
The program can automatically clip traces in the silkscreen layer to allow for a specified clearance 
around pads in the padmaster layer.  

To Clip Silkscreen Traces for Padmaster Clearance: 
1. Make the padmaster and silkscreen layers active, visible layers. See Select from the Active 

Layers on page 152. 

2. On the D Code Table and the Tool Code Table, define all D Codes and Tool Codes. The 
program needs accurate dimensions in order to determine the clearance.  

3. Set the Visibility settings. 

The operation only checks visible elements, so make sure all pads, traces, selected, and unselected 
elements to be checked are visible. See Element Visibility on page 84. 

4. If you want to clip silkscreen from only part of the plot, position the reference frame around 
that part. See Reference Frame on page 177.  

 If you want to check all data, it does not matter where the reference frame is positioned. 

5. On the Tools menu, click Clip Silkscreen Traces. 

6. On the Layers tab, select the layers for the operation. 
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Clip Silkscreen Layers Selection Tab 

Silkscreen Layer: Select the silkscreen layer to clip. 

Padmaster Layer: Select the padmaster layer that the silkscreen layer will be clipped to. 

7. On the Options tab, set the standard Options. 
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Clip Silkscreen Options Tab 

Affect only Elements Inside the Reference Frame: A check mark indicates the program will 
only clip silkscreen traces that are inside the Reference Frame. No check mark means the system 
will check the entire plot. 

Save Milestone Before Operation: This option saves a Milestone file before running the 
operation, so in case the results are not what you want, you can easily revert to the Milestone file. 
To have the system save a Milestone file before running the operation, click this option so that it 
has a check mark. Otherwise do not check this option. 

8. On the Intersected Traces tab, set the options for determining whether and how traces are 
clipped. 



Lavenir CAM Software User’s Guide 

256 

 

Clip Silkscreen Intersected Traces Tab 

Delete Original Traces: When this option has a check mark, the system deletes the original traces 
as it inserts the clipped traces. When this option does not have a check mark, the system selects the 
original traces as it inserts the clipped traces. You can view the selected traces, and it you want to 
delete them use the Delete command; otherwise revert to the Milestone file and run the operation 
again with different settings. 

Clearance: Enter the minimum allowed clearance around pads in the padmaster layer. Silkscreen 
traces that come closer than the clearance are clipped. 

Delete Traces Shorter Than: Enter the minimum clipped trace length allowed. Traces shorter 
than this after clipping are deleted.  

9. On the main Clip Silkscreen dialog, click OK.  

When the operation finishes, the system reports how many traces were affected on the message 
line.  
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Generate Soldermask Data from Padmaster 

 
The program can generate a soldermask layer from a padmaster layer. For each D Code in a padmaster 
layer the module generates a corresponding swelled D Code in the soldermask layer using existing 
D Codes of the correct size or creating new ones for the swelled D Codes. 

To Generate a Soldermask Layer: 
1. Make the padmaster layer and the new soldermask layer active, visible layers. See Select from 

the Active Layers on page 152. 

2. On the D Code Table and the Tool Code Table, define all D Codes and Tool Codes. The 
program needs accurate dimensions in order to determine the new soldermask layer D Code 
dimensions.  

3. Set the Visibility settings. 

The operation only checks visible elements, so make sure all pads, traces, selected, and unselected 
elements to be checked are visible. See Element Visibility on page 84. 

4. If you want to generate soldermask for only part of the plot, position the reference frame 
around that part. See Reference Frame on page 177.  

 If you want to check all data, it does not matter where the reference frame is positioned. 

5. On the Tools menu, click Generate Soldermask. 

6. On the Layers tab, select the layers for the operation. 
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Generate Soldermask Layers Selection Tab 

Padmaster Layer: Select the padmaster layer to be used as the model for the soldermask. 

Soldermask Layer: Select the new soldermask layer to be generated. 

Clear Soldermask Layers First: This option clears all data out of the new soldermask layers 
before generating the soldermask. To have the system clear the soldermask layer before running 
the operation, click this option so that it has a check mark. Otherwise do not check this option. Do 
not use this option if there is any data on the soldermask layer that you want to keep. 

7. On the Options tab, set the standard Options. 
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Generate Soldermask Options Tab 

Affect only Elements Inside the Reference Frame: A check mark indicates the program will 
only generate soldermask for the padmaster data that are inside the Reference Frame. No check 
mark means the system will check the entire plot. 

Current D Code Only: A check mark indicates the program will only generate soldermask for the 
padmaster data of the current D Code. If you select this option, set the current D Code in the 
D Code edit field. No check mark means the system will check all elements regardless of D Code. 

Save Milestone Before Operation: This option saves a Milestone file before running the 
operation, so in case the results are not what you want, you can easily revert to the Milestone file. 
To have the system save a Milestone file before running the operation, click this option so that it 
has a check mark. Otherwise do not check this option. 

8. On the D Codes tab, set the options for how you want to handle D Codes for the new 
soldermask data. 
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Generate Soldermask D Codes Tab 

Round Decimal to: Enter the number of places after the decimal point for new D Code sizes. The 
program can calculate exact sizes for new D Codes based on parameters of the Swell tab, but you 
can set the decimal place to round the sizes to.  

Use Existing D Codes within Tolerance: This option uses the closest available existing D Code 
size within tolerance for the soldermask data. If you use this option, enter a Tolerance. A 
tolerance of zero forces the system to select exact-size D Codes. If no appropriate D Code is 
found, the system aborts the operation with a message indicating the aperture shape and size were 
not found. 

Create New D Code: This option creates new D Codes not currently defined in the D Code table 
for the soldermask data. If you select this option, enter the First New D Code to be created.  

9. On the Swell tab, set the options for how to swell the soldermask data. 
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Generate Soldermask Swell Tab 

By Percentage: This option swells the soldermask elements to a percentage of the padmaster 
elements (i.e., 100 percent equals no increase, 110 means soldermask pads are 110 percent of the 
size of padmaster pads, etc.). If you select this option you must also set the percentage and pick 
one the of the following methods: 

• Area: The area of the soldermask elements equals the designated percentage of the 
padmaster elements. 

• X and Y Independently: The X and Y dimensions of the soldermask elements equal the 
designated percentage of the padmaster element dimensions. 

• Scale:  

Fixed Amount: This option makes the soldermask element dimensions a fixed amount larger than 
the padmaster elements. If you select this option you must also set the amount to increase the 
soldermask element dimension over the padmaster elements. 

Swell Heat Reliefs also: This option swells Heat Reliefs in addition to other pads in the 
soldermask. 

Swell Traces also: This option swells Traces in addition to pads in the soldermask. 

10. On the main Generate Soldermask dialog, click OK. 

The program generates the soldermask data. In the message line the system reports how many 
elements were generated and how many new D Codes were defined. 
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Generate Outline Data 

 

 The Raster Outline Routine is only available in CAMMaster, while the Vector Outline Routine 
is available in ViewMaster PRO as well. 

The program can generate outline files for all elements in selected layers using either a Raster outline 
Routine or a Vector Outline Routine. 

Differences between Raster and Vector Outline Routines 
The Vector Outline Routine generates linear and arc data outlines for all elements. Elements that 
overlap generate overlapping outlines with the Vector Outline Routine. The outlines can be swollen or 
contracted by a designated amount, and you have the option to generate outlines for traces and pads or 
for pads only. 

The Raster Outline Routine first creates a raster bitmap of the image and then generates outlines that 
trace the vertices of the outline of the bitmap. Elements that overlap do not generate overlapping 
outlines with the Raster Outline Routine; the operation produces one outline for the overlapped image. 
The accuracy of the outlines generated by the Raster Outline Routine is limited by the raster resolution, 
and round elements and arcs are generally jagged due to the raster resolution. The Raster Outline 
Routine does not generate any arc data.  

 

Original Data Elements to Outline 

 

Vector Outlines 

 

Raster Outlines 
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Vector Outline Routine 

 
The program can generate outline files for all elements in selected layers. Outlines are drawn on 
destination layers with an F-type D Code and can be swollen or contracted by a designated amount. 

The outlines represent linear and arc data that can be used to generate cut patterns for making stencils.  

To Generate Element Outlines with the Vector Outline Routine: 
1. Make the source layers and destination layers active, visible layers. See Select from the 

Active Layers on page 152. 

2. On the D Code Table and the Tool Code Table, define all D Codes and Tool Codes. The 
program needs accurate dimensions in order to outline the elements properly.  

3. Set the Visibility settings. 

The operation only checks visible elements, so make sure all pads, traces, selected, and unselected 
elements to be checked are visible. See Element Visibility on page 84. 

4. If you want to outline elements on only part of the plot, position the reference frame around 
that part. See Reference Frame on page 177.  

 If you want to check all data, it does not matter where the reference frame is positioned. 

5. On the Tools menu, click Generate Outlines-Vector. 

6. On the Layers tab, select the layers for the operation. 
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Generate Outlines Layers Selection Tab 

Source Layers: Select the layers where the elements you want to outline are located. 

First Destination Layer: Select the first layer where the outlines are to be generated. 

Clear Destination Layers First: This option clears all data out of the destination layers before 
generating the outline data. To have the system clear the destination layers before running the 
operation, click this option so that it has a check mark. Otherwise do not check this option. Do not 
use this option if there is any data on the destination layers that you want to keep. 

7. On the Options tab, set the standard Options. 
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Generate Outlines Options Tab 

Affect only Elements Inside the Reference Frame: A check mark indicates the program will 
only outline elements that are inside the Reference Frame. No check mark means the system will 
check the entire plot. 

Current D Code Only: A check mark indicates the program will only outline elements of the 
current D Code. If you select this option, set the current D Code in the D Code edit field. No check 
mark means the system will check all elements regardless of D Code. 

Save Milestone Before Operation: This option saves a Milestone file before running the 
operation, so in case the results are not what you want, you can easily revert to the Milestone file. 
To have the system save a Milestone file before running the operation, click this option so that it 
has a check mark. Otherwise do not check this option. 

8. On the Outlines Settings tab, set the outlines settings. 
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Generate Outlines Settings Tab 

Outline Traces in Addition to Pads: A check mark indicates the program will outline traces in 
addition to pads. No check mark indicates only traces will be outlined. 

Minimum D Code Size that is Outlined: Enter a minimum D Code size to outline. Only 
D Codes larger than this will be outlined. If you do not want to limit the D Code size, enter a Zero. 

Expand Outlines: Enter the X and Y amounts for the outlines to be expanded or contracted. If 
you do not want to expand or contract the outlines, enter a Zero. 

D Code for Generated Outlines: Enter the D Code to use for the outlines. The system will make 
this D Code into an F-type. 

9. On the main Generate Outlines dialog, click OK. 

The program generates the outline data. In the message line, the system reports how many 
elements were outlined. 
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Raster Outline Routine 

 
The program can generate outline files for the images in selected layers. Outlines are drawn on 
destination layers with an F-type D Code. The accuracy of the outlines is limited by the raster 
resolution.  

To Generate Element Outlines with the Raster Outline Routine: 
1. Make the source layers and destination layers active, visible layers. See Select from the 

Active Layers on page 152. 

2. On the D Code Table and the Tool Code Table, define all D Codes and Tool Codes. The 
program needs accurate dimensions in order to outline the elements properly.  

3. Set the Visibility settings. 

The operation only checks visible elements, so make sure all pads, traces, selected, and unselected 
elements to be checked are visible. See Element Visibility on page 84. 

4. On the Tools menu, click Generate Outlines-Raster.  

5. On the Layers tab, select the layers for the operation. 
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Generate Raster Outlines Layers Selection Tab 

Source Layers: Select the layers where the elements you want to outline are located. 

First Destination Layer: Select the first layer where the outlines are to be generated. 

Clear Destination Layers First: This option clears all data out of the destination layers before 
generating the outline data. To have the system clear the destination layers before running the 
operation, click this option so that it has a check mark. Otherwise do not check this option. Do not 
use this option if there is any data on the destination layers that you want to keep. 

6. On the Raster Resolution tab, enter the Raster Tools Resolution.  

 The Raster Tools Resolution is a very important value because it determines the accuracy 
of the outlines. 

The raster tools resolution is the size of each pixel is in the raster bitmaps. You may enter a value 
from 0.1 through 50 mils, or from 1 through 1000 microns, inclusive. For more information 
regarding important considerations for setting the Raster Tools Resolution, see Raster Tools 
Resolution on page 425. 
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Generate Outlines Raster Resolution Tab 

7. On the main Generate Outlines dialog, click OK. 

The program generates the outline data. In the message line, the system reports how many 
elements were outlined. 
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Generate Pad Filleting 

 
The program can generate snowman or teardrop filleting for Gerber plots.  

Generate Snowman Fillets 

 
The program generates Snowman filleting by adding a new, smaller circular pad at the intersection 
points of existing pads and traces. The resulting shape, smaller pad on top of larger pad, looks like a 
snowman. You set the fillet placement and size. Fillet pads can be mapped either to existing D Codes 
or new D Codes. 

To Generate Snowman Fillets: 
1. Make the layers you want to add filleting to active, visible layers. See Select from the Active 

Layers on page 152. 

2. On the D Code Table and the Tool Code Table, define all D Codes and Tool Codes. The 
program needs accurate dimensions in order to determine fillet size and placement.  

3. Set the Visibility settings. 

The operation only checks visible elements, so make sure all pads, traces, selected, and unselected 
elements to be checked are visible. See Element Visibility on page 84. 

4. If you want to add filleting to only part of the plot, position the reference frame around that 
part. See Reference Frame on page 177.  

 If you want to check all data, it does not matter where the reference frame is positioned. 

5. On the Tools menu, click Add Filleting. 

6. On the Layers tab, select the layers for the operation. 
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Filleting Layers Selection Tab 

Source Layers: Select the layers where the elements you want to generate filleting for are located. 

First Destination Layer: Select the layers where you want the filleting elements to be added. If 
you want the filleting to be added directly to the source layers, select Same. 

Clear Destination Layers First: This option clears all data out of the destination layers before 
generating the filleting elements. To have the system clear the destination layers before running 
the operation, click this option so that it has a check mark. Otherwise do not check this option. Do 
not use this option if there is any data on the destination layers that you want to keep. 
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7. On the Options tab, set the standard Options. 

 

Filleting Options Tab 

Affect only Elements Inside the Reference Frame: A check mark indicates the program will 
only generate fillets for pads that are inside the Reference Frame. No check mark means the 
system will generate fillets for the entire plot. 

Current D Code Only: A check mark indicates the program will only generate fillets for 
elements of the current D Code. If you select this option, set the current D Code in the D Code edit 
field. No check mark means the system will generate fillets for all elements regardless of D Code. 
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Save Milestone Before Operation: This option saves a Milestone file before running the 
operation, so in case the results are not what you want, you can easily revert to the Milestone file. 
To have the system save a Milestone file before running the operation, click this option so that it 
has a check mark. Otherwise do not check this option. 

8. On the Fillet Type tab, select Snowman Filleting. 

9. On the Snowman tab, set the snowman filleting options. 

 

Filleting Snowman Tab 
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Snowman Centerpoint Factor: Enter a Snowman Centerpoint Factor to determine the placement 
of the snowman pad. The snowman pad is placed at a point on the incoming trace that is at a 
distance from the original pad’s centerpoint. The Distance is equal to the Factor x Radius of the 
original pad. So a factor of 1 puts the snowman at the intersection of the trace and the edge of the 
pad. And a factor of .5 puts the snowman pad half way between the edge of the original pad and 
it’s center. 

Fillet Size options: 

• Round Size to Decimal: Enter the decimal position to round the size to. The system can 
calculate an exact size for the snowman pads based on the equations below, but you pick 
the decimal position to round to. 

• Pad Size Only: This option calculates the snowman pad size based on only the original 
pad’s size. The Snowman Pad Size is equal to the Original Pad Size x the Reduction 
Factor. 

• Pad and Trace Size: This option calculates the snowman pad size based on both the 
original pad’s size and the width of the incoming trace. The Snowman Pad Size is equal 
to (Original Pad Size – Trace Width) x the Reduction Factor + Trace Width. 

• Reduction Factor: Enter a reduction factor for the size formula you selected. 

D Code options: 

• Use Existing D Codes within Tolerance: This option uses the closest available existing 
D Code size within tolerance for the fillet pads. If you use this option, enter a Tolerance. 
A tolerance of zero forces the system to select exact-size D Codes. If no appropriate 
D Code is found, the system aborts the operation with a message indicating the aperture 
shape and size were not found. 

• Create New D Code: This option creates new D Codes not currently defined in the 
D Code table for the fillet pads. If you select this option, enter the First New D Code to 
be created.  

10. On the main Filleting dialog, click OK. 
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Generate Teardrop Fillets 

 
The program generates Teardrop filleting by drawing a triangular shape at the intersection points of 
existing pads and traces. The fillet is drawn from traces of the same D Code as the incoming trace. You 
set the start point on the incoming trace. Teardrop filleting can only be added to round pads. 

To Set Teardrop Fillet Options: 
1. Make the layers you want to add filleting to active, visible layers. See Select from the Active 

Layers on page 152. 

2. On the D Code Table and the Tool Code Table, define all D Codes and Tool Codes.  

• The program needs accurate dimensions in order to determine fillet size and placement.  

• Teardrop filleting can only be added to Round © shapes. To add teardrop filleting to 
another shape pad, temporarily transcode it to a Round pad, add the filleting, and then 
convert the pad back to its original shape. 

3. Set the Visibility settings. 

The operation only checks visible elements, so make sure all pads, traces, selected, and unselected 
elements to be checked are visible. See Element Visibility on page 84. 

4. If you want to add filleting to only part of the plot, position the reference frame around that 
part. See Reference Frame on page 177.  

 If you want to check all data, it does not matter where the reference frame is positioned. 

5. On the Tools menu, click Add Filleting. 

6. On the Layers tab, select the layers for the operation. 
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Filleting Layers Selection Tab 

Source Layers: Select the layers where the elements you want to generate filleting for are located. 

First Destination Layer: Select the layers where you want the filleting elements to be added. If 
you want the filleting to be added directly to the source layers, select Same. 

Clear Destination Layers First: This option clears all data out of the destination layers before 
generating the filleting elements. To have the system clear the destination layers before running 
the operation, click this option so that it has a check mark. Otherwise do not check this option. Do 
not use this option if there is any data on the destination layers that you want to keep. 
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7. On the Options tab, set the standard Options. 

 

Filleting Options Tab 

Affect only Elements Inside the Reference Frame: A check mark indicates the program will 
only generate fillets for pads that are inside the Reference Frame. No check mark means the 
system will generate fillets for the entire plot. 

Current D Code Only: A check mark indicates the program will only generate fillets for 
elements of the current D Code. If you select this option, set the current D Code in the D Code edit 
field. No check mark means the system will generate fillets for all elements regardless of D Code. 
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Save Milestone Before Operation: This option saves a Milestone file before running the 
operation, so in case the results are not what you want, you can easily revert to the Milestone file. 
To have the system save a Milestone file before running the operation, click this option so that it 
has a check mark. Otherwise do not check this option. 

8. On the Fillet Type tab, select Teardrop Filleting. 

9. On the Teardrop tab, enter a value for the Teardrop Endpoint Factor to determine the fillet 
size. The Teardrop Endpoint Factor determines the distance from the pad center to the start of 
the fillet. The distance is equal to the Factor x the Pad Radius. So a factor of 1 would place 
the start point right at the pad/trace intersection and would yield no filleting. The factor must 
be greater than 1, and the larger the teardrop factor, the larger the fillet. 



 Chapter 5 Use Automatic Editing Tools 

 279 

 

Filleting Teardrop Tab 

10.  On the main Filleting dialog, click OK. 
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Generate Centroid Data 

 
The program can generate two types of Centroid data files: an ASCII text file containing component 
numbers and the X, Y coordinates of the pad centers of the source layer, and a Gerber reference file 
showing pad outlines and component numbers. With some editing the ASCII text file may be used by 
pick-and-place machines and glue dispensers. The Gerber reference file can be displayed in the 
viewing area, printed and plotted. 

Prepare a Component Footprint File 

 
The Centroid Data operation finds individual pad centers and does not automatically recognize 
component footprints composed of several pads. Therefore, you must represent component footprints 
as single pads. The following steps convert the multi-pad component footprints of a source layer into 
single pads on a component footprint layer that you can use for the Centroid Data operation. 

To Prepare a Component Footprint File: 
1. Import a solderpaste layer. 

2. Delete any elements that are not parts of component footprints to be included in the pick-and-
place file. 

3. Position the Reference Frame around the first component footprint to be converted. See 
Reference Frame on page 177.  

Because large, complex footprints may look to the program like several smaller and less complex 
footprints, convert the largest and most complex footprints first. 

4. On the Tools menu, click Convert Drawn Pads-Single Shape. 

5. On the Layers tab, set the parameters as follows: 
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Single Shape Layers Tab for Footprint File 

Old Shapes Layers: Select the solderpaste source layer. 

First New Shapes Layer: Select the new component footprint layer. 

Clear Transfer Layer: Do not check this option. 

6. On the Old Shapes tab, select Keep. 
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Single Shape Old Shape Tab for Footprint File 

7. On the Options tab, set the parameters as follows: 
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Single Shape Options Tab for Footprint File 

Identify Old Shapes by Outlines Only: Check this option. 

Automatically Set the New D Code Dimensions: Check this option. 

Automatically Determine Shape Centers: Check this option. 

Tolerance: Enter 1 or 2 mils 

Do not check any other Options. 

8. On the Pad D Code tab, select an unused D Code. 

9. Click OK. 

The system converts all instances of the selected component footprint into flashed pads. Continue 
at step 3 to convert all the remaining component footprints. 

Once all the footprints have been converted to flashed pads, you are ready to run the Centroid 
operation on the component footprint layer. 
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Run the Centroid Operation 

 

To Run the Centroid Operation: 
1. Make the footprint layer and the destination layer for the Gerber reference data active, visible 

layers. See Select from the Active Layers on page 152. 

2. Set the Visibility settings. 

The operation only works on visible elements, so make sure elements in the footprint file are 
visible. See Element Visibility on page 84. 

3. On the Tools menu, click Generate Centroid Data. 

4. On the Layers tab, select the layers for the operation. 

 

Centroid Data Layers Selection Tab 

Source Layer: Select the component footprint layer. 

Destination Layer: Select the layer where you want the Gerber reference data to be generated. 

5. On the Settings tab, set the Centroid options. 
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Centroid Data Settings Tab 

Starting Component Number: Enter the first number for the program to use when numbering the 
components. 

Component Number Text Size: Enter the size of lettering for the program to use when 
numbering the components in the Gerber reference file. 

Report File Format: Select the format for the ASCII data file: either a Lavenir Format report 
file, or a Universal Pick-and-Place report file. 

6. On the Origin tab, set the origin to be used in the report file. 
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Centroid Data Origin Tab 

Absolute: The report file references the Absolute origin (0,0) as the origin. 

Current Cursor Position: The report file references the current cursor position as the origin. 

7. On the main Centroid Data dialog, click OK. 

The program calculates the center for each component footprint pad and assigns each a component 
number.  

The program generates the ASCII file containing component numbers and X, Y coordinate 
locations for the component centers in the current directory. You will probably need to edit the 
Centroid report file to the specific requirements of your machine.  
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View and Edit a Centroid Report File 

 
The Centroid operation generates an ASCII text file containing component numbers and the X, Y 
coordinates of the pad centers of the component footprint source layer. The file is automatically given 
the prefix of the Job File with the extension .CEN. With some editing the ASCII text file may be used 
by pick-and-place machines and glue dispensers.  

To View and Edit the Centroid Report File: 
1. On the File Menu, click a Report-View. 

2. In the Files of Type list, select All Files (*.*). 

3. In the Look in box, click the drive, folder, or network location that contains the report. 

4. In the folder list, double-click folders until you open the folder that contains the report you 
want. 

5. Double-click the Report. 

6. Edit the file as necessary 

7. If you want to rename the file, save it under a new name by using the Save As command. 



Lavenir CAM Software User’s Guide 

288 

Compare Layers 

 
The program can show you differences between any two layers. The program selects or transfers to a 
destination layer all elements that appear on one of the two original layers but not on the other. You 
may set the system to ignore D Code differences, which is useful when comparing a padmaster or drill 
layer to a soldermask.  

Run the Layer Comparison 

 

To Run the Layer Comparison: 
1. Make the two layers you want to compare active, visible layers. See Select from the Active 

Layers on page 152. 

2. Set the Visibility settings. 

The operation only compares visible elements, so make sure all Pads, Traces, Selected, and 
Unselected Elements to compare are visible. See Element Visibility on page 84. 

3. If you want to compare only part of the plot, position the reference frame around that part. 
See Reference Frame on page 177.  

 If you want to check all data, it does not matter where the reference frame is positioned. 

4. Clear selection from all elements.  

Depending on your preference, the operation can use selection to indicate layer differences. 
Clearing the selection first helps avoid confusion. 

5. On the Tools menu, click Compare Layers. 
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Compare Layers Dialog 

6. Select the layers for the operation. 

First Layer: Select one of the layers to compare. 

Second Layer: Select the other layer to compare. 

Layer Discrepancy Transfer Layer: Select the layers you want the differing elements to be 
transferred to. If you want the differences to be selected instead of transferred, select Same. 

7. Set the remaining options. 

Affect only Elements Inside the Reference Frame: A check mark indicates the program only 
compares elements that are inside the Reference Frame. No check mark means the system 
compares the entire plot. 

Ignore D Codes: A check mark indicates the program only compares element locations; any 
element that doesn’t have a corresponding element at the same location is flagged. No check mark 
means the system compares both the locations and the D Codes; any element that doesn’t have 
another element of the same D Code at the same location is flagged. 

Save Milestone Before Operation: This option saves a Milestone file before running the 
operation, so in case the results are not what you want, you can easily revert to the Milestone file. 
To have the system save a Milestone file before running the operation, click this option so that it 
has a check mark. Otherwise do not check this option. 

8. On the main Compare Layers dialog, click OK. 

The system compares the layers and transfers or selects the elements that are different in the two 
layers. You can inspect the differences. 
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Inspect the Layer Differences 

 
After you have run the layer comparison, differences between the two layers are flagged by 
transferring or selecting differing elements, depending on the option you set. Here are some 
suggestions for inspecting the differences: 

To Inspect the Layer Differences: 
Ø To clearly see all instances of selected differences, shut off the visibility of unselected 

elements, leaving only the selected elements visible. See Element Visibility on page 84. 

Ø To clearly see all instances of transferred differences, shut off the layer visibility of the non-
transfer layers, leaving only the transferred elements visible. 

Ø To see all instances of a particular type of element, query the properties of a selected or 
transferred element, set the selection criteria to look for only that type of element, and use the 
First Element and Next Element commands. 
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Compare Netlists 

 
The netlist comparison feature compares two netlists: one netlist is the netlist under test (NUT) and the 
other one is the reference netlist (REF). The REF netlist is assumed to be accurate, and the NUT is 
compared to the REF to find differences. For every pad in the NUT, the system looks for a 
corresponding pad in the REF. When the system finds corresponding pads, it compares the 
corresponding nets to find the following types of errors: 

• Shorts: One net in the NUT corresponds to two or more nets in the REF. 

• Opens: Two or more nets in the NUT correspond to one net in the REF. 

• Unmapped Nets: Nets that exist only in the NUT, with no corresponding elements in the 
REF.  

 Netlists that exist only in the REF are ignored. 

Prepare Data for Netlist Comparison 

 
The netlist data need to be properly prepared in order for the netlist comparison to be accurate.  

To Prepare Data for Netlist Comparison: 
1. Load the NUT netlist information into the system using one of the following techniques. 

• Extract the netlist. See Netlist Extraction on page 413. If you do a vector netlist 
extraction, you will still need to import the netlist. 

• Open or import a job file containing netlist information. See Open a Job File on page 22 
or Import a Job File on page 27. 

• Import a netlist. See Import Netlist Data on page 55. 

2. Load the REF netlist into layers that start at a layer number higher than any of the layers of 
the NUT. You can use any of the same techniques used to load the NUT. 

3. Align REF and NUT netlists. See Move Layers on page 164 and Align Layers on page 167. 

4. If necessary, change the board layer numbers so that layers in the NUT match 
corresponding layers in the REF.  

 The netlist comparison feature compares the netlist information board layer by board 
layer. Any layer with a board layer number 0 will be compared against all other board 
layers; this follows the IPC-356 convention of layer 0 being the through hole layer. 

Ø When the data is prepared, you can run the netlist comparison. 
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Run the Netlist Comparison 

 

To Run the Netlist Comparison: 
1. When the data is prepared, go to the Tools menu, and click Netlist-NetCompare-Compare 

Two Netlists. 

 

Netlist Comparison Dialog 

2. On the Netlist Comparison Dialog, set the following options: 

Reference Net Starts At: Enter the Layer Number where the REF netlist begins. The REF netlist 
must begin at a higher layer number than any layer of the NUT netlist. 

Board Layers to Compare: Select the board layers to compare: 

• Click a layer to select that layer. 
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• Shift+Click to add multiple layers to the selection. 

• Ctrl+Click to remove layers from the selection. 

Flag Netlists that Exist Only in NUT: 

• If the option has a checkmark, then the system will flag netlists that exist only in the NUT 
and do not have any corresponding elements in the REF. 

• If the option does not have a checkmark, then the system will not flag netlists that exist 
only in the NUT and do not have any corresponding elements in the REF. 

Use Pad Center for Matching: 

• If the option has a checkmark, then the system will find elements in the REF that 
correspond to elements in the NUT by comparing the centerpoints of elements. If this 
option is selected, you can enter a Tolerance value within which the system can identify 
corresponding centerpoints. A Tolerance of 0 (zero) means that centerpoints must match 
exactly. 

• If the option does not have a checkmark, then the system will find elements in the REF 
that correspond to elements in the NUT by determining if the elements overlap. 

Report File: Enter a file name and path for the report file, or click the Browse button to select 
from the available directories. 

3. Click Compare. 

The system compares the netlists and reports any differences found by generating a report file and 
displaying a Netlist Comparison Error dialog. 
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Inspect Netlist Comparison Discrepancies 

 

To Inspect Netlist Comparison Discrepancies: 
1. Display the Netlist Comparison Error dialog. The dialog is automatically displayed when the 

netlist comparison ends or can be displayed by going to the Tools menu, and clicking Netlist-
NetCompare-Display Errors. 

 

Netlist Comparison Error Dialog 

In the dialog title bar, the Netlist Comparison Error dialog indicates how many errors were 
found, which error number is currently shown and whether the error is a Short, an Open or an 
Unmapped Net. 

Shorting Elements List: If the system can identify elements that cause shorts between nets, then 
those elements are listed in the Shorting Elements list box. The element is identified in the list box 
by which two nets it shorts. 

NUT/REF Checkboxes: Indicates whether the NUT and REF netlists are visible or not. 

• If there is a checkmark in the given checkbox, then that netlist is visible. 

• If there is not a checkmark in the given checkbox, then that netlist is not visible. 

NUT/REF List Boxes: Indicates which nets in the NUT and REF netlists are involved in the 
current error. 

• In the case of a short, one net in the NUT list box corresponds to two or more nets in the 
REF list box. 

• In the case of an open, two or more nets in the NUT list box correspond to two one net in 
the REF list box. 

• In the case of an unmapped net, a net in the NUT list box corresponds to no net in the 
REF list box. 
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2. Navigate to the error you want to inspect by clicking the First, Next, Previous or Last 
buttons. 

3. To see a Shorting element on screen, click on the element you want to see in the Shorting 
Elements list box.  

On screen, the crosshair hops to the element you clicked on in the list. 

4. To turn on or off the display of the two netlists, click on the checkboxes next to NUT and 
REF.  

• If there is a checkmark in the given checkbox, then that net is visible. 

• If there is not a checkmark in the given checkbox, then that net is not visible. 

5. To highlight nets related to the current error on screen, click on the net(s) you want to 
highlight in the NUT or REF columns so that they are highlighted in the lists. Use Shift+Click 
to add multiple nets to the selection, and use Ctrl+Click to remove nets from the selection. 
Then click Select. 

The system selects the nets on screen so that they are highlighted.  
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Make Net Numbers in the NUT Match Net Numbers in the REF 

 
In addition to doing netlist comparison, the program also has a feature for mapping the net numbers in 
the NUT to the corresponding net numbers in the REF. This feature can be useful for mapping the REF 
net numbers to alphanumeric net names, or for facilitating the inspection of errors by having the same 
net numbers or names in the REF and the NUT. 

To Make Net Numbers in the NUT Match Net Numbers in the REF: 
1. Prepare the netlist data the same way you would prepare it for a netlist comparison. See 

Prepare Data for Netlist Comparison on page 291. 

2. When the data is prepared, go to the Tools menu, and click Netlist-NetCompare-Compare 
Two Netlists. 

 

Netlist Comparison Dialog 

3. On the Netlist Comparison Dialog, set the following options: 

Reference Net Starts At: Enter the Layer Number where the REF netlist begins. The REF netlist 
must begin at a higher layer number than any layer of the NUT netlist. 

Board Layers to Compare: Select the board layers to compare: 
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• Click a layer to select that layer. 

• Shift+Click to add multiple layers to the selection. 

• Ctrl+Click to remove layers from the selection. 

Flag Netlists that Exist Only in NUT: This setting is not important for mapping net numbers; it 
is used for doing netlist comparisons.  

Use Pad Center for Matching: 

• If the option has a checkmark, then the system will find elements in the REF that 
correspond to elements in the NUT by comparing the centerpoints of elements. If this 
option is selected, you can enter a Tolerance value within which the system can identify 
corresponding centerpoints. A Tolerance of 0 (zero) means that centerpoints must match 
exactly. 

• If the option does not have a checkmark, then the system will find elements in the REF 
that correspond to elements in the NUT by determining if the elements overlap. 

Report File: Enter a file name and path for the report file, or click the Browse button to select 
from the available directories. 

4. Click Map NUT. 

The system changes the net numbers of the NUT to match the corresponding net numbers of the 
REF. 
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Correct Trace/Pad Overlap Problems 

 
The program can fix trace overlap problems. The program can retract traces to edges of center holes or 
to pad borders, extend traces to pad centers or to intersecting trace endpoints, and transfer duplicate 
traces and pads, traces covered by pads, and dangling traces to other layers. These operations are 
useful for cleaning up scanned artwork. 

To Correct Trace Overlap Problems: 
1. Make the sources layers and destination layers active, visible layers. See Select from the 

Active Layers on page 152. 

2. On the D Code Table and the Tool Code Table, define all D Codes and Tool Codes. The 
program needs accurate dimensions in order to correct the overlap properly.  

3. Set the Visibility settings. 

The operation only checks visible elements, so make sure all pads, traces, selected, and unselected 
elements to be checked are visible. See Element Visibility on page 84. 

4. Clear selection from all elements.  

Depending on the options you select, some of the operations select elements for identification. 
Clearing the selection first helps avoid confusion. 

5. If you want to correct overlap problems for only part of the plot, position the reference frame 
around that part. See Reference Frame on page 177.  

 If you want to check all data, it does not matter where the reference frame is positioned. 

6. On the Tools menu, click Trace/Pad Overlap. 

7. On the Layers tab, select the layers for the operation. 
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Overlap Layers Selection Tab 

Source Layers: Select the layers where the elements you want to correct are located. 

First Destination Layer: Select the first layer where elements are to be transferred for transfer 
operations. If you want elements to be selected rather than transferred, select Same. Some of the 
operations do not transfer elements, and for those operations, this setting is irrelevant.  

Clear Destination Layers First: This option clears all data out of the destination layers before 
transferring elements. To have the system clear the destination layers before running the operation, 
click this option so that it has a check mark. Otherwise do not check this option. Do not use this 
option if there is any data on the destination layers that you want to keep. 

8. On the Options tab, set the standard Options. 
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Overlap Options Tab 

Affect only Elements Inside the Reference Frame: A check mark indicates the program will 
only check elements that are inside the Reference Frame. No check mark means the system will 
check the entire plot. 

Save Milestone Before Operation: This option saves a Milestone file before running the 
operation, so in case the results are not what you want, you can easily revert to the Milestone file. 
To have the system save a Milestone file before running the operation, click this option so that it 
has a check mark. Otherwise do not check this option. 

9. On the Operations tab, select the overlap operation: 
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Overlap Operations Tab 

Transfer Duplicate Pads and Traces: This operation transfers duplicate elements to the 
destination layer. Duplicate traces are defined as having the same size, shape and endpoints. And 
duplicate pads are defined as having the same size, shape and centerpoint. 

Transfer Dangling Traces: This operation transfers to the destination layer traces that don’t have 
both endpoints connected to either a pad centerpoint or another trace endpoint. 

Transfer Traces Covered by Pads: This operation transfers any trace covered by a single pad to 
the destination layer. If you enter a value for the Margin, the pad and trace sizes are increased by 
the margin to determine if the trace is completely covered by the pad. The difference between this 
option and the Transfer Traces Obstructed by Pads option is that this option requires that the trace 
be covered by a single pad in order to be transferred.  

Transfer Traces Obstructed by Pads: This operation transfers any trace covered by a pad or by 
a combination of pads to the destination layer. If you enter a value for the Margin, the pad and 
trace sizes are increased by the margin to determine if the trace is completely covered by the pad. 
The difference between this option and the Transfer Traces Obstructed by Pads options is that this 
option allows the trace to be covered by a combination of pads in order to be transferred. 
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Retract Traces that Cover Holes: This operation retracts traces covering the center holes of Heat 
Reliefs (H), Squares (S), Diamonds (D), or Rounds © to the edge of the center hole. If you enter a 
value for the Margin, the hole and trace size are increased by the margin to determine if the trace 
penetrates the hole and to what point it will be retracted. 

Retract Traces to Inside Pad Borders: This operation retracts traces that end in pads so that the 
trace endpoint area will be inside the pad border. If you enter a value for the Margin, the pad and 
trace sizes are increased by the margin to determine if the trace penetrates the pad and to what 
point it will be retracted. 

Retract Traces to Outside Pad Borders: This operation retracts traces that end in pads so that 
the trace endpoint area will be outside the pad border. If you enter a value for the Margin, the pad 
and trace sizes are increased by the margin to determine if the trace penetrates the pad and to what 
point it will be retracted. 

Extend Traces from Pad Borders to Pad Centers: This operation finds all traces that end at pad 
borders, and either extends the trace to the pad center or adds a new trace connecting the original 
endpoint to the pad center. 

Extend Traces from Inside Pads to Pad Centers: This operation finds all traces that end in a 
pad, but not in a pad centerpoint, and either extends the trace to the pad center or adds a new trace 
connecting the original endpoint to the pad center. If you enter a value for the Margin, then the 
trace endpoint must be that far inside the pad outline to be extended by this operation. 

Extend Traces at Endpoints: This operation extends traces of the same D Code that touch in 
their endpoint area but are not chained exactly. The traces are extended to make them intersect. If 
you enter a value for the Margin setting, the trace sizes are extended by this amount to determine 
if they touch. 

Replace Linear Chains of Traces with One Trace: This operation finds traces that are chained 
endpoint to endpoint and that continue in a straight line. The feature replaces the chain with a 
single trace that extends from one end of the chain to the other. 

10. On the main Overlap dialog, click OK. 

The program corrects the overlap problems as you specified. 
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Generate Contours 

 
The program can generate closed polygon contours from existing trace contours. The system identifies 
existing loops of intersecting traces and replicates the contours using an F-type D Code. The original 
traces do not need to be chained and do not need to form perfectly closed polygons. The operation 
generates a perfectly closed polygon contour by connecting all intersection points and adding traces to 
bridge gaps. This feature can be used to generate split plane layers for netlist extraction.  

To Generate Contours: 
1. Make the layers where the original traces are and where you want to generate contours active, 

visible layers. See Select from the Active Layers on page 152. 

2. Set the Visibility settings. 

The operation only checks visible elements, so make sure all pads, traces, selected, and unselected 
elements to be checked are visible. See Element Visibility on page 84. 

3. If you want to generate contours from traces on only part of the plot, position the reference 
frame around that part. See Reference Frame on page 177.  

 If you want to check all data, it does not matter where the reference frame is positioned. 

4. On the Tools menu, click Build Contour. 

5. On the Layers tab, select the layers for the operation. 
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Build Contour Layers Selection Tab 

Source Layers: Select the layers where the traces you want to generate the contour from are 
located. 

First Destination Layer: Select the layers where you want the contour traces to be added. If you 
want the contour traces to be added directly to the source layers, select Same. 

Clear Destination Layers First: This option clears all data out of the destination layers before 
generating the contour traces. To have the system clear the destination layers before running the 
operation, click this option so that it has a check mark. Otherwise do not check this option. Do not 
use this option if there is any data on the destination layers that you want to keep. 

6. On the Options tab, set the standard Options. 
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Build Contour Options Tab 

Affect only Elements Inside the Reference Frame: A check mark indicates the program will 
only generate contour traces for source traces that are inside the Reference Frame. No check mark 
means the system will generate contour traces for the entire plot. 

Current D Code Only: A check mark indicates the program will only generate contour traces for 
source traces of the current D Code. If you select this option, set the current D Code in the D Code 
edit field. No check mark means the system will generate contour traces for all elements regardless 
of D Code. 

Save Milestone Before Operation: This option saves a Milestone file before running the 
operation, so in case the results are not what you want, you can easily revert to the Milestone file. 
To have the system save a Milestone file before running the operation, click this option so that it 
has a check mark. Otherwise do not check this option. 

7. On the Contour tab, set the options for generating the Contours. 
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Build Contour Contours Tab 

Calculate Trace Intersections Based on Zero-Width Traces: This option looks at source trace 
centerlines, endpoint to endpoint, to determine if they intersect and are part of the polygon 
contour. 

Calculate Trace Intersections Based on Full-Width Traces: This option looks at full-width 
source traces to determine if they intersect and are part of the polygon contour. 

Close Gaps Smaller Than: Enter the maximum size gap that the operation can close to form a 
polygon contour. When the operation encounters a gap smaller that this value it adds a trace to 
close the gap on the replicated polygon contour. The replicated polygon has no gaps. 

8. On the main Build Contours dialog, click OK. 

The system displays a Build Contours cursor to indicate that the Build Contours operation is 
selected. 

 

Build Contour Tool 
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9. Click the cursor inside a loop of traces that you want to replicate as a polygon contour. 

The system looks at the traces surrounding the cursor, finds the smallest loop of intersecting traces 
that forms a closed loop around the cursor, and replicates the polygon contour on the destination 
layer. The message line reports how many traces were generated to form the contour. 

The Build Contours operation remains selected, so you can replicate as many polygon contours as 
you want until you release the tool or select another one. 
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Consolidate Soldermask Data 

 
The program can consolidate drawn features in a soldermask layer into flashed pads. This is basically 
an automatic Draw-to-Flash operation for the soldermask layer. The feature was called “Autoblob” in 
the DOS View2001 software. 

To Consolidate Soldermask Data: 
1. Make the sources layers and destination layers active, visible layers. See Select from the 

Active Layers on page 152. 

2. On the D Code Table and the Tool Code Table, define all D Codes and Tool Codes. The 
program needs accurate dimensions in order to consolidate the elements properly.  

3. Set the Visibility settings. 

The operation only checks visible elements, so make sure all pads, traces, selected, and unselected 
elements to be checked are visible. See Element Visibility on page 84. 

4. If there is a board outline on the soldermask layer, remove the board outline. 

5. If you want to consolidate elements on only part of the plot, position the reference frame 
around that part. See Reference Frame on page 177.  

 If you want to check all data, it does not matter where the reference frame is positioned. 

6. On the Tools menu, click Soldermask Consolidation. 

7. On the Layers tab, select the layers for the operation. 



 Chapter 5 Use Automatic Editing Tools 

 309 

 

Soldermask Consolidation Layers Selection Tab 

Soldermask Layer: Select the soldermask layer where the elements you want to consolidate are 
located. 

Destination Layer: Select the layer where the consolidated data is to be generated. 

Clear Destination Layers First: This option clears all data out of the destination layer before 
generating the consolidated data. To have the system clear the destination layers before running 
the operation, click this option so that it has a check mark. Otherwise do not check this option. Do 
not use this option if there is any data on the destination layers that you want to keep. 

8. On the Options tab, set the standard Options. 
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Soldermask Consolidation Options Tab 

Affect only Elements Inside the Reference Frame: A check mark indicates the program will 
only consolidate elements that are inside the Reference Frame. No check mark means the system 
will check the entire plot. 

9. On the Settings tab, set the consolidation settings. 
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Soldermask Consolidation Settings Tab 

Shape Tolerance: Drawn features that are not exactly the same size but whose size difference is 
within the Shape Tolerance size are flashed to the same shape using the same D Code. 

Largest Shape Size: Drawn features that are larger than the Largest Shape Size are not flashed as 
pads. This is to avoid converting large drawn features, such as text blocks, that should not be 
converted into soldermask pads. 

10. On the main Soldermask Consolidation dialog, click OK. 

The program generates the consolidated soldermask data.  
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Chapter 6 
D Code Table Overview 

 
 On the D Code Table, the program handles shape, size and other aperture information for up to 2000 
total D Codes definitions per file, ranging from D10 to D9999. Additional information for up to 255 
Tool Codes is handled on the Tool Code Table. Together these two tables describe the plot data 
elements. 

To Display the D Code Table: 
Ø On the Setup menu, click D Codes. 

 F5 

 

D Code Table 

Aperture information for imported Gerber, NC Drill, HPGL, DMPL, and Pattern Generator data can be 
imported from any of several CAD/CAM systems or you can manually set up new aperture 
information.  
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D Code numbers can have up to five digits. Leading zeros are allowed, as in D00125. D Codes have a 
resolution to 0.001 mil when the Database Units are English and .01 micron when in metric.  

On the D Code Table you can see the number of occurrences of each D Code in the loaded data, 
including the number of pads, traces, and arcs for each D Code. 

The D Code Table has its own menu bar with many D Code editing commands that allow you to insert 
and delete D Codes from the table; change D Code values by directly editing them, or by rotating, 
swelling, growing, scaling, or rounding off D Code dimensions; transcode elements to a new D Code 
or transcode D Codes to unique shapes.  

To help you navigate the table and select D Codes for operations, you can select D Codes manually, 
select all D Codes, select used D Codes, select D Codes of the same shape, invert the selected 
D Codes, and select D Codes by size.  

Current D Code 

 
The Current D Code is indicated in the Current Element Toolbar. 

 

Current D Code in Current Element Toolbar 

The Current D Code is the D Code of elements inserted using the Insert Commands and it is also one 
of the optional selection criteria for selecting elements for editing. Selection can be limited to only 
elements of the Current D Code.  

To Set the Current D Code: 
Ø Set the Current D Code in the Current Element Toolbar. 

Ø Select a single D Code in the D Code Table.  

Ø Query an Element in the Graphics Screen. See Query Element on page 103. 
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D Code Shapes and Dimensions 

 
All aperture shapes built into the Lavenir Photoplotters are legal shape entries. A D Code is described 
by its Shape Code and its Dimension Values. 

Round “C” 

 

Round Shape Dimensions: 
• Symmetrical X, Y Diameter  

• Center Hole Diameter (set to 0 when there is no hole.) 

Diamond “D” 

 

Diamond Shape Dimensions: 
• Symmetrical X, Y Size 

• Center Hole Diameter (set to 0 when there is no hole.) 

Octagon “E” 

 

Octagon Shape Dimensions: 
• Symmetrical X, Y Size 

• Center Hole Diameter (set to 0 when there is no hole.) 
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Polygon Trace “F” 

 
On screen, the Polygon Trace is drawn 1 pixel wide; however, the trace is considered to have zero-
width. The Polygon Trace is used to define polygon boundaries for polygon-filling operations such as 
Copper Pouring and Venting and Thieving. The polygon ID is used to identify the polygon for 
determining the polygon nesting order. The fill polarity determines whether a polygon is to be filled 
inside or whether it defines a keep-out area. 

 The Fill Polarity setting is not saved in Lavenir .ENV files. 

Polygon Shape Dimensions: 
• ID number 

• Fill Polarity:  

Auto: Polarity is determined automatically by determining whether one polygon is inside another. 

POEX: The polygon is an external polygon that is to be filled inside. 

POIN: The polygon is an internal polygon that defines a keep-out area for fill. 

Heat Relief “H” 

 

Heat Relief Shape Dimensions: 
• Outer Diameter 

• Inner Diameter 

• Number of Cuts 

• Cut Width 

• Cut Angle of the first cut  
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Custom Aperture “M” 
Custom apertures are shapes that are constructed from other more basic pads and traces called 
primitives. Custom apertures can be composed of any combination of paint and scratch or positive and 
negative primitives. The custom apertures are exported as miniature plot files of various formats. 
When you want to include the shape in a job, use a custom aperture that references the shape file.  

The program has many commands that allow you to process custom apertures. You can capture, 
export, and import custom aperture files. You can also recreate primitives used in a custom aperture 
and convert elements of custom aperture D Codes to primitives. For information on handling custom 
apertures and what to do if your custom apertures only display as an M in a square in the viewing area, 
see Custom Apertures on page 334. 

Custom Aperture Shape Dimensions: 
• File Name: Name of the miniature plot file where the custom aperture definition is exported. 

• File Format: Format of the miniature plot file where the custom aperture definition is 
exported. 

MEMPACK: Lavenir RPG series photoplotter MEMPACK format. 

MDA Autoplot 

Gerber Extended 

Subfigure 
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NC Drill Hole “N” 

 
NC Drill data is represented in the system by the N shape D Code. 

Map Drill data to shape N as you import it or as you add it. When you output Drill data, only N shape 
pads are output.  

In the D Code table you can assign a Tool Code to each N shape D Code and then you can set the Tool 
Code parameters for that Tool Code. You can also set the Tool Code parameters on the Tool Code 
table, but you cannot map N Shape D Codes there. 

Drill Shape Dimensions: 
• Tool Code Number: This defines the corresponding Tool Code. Click Setup Tool to see the 

current parameters for this Tool Code in the Tool Code Table and to change the Tool Type 
and Diameter if you wish. 

Tool Parameters: 
• Diameter. This is the diameter of the hole. It is the same as the Diameter value in the Tool 

Code Table, and it can be entered and edited in either table. 

• Four tool types are supported. This value is the same as the Type value in the Tool Code 
Table, and it can be entered and edited in either table. 

Plated 

Non-Plated 

Tooling 

Via (X) 

Obround “O” 

 
Obrounds are like rectangles that have been rounded to a semi-circle on the short sides. 

Obround Shape Dimensions: 
• X size  

• Y size  
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Rounded Rectangle “Q” 

 
Rounded Rectangles are rectangular shapes that have corners rounded to a specific radius. 

Rounded Rectangle Shape Dimensions: 
• X size 

• Y Size 

• Radius 

Rectangle “R” 

 

Rectangle Shape Dimensions: 
• X size  

• Y size  

Square “S” 

 

Square Shape Dimensions: 
• Symmetrical X, Y size  

• Center Hole Diameter (set to 0 when there is no hole.) 
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Undefined “?” 

 
This is the shape of all newly created D Codes before they are mapped to some other shape. On the 
Graphics Screen these shapes will be displayed as circular. 

The system generates a warning message if you try to export an environment file, Extended Gerber file 
or report that contains undefined shapes. 

Target “T” 

 
The Target ID determines the shape of the target. 

Target Shape Dimensions: 
• Symmetrical X, Y size  

• Target ID. The RPG photoplotter plots targets T0 to T3. Targets T0 to T14 appear on the 
graphics screen as shown here. 
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Drawn Obround “X” 

 
The Drawn Obround is displayed as an obround on screen. The D Code is used to convert flashed 
rectangles or obrounds to drawn pads on output. This shape can be used to generate surface mount 
pads with a vector plotter that does not have the appropriate aperture shape. 

When exporting the file, the program generates a drawn trace for Drawn Obround D Codes. If you then 
manually convert the D Code to a circular or square aperture with a size equal to the smaller of the X 
or Y size fields, the vector plotter can draw the pads to the correct size.  

Drawn Obround Shape Dimensions: 
• X size of drawn pad 

• Y size of drawn pad 
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Drawn Crosshair “Y” 

 
The drawn crosshair is drawn from specified lengths of traces of the draw D Code.  

Drawn Crosshair Shape Dimensions: 
• Symmetrical X, Y Draw Length 

• Draw D Code: This D Code must be set to shape C. Line width is the diameter of the draw 
D Code. 

Blank “B” 
Blank D Codes are not displayed on screen or exported. 

Imported Environment File data mapped to shape B is ignored. If a D Code is changed to Blank, all 
elements with the corresponding D Code have visibility turned off on the Graphics Screen. 

The Blank shape can be toggled. When a D Code is blanked, the system remembers the old shape. 
Selecting shape B for a D Code that is already shape B will unblank it, restoring the previously 
remembered shape. 
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Select D Codes 
The program includes many commands to allow you to select D Codes in the D Code Table.  

Manually Select D Codes 

 

To Manually Select D Codes on the D Code Table: 
Ø To select a single D Code, Click on it.  

Ø To select a range of D Codes, use Shift+Click.  

Ø To add a single D Code to a group of selected D Codes, or to remove one, use Ctrl+Click.  

Select All D Codes 

 

To Select All D Codes: 
Ø On the Edit Menu of the D Code Table, click Select-All. 

Select Used D Codes 

 

To Select All Used D Codes: 
Ø On the Edit Menu of the D Code Table, click Select-Used. 

Select D Codes of the Same Shape 

 
You can select all of the D Codes on the D Code table that have the same Shape Code. This operation 
selects all D Codes with the same Shape Code, but the selected D Codes do not necessarily have the 
same dimensions. 

To Select All D Codes of the Same Shape Code: 
1. On the D Code Table, click on a single D Code with the Shape Code you want to select.  

2. On the Edit Menu of the D Code Table, click Select-Of Same Shape.  
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Invert the Selected D Codes 

 
The Invert Selection command inverts the group of selected D Codes so that the selected ones are 
unselected and the unselected ones are selected. 

To Invert the Selected D Codes: 
Ø On the Edit Menu of the D Code Table, click Select-Invert Selection. 

Select the Smallest Shape D Code 

 
This operation selects the first D Code in the D Code table with the smallest large dimension. 

To Select the Smallest Shape D Code: 
Ø On the Edit Menu of the D Code Table, click Select-By Size-Smallest.  

Select the Next Smaller Shape D Code 

 
The operation selects the D Code with the next smaller large dimension compared to the current 
selected D Code. 

To Select the Next Smaller Shape D Code: 
Ø On the Edit Menu of the D Code Table, click Select-By Size-Previous (Smaller).  

Select the Next Larger Shape D Code 

 
The operation selects the D Code with the next larger large dimension compared to the current selected 
D Code. 

To Select the Next Larger Shape D Code: 
Ø On the Edit Menu of the D Code Table, click Select-By Size-Next (Larger). 

Select the Largest Shape D Code 

 
This operation selects the first D Code in the D Code Table with the largest large dimension. 

To Select the Largest Shape D Code: 
Ø On the Edit Menu of the D Code Table, click Select-By Size-Largest.  
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Edit D Codes 
The program has many commands to edit D Codes on the D Code Table. Most of these commands are 
activated from menus on the D Code Table. 

Change D Code Shapes on the D Code Table 

 

To Change the Shape of a Selected D Code: 
1. On the D Code Table, select the D Code. 

2. Type the Shape Code for the new shape.  

After you select the new shape, the system displays a dialog in which you set the shape 
dimensions. 

If you don’t know the Shape Code for the Shape you want, the system provides a list of supported 
D Code shapes and Shape Codes from which you can select the shape of a D Code. There are several 
ways to display the list. 

To Display the Shape Code List: 
Ø Click the Shapes menu on the D Code Table Menu Bar. 

Ø Right-Click on a selected D Code to display the list on the Context Menu. 

Ø The system displays the list automatically when you insert a new D Code. 

Change D Code Dimensions on the D Code Table 

 

To Change D Code Dimensions on the D Code Table: 
1. On the D Code Table, select the D Code. 

2. On the D Code Table Menu Bar, click the Dimensions menu.  

 You can also access the dimensions dialog on the Right-Click Context Menu, and the system 
automatically displays the dimensions dialog after you select a new shape for a D Code. 
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Insert a D Code on the D Code Table 

 

To Insert a D Code on the D Code Table: 
1. On the Edit menu of the D Code Table Menu Bar., click Insert 

The system prompts with the first available unused D Code. 

 

Insert D Code Dialog 

2. Enter the D Code number you want to insert. 

3. Click OK. 

The system prompts you to set the Shape Code. 

 

Shape Code List 
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Delete a D Code on the D Code Table 

 
The Delete command deletes selected unused D Codes from the D Code Table. To protect your data, 
the system will not delete D Codes that are used in the loaded plot. If you want to delete a used 
D Code, first transcode the elements to a new D Code, then delete the D Code. 

To Delete a D Code on the D Code Table: 
1. On the D Code Table, select the D Codes you want to delete. 

2. On the Edit menu of the D Code Table Menu Bar, click Delete. 

Transcode D Codes 

 
Transcoding is the process of reassigning plot elements to new D Codes.  

To Transcode Elements of the Selected D Code on the D Code Table: 
1. If you only want to transcode elements for a portion of the data, then surround the elements to 

be transcoded with the reference frame in the viewing area. See Reference Frame on page 
177.  

 If you want to check all data, it does not matter where the reference frame is positioned. 

2. On the Setup menu, click D Codes. 

3. On the D Code Table, select the D Codes to be transcoded.  

4. On the Operations menu of the D Code Table, click Transcode. 
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Transcode D Codes Dialog 

5. In the To box, enter the range of unused D Codes that you want to transcode the selected 
D Codes to.  

6. To also swell the selected D Codes as they are transcoded, enter the amount to swell the 
D Codes in the Swell Dimension box. 

7. Select an option for Frame Selection: 

• Do Not Use Frame: Transcodes all elements of the selected D Codes. 

• Inside Frame: Transcodes only elements of the selected D Codes inside the Frame in the 
Viewing Area. 

• Outside Frame: Transcodes only elements of the selected D Codes outside the Frame in 
the Viewing Area. 

8. Click OK. 

The system transcodes the selected elements to the unused D Codes in the new range. 

To Transcode to Unique shapes on the D Code Table: 
The Unique Shapes command on the D Code Table transcodes all D Codes that have the same shape 
and size to the first D Code of that shape and size. This decreases the size of the aperture list.  

1. On the Setup menu, click D Codes. 

2. On the Operations menu of the D Code Table, click Unique Shapes. 
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Unique Shapes Tolerance Dialog 

3. To transcode only D Codes of exactly the same size, enter 0 in the Tolerance box.  
If you set the Tolerance to a value other than 0, the system transcodes D Codes within the 
tolerance to the smallest D Code in the group. 

4. Click OK. 

The program reports how many shapes were transcoded in the Toolbar and appends the 
information to the report file. 

Rotate D Codes 

 
If you rotate a plot by 90 degrees, you must also rotate the rectangular and obround shapes in the file 
or the resulting plot won’t be correct. This procedure covers rotating D Codes on the D Code Table by 
90 degrees. See also Rotate Selected Elements on page 138.  

To Rotate D Codes on the D Code Table 90 Degrees: 
1. On the Setup menu, click D Codes. 

2. On the D Code Table, select the D Codes to be rotated.  

3. On the Operations menu of the D Code Table, click Rotate 90 Degrees. 

The system swaps the X and Y dimensions of X, Y asymmetrical-shaped selected elements so that 
they are rotated in the plot. The affected shapes are R, O, X, H, T, Q and M. 
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Swell D Code 

 
The Swell D Code command changes the size of selected D Codes by the positive or negative amount 
entered in the Swell box.  

Holes in C, S and D shapes will be swelled the opposite way from the dimension of the shape. So, if 
the shape gets bigger the hole gets smaller. Custom shapes (M) cannot be swelled.  

To Swell a D Code: 
1. On the Setup menu, click D Codes. 

2. On the D Code Table, select the D Codes to be swelled.  

3. On the Operations menu of the D Code Table, click Swell. 

 

Swell D Codes 

4. Enter the amount to increase the dimensions in the Swell box. 

5. Click OK. 

Elements can also be swelled as they are transcoded.  
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Grow D Code 

 
The Grow D Code command changes the size of selected D Codes by the positive or negative amount 
entered in the Grow box.  

Holes in C, S and D shapes will be grown the same way as the dimension of the shape. So, if the shape 
gets bigger the hole also gets bigger. Custom shapes (M) cannot be grown.  

To Grow a D Code: 
1. On the Setup menu, click D Codes. 

2. On the D Code Table, select the D Codes to be grown.  

3. On the Operations menu of the D Code Table, click Grow. 

 

Grow D Codes 

4. Enter the amount to increase the dimensions in the Grow box. 

5. Click OK. 
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Scale D Code Dimensions 

 
The Scale D Code Dimensions command multiplies dimensions of selected D Codes by the factor 
entered in the Scale Factor box. To make shapes bigger, the factor must be greater than 1.0. 

To Scale D Code Dimensions: 
1. On the Setup menu, click D Codes. 

2. On the D Code Table, select the D Codes to be scaled.  

3. On the Operations menu of the D Code Table, click Scale Dim. 

 

Scale D Code Dimensions Dialog 

4. Enter the amount to multiply the dimensions in the Scale Factor box. 

5. Click OK. 
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Scale D Code Area 

 
The Scale D Code Area command scales the areas of selected D Codes by the factor entered in the 
Scale Factor box. This is similar to Scale Dimension, except that the factor multiplies the area of the 
shape instead of the dimensions. The linear dimensions increase by the square root of the given factor.  

To Scale D Code Area: 
1. On the Setup menu, click D Codes. 

2. On the D Code Table, select the D Codes to be scaled.  

3. On the Operations menu of the D Code Table, click Scale Area. 

 

Scale D Code Area 

4. Enter the amount to multiply the area in the Scale Factor box. 

5. Click OK. 

Round D Code Dimensions to the Nearest mil or .01mm 

 
The program can round D Code dimensions to the nearest mil when in English units, and the nearest 
.01mm when in metric. This can be useful after converting from English to metric or vice versa. 

To Round D Code Dimensions to the Nearest mil or .01mm: 
1. On the Setup menu, click D Codes. 

2. On the D Code Table, select the D Codes to be rounded.  

3. On the Operations menu of the D Code Table, click Round to Closest mill or .01mm. 

4. Click OK. 



Lavenir CAM Software User’s Guide 

334 

 

Custom Apertures 
Custom apertures are shapes that are constructed from other more basic pads and traces called 
primitives. Custom apertures can be composed of any combination of paint and scratch or positive and 
negative primitives. The custom apertures are exported as miniature plot files of various formats. 
When you want to include the shape in a job, use a custom aperture that references the shape file.  

The program has many commands that allow you to process custom apertures. You can capture, 
export, and import custom aperture files. You can also recreate primitives used in a custom aperture 
and convert elements of custom aperture D Codes to primitives.  

Capture a Custom Aperture 

 
The program can capture a model of a custom aperture composed of primitive elements in the current 
Job File and then use the custom aperture like any other D Code. 

To Capture a Custom Aperture: 
1. In the Viewing Area, build an aperture following these rules: 

• Insert the primitives on paint and scratch layers to build the shape you want to capture. 

• Traces of F-type D Code are assumed to form polygons that will be filled when the 
custom aperture is made. Polygons must be convex, no indents. 

• Use primitives supported by the format you will be saving to.  

• Don’t use another M-type D Code as a primitive unless it has already been defined. 

2. Make the layers where the model for the custom aperture is active, visible layers. See Select 
from the Active Layers on page 152. 

3. Set the Visibility settings. 

The operation only checks visible elements, so make sure all pads, traces, selected, and unselected 
elements to be checked are visible. See Element Visibility on page 84. 

4. Position the reference frame around the elements that you want to use as the custom aperture 
model. See Reference Frame on page 177.  

Your reference frame selection should contain only the elements that are part of the custom 
aperture model. If you can’t position the reference frame without also selecting extraneous 
elements, select and replicate the elements of the custom aperture model to another unused layer, 
then select the custom aperture model with the reference frame. 

5. If you do not want the system to automatically determine the centerpoint of the custom 
aperture, position the cursor where you want the centerpoint of the custom aperture to be and 
separate the cursor. See Separate the Crosshair and Mouse Cursor on page 112. 

6. On the Setup menu, click D Codes. 
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7. Click on the unused D Code that you want to make the custom aperture.  

8. Type M for custom aperture. 

 

Custom Aperture Dialog 

9. On the custom aperture dialog, click Build Shape.  

The system prompts whether you want to Autocenter the custom aperture. 

10. If you want the system to automatically determine the centerpoint of the custom aperture, 
click Yes. 
If want the system to use the current crosshair position as the centerpoint of the custom 
aperture, click No. 

The custom aperture is now captured and part of the current Job File database. It can be used in the 
current Job File like any other D Code and can be saved with the job. However, capturing the 
custom aperture does not save the custom aperture outside of the current job. If you close the job 
without exporting the aperture, you can’t import the aperture for use in another job. 

If a plot file containing this aperture is subsequently exported in either Extended Gerber or MDA 
Autoplot format, the aperture definition is exported as part of the plot file header. 

If a plot file containing this aperture is subsequently exported in basic Gerber format and the 
aperture has not been exported, then the aperture definition will not be part of the Gerber file. 

11. If you want to export the custom aperture file at this point, see the procedure to export a 
custom aperture file and begin the procedure at step 4. 
If you do not want to export the custom aperture file at this point, click OK. You can always 
export the custom aperture file from the saved Job File later. 
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Export a Custom Aperture File 

 
In order for a custom aperture captured in one job to be used in another job, the custom aperture must 
be exported. Later it can be imported into another job. 

To Export a Custom Aperture File: 
1. On the Setup menu, click D Codes. 

2. Click on the M-type D Code you want to export. 

3. Click the Dimensions menu. 

 

Custom Aperture Dialog 

4. In the File field of the Custom Aperture dialog, enter a File Name including the path or click 
Browse to select from available directories and file names. 

5. In the Type list of the Custom Aperture dialog, click on the File Format that you want to use 
for the custom aperture file: 

• MEMPAK: This is the Lavenir QuickPAD format. An aperture exported in Lavenir 
QuickPAD format, with extension .AP, can be saved in a MEMPAK cartridge and read 
by RPG photoplotters. 

• MDA: An aperture exported in MDA Autoplot format can be automatically merged into 
the file header of an exported MDA Autoplot file. 

• GerberX: An aperture exported in Extended Gerber format can be automatically merged 
into the file header of an exported Extended Gerber file. 
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• Subfigure: The aperture is exported as an Extended Gerber file, and represented on 
screen as the standard unmapped custom shape, the letter M over a square. 

6. On the Custom Aperture dialog, click OK. 

7. On the D Code Table, go to the Custom Apertures menu, and click Export to File. 

The aperture definition is exported and can be imported into the D Code Table in subsequent jobs. 
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Import a Custom Aperture File into the D Code Table 

 
In order for a custom aperture that was captured and exported from one job to be used in another job it 
needs to be imported into the second job. 

To Import a Custom Aperture File into the D Code Table: 
1. On the Setup menu, click D Codes. 

2. Click on the unused D Code for which you want to import a custom aperture file, and type M 
for custom aperture. 

 

Custom Aperture Dialog 

3. In the File field of the Custom Aperture dialog, enter the File Name including the path of the 
custom aperture file, or click Browse to select the file from available directories. 

4. In the Type list of the Custom Aperture dialog, click on the file format of the custom 
aperture file: 

5. On the Custom Aperture dialog, click OK. 

6. On the D Code Table, go to the Custom Apertures menu, and click Import from File. 

The system imports the aperture definition into the D Code Table.  

 In some cases the D Code Table may already contain several M-type D Codes with file names 
and formats already set, but no custom aperture files imported. You can import all of the 
custom aperture files simultaneously, by selecting all the M-Type D Codes on the D Code 
Table, going to the Custom Apertures menu, and clicking Import from File.  
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Recreate Primitives Used in a Custom Aperture 

 
The program can recreate the primitives of the selected custom aperture D Code and insert those 
primitives into the job at the cursor location. The operation inserts any paint and scratch primitives on 
separate layers, starting with the layer you designate. This operation does not convert elements of 
custom aperture D Codes to primitives. 

To Recreate Primitives Used in a Custom Aperture: 
1. Position the cursor where you want the custom aperture primitives to be inserted and separate 

the cursor. See Separate the Crosshair and Mouse Cursor on page 112. 

2. On the Setup menu, click D Codes. 

3. Click on the M-type D Code for which you want to recreate primitives. 

4. Click the Dimensions menu. 

 

Custom Aperture Dialog 

5. On the Custom Aperture dialog, click Make Primitives.  

6. On the Start Layer dialog enter the first layer where you want the program to insert 
primitives. 

The program inserts any paint and scratch primitives on separate layers, starting with the layer you 
designate.  

7. Click OK. 
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Convert Elements of Custom Aperture D Codes to Primitives 

 
The program can convert elements of M-type D Codes into their primitive elements. The original 
custom elements are removed and replaced by their primitive components.  

 The elements of the selected M-Type D Codes are replaced by their primitives in the same 
active, visible layers as the original M-type elements, so only shapes that don’t have both 
paint and scratch components can be converted this way.  

To Convert Elements of Custom Aperture D Codes to Primitives: 
1. Make the layers where you want to convert custom apertures active, visible layers. See Select 

from the Active Layers on page 152. 

2. On the Setup menu, click D Codes. 

3. Select the M-type D Codes for which you want to recreate primitives. This operation is not 
limited to one D Code at a time, so select all the M-Type D Codes you want to convert. 

4. On the D Code Table, go to the Custom Apertures menu, and look at Rounded Ends OK. 

• If Rounded Ends OK has a check mark, then the system will replace square-ended trace 
primitives with round-ended ones in cases where the system would otherwise generate 
polygons. This applies only to non-vertical and non-horizontal traces. This option is 
useful for languages such as Extended Gerber in which there are no round-ended 
primitives. In such languages round-ended primitives are usually made with a trace and 
two circles, and it is OK to replace them with round-ended primitives on conversion. 

• If Rounded Ends OK does not have a check mark, then the system will not replace 
square-ended primitive traces with round-ended traces. 

5. On the D Code Table, go to the Custom Apertures menu, and click Replace with 
Primitives. 

If You See an M in a Square in the Viewing Area 

 
If you see an element that looks like an M in a square in the viewing area, then the file contains an 
undefined custom aperture. The square with an M is a default placeholder for your custom aperture. To 
see the custom aperture the way it is supposed to look, import the custom aperture file into the D Code 
Table.  
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Chapter 7 
Tool Code Table Overview 

 
The program handles diameter and type information for up to 255 unique Tool Codes, ranging from T1 
to T255. Even though it is possible to completely set up Tool Codes in the D Code Table, the Tool 
Code table provides a more condensed summary of Tool Code information than the D Code table. 

To Display the Tool Code Table: 
Ø On the Setup menu, click Tool Codes. 

 Shift+F5 

 

Tool Code Table 

On the Tool Code table you can select Tool Codes for editing, change tool type and tool diameter, see 
the number of occurrences of each Tool Code in the loaded data and sort the Tool Code Table by 
various criteria such as Tool Code, tool type, tool diameter, or number of occurrences 

Each Tool Code record includes two editable fields: tool type and tool diameter. 
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Tool Type 

 
Four tool types are supported:  

• Plated: Plated through holes are plated with copper that electrically connects pads in different 
layers. Plated through holes are often used for mounting components. 

• Non-Plated: Non-Plated through holes are not plated with copper and do not electrically 
connect different layers. 

• Tooling: Tooling holes may or may not be plated with copper. They are typically used for 
attaching the board to other things.  

• Via (X): Vias are plated with copper that electrically connects pads in different layers. Vias 
are generally only for electrical connection and are typically not used for mounting 
components or for testing. Vias that pass through the entire board can be placed in PAD or 
DRI layer types; blind or buried vias can be placed in VIA or VID layer types. See Layer 
Type on page 355. 

Tool types are used for netlist extraction, in Copper Area Calculation, and in other Lavenir programs 
such as FixMaster and ProbeMaster. 

Tool Diameter 

 
Tool Diameter is the diameter of the hole. Tool Codes have a resolution to 0.001 mil when the 
Database Units are English and .01 micron when in metric.  

Number of Occurrences of each Tool Code 

 
The number of occurrences of each Tool Code is shown in the Counts column of the Tool Code Table. 
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Select Tool Codes 

 
In order to edit a Tool Code, you must select it. You can select and edit more that one Tool Code at a 
time. 

To Select Tool Codes on the Tool Code Table: 
Ø To select a single Tool Code, Click on the Tool Code in the T Code column of the Tool Code 

table. 

Ø To select a range of Tool Codes, Shift+Click on the first and last Tool Codes of the range in 
the T Code column of the Tool Code table. 

Ø To add or remove a single Tool Code from the selection, Ctrl+Click on the Tool Code in the 
T Code column of the Tool Code table. 

Change Tool Type and Tool Diameter 

 

To Change Tool Type and Tool Diameter on the Tool Table: 
1. On the Setup menu, click Tool Codes. 

2. On the Tool Codes table, select the Tool Code(s) you want to edit. 

All selected Tool Codes will be set to the same values when you edit the Tool Codes. 

3. Double+Click or press Spacebar on the selected Tool Code(s). 

4. Enter the new Diameter. 

5. Enter the new Tool Type. 

6. Click OK. 

 Spacebar = Display the Tool Code Values dialog, same as a double-click. 
Arrow Keys = Go up and down to other Tool Codes in the table. 



Lavenir CAM Software User’s Guide 

344 

Sort the Tool Code Table 

 
To make it easier to inspect Tool Code information you can sort the Tool Code Table by Tool Code, 
Tool Type, Tool Diameter, or Number of Occurrences. 

To Sort the Tool Code Table: 
1. On the Setup menu, click Tool Codes. 

2. On the Tool Codes table, click on the labeled button at the top of the column you want to 
sort: 

• T Code 

• Type 

• Diameter 

• Count 

One click sorts the table in ascending order, and the second click on the same column sorts the 
table in descending order.  

 Sorting the table does not change the values of the Tool Codes, it just displays the table in a 
different order. To transcode the table in ascending order, see Transcode the Tool Code 
Table in Ascending Order below. 

Transcode the Tool Code Table in Ascending Order 

 
The program can change the Tool Codes of all tools in use so that their diameters are in ascending 
order. For instance, T1 would have the smallest diameter, T2 would have the next larger diameter, and 
so on.  

To Transcode the Tool Code Table in Ascending Order: 
Ø On the Tool Code Table, click Transcode Ascending. 
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Set Up Tool Codes In the D Code Table 

 
Plot elements must be defined by D Codes. To represent Drill data, set up an N-Shape D Code in the 
D Code Table. The N-Shape D Code represents an NC Drill Hole. Then map that D Code to a 
corresponding Tool Code. When you export Drill data, only N-shape pads are output with the 
corresponding Tool Code information. 

To Set Up Tool Codes in the D Code Table: 
1. On the Setup menu, click D Codes. 

2. In the D Code Table, select the N-shape for a new D Code. 

3. In the Drill dimensions dialog for the N-shape, enter a Tool Code. 

4. Click Tool Setup. 

The program displays the Tool Setup dialog that you would see if setting up the Tool Code on the 
Tool Code Table. 

 

Tool Setup Dialog 

5. Enter the new Diameter. 

6. Enter the new Tool Type. 

7. On the Tool Setup dialog, click OK. 

8. On the Drill dimensions dialog, click OK. 

9. On the D Code Table, click OK. 
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Chapter 8 
Layers of Data 

 
The program can load up to 99 layers of plot data.  

Your tools for managing layers of plot data are the Layers Table, the Layers Toolbar and the Current 
Element Toolbar. 

Using these tools you can see and control the active layer(s), the layer number, board layer, layer 
name, layer type, layer element counts, layer color, layer visibility, positive and negative layers, paint 
and scratch layers. 

The Layers Table and Layers Toolbar also have commands for editing entire layers. You can delete, 
swap, replicate, and transfer layers. For information on editing layers using menu and keyboard 
commands outside of the Layers Table and Layers Toolbar, see Edit Entire Layers of Data on page 
164. 

You can also import Gerber data directly into the Layers Table. See Import Gerber Directly into the 
Layers Table on page 37. 
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Layers Table 

 
The Layers Table is the most comprehensive tool for controlling layers of plot data.  

 

Layers Table 

To Display the Layers Table: 
Ø On the Setup menu, click Layers. 

 F10 

 You can resize the Layers Table to show more layers by dragging the corner of the dialog or 
by clicking on the maximize button. 
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Layer Toolbar 

 
The Layers Toolbar is a compact tool for controlling layers of plot data. It is not as comprehensive as 
the Layers Table, but it is small enough that it can remain docked to the side of the viewing area while 
you do other work.  

 

Layers Toolbar 

To Display the Layers Toolbar: 
Ø On the View menu, look at Toolbars-Layers. 

• If Layers has a checkmark next to it, then the Layers Toolbar is displayed. 

• If Layers does not have a checkmark next to it, then the Layers Toolbar is not displayed. 

To change the display of the Layers Toolbar, click Layers. 

  Layers Toolbar button on Main Toolbar. Down = Displayed, Up = Not Displayed 
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Active Layers 

 
A rectangular box around a layer on the Layers Toolbar indicates the Active Layer. And the Layer 
Number of the active layer is shown in the Current Element Toolbar. 

 

Active Layer in Current Element Toolbar 

To Set the Active Layer on the Layers Toolbar: 
Ø Click on the layer you want to be active. 

For more information on how to use the active layer for selection and editing, see Select from the 
Active Layers on page 152. 

Layer Number 
The Layer Number indicates the order of the layers in the loaded database. 

You can see the Layer Numbers in the Layers Table and the Layers Toolbar. And the Layer Number of 
the active layer is shown in the Current Element Toolbar. 

Layer Number on Layers Table 

 
The buttons on the left edge of the Layers Table show the Layer Numbers. The Layer Number 
indicates the order of the layers in the Layers Table. You cannot edit the Layer Number directly, so to 
change the layer number of a layer of data you must Transfer or Replicate the layer data to a new layer. 

Layer Number on Layer Toolbar 

 
The left column of the Layers Toolbar contains the Layer Number. The Layer Number indicates the 
order of the layers in the Layers Toolbar. You cannot edit the Layer Number directly, so to change the 
layer number of a layer of data you must Transfer or Replicate the layer data to a new layer. 
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Board Layer 

 
The Board Layer indicates where a layer of data will be in the finished board. By setting the Board 
Layer to the same value for more than one layer of data, you can combine those layers into a single 
Board Layer. By doing so you indicate that all of the features of the combined layers will be 
manufactured on the same layer of the finished board. 

The concept of several data layers combined into a single board layer has use in several operations: 

• Exporting Combined Files  

• Combining Paint and Scratch Layers  

• Raster Design Rule Checking  

• Raster Netlist Extraction  

Board Layer on the Layers Table 
The B Layer column of the Layers Table shows the Board Layer. 

To Set the Board Layer on the Layers Table: 
1. Click in the B Layer field for the layer you want to edit.  

2. Type the new Board Layer. 

 To make the Board Layer the same for several layers, select all the layers first. Then when 
you set the Board Layer for one layer, all the selected layers are given the same Board Layer. 

To Renumber the Board Layers Sequentially from the Top of the Layers Table: 
1. Right-Click on B Layer at the top of the B Layer column.  

2. On the context menu that pops up, click Renumber Board Layers. 

The program renumbers the board layers sequentially from the top of the table. 

Board Layer on the Layers Toolbar 
To Set the Board Layer on the Layers Toolbar: 
1. Right-click the Layers Toolbar on the layer you want to change. 

The context menu shows the current Board Layer number. 

2. On the context menu, click Board Layer. 

3. Select the new Board Layer from the drop down list. 

4. Click OK. 



Lavenir CAM Software User’s Guide 

352 

Layer Name 
The Layer Names are for organizing the layer data and are used for the layer file names if you export 
Gerber data layer-by-layer.  

You can see and set the Layer Name in the Layers Table and the Layers Toolbar. And the Layer Name 
of the Active Layer is shown on the Current Element Toolbar.  

Layer Name on Layers Table 

 
The Name column of the Layers Table contains the Layer Names. If Gerber Files are imported into the 
Job File, the individual layer file names become the Layer Names and may contain the entire path 
name for the layer file.  

To Enter a New Layer Name on the Layers Table: 
1. Click on the Name field for the layer you want to rename.  

2. Type the new Layer Name. 

 To make the Layer Name the same for several layers, select all the layers first. Then when you 
set the Layer Name for one layer, all the selected layers are given the same Layer Name. 

To Rename Multiple files using Wildcards in the Layers Table: 
1. Click on the Name field for the first of the layers you want to rename.  

2. Type the new Layer Name with the extension “.*” For instance, type: name.* 

• If the existing Layer Name prefixes are different, the system renames this layer and all 
following loaded layers with the new prefix and a sequentially numbered suffix, .01, .02, 
.03, etc. 

• If the existing Layer Name prefixes are all the same, the system renames this layer and all 
following loaded layers with the new prefix and keeps the original suffixes. 

To Browse the Directories for File Names: 
Ø Double-click the Name field for the layer you want to rename.  

The system displays the File Open dialog where you can pick among available drives, directories 
and files. 
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Browse for Layer Name Dialog 

To Toggle Display of the Path Portion of the Layer Name: 
1. Select the layers.  

2. Click Path 
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Layer Name on the Layers Toolbar 

 

To See the Name of a Layer on the Layers Toolbar: 
Ø Hold the cursor over the layer for a second, and a ToolTip with the layer name will pop up.  

Ø Or right-click the Layers Table on the layer you want to check, and read the layer name off 
the context menu. 

To Change the Name of a Layer on the Layers Toolbar: 
1. Right-click the Layers Toolbar on the layer you want to change. 

2. On the context menu, click the layer name. 

 

Set Layer Name Dialog 

3. On the Set Layer Name dialog, enter the new layer name, or click Browse to browse a list of 
directories and files for the layer name you want. 
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Layer Type 
The Layer Type identifies the layer by its function in the completed board.  

You can see and set the Layer Type in the Layers Table and the Layers Toolbar. 

The Layer Types include: 

• CPU, CPL: Component Layer Upper and Lower 

• PAD: Gerber Padmaster 

• DRI: NC Drill Padmaster 

 When you enter a Layer Name with a .DRI extension, the Layer Type is automatically set 
to DRI also. 

• VIA: Gerber Blind or Buried Via Layer 

• VID: NC Drill Blind or Buried Via Layer 

• GD1-5: Ground Plane Layers 1-5 

• GS1-5: Ground Split Layers 1-5 

• PW1-5: Power Plane Layers 1-5 

• PS1-5: Power Split Layers 1-5 

• SIG: Internal Signal Layer 

• MSU, MSL: Soldermask Layers Upper and Lower 

• SKU, SKL: Silkscreen Layers Upper and Lower 

• SPU, SPL: Solderpaste Layers Upper and Lower, also “Filter” Layers Upper and Lower 

• OTH: Layers of a type other than those in the Layer Types list 

• NFL: Non-Functional Layer 

• BOL: Board Outline Layer 

The concept of identifying layers by Layer Type has use in several operations including netlist 
extraction and design rule checking. 
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Layer Type on Layers Table 

 
The Type column of the Layers Table indicates the Layer Type. The Layer Type identifies the layer by 
its function in the completed board.  

To Set the Layer Type on the Layers Table: 
1. Click on the Type field drop down list for the layer you want to edit. 

2. Select the Layer Type off the list.  

 To make the Layer Type the same for several layers, select all the layers first. Then when you 
set the Layer Type for one layer, all the selected layers are given the same Layer Type. 

Layer Type on the Layers Toolbar 

 

To Set the Layer Type on the Layers Toolbar: 
1. Right-click on the layer and look at the Layer Type on the context menu.  

2. Click the Layer Type on the context menu. 

3. Select the new Layer Type off the Layer Type dialog. 
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Layer Color 
The Layer Color is the color used to display the layer in the Viewing Area. The program supports a 
palette of 15 layer colors that you can use for layer colors at any one time, and you can select the 15 
color palette from as many colors as your graphics card supports. 

You can see and set the Layer Color in the Layers Table and the Layers Toolbar. 

Layer Color on Layers Table 

 
The Color column of the Layers Table indicates the color used to display the layer in the Viewing 
Area.  

Quick Set the Layer Color on the Layers Table Using the Color Index: 
1. Click on the Layer Color field of the layer you want to change in the Layers Table. 

The program displays the current color index number for that layer. 

2. Type a new color index number. 
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To Set the Layer Color on the Layers Table: 

 To make the Layer Color the same for several layers, select all the layers first. Then when you 
set the Layer Color for one layer, all the selected layers are given the same Layer Color. 

1. Double-click on the Layer Color field of the layer you want to change in the Layers Table. 

The program displays the palette of 15 layer colors currently available to choose from. 

 

Color Palette 

2. If you see the color you want in the current palette, then click on the color you want, and 
click OK. 
If you do not see the color you want in the current palette, then click Redefine Color. 

The program displays the basic and custom colors currently available to add to the pallet. 
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Basic and Custom Color Dialog 

3. If you see the color you want in the basic and custom colors, then click on the color you 
want, and click OK. 
If you do not see the color you want in the basic and custom colors, then click on Define 
Custom Colors. 

The program displays the custom color picker. 
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Custom Color Picker 

4. Adjust the color values to what you want. 

5. Click Add to Custom Colors. 

6. Click OK. 
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Layer Color on Layer Toolbar 

 
A block of color on the right side of the Layers Toolbar indicates the color used to display the layer in 
the Viewing Area. The block can be solid or crosshatched, depending on whether the layer is visible or 
not. 

The program supports a palette of 15 layer colors that you can use for layer colors at any one time, and 
you can select the 15 color palette from as many colors as your graphics card supports. Using the layer 
color system you can: 

To Set the Layer Color on the Layers Toolbar: 
1. Right-click on the layer you want to change in the Layers Toolbar. 

2. From the context menu, click on Color. 

The program displays the palette of 15 layer colors currently available to choose from. 

 

Color Palette 

3. If you see the color you want in the current palette, then click on the color you want, and 
click OK. 
If you do not see the color you want in the current palette, then click Redefine Color. 
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The program displays the basic and custom colors currently available to add to the pallet. 

 

Basic and Custom Color Dialog 

4. If you see the color you want in the basic and custom colors, then click on the color you 
want, and click OK. 
If you do not see the color you want in the basic and custom colors, then click on Define 
Custom Colors. 

The program displays the custom color picker. 
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Custom Color Picker 

5. Adjust the color values to what you want. 

6. Click Add to Custom Colors. 

7. Click OK. 
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Layer Visibility 
Layers can be either visible or not visible. Visible layers are shown in the Viewing Area and non-
visible layers are not. 

Layer Visibility on Layers Table 

 
The Vis column of the Layers Table indicates the Visibility status of the layer. A check mark indicates 
the layer is visible in the Viewing Area and no check mark indicates the layer is not visible.  

To Toggle the Visibility of a Single Layer on the Layers Table: 
Ø Click on the Vis field for the layer you want to switch. 

 Spacebar (in the Vis field of the layer you want to switch) 
V (in the row of the layer you want to switch) 

 To make the Layer Visibility the same for several layers, select all the layers first. Then when 
you set the Layer Visibility for one layer, all the selected layers are given the same Layer 
Visibility. 

To Make All Layers Visible on the Layers Table: 
Ø Click the All Layers Visible button above the Vis column. 

To Toggle the Visibility of All Layers on the Layers Table: 
Ø Click the Toggle All Layers button above the Vis column.
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Layer Visibility on Layer Toolbar 

 
The block of color on the right side of the Layers Toolbar that indicates the layer color also indicates 
whether the layer is visible in the Viewing Area.  

• If the block is solid the layer is visible.  

• If the block is crosshatched, the layer is not visible.  

To Toggle the Visibility of a Single Layer on the Layers Toolbar: 
Ø Double-click on the layer you want to switch. 

Ø Or right-click on the layer you want to switch, and click Visibility on the Context Menu. 

 After you have switched the focus to the Layers Toolbar by clicking on it, you can use the 
following key commands to toggle visibility of individual layers: 
Enter Key = Toggle Visibility for the current layer 
Arrow Keys = Go up or down to the next layer in the Layers Toolbar. 

To Make All Layers Visible on the Layers Toolbar: 
Ø Click the All Layers Visible button at the bottom of the toolbar. 

  

To Toggle the Visibility of All Layers on the Layers Toolbar: 
Ø Click the Toggle All Layers button at the bottom of the toolbar. 
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Positive and Negative Layers 
The Positive/Negative setting indicates whether a layer is positive or negative. Positive layers are 
displayed in the Viewing Area as colored elements on a black background. And negative elements are 
displayed in the Viewing Area as black elements on a colored background. 

You can see and set the Positive/Negative setting in the Layers Table and the Layers Toolbar. 

Positive and Negative on Layers Table 

 
The Neg column on the Layers Table indicates whether a layer is Positive or Negative. If there is a 
check mark in the Neg column, then that layer is Negative, and if there is no check mark, the layer is 
Positive.  

To Switch the Positive/Negative Setting of a Layer on the Layers Table: 
Ø Click on the Neg field for the layer you want to switch. 

 Spacebar (in the Neg field of the layer you want to switch) 
N (in the row of the layer you want to switch) 

 To make the Positive/Negative setting the same for several layers, select all the layers first. 
Then when you set the Positive/Negative setting for one layer, all the selected layers are given 
the same Positive/Negative setting. 

Positive and Negative on the Layers Toolbar 

 

To Set Positive and Negative Polarity on the Layers Toolbar: 
1. On the Layers Toolbar, right-click on the layer. And look at Negative on the Context Menu. 

• If there is a check mark next to the word Negative on the context menu, then that layer is 
Negative 

• If there is no check mark next to the word Negative on the context menu, the layer is 
Positive.  

2. To switch the Positive/Negative setting of the layer, click on Negative on the context menu. 
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Paint and Scratch Layers 
The Paint/Scratch setting indicates whether a layer is a Paint or Scratch layer.  

When displayed in the Viewing Area, a Scratch layer scratches away its color from previous layers of 
the same color. By combining alternating paint and scratch layer pairs, sophisticated artwork can be 
generated.  

In order to be plotted, paint and scratch layer combinations need to be exported in formats that support 
the paint and scratch layer types, such as MDA Autoplot (“MRGE=PAINT” or “MRGE=SCRATCH” 
commands) or Extended Gerber files (“LPD” or “LPC” commands). Other techniques may involve 
exporting the layers separately and combining them later. 

You can see and set the Paint/Scratch setting in the Layers Table and the Layers Toolbar. 

Paint and Scratch on the Layers Toolbar 

 

To Set the Paint and Scratch Setting on the Layers Toolbar: 
1. On the Layers Toolbar, right-click on the layer, and look at Scratch on the Context Menu. 

• If there is a check mark next to the word Scratch on the context menu, then that layer is a 
Scratch layer. 

• If there is no check mark next to the word Scratch on the context menu, the layer is a 
Paint layer.  

2. To switch the Paint /Scratch setting of the layer, click on Scratch on the context menu. 

Paint and Scratch on Layers Table 

 
The Scr column on the Layers Table indicates whether a layer is a Paint or Scratch layer. If there is a 
check mark in the Scr column, then that layer is a Scratch layer, and if there is no check mark, the layer 
is a Paint layer. 

To Switch the Paint/Scratch Setting of a Layer on the Layers Table: 
Ø On the Layers Table, click on the Scr field for the layer you want to switch. 

 Spacebar (in the Scr field of the layer you want to switch) 
S (in the row of the layer you want to switch) 

 To make the Paint/Scratch setting the same for several layers, select all the layers first. Then 
when you set the Paint/Scratch setting for one layer, all the selected layers are given the same 
Paint/Scratch setting. 
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Fill Layer 

 
The Fill column on the Layers Table indicates whether a layer is a Fill layer. If there is a check mark in 
the Fill column, then that layer is a Fill layer, and if there is no check mark, the layer is not a Fill layer. 

A Fill layer is generally a layer with large plane areas that are drawn using lots of traces. By 
designating such a layer as a fill layer you can speed up the processing of certain operations such as 
Vector Design Rule Checking and Vector Netlist Extraction. 

To Switch the Fill Setting of a Layer on the Layers Table: 
Ø On the Layers Table, click on the Fill field for the layer you want to switch. 

 Spacebar (in the Fill field of the layer you want to switch) 
F (in the row of the layer you want to switch) 

 To make the Fill setting the same for several layers, select all the layers first. Then when you 
set the Fill setting for one layer, all the selected layers are given the same Fill setting. 

Loaded Data in a Layer 
The Layers Table and Layers Toolbar indicate whether there is data in a given layer. 

Layer Element Counts on Layers Table 

 
The Traces and Pads columns of the Layers Table report the number of elements on each layer. This is 
statistical information and cannot be edited. Layers that do not contain data are shown in the table with 
a gray background. 

Loaded Data on Layer Toolbar 

 
When a layer in the Layers Toolbar contains data, an asterisk is shown next to the layer number in the 
Layers Toolbar. Element counts for each layer are not shown in the Layers Toolbar, but are shown on 
the Layers Table.  
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Select Layers on Layers Table 
In order to edit layers on the Layers Table, you must first select them. Selected layers are indicated 
when the button at the left of the row is down and the row is highlighted in color. 

When more than one layer is selected and you change a setting (such as board layer, layer name, type, 
visibility, paint/scratch, positive/negative, or fill) on one of the selected layers, then all of the selected 
layers are given the same setting. 

Manually Select Single or Multiple Layers on the Layers Table 

 
When a layer is selected, its Layer Number button is down, and the row is highlighted. 

To Manually Select Single or Multiple Layers on the Layers Table: 
Ø To select a single layer on the Layers Table, click on the Layer Number button to the left of 

the layer row. 

Ø To select a range of layers, use Shift+Click.  

Ø To add a single layer to a group of selected layers, or to remove one, use Ctrl+Click.  

Select All Layers on the Layers Table 

 

To Select All Layers on the Layers Table: 
Ø On the Layers Table, click the All button at the bottom of the table. 

Select None on the Layers Table 

 
The Select None button clears selection from all layers in the Layers Table so that you can make 
certain that no layers are selected. 

To Clear Selection from All Layers in the Layers Table: 
Ø On the Layers Table, click the None button at the bottom of the table. 
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Invert Selected Layers on the Layers Table 

 
The Invert Selection command inverts the selection of layers in the Layers Table, so that selected 
layers become unselected and the unselected become selected. 

To Invert Selected Layers on the Layers Table: 
Ø On the Layers Table, click the Invert button at the bottom of the table. 

Select Loaded Layers on the Layers Table 

 

To Select Only the Loaded Layers on the Layers Table: 
Ø On the Layers Table, click the Loaded button at the bottom of the table. 
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Delete Layers 
You can delete layers in the Layers Table or in the Layers Toolbar. For information on deleting layers 
using menu commands outside of the Layers Table and Layers Toolbar, see Delete Layers on page 
171. 

Delete Layers on the Layers Table 

 

To Delete Layers on the Layers Table: 
1. Select the layers to delete. 

2. Click the Delete button. 

Delete Layers on the Layers Toolbar 

 
You can delete data from a layer on the Layers Toolbar. You have options to delete all the data, or only 
the pads, or only the traces. 

To Delete Data from a Layer on the Layers Toolbar: 
1. Right-click the Layers Toolbar on the layer you want to delete. 

2. On the context menu, go to Edit-Delete- 

• To delete all the data from the layer, click All. 

• To delete all pads from the layer, click Pads. 

• To delete all traces from the layer, click Traces. 
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Replicate Layers 
Replicating layers means to copy the data of one layer or a range of layers into new layers. The data 
remains at the old location and is copied to the new location. 

You can Replicate Layers in the Layers Table or in the Layers Toolbar. For information on replicating 
layers using menu commands outside of the Layers Table and Layers Toolbar, see Replicate Layers on 
page 170. 

Replicate Layers on the Layers Table 

 

To Replicate Layers on the Layers Table: 
1. Select the layers you want to Replicate. 

2. Click the Replicate button. 

 

Replicate Selected Layers Dialog 

3. In the Replicate Layers dialog, enter the first of the layers where the selected layers are to 
be copied in. 

4. Click OK. 

The program copies the data of the selected layers into a series of layers beginning with the one in 
the Replicate Layers dialog. If the layers copied to are empty, this results in exact layer copies of 
the selected layers. If the layers copied to have data, the data from the selected layers are merged 
into the target layers as the data are copied. 
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Replicate Layers on the Layers Toolbar 

 

To Replicate a Layer on the Layers Toolbar: 
1. Right-click the Layers Toolbar on the layer you want to replicate to another layer. 

2. On the context menu, click Replicate. 

 

Replicate Selected Layers Dialog 

3. On the Replicate Layers dialog, enter the layer to which you want to replicate the selected 
layer. 
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Transfer Layers 
You can transfer layers in the Layers Table or in the Layers Toolbar. For information on transferring 
layers using menu commands outside of the Layers Table and Layers Toolbar, see Transfer Layers on 
page 169. 

Transfer Layers on the Layers Table 

 

To Transfer Layers on the Layers Table: 
1. Select the layers you want to transfer. 

2. Click the Transfer button. 

 

Transfer Selected Layers Dialog 

3. In the Transfer Layers dialog, enter the first of the layers where the selected layers are to be 
transferred to. 

4. Click OK. 

The program transfers the selected layers to a series of layers beginning with the one in the 
Transfer Layers dialog. If the layers where the data is transferred to are empty, the selected layers 
are transferred exactly as they were. If the layers where the data is transferred to have data, the 
data from the selected layers are merged into the target layers as the data are transferred. 
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Transfer Layers on the Layers Toolbar 

 

To Transfer a Layer on the Layers Toolbar: 
1. Right-click the Layers Toolbar on the layer you want to transfer to another layer. 

2. On the context menu, click Transfer. 

 

Transfer Selected Layers Dialog 

3. On the Transfer Layers dialog, enter the layer to which you want to transfer the selected layer. 
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Swap Layers 
You can swap layers in the Layers Table or in the Layers Toolbar. For information on swapping layers 
using menu commands outside of the Layers Table and Layers Toolbar, see Swap Layers on page 171. 

Swap Layers on the Layers Table 

 

To Swap Layers on the Layers Table: 
1. Select the layers you want to swap with other layers. 

2. Click the Swap button. 

 

Swap Selected Layers Dialog 

3. In the Swap Layers dialog, enter the first of the layers to be swapped with the selected 
layers. 

4. Click OK. 

The program swaps the selected layers with a series of layers beginning with the one in the Swap 
layers dialog.  
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Swap Layers on the Layers Toolbar 

 

To Swap Layers on the Layers Toolbar: 
1. Right-click the Layers Toolbar on the layer you want to swap with another layer. 

2. On the context menu, click Swap. 

 

Swap Selected Layers Dialog 

3. On the Swap Layers dialog, enter the layer you want to swap with the first layer. 
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Chapter 9 
Printing 

The program can print a file on a color or black and white printer.  

Print a Plot 

 

To Print a Plot: 
1. If you only want to print part of the data, adjust the view of the data and set the visibility 

settings so that exactly what you want to print is on screen. 

2. On the Files menu, click Print. 

3. On the Print dialog, select a Print Range: 

• Screen: Prints the visible data on screen. 

• All Board Layers: Prints all visible layers, one Board Layer at a time. The print is not 
limited to the data within the rectangle of the viewing area; it includes the entire extents 
of each Board Layer. 

• Current Board Layer: Prints all data that shares the same Board Layer as the active 
layer. The print is not limited to the data within the rectangle of the viewing area; it 
includes the entire extents of the Board Layer. 

4. On the Print dialog, select a Color Scheme: 

• Black on White: Data on screen is printed as black, and background color is left white. 
This is the most useful choice for a black and white laser printer. 

• White on Black: Background color is printed as black, and data on screen is left white. 
This is the other choice for a black and white laser printer. 

• Screen Colors: Data and background color is printed as it is shown on screen. This 
option requires a color printer. Do not choose this option for a black and white laser 
printer because all colors will be forced to black. 

• Colors on White Background: Data on screen is printed as it is shown on screen, and 
background color is left white. This option requires a color printer. Do not choose this 
option for a black and white laser printer because all colors will be forced to black. 

 On some printers the Black on White and White on Black options print in reverse of how 
they are labeled. If this happens with your printer, reverse your selection for the color 
scheme, and the print should come out how you want it. 

5. On the Print dialog, select a Scale Factor: 
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• Fit on Page: All data within the rectangle of the viewing area is scaled to fit the selected 
paper size. 

• By Factor: All data within the rectangle of the viewing area is scaled to the factor that 
you enter. 

6. If you want to print a page header containing file name, scale factor and date, click Add Page 
Header so that the option has a check mark. 

7. Click OK. 

The system displays the printer setup dialog where you can set printer driver settings.  

We recommend you select a Non-PostScript printer driver that is compatible with your printer. 

8. Click OK. 

 Ctrl+P 

  

Preview a Print 

 
You can preview what is going to be printed before actually printing the image. This gives you the 
option of changing settings before printing the file.  

To Preview a Print: 
Ø Follow the procedure for how to print, but instead of going to File-Print, go to File-Print 

Preview. 

Before printing the image, the system displays a print preview screen in which you can: 

• Zoom in on the image 

• View each page in the print job 

• Select to print or cancel the print job 
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If You Get a Black Rectangle 

 
If you get a black rectangle when you print, check the following. 

Select Only Black and White Options for a Black and White Printer 
The printing feature is capable of generating a print file for a color printer. So if you are using a black 
and white printer and select a color scheme other than black on white or white on black, all colors 
will be forced to black, and you will get a black rectangle.  

Try a Non-PostScript Printer Driver  
The printing feature does not generate a print file that is compatible with all PostScript printer drivers. 
If you get a black rectangle, click Setup on the Print dialog and try selecting a Non-PostScript printer 
driver that is compatible with your printer. If this does not help, you may also try installing an updated 
printer driver; updated drivers are generally available for download from the printer manufacturer’s 
web site. 
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Chapter 10 
Report File 

 
The program can generate a Report File that provides information about the loaded data, and the 
program can also open a text editor in which you can view the Report File. 

The report file provides the following information: 

• Date 

• Report file name and path 

• Units of the database 

• Gerber data format 

• Drill data format 

• Table of information on the visible layers, including: 
Layer number 
Counts of traces, arcs, and pads 
Layer dimensions 
Layer name 
Layer type 
Positive or Negative 
Paint or Scratch 
Board layer 

• Table of D Code information, including: 
D Code number 
Shape Code 
D Code dimensions 
Counts of traces, arcs, and pads 

• List of D Codes in order of size, including: 
D Code number 
Shape Code 
D Code dimensions 

• Table of Tool Code information, including: 
Tool Code 
Hole Type 
Tool size 
Counts of Holes 

The program also automatically creates other types of reports during certain types of operations such 
as netlist extraction, design rule checking, copper area calculation, and transcoding. 
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Generate a Report File 

 

To Generate a Report File: 
1. Make all the layers you want included in the Report File Layers Table visible. 

2. On the File menu, click Report-Generate. 

3. To save the Report File in a different folder, click a different drive in the Look in box, or 
double-click a different folder in the folder list. 

To save the Report File in a new folder, click Create New Folder. 

4. In the File name box, type a name for the Report File. 

View A Report File 

 

To View A Report File: 
1. On the File menu, click Report-View. 

2. In the Look in box, click the drive, folder, or network location that contains the Report File. 

3. In the folder list, double-click folders until you open the folder that contains the Report File 
you want. 

4. Double-click the Report File. 
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Chapter 11 
Design Rule Checking 

 

 The Raster DRC is only available in CAMMaster, while the Vector DRC and Distance 
Histogram are available in ViewMaster PRO and ViewMaster as well. 

The program can run a Design Rule Check to verify the accuracy and manufacturability of plot data 
using either a Raster Design Rule Check routine or a Vector Design Rule Check routine. 

In addition to Design Rule Checking, the program can generate a Distance Histogram report. 

Two Types of Design Rule Checking Routines 

 
There are some significant differences between the technique and the error inspection methods of the 
Raster and Vector DRC routines, and there are advantages to both systems.  

Raster vs. Vector DRC Technique 

 
Raster DRC converts the Gerber image into a raster bitmap and uses that bitmap to create polygonal 
outlines of the image. Then the Raster DRC checks for clearances and contact between polygons.  

Vector DRC uses the Gerber description of the position, size and shape of elements to determine 
clearance and contact between elements.  

Raster vs. Vector DRC Error Inspection Method 

 
The Raster DRC routine tags DRC errors with a user-definable color-coded graphic. You can go to the 
first, next, previous, or last error of each error type using a specialized DRC error inspection tool.  

Vector DRC tags errors by inserting selected elements of special error tag D Codes into the file at the 
location of the error. You can inspect the Vector DRC errors by using the program’s selection and 
inspection tools to find each element that has an error tag D Code. 
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Raster DRC Advantages 

 
The Raster DRC technique can process paint and scratch images, while the Vector DRC technique 
cannot.  

Images that are comprised of many elements, such as planes drawn with traces, do not necessarily slow 
down Raster DRC, while these types of images do slow down Vector DRC. So Raster DRC can be 
much faster than Vector DRC on files that contain many elements. 

The Raster DRC error inspection tool is much easier to use than the Vector DRC method, and it does 
not involve inserting data into the file the way Vector DRC does. 

Raster DRC can do a Silkscreen-to-Pad check, while the Vector DRC cannot. 

Vector DRC Advantages 

 
The time required to do a Vector DRC is related more to the number of elements than to the physical 
size of the image or elements. So a large board does not necessarily take longer than a small board, as 
long as they both have the same number of elements. The time required to do a Raster DRC is related 
more to the number of pixels that have to be examined than to the number of elements. So a large 
image or an image with very small parts that has to be examined at high resolution can take longer than 
a smaller or low-resolution image, regardless of the number of elements involved. This means that 
Vector DRC can be faster than Raster DRC on boards that have a large physical size.  

Vector DRC does not have a concept of image resolution, and the accuracy of Vector DRC is not 
affected by user-specified variables. In contrast, Raster DRC operations that are not performed at 
adequately fine raster resolution may have errors.  

Vector DRC can do the following checks that Raster DRC cannot: 

• Pad-to-Pad Contact 

• Unterminated Traces 

• Centerline Disconnect 

• Trace Intersection 

Raster DRC 

 
The program can run a Raster Design Rule Check to verify the accuracy and manufacturability of plot 
data. The process examines individual layers, layer sets, portions of layers selected with the reference 
frame, or the entire database, depending on how you set it up. The program reports design rule 
violations in a text file and flags the errors in the Viewing Area for easy identification. 
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Prepare Plot Data for the Raster Design Rule Check 

 
The best Raster Design Rule Check results are obtained from plot data that has been prepared. You 
need complete and accurate D Code and Tool Code information and Layer Type identification. Flashed 
(not drawn) pads are essential for any check involving pads. The Board Layer is important if you have 
composite layers or paint and scratch layer combinations.  

To Prepare Plot Data for the Raster Design Rule Check: 
1. Extract a netlist by running the Raster Netlist Extraction procedure using the same raster 

resolution as will be used in Raster DRC. See Raster Netlist Extraction on page 415. 

The Raster DRC routine needs net information to correctly run the design rules checks. 
Specifically, the air-gap checks do not flag violations between elements of the same net. And the 
soldermask checks use this information to avoid flagging masks as being to close to the traces 
connecting to the pad the mask is covering. If the net information is missing, the system tries to 
guess the correct connections, but this is not always possible.  

If you run the raster netlist extraction as instructed above, then you will have already performed 
most of the following data preparation for the netlist extraction. Verify the data has been set up as 
follows: 

2. On the D Code Table and the Tool Code Table, define all D Codes and Tool Codes. 

• NC Drill Tool Codes must be defined as P-plated, N-non-plated, T-tooling, or V-via.  

• If you use a Gerber padmaster to define drill data rather than a drill file, the D Code hole 
sizes must reflect the actual tool sizes.  

3. On the Layers Table, set up the Layer Types. 

In layer-to-layer checks for soldermask and annular ring violations, the system has to know the 
type of each layer used.  

4. On the Layers Table, set the Board Layer Number for each layer.  

Layers are processed consecutively by board layer number, and all layers that have the same 
Board Layer Number are processed as single composite layers. This allows DRC on paint and 
scratch combinations.  

5. Convert drawn pads to flashed pads. See Convert Drawn Pads on page 227. 

If you don’t have flashed pads on the CPU and CPL layers, extract them from the top and bottom 
soldermasks. The surface layer pad files do not have to match the padmaster since many of the 
component pads will not be drilled. 

6. Set the Visibility settings. 

The Raster Design Rule Check only checks visible elements. 

• Make sure all the layers to be checked are visible layers.  

• Make sure all pads, traces, selected, and unselected elements to be checked are visible. 
See Element Visibility on page 84. 
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7. If you want to check only part of the data, put a reference frame around that data. See 
Reference Frame on page 177.  

 If you want to check all data, it does not matter where the reference frame is positioned.  

Once you are done preparing the plot data, go ahead and run the Raster Design Rule Check. 
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Run the Raster Design Rule Check 

 

To Run the Raster Design Rule Check: 
1. After you have prepared the plot data for the Raster Design Rule Check, go to the Tools menu 

and click Design Rules Check-Raster-Run DRC. 

2. On the Layer tab, select which layers to check. Only currently visible layers are displayed. 

 

Raster DRC Layers Selection Tab 
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3. On the Rules tab, select the type of Design Rule Violations to include in the Raster Design 
Rule Check. Click the types of violations you want to check so that there is a check mark next 
to the violation, and set the required gap settings to your specifications. For the types of 
violations you do not want to check, click so that there is no check mark. 

 

Raster DRC Rules Tab 

Air Gap Violations: The system flags elements that are closer together than the minimum 
acceptable air gap. Set values for: 

• Trace-to-Trace Air Gap: Gap between traces on the same layer. (CPU, CPL, SIG, OTH, 
no negative plane layers) 
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• Trace-to-Pad Air Gap: Gap between traces and pads on the same layer. (CPU, CPL, 
SIG, OTH, no negative plane layers) 

• Pad-to-Pad Air Gap: Gap between pads on the same layer. (CPU, CPL, SIG, OTH, no 
negative plane layers) 

Soldermask Gap Violations: The system checks the upper soldermask against the upper 
component layer and the lower soldermask against the lower component layer looking for 
clearance between a component pad and an enclosing soldermask pad and a component trace and a 
soldermask pad. Set values for: 

• Pad-to-Mask Clearance: Clearance between pads on component layers and their 
enclosing soldermask pads (CPU to MSU, CPL to MSL). 

• Trace-to-Mask Clearance: Clearance between traces on component layers and 
soldermask pads (CPU to MSU, CPL to MSL). 

  In addition to the soldermask checks you specify above, the system flags soldermask 
pads (MSU, MSL) that are smaller than their component layer pads (CPU, CPL). Also 
the system checks for soldermask to soldermask gaps using the value of trace-to-mask 
clearance. 

Annular Ring Violations: The system flags violations between drill holes and the corresponding 
clearing pads, landing pads, or thermals on the other layers. The system also flags drills that make 
connection in more than one power or ground layer and elements too close to drills or clearing 
pads. A DRI or PAD layer must be present. VIA layers are not checked. Set clearance values for: 

• Drill-to-Outer Layers: Clearance between drills (DRI or PAD) and corresponding outer 
layer clearing or landing pads (CPU, CPL). 

• Drill-to-Other Layers: Clearance between drills (DRI or PAD) and corresponding other 
layer clearing or landing pads (OTH, SIG). 

• Drill-to-Plane Layers: Clearance between drills (DRI or PAD) and corresponding 
clearing pads on power and ground layers (GD1-5, PW1-5,). 

• Drill-to-Thermal: Inner ring clearance between drills (DRI or PAD) and thermals on 
power and ground layers (GD1-5, PW1-5). 

 In addition to the annular ring checks you specify above, the system flags drills (DRI or 
PAD) that do not have landing pad on CPx, SIG, and OTH layers or that do not have 
clearing pads or thermals on GDx and PWx layers. The system flags unplated drills close 
to elements on CPx, SIG, and OTH layers using the clearance value of drill-to-plane.  

Outline-to-Copper Area Violations: The system flags any copper area elements that are closer 
than the minimum distance to the board outline layer (BOL). For Outline-to-copper area checks to 
be run, a BOL layer must be present. The system checks CPx, SIG, OTH, GDx, and PWx for 
copper elements within the specified distance of the board outline. Set a value for the Outline-to-
Copper Area clearance.  
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Silkscreen-to-Pad Gap Violations: The system flags any silkscreen elements (SKU, SKL) that 
are closer than the minimum distance to the pads of the corresponding component layer (CPU, 
CPL).  

4. On the Options tab, set the Raster Design Rule Check Options: 

 

Raster DRC Options Tab 

Reference Frame: If you want to check only a portion of the plot, click the Check Only Data 
Inside Frame option so that there is a check mark next to the option. Otherwise, click the option 
so that there is no check mark. If you are using this option, you need to have positioned the frame 
when you prepared the plot data for the Raster Design Rule Check. 
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Text Error Report: The Raster DRC can output a text error report containing the conditions 
specified for the Raster DRC and the results of the check. Violations are listed by board layer and 
by type within the layer. If you want to output a text error report, click the Output a Text Error 
Report option so that there is a check mark next to the option and enter a name for the file. 
Otherwise, click the option so that there is no check mark. If you run the Raster Design Rule 
Check without outputting a text error report, you will still get the error tags that you can inspect 
added to the CAMMaster database. 

Maximum Errors: Set the maximum number of errors before aborting the Raster Design Rule 
Check. The system gives you the option to abort a DRC when it hits this number on the theory that 
the setup may be faulty to have generated so many errors. You can stop to correct the problem on 
the plot or change the Raster Design Rule Check parameters. Entering zero turns off this feature. 

5. On the Raster Resolution tab, enter the Raster Tools Resolution.  

 The Raster Tools Resolution is a very important value because it determines the accuracy 
of the DRC. 

The Raster Tools Resolution is the size of each pixel is in the raster bitmaps. You may enter a 
value from 0.1 through 50 mils, or from 1 through 1000 microns, inclusive. For more information 
regarding important considerations for setting the Raster Tools Resolution, see Raster Tools 
Resolution on page 425. 



Lavenir CAM Software User’s Guide 

394 

 

Raster DRC Raster Resolution Tab 

6. At the bottom of the DRC Setup dialog, click OK. 
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Raster DRC Progress Dialog 

The system displays the error count for each violation on the fly so you can keep track of the 
process.  

After the Raster Design Rule Check is complete, the Toolbar displays the elapsed time and the 
total number of violations detected. 

If any violations were detected, the Inspect DRC Errors dialog is displayed, so you can inspect the 
Raster DRC violations. 

You can also view the Raster DRC error report. See View the DRC Report on page 412. 
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View Raster DRC Errors on Screen  

 
The Raster DRC errors are displayed as colored lines indicating the closest approach of the offending 
elements. The endpoints of the colored lines correspond to the pixels in the bitmaps generated by the 
selected raster resolution. The lower the raster resolution number, the closer the bitmap corresponds to 
the elements in the display.  

Only the violations for the visible layers are shown. When there are more than one layer with the same 
board number, it is sufficient to have one of these layers visible; although some of the violations won’t 
make sense unless all the layers selected for the DRC are visible.  

The violations are ordered by type and within a type they are ordered by severest violation first.  

The Inspect DRC Errors dialog allows you to automatically move the cursor to the violations.  

To Inspect Raster DRC Violations: 
1. Make the layers you want to inspect visible. 

2. Display the Inspect DRC Errors dialog. The dialog box is displayed automatically after 
completion of Raster DRC or can be displayed by going to the Tools menu and clicking 
Design Rule Checking-Raster-Display Errors. 

 

Raster DRC Inspect DRC Errors Dialog 

3. On the Inspect DRC Errors dialog, click Error Types. 
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Raster DRC Error Types Dialog 

4. On the DRC Errors dialog, click each error type that you want to display so that it has a 
checkmark. 

5. To change the color for a DRC error type, click the button for that error type, and select a new 
color. 

 

Raster DRC Error Colors Dialog 

6. When you have selected the types and colors to display, click OK. 
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Raster DRC Error Tag 

7. To sequentially go to each error of the selected type, click the First, Next, Previous, and Last 
buttons on the Inspect DRC Errors dialog.  

8. To toggle focus between the Inspect DRC Errors dialog and the main application window, 
press Ctrl+PgUp. This is useful for returning to the main application window for adjusting 
the zoom factor or editing. 
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Vector DRC 

 
The program can run a Vector Design Rule Check to verify the accuracy and manufacturability of plot 
data. The process examines individual layers, layer sets, portions of layers selected with the reference 
frame, or the entire database, depending on how you set it up. The program reports design rule 
violations in a text file and flags the errors in the Viewing Area for easy identification. 

Prepare Plot Data for the Vector Design Rule Check 

 
The best Vector Design Rule Check results are obtained from plot data that has been prepared. You 
need complete and accurate D Code and Tool Code information and layer type identification. Flashed 
(not drawn) pads are essential for any check involving pads. Layer stacking is important if you have 
more than one via, drill, or padmaster layer.  

To Prepare Plot Data for the Vector Design Rule Check: 
1. On the D Code Table and the Tool Code Table, define all D Codes and Tool Codes. 

• NC Drill Tool Codes must be defined as P-plated, N-non-plated, T-tooling, or V-via.  

• If you use a Gerber padmaster to define drill data rather than a drill file, the D Code hole 
sizes must reflect the actual tool sizes.  

2. On the Layers Table, set up the Layer Types. 

In layer-to-layer checks for soldermask and annular ring violations, the system has to know the 
type of each layer used.  

3. Arrange the layers in order on the Layers Table. 

Layers are processed consecutively as listed. When there are multiple drill files, each new one 
takes precedence over the previous one. List the layers the way the board will be built or the way 
the layer sets will be drilled. 

4. Convert drawn pads to flashed pads. See Convert Drawn Pads on page 227. 

If you don’t have flashed pads on the top and bottom sides, extract them from the top and bottom 
soldermasks. The surface layer pad files do not have to match the padmaster since many of the 
component pads will not be drilled. 

5. Set the Visibility settings. 

The Vector Design Rule Check only checks visible elements.  

• Make sure all the layers to be checked are visible layers.  

• Make sure all pads, traces, selected, and unselected elements to be checked are visible. 
See Element Visibility on page 84. 
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6. Clear selection from all elements.  

The Vector Design Rule Check inserts selected data to indicate errors. Clearing the selection first 
helps avoid confusion. 

7. If you want to check only part of the data, put a reference frame around that data. See 
Reference Frame on page 177.  

 If you want to check all data, it does not matter where the reference frame is positioned. 

Once you are done preparing the plot data, go ahead and run the Vector Design Rule Check. 
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Run the Vector Design Rule Check 

 

To Run the Vector Design Rule Check: 
1. After you have prepared the plot data for the Vector Design Rule Check, go to the Tools 

menu and click Design Rules Check-Vector-Run DRC. 

2. On the Layer tab, select which layers to check. Only currently visible layers are displayed. 

 

Vector DRC Layers Selection Tab 
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3. On the Rules tab, select the type of Design Rule Violations to include in the Vector Design 
Rule Check. Click the types of violations you want to check so that there is a check mark next 
to the violation, and set the required gap settings to your specifications. For the types of 
violations you do not want to check, click so that there is no check mark. 

 

Vector DRC Rules Tab 

Air Gap Violations: The system flags elements that are closer together than the minimum 
acceptable air gap. Set values for: 

• Trace-to-Trace Air Gap: Gap between traces on the same layer. (CPU, CPL, SIG, OTH, 
no negative plane layers) 
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• Trace-to-Pad Air Gap: Gap between traces and pads on the same layer. (CPU, CPL, 
SIG, OTH, no negative plane layers) 

• Pad-to-Pad Air Gap: Gap between pads on the same layer. (CPU, CPL, SIG, OTH, no 
negative plane layers) 

Soldermask Gap Violations: The system checks the upper soldermask against the upper 
component layer and the lower soldermask against the lower component layer looking for 
clearance between a component pad and an enclosing soldermask pad and a component trace and a 
soldermask pad. Set values for: 

• Pad-to-Mask Clearance: Clearance between pads on component layers and their 
enclosing soldermask pads (CPU to MSU, CPL to MSL). 

• Trace-to-Mask Clearance: Clearance between traces on component layers and 
soldermask pads (CPU to MSU, CPL to MSL). 

Annular Ring Violations: The system flags violations between drill holes and the corresponding 
clearing pads, landing pads, or thermals on the other layers. The system also flags drills that make 
connection in more than one power or ground layer and elements too close to drills or clearing 
pads. Set clearance values for: 

• Drill-to-Outer Layers: Clearance between drills (DRI or PAD) and corresponding outer 
layer clearing or landing pads (CPU, CPL). 

• Drill-to-Other Layers: Clearance between drills (DRI or PAD) and corresponding other 
layer clearing or landing pads (OTH, SIG). 

• Drill-to-Plane Layers: Clearance between drills (DRI or PAD) and corresponding 
clearing pads on power and ground layers (GD1-5, PW1-5,). 

• Drill-to-Thermal: Inner ring clearance between drills (DRI or PAD) and thermals on 
power and ground layers (GD1-5, PW1-5). 

Pad-to-Pad Contact Violations: The system flags touching pads, including padstacks. (CPU, 
CPL, SIG, OTH) 

Centerline Disconnection Violations: The flags any trace to trace connections that are not 
endpoint to endpoint and trace to pad connections that are not endpoint to centerpoint.  

Unterminated Trace Violations: The system flags any traces whose endpoints do not terminate 
in the endpoint of a trace or the centerpoint of a pad.  

Trace Intersection Violations: The system flags traces that intersect anywhere other than at 
endpoints.  

Outline-to-Copper Area Violations: The system flags any copper area elements that are closer 
than the minimum distance to the board outline. Set a value for the Outline-to-Copper Area 
clearance.  

4. On the Options tab, set the Vector Design Rule Check Options: 
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Vector DRC Options Tab 

Reference Frame: If you want to check only a portion of the plot, click the Check Only Data 
Inside Frame option so that there is a check mark next to the option. Otherwise, click the option 
so that there is no check mark. If you are using this option, you need to have positioned the frame 
when you prepared the plot data for the Vector Design Rule Check.  

Text Error Report: If you want to output a text error report, click the Output a Text Error 
Report option so that there is a check mark next to the option and enter a name for the file. 
Otherwise, click the option so that there is no check mark. If you run the Vector Design Rule 
Check without outputting a text error report, you will still get the Gerber error tags. 
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Maximum Errors: Set the maximum number of errors before aborting the Raster Design Rule 
Check. The system gives you the option to abort a DRC when it hits this number on the theory that 
the setup may be faulty to have generated so many errors. You can stop to correct the problem on 
the plot or change the Vector Design Rule Check parameters.  

5. On the Violations D Code tab, set the first violation D Code.  

 

Vector DRC Violations D Code Tab 

The Violations D Code should be the first of 12 consecutive, available D Codes for on-screen 
error reporting. The system assigns the remaining D Codes automatically. Each type of error is 
automatically mapped to a different D Code for easy identification. 
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6. At the bottom of the DRC Setup dialog, click OK. 

The system displays the error count for each violation on the fly so you can keep track of the 
process.  

Violations are flagged by inserting selected elements of the Violation D Codes on the original 
layers. Each type of error is automatically mapped to a different D Code for easy identification.  

 The error flags are real data elements and should be removed before exporting data or 
saving the file. See Remove Vector Design Rule Check Errors Flags from the Plot on 
page 408. 

Errors are recorded in the error file V2001DRC.DRC in the current directory. See View the DRC 
Report on page 412. 

After the Vector Design Rule Check is complete, the system reports in the message line if any 
violations were found. 
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View Vector Design Rule Check Errors on Screen 

 
Violations are flagged by inserting selected elements of the Violation D Codes on the original layers. 
Each type of error is automatically mapped to a different D Code for easy identification. Selected error 
flags make it easy to view violations. Here are other suggestions for working with error data. 

 

Vector DRC Error Tags 

To View Vector Design Rule Check Errors on Screen: 
Ø To clearly see all instances of design rule violations, shut off the visibility of unselected 

elements, leaving only the selected error flags visible. See Element Visibility on page 84. 

Ø To see intersections and connections, try viewing data at zero width. 

Ø To see all instances of a particular type of violation, query the properties of a selected error 
flag, set the selection criteria to look for only that D Code, and use the First Element and Next 
Element commands. 
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Ø To export the selected error flags separate from the original data, shut off the visibility of 
unselected elements, leaving only the selected error flags visible, and then export the files as 
usual. 

Ø The D Codes of highlighted violations can be changed as any other D Code can be. Change 
D Code Shapes and Dimensions if it will make visual inspection easier. 

Remove Vector Design Rule Check Errors Flags from the Plot 

 

 The error flags are real data elements and should be removed before exporting data or saving 
the file. 

To Remove Vector Design Rule Check Errors Flags from the Plot: 
1. Make all elements visible (Pads, Traces, Selected, Unselected). 

2. Make all layers visible. 

3. Make all layers active. See Select from the Active Layers on page 152. 

4. If the error flags are no longer selected, go to the Edit menu and click Select-Select All. 

The error tags must be selected in order to be removed. The Select All command selects all the 
data, including the tags. But don’t worry, the following command will only delete the error tags, 
nothing else. 

5. On the Tools Menu, click Design Rules Checking-Clear Errors. 

The program removes all of the selected error flags. 
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Distance Histogram 

 
The program can generate a Distance Histogram report to verify the manufacturability of plot data and 
aid in the quoting process. The Distance Histogram report is a text file that includes the number of 
times each particular clearance occurs in the plot.  

To Generate the Distance Histogram Report: 
1. If you want to check only a portion of the plot, position the reference frame around the data 

you want to check. See Reference Frame on page 177.  

 If you want to check all data, it does not matter where the reference frame is positioned. 

2. On to the Tools menu, click Design Rules Check-Vector-Generate. 

3. On the Layer tab, select which layers to check. Only currently visible layers are displayed. 

 

Distance Histogram Layers Selection Tab 
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4. On the Max Air Gap tab, set the largest clearance to include in the report. The report will 
count all instances of clearances in the plot that are smaller than the Max Air Gap. 

 

Distance Histogram Max Air Gap Tab 

5. On the Options tab, set the Distance Histogram Options: 
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Distance Histogram Options Tab 

Reference Frame: If you want to check only a portion of the plot, click the Check Only Data 
Inside Frame option so that there is a check mark next to the option. Otherwise, click the option 
so that there is no check mark. If you are using this option, you need to have positioned the 
Reference Frame before setting up this dialog. 

Histogram Report Name: Enter a name for the Distance Histogram report file. If you want to 
select an existing file name or set a different directory, click Browse. The default file extension is 
.DST. 

Display Histogram Report after Operation: If you want the system to display the report 
automatically when the operation is done, click this option so that there is a check mark. 
Otherwise, click the option so that there is no check mark. If you do not select this option, you can 
always view the report later. 

6. At the bottom of the Design Rules Histogram dialog, click OK. 

The system displays the clearance count on the fly so you can keep track of the process. When 
complete, the program saves the Distance Histogram report. If the option was selected, the system 
displays the report; otherwise you can view the report later. See View the DRC Report on page 
412. 
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View the DRC Report 

 
The Vector and Raster DRC routines can generate an optional Vector Design Rule Check report, which 
you name when you set up the design rule check. And the Distance Histogram is also a report that you 
can view. 

To View the DRC Report: 
1. On the File Menu, click Report-View. 

2. In the Files of Type list, select All Files (*.*). 

3. In the Look in box, click the drive, folder, or network location that contains the Report. 

4. In the folder list, double-click folders until you open the folder that contains the report you 
want. 

5. Double-click the report. 
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Chapter 12 
Netlist Extraction 

 

 The Raster Netlist Extraction Routine is only available in CAMMaster, while the Vector 
Netlist Extraction Routine is available in ViewMaster PRO as well. 

The program can extract a variety of netlist data from multiple layers of Gerber and NC drill data using 
either a Raster Netlist Extraction routine or a Vector Netlist Extraction routine. 

In addition to extracting netlist data, the program can import netlist data into the current Job. See 
Import Netlist Data on page 55. 

Two Types of Netlist Extraction Routines 

 
There are some significant differences between the technique and the output of the Raster and Vector 
Netlist Extraction routines, and there are advantages to both systems. 

Raster vs. Vector Netlist Extraction Technique 

 
Raster Netlist Extraction converts the Gerber image into a raster bitmap and uses that bitmap to create 
polygonal outlines of the image. The Raster Netlist Extraction routine defines elements that are inside 
a single polygon to be in the same net.  

Vector Netlist Extraction uses the Gerber description of the position, size and shape of elements to 
determine if the elements intersect. The Vector Netlist Extraction routine defines elements that 
intersect to be in the same net.  

Raster vs. Vector Netlist Extraction Output 

 
The Raster Netlist Extraction saves the netlist information in the current Job File database. When you 
want to create a netlist file from the current Job File database, you export the netlist. 

When doing a Vector Netlist Extraction, you select the type of output you want at the time of the 
extraction. The Vector Netlist Extraction does not save any netlist information in the current Job File 
database; instead, the Vector Netlist Extraction exports the extracted netlist information in the form of 
the selected netlist file formats, report files or Gerber files. To get this information into the database, 
you import the netlist file and/or Gerber files. 
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Raster Netlist Extraction Advantages 

 
The Raster Netlist Extraction technique can process paint and scratch images, while the Vector Netlist 
Extraction technique cannot.  

Images that are comprised of many elements, such as planes drawn with traces, do not necessarily slow 
down Raster Netlist Extraction, while these types of images do slow down Vector Netlist Extraction. 
So Raster Netlist extraction can be much faster than Vector on files that contain many elements. 

Negative plane layers that have more than one power or ground region do not need to have split plane 
layers generated before Raster Netlist Extraction, while these types of files do need to have split plane 
layers generated before a Vector Netlist Extraction. So Raster Netlist Extraction does not require as 
much file preparation as Vector does. 

Vector Netlist Extraction Advantages 

 
The time required to do a Vector Netlist extraction is related more to the number of elements than to 
the physical size of the image or elements. So a large board does not necessarily take longer than a 
small board, as long as they both have the same number of elements. The time required to do a Raster 
Netlist extraction is related more to the number of pixels that have to be examined than to the number 
of elements. So a large image or an image with very small parts that has to be examined at high 
resolution can take longer than a smaller or low-resolution image, regardless of the number of elements 
involved. This means that Vector Netlist Extraction can be faster than Raster Netlist Extraction on 
boards that have a large physical size.  

Vector Netlist Extraction does not have a concept of image resolution and the accuracy of Vector 
Netlist Extraction is not affected by user-specified variables. In contrast, Raster Netlist Extractions that 
are not performed at adequately fine raster resolution may have errors. 



 Chapter 12 Netlist Extraction 

 415 

 

Raster Netlist Extraction 

 
The program can extract a variety of netlist data from multiple layers of Gerber and NC drill data.  

Prepare Plot Data for Raster Netlist Extraction 

 
Accurate and useful netlist results depend on correctly prepared plot data. Raw data must be edited for 
problems such as drawn pads, misalignment, and design rule violations. In some cases, you may have 
to generate additional layers of data or eliminate data to define conductivity clearly. Finally, composite 
layers and paint and scratch layer combinations must be given the same Board Layer, and layers must 
be organized in the proper Board Layer order on the Layers Table.  

To Prepare Plot Data for Raster Netlist Extraction: 
1. Clean up the raw data. Examine your original files for the following problems, and resolve 

each before attempting to extract a netlist: 

• Drawn Pads: The Raster Netlist Extraction routine generates net nodes for flashed, not 
drawn pads. With the Convert Drawn Pads tool, convert drawn pads to flashed pads of 
the same size and orientation. See Convert Drawn Pads on page 227. 

• Non-Circular Pads on Padmaster or Drill Layers: All pads on a padmaster or drill 
master layer should be circular. Transcode non-circular pads on the padmaster to circular 
pads of the same size and orientation. The Raster Netlist Extraction routine flags as shorts 
pads in the padmaster that do not have adequate annular clearance on the plane layers, 
and these types of shorts are sometimes caused by non-circular pads for which a circular 
aperture of the same diameter would not cause a short.  

• Padstacks: Using the Delete Pads tool, delete all but the largest pad in a padstack. This is 
to avoid having multiple netlist nodes generated for a single location. See Delete Non-
Functional Pads on page 245. 

• Layers Misaligned: Using the Snap to Padmaster tool, align all layers to a padmaster 
layer. See Snap Data to Padmaster on page 249. 

2. On the D Code Table and the Tool Code Table, define all D Codes and Tool Codes. 

NC Drill Tool Codes must be defined as P-plated, N-non-plated, T-tooling, or V-via. Every pad in 
a VIA or VID layer is considered to be conductive unless its D Code indicates that it is a non-
plated through hole.  

3. Generate supplemental layers. The original layers may require further detail for an accurate 
netlist to be generated. Look for these situations in the original layers: 
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• Additional Test Points: You can set up special test points on filter layers SPU, for the 
upper component layer, and SPL, for the lower component or solder side layer. The 
system uses these test points exclusively or in addition to the normal test points in 
extracting the netlist data, depending on how you set up the operation.  

• Buried Vias: The system recognizes buried vias in internal layers as opposed to through-
hole drills by processing padmaster and via files differently. The Gerber padmaster 
(PAD) or NC Drill master drill file (DRI) contains the primary drill holes defined for 
through-hole conductivity. The Gerber via files (VIA) or NC Drill via files (VID) contain 
drill information for internal layer conductivity between layers. Sometimes the buried via 
data is already separated on its own layer. If it isn’t, transfer the buried vias to separate 
layers. 

4. Exclude part of the data.  

If the PCB data has elements too small or fragile to test, or borders, text, or nonfunctional traces 
unrelated to the electrical characteristics of the board, use the Blank D Codes command to remove 
certain D Codes from the process. 

5. Set the Visibility settings. 

The Raster Netlist Extraction only checks visible elements, so make sure all pads, traces, selected, 
and unselected elements to be checked are visible. See Element Visibility on page 84. 

6. On the Layers Table, set up the Layer Types. 

The system has to know the layer type of each layer used.  

• CPU, CPL: Component layers, upper and lower. You must have one of each. Surface-
mount pads, if present, are included as nodes of the netlist. 

• PAD or DRI: Gerber or Drill padmaster layer. Use only one padmaster file per plot (or at 
least one via layer) to define the electrical connectivity between layers. In Gerber 
padmasters, pads are assumed to have the same sizes as their corresponding drill points; 
traces are ignored. 

• VIA or VID: Gerber or Drill buried via layers. In the case of inner layers with buried 
vias, there may be more than one via layer in addition to a padmaster. In the absence of a 
padmaster, there should be a via layer between each two consecutive layers to define the 
electrical connectivity between layers. 

• GD1-5: Ground planes. 

• GS1-5: Split ground planes. Do not generate or use split planes for Raster Netlist 
Extraction. Split planes are required to define different non-connected negative plane 
areas for Vector Netlist Extraction, but are not used for Raster Netlist Extraction.  

• PW1-5: Power planes. 

• PS1-5: Split power planes. Do not generate or use split planes for Raster Netlist 
Extraction. Split planes are required to define different non-connected negative plane 
areas for Vector Netlist Extraction, but are not used for Raster Netlist Extraction.  

• SIG: Internal signal layers. Only drill points may appear as nodes in the netlist. Other 
pads are not included in netlist output. 
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• MSU, MSL: Soldermask layers, upper and lower. These layers are used to determine if 
pads in the netlist are cleared of soldermask. 

• SKU, SKL: silkscreen layers, upper and lower. These layers are used to determine if 
pads in the netlist are cleared of silkscreen. 

• SPU, SPL: Filter Layers for CPU and CPL. These layers define additional test points that 
may be used in addition to or in place of normal test points. Corresponding pads on the 
CPU, CPL are not necessary. 

7. On the Layers Table, make sure all the layers to be checked are visible layers. Make sure all 
layers you do not want to process are turned off. For instance, if you want the Raster Netlist 
Extraction to ignore the soldermask and/or silkscreen information, make the MSU, MSL 
and/or SKU, SKL layers non-visible. Or if you want the Raster Netlist Extraction to ignore 
any additional test points, make the SPU, SPL layers non-visible.  

8. On the Layers Table, identify Negative layers.  

9. On the Layers Table, set the Board Layer Number for each layer.  

Layers are processed consecutively by Board Layer Number, and all layers that have the same 
Board Layer Number are processed as single composite layers. This allows netlist extraction on 
paint and scratch combinations. Assign board layer numbers to define the way the board will be 
built or the way the layer sets will be drilled. See Board Layer Stacking Examples on page 418. 

Ø Once you are done preparing the plot data, go ahead and run the Raster Netlist Extraction. 
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Board Layer Stacking Examples 

 
In general, board layers should be sequenced the way the board is to be built or the way the layer sets 
are to be drilled. The standard procedure is to put all layers for the upper board layer into board layer 
number 1, and to put layers for “descending” board layers into ascending-numbered board layers. The 
drill file or padmaster and the remaining supplemental layers can be stacked anywhere. The following 
examples illustrate typical cases: 

Composite Board Layers 

 
When the image for a single layer of the board is to be made by combining the images on several 
layers in the Layers Table, all the layers that make up the composite image need to be given the same 
Board Layer Number. That way, the single Board Layer can be processed as a single image. This 
makes it possible to process paint and scratch composites. 

In this example, layers 3 and 4, which form board layer 3, will be processed as a single composite 
layer, and layers 6 and 7, which form board layer 5, will be processed together.  

 

Layer Number: Board Layer: Layer Type: Explanation: 

1 1 CPU Upper Component Layer 

2 2 SIG Signal Layer 1 

3 3 PW1 1st layer in Composite Power Layer 

4 3 PW1 2nd layer in Composite Power Layer 

5 4 SIG Signal Layer 2 

6 5 GD1 1st layer in Composite Ground Layer 

7 5 GD1 2nd layer in Composite Ground Layer 

8 6 SIG Signal Layer 3 

9 7 CPL Lower Component Layer 

10 8 PAD or DRI Padmaster or Drill file 
(Connects all Layers) 
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Buried Vias 
Board layers which contain VIA or VID layers may not contain any other types of layers. If a Job File 
does not contain either a PAD or DRI layer, every alternating internal board layer must be a VIA or 
VID layer. 

This example has buried vias (VIA layers) stacked with signal layers (SIG). Each via layer defines the 
conductivity for the preceding and following layers in the stack. All layers are drilled by the padmaster 
(PAD), including layers that are not stacked before or after a VIA layer. 

 

Layer Number: Board Layer: Layer Type: Explanation: 

1 1 PAD Padmaster 
(Connects all layers) 

2 2 CPU Upper Component Layer 
(Connected by padmaster to all) 

3 3 SIG Signal Layer 1 
(Connected by padmaster to all) 

4 4 GD1 Ground Layer 1 
(Connected by padmaster to all) 

5 5 PW1 Power Layer 1 
(Connected by padmaster to all) 

6 6 SIG Signal Layer 2 
(Connected by Padmaster to all and 
connected to Signal 3 by Via 1) 

7 7 VIA Buried Via Layer 1 
(Connects Signal 2 to Signal 3) 

8 8 SIG Signal Layer 3 
(Connected by Padmaster to all and 
connected to Signal 2 by Via 1and 
connected to Signal 4 by via 2) 

9 9 VIA Buried Via Layer 2 
(Connects Signal 3 to Signal 4) 

10 10 SIG Signal Layer 4 
(Connected by Padmaster to all and 
connected to Signal 3 by Via 2) 

11 11 SIG Signal Layer 5 
(Connected by padmaster to all) 

12 12 CPL Lower Component layer  
(Connected by padmaster to all) 
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No Through-Hole Padmaster 

 
This example is a surface mount board with no padmaster. Instead the example has a via layer 
containing main pads and via holes shared by each working layer and the next. 

 

Layer Number: Board Layer: Layer Type: Explanation: 

1 1 CPU Upper component layer 

2 2 VIA Blind common via layer 1 
(Connects Upper Comp. To Signal 1) 

3 3 SIG Signal layer 1 

4 4 VIA Buried common via layer 2 
(Connects Signal 1 to Signal 2) 

5 5 SIG Signal layer 2 

6 6 VIA Buried common via layer 3 
(Connects Signal 2 to Signal 3) 

7 7 SIG Signal layer 3 

8 8 VIA Buried common via layer 4 
(Connects Signal 3 to Signal 4) 

9 9 SIG Signal layer 4 

10 10 VIA Blind common via layer 5 
(Connects Signal 4 to Lower Comp.) 

11 11 CPL Lower component layer  
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Supplemental Layers 

 
Supplemental layers such as soldermask layers (MSU, MSL), silkscreen layers (SKU, SKL), or layers 
defining additional test points (SPU, SPL) do not need to be stacked in any particular order because 
they do not define conductivity. In this example the soldermask, silkscreen, and additional test point 
layers are placed after the layers that define conductivity. 

 

Layer Number: Board Layer: Layer Type: Explanation: 

1 1 CPU Upper Component Layer 

2 2 SIG Signal Layer 1 

3 3 PW1 Power Layer 1 

4 4 SIG Signal Layer 2 

5 5 GD1 Ground Layer 1 

6 6 SIG Signal Layer 3 

7 7 CPL Lower Component Layer 

8 8 PAD or DRI Padmaster or Drill file 
(Connects all Layers) 

9 9 MSU Upper Soldermask 

10 10 MSL Lower Soldermask 

11 11 SKU Upper Silkscreen 

12 12 SKL Lower Silkscreen 

13 13 SPU Upper Additional Test Points 

14 14 SPL Lower Additional Test Points 
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Run the Raster Netlist Extraction 

 

To Run the Raster Netlist Extraction: 
1. After you have prepared the data for raster netlist extraction, go to the Tools menu, and click 

Netlist-Extract Raster.  

 

Raster Netlist Extraction Options Dialog 

2. On the Raster Netlist Extraction Options dialog, set the Board Layer Processing Options: 
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• Combine Board Layers: Extracts a single netlist for the board, processing all board 
layers together as connected by the drill layers and defined by the layer stack up. This is 
the most commonly used option. 

• Process Board Layers Individually: Extracts a separate netlist for each Board Layer 
and does not consider the inter-layer connectivity of the drill files. This option is 
sometimes used to generate netlist data for AOI machines, such as Lloyd Doyle. When 
this option is taken and the netlist data is subsequently exported, it is exported as 
individual netlist files for each Board Layer. 

3. Set the General Options: 

• Base Output File Name: This provides the path and base name for any files generated 
by the raster netlist extraction. CAMMaster extends the base name with a unique 
extension for each type of file generated by the raster netlist extension. 

• Raster Tools Resolution: This is the size of each pixel is in the raster bitmaps. You may 
enter a value from 0.1 through 50 mils, or from 1 through 1000 microns, inclusive. For 
more information regarding important considerations for setting the Raster Tools 
Resolution, see Raster Tools Resolution on page 425. 

  The Raster Tools Resolution is a very important value because it determines the 
accuracy of the Netlist Extraction. 

• Minimum Plane Size: Features in the plane layers that are smaller than this size are not 
considered to be planes. So, nets that only make contact in the plane layers to features 
smaller than this value are not considered to be plane layer nets. The reason for this is so 
that board designs in which there are covering pads for drill holes in plane layers will not 
generate net numbers over 200 or false short circuit reports. 

• Identify Net Midpoints: Format 2 and Format 4 netlists may contain midpoint records. 
If you want net midpoints to be identified when you export your Format 2 and Format 4 
netlist files, click on the Identify Net Midpoints checkbox so that it has a check mark.  

• Generate Net Count Report: The Net Count Report is an ASCII text file that lists the 
number of points and traces in each net and the number of nets with the same point count. 
If you want to generate a Net Count Report for this netlist extraction operation, click the 
Generate Net Count Report checkbox so that it has a check mark. The program generates 
the file using the Base Output File Name and the extension .REP. 

4. If you are generating netlist data for use with a MP Series moving probe tester, you may set 
the following Tester Options: 

• Generate Phase Test Data: The program can generate phase test data for a MP Series 
moving probe tester when you export your Format 4 netlist file. If you want to generate 
phase test data for an MP Series tester, click the Generate Phase Test Data checkbox so 
that it has a check mark. Since generating the phase test data takes additional time, you 
should probably only check this box if you will be using ProbeMaster to drive an MP 
Series tester from your Format 4 netlist files.  
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• Generate Net Adjacency Data: The program can generate net adjacency data for 
ProbeMaster when you export your Format 4 netlist file. If you want to generate net 
adjacency data, click the Generate Net Adjacency Data checkbox so that it has a check 
mark and enter a value for the minimum allowable separation between elements from 
different nets. The legal range is from 1 through 3000 mils, or from 10 through 70,000 
microns, inclusive. If you produce net adjacency data, your exported Format 4 netlist file 
will contain unique net numbers for all test points, even those points for single point nets. 
In other words, no test point will have a net identifier of “N/C”.  

5. Click OK. 

Once the Extracting Netlist Data dialog disappears, the net information has been deposited into the 
CAMMaster database.  

If any short circuits were detected between different types of plane layers, CAMMaster displays 
the message “possible short circuits were detected” in the dialog box which appears at the 
conclusion of the netlist extraction operation. See Short Circuits on page 426. 

Once the Raster Netlist Extraction is complete you can export the netlist files. See Export Netlist 
Data on page 80. 
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Raster Tools Resolution 

 
The Raster Tools Resolution determines the accuracy of raster operations such as Raster DRC, Raster 
Netlist Extraction and Raster Outline Generation.  

The Raster Tools Resolution is the size of each pixel is in the raster bitmaps. You may enter a value 
from 0.1 through 50 mils, or from 1 through 1000 microns, inclusive. 

In general, you should select a resolution value which is as large as possible, but not so large that the 
smallest features in your data lose their definition. The reason is that larger resolution values result in 
larger pixels, and therefore in fewer pixels per inch and shorter processing times.  

For example, doubling the Raster Tools Resolution means: 

• Double the pixel size. 

• Half the number of pixels per inch. 

• Quarter the number of pixels in an image. 

• Quarter the time required to process.  

So using larger resolution values makes the process run much faster. However, larger resolution values 
also result in less detailed bitmaps. In addition there is some uncertainty as to whether a pixel on the 
edge of an element will be considered to be inside the element or outside. For example, if a pair of 
pads is separated by 2 mils, the pads will appear to touch at resolution values larger than 2 mils, and 
they may appear to touch at resolutions as low as 1 mil. This is because the raster resolution is about 
the same size as the separation between the pads. 

 

Raster Pixels 

In addition, with larger resolution values, smaller features will become a single pixel in size, which is 
undesirable because the Raster Netlist Extraction and Raster DRC do not recognize single-pixel-sized 
shapes reliably.  
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Short Circuits 

 
The netlist extraction operation identifies drill holes and/or vias that connect plane layers of different 
types (e.g., GD1 and GD2) as short circuit elements. The program generates a Short Circuit Report file 
containing the list of offending pads and gives the file the base output file name with the extension 
.SCT. The program also flags the short circuit elements with the “S/C” identifier in the job file 
database, so you can use the selection tools to select the elements. See View Netlist Data On Screen on 
page 440.  



 Chapter 12 Netlist Extraction 

 427 

Vector Netlist Extraction 

 
The program can extract a variety of netlist data from multiple layers of Gerber and NC drill data.  

Types of Netlist Data, Files and Reports Extracted 

 
The Vector Netlist Extraction can extract a variety of netlist data and can generate the following files 
and reports.  

Lavenir Format 0 Netlist (.F00) 
The Lavenir Format 0 Netlist file (.F00) lists the location and aperture information for each net point in 
the padmaster layer, component layers, and/or filter layers. This is a Lavenir proprietary netlist format 
that can be used by other Lavenir software, such as FixMaster, ProbeMaster, and Verify. 

Lavenir Format 1 Netlist (.F01) 
The Lavenir Format 1 Netlist file (.F01) lists the net number, layer number, D Code or Tool Code, and 
coordinates for each net point in the padmaster and each pad and trace in the component layers and/or 
the filter layers. This is a Lavenir proprietary netlist format that can be used by other Lavenir software, 
such as FixMaster, ProbeMaster, and Verify. 

Lavenir Format 2 Netlist (.F02) 
The Lavenir Format 2 Netlist file (.F02) is the IPC-D-356 netlist format. It lists the Operation Code, 
Identifiers and aperture information for each net point in the padmaster layer, component layers, and/or 
filter layers. Format 2 netlists may distinguish between endpoints and midpoints and may include 
alternate test points and soldermask information. This is an open format that is used by many types of 
software including the Lavenir software FixMaster, ProbeMaster, and Verify. 

Lavenir Format 3 Netlist (.F03) 
The Lavenir Format 3 Netlist file (.F03) lists X and Y coordinates and net number of each net point in 
the padmaster layer, component layers, and/or filter layers. This is a Lavenir proprietary netlist format 
that can be used by other Lavenir software, such as FixMaster, ProbeMaster, and Verify. 

Lavenir Format 4 Netlist (.F04) 
The Lavenir Format 4 Netlist file (.F04) is a version of the IPC-D-356 netlist format that contains 
additional trace information. It lists the Operation Code, Identifiers and aperture information for each 
net point and trace in the padmaster layer, component layers, and/or filter layers. Format 4 netlists may 
distinguish between endpoints and midpoints and may include alternate test points and soldermask 
information. This standard IPC-D-356 portion of this file is an open format that is used by many types 
of software including the Lavenir software FixMaster, ProbeMaster, and Verify. The trace information 
is what distinguishes it from the standard IPC-D-356 format and the Lavenir Format 2. 
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Net Count Report (.REP) 
The Vector Netlist Extraction can produce a Net Count Report file. The Net Count Report file (.REP) 
is an ASCII text file that lists the number of points and traces in each net and the number of nets with 
the same point count. 

Gerber Reference Plot (.GNT) 
The Vector Netlist Extraction can produce a Gerber Reference Plot file. The Gerber Reference Plot file 
(.GNT) is a Gerber file that contains pads at the net point coordinates, each identified by a net number 
plotted in Gerber text. The file can be imported into the Job File like any Gerber file for reference on 
screen, or it can be plotted or printed.  

Short Circuit Report (.SCT) 
The Vector Netlist Extraction automatically generates a Short Circuit Report file (.SCT) when it finds 
a ground plane layer shorted to a power plane layer. The file is an ASCII text file, with a list of (X, Y) 
coordinate locations of elements that appear to be in contact with both a power and ground plane layer. 
If this happens, make sure that pads in the padmaster and drill layers, especially and non-circular 
elements, have annular clearance with the clearing pads in the plane layers. 

Short Circuit Gerber Plot (.VGD) 
The Vector Netlist Extraction automatically generates a Short Circuit Gerber Plot file (.VGD) when it 
finds a ground plane layer shorted to a power plane layer. The file is Gerber plot that shows the 
locations of elements that appear to be in contact with both a power and ground plane layer. If this 
happens, make sure that pads in the padmaster and drill layers, especially and non-circular elements, 
have annular clearance with the clearing pads in the plane layers. 

Split Plane Error Report (.SPT) 
The Vector Netlist Extraction automatically generates a Split Plane Error Report file (.SPT) when it 
finds open or overlapping polygons on the split plane layers PS!-5 and GS1-5. If this happens, make 
sure that the polygons that define the split planes are closed polygons with traces that chain end-to-end, 
and make sure that none of the polygons overlap. 

 The CAMMaster Raster Netlist Extraction does not generate a Split Plane Error Report. 
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Prepare Plot Data for Vector Netlist Extraction 

 
Accurate and useful netlist results depend on correctly prepared plot data. Raw data must be edited for 
problems such as drawn pads, misalignment, and design rule violations. In some cases, you may have 
to generate additional layers of data or eliminate data to define conductivity clearly. Finally, the layers 
have to be stacked in the proper order on the Layers Table  

To Prepare Plot Data for Vector Netlist Extraction: 
1. Clean up the raw data. Examine your original files the following problems, and resolve each 

before attempting to extract a netlist: 

• Drawn Pads: The Vector Netlist Extraction routine recognizes flashed, not drawn pads. 
With the Convert Drawn Pads tool, convert drawn pads to flashed pads of the same size 
and orientation. See Convert Drawn Pads on page 227. 

• Non-Circular Pads: The Vector Netlist Extraction routine flags non-circular pads in the 
padmaster that do not have adequate annular clearance on the plane layers as shorts. 
Transcode non-circular pads on the padmaster to circular pads of the same size and 
orientation.  

• Padstacks: Using the Delete Pads tool, delete all but the largest pad in a padstack. See 
Delete Non-Functional Pads on page 245. 

• Trace and Pad Connections and Traces Covered by Pads or Other Traces: Using the 
Trace/Pad Overlap tool, find and correct problems with traces not ending exactly at pad 
center point or at the endpoint of another trace as well as traces completely covered by 
other pads or traces. See Correct Trace/Pad Overlap Problems on page 298. 

• Layers Misaligned: Using the Snap to Padmaster tool, align all layers to a padmaster 
layer. See Snap Data to Padmaster on page 249. 

2. On the D Code Table and the Tool Code Table, define all D Codes and Tool Codes. 

NC Drill Tool Codes must be defined as P-plated, N-non-plated, T-tooling, or V-via.  

3. Generate supplemental layers. The original layers may require further detail for an accurate 
netlist to be generated. Look for these situations in the original layers: 

• Buried Traces or Pads in Power and Ground Planes: Transfer buried elements in 
power and ground plane layers to new layers, and designate these new layers as layer 
type SIG. 

• Splits in Power and Ground Planes: Power and ground plane layers that have split 
power areas in them must have corresponding layers that outline the splits. These layers 
are type PS1-5 and GS1-5, where the split layer number is the same as its original plane 
layer number. 

To define splits in a plane layer, replicate the traces that outline the split power area on a new 
layer using the Build Contour tool. This command automatically recreates the outline of a 
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split on a new layer using an F-type D Code specifically for this purpose. See Generate 
Contours on page 303. 

Outlines drawn with the same F-type D Code are interpreted as having the same voltage. 
Outlines drawn with unique F-type D Codes indicate different voltage areas. Splits may be 
nested, but not overlapping. Outlines of the splits don’t have to be drawn perfectly, but they 
must include all the data in that power area. Make sure the outline is closed, with no gaps in 
the corners. 

• Additional Test Points: You can set up special test points on filter layers SPU, for the 
upper component layer, and SPL, for the lower component or solder side layer. The 
system uses these test points exclusively or in addition to the normal test points in 
extracting the netlist data, depending on how you set up the operation.  

• Buried Vias: The system recognizes buried vias in internal layers as opposed to through-
hole drills by processing padmaster and via files differently. The Gerber padmaster 
(PAD) or NC Drill master drill file (DRI) contains the primary drill holes defined for 
through-hole conductivity. The Gerber via files (VIA) or NC Drill via files (VID) contain 
drill information for internal layer conductivity between layers. Sometimes the buried via 
data is already separated on its own layer. If it isn’t, transfer the buried vias to separate 
layers. 

4. Exclude part of the data. If the PCB data has elements too small or fragile to test, or borders, 
text, or nonfunctional traces unrelated to the electrical characteristics of the board, omit them 
from Vector Netlist Extraction in one of these ways: 

• Blanking Elements: Use the Blank D Codes command to remove certain D Codes from 
the process. 

• Isolating Part of a Board: Enclose the data you want used for the Vector Netlist 
Extraction in the Reference Frame. Later, when you set up the extraction options, turn 
on the Check Inside Frame only option. The system will check only the data inside the 
window, including nets that begin inside and end outside the window frame. 

5. Set the Visibility settings. 

The Vector Netlist Extraction only checks visible elements, so make sure all pads, traces, selected, 
and unselected elements to be checked are visible. See Element Visibility on page 84. 

6. Clear selection from all elements.  

The Vector Netlist Extraction uses selection to indicate extracted nets. Clearing the selection first 
helps avoid confusion. 

7. On the Layers Table, set up the Layer Types. 

The system has to know the layer type off each layer used.  

• CPU, CPL: Component layers, upper and lower. You must have one of each. Surface-
mount pads, if present, are included as part of the netlist. 

• PAD or DRI: Gerber or Drill padmaster layer. Use only one padmaster file per plot (or at 
least one via layer) to define the electrical connectivity between layers. In Gerber 
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padmasters, pads are assumed to have the same sizes as their corresponding drill points; 
traces are ignored. 

• VIA or VID: Gerber or Drill buried via layers. In the case of inner layers with buried 
vias, there may be more than one via layer in addition to a padmaster. In the absence of a 
padmaster, there should be a via layer between each two consecutive layers to define the 
electrical connectivity between layers. 

• GD1-5, GS1-5: Ground planes and split ground planes. 

• PW1-5, PS1-5: Power planes and split power planes. 

• SIG: Internal signal layers. Only drill points may appear in the netlist as net points; other 
pads are not included in netlist output. 

• MSU, MSL: Soldermask layers, upper and lower. These layers are used to determine if 
pads in the netlist are cleared of soldermask (Format 2 or 4 netlists only). 

• SPU, SPL: Filter Layers for CPU and CPL. These layers define additional test points that 
may be used in addition to or in place of normal test points. Corresponding pads on the 
CPU, CPL are not necessary. 

8. On the Layers Table, make sure all the layers to be checked are visible layers.  

9. On the Layers Table, add all other information as needed to identify Negative or Filled 
layers. 

10. Arrange the layers in order on the Layers Table. 

Layers are processed consecutively as listed in the Layers Table. List the layers the way the board 
will be built or the way the layer sets will be drilled. See Layer Stacking Examples on page 432. 

Once you are done preparing the plot data, go ahead and run the Vector Netlist Extraction. 
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Layer Stacking Examples 

 
In general, original layers, vias and supplemental splits should be sequenced the way the board is to be 
built or the way the layers sets are to be drilled. The drill file or padmaster and the remaining 
supplemental layers can be stacked anywhere. 

Split Plane Layers 

 
Both plane layers in this example had splits. The splits are stacked in order with their respective 
planes. The padmaster or drill layer defines through-hole conductivity for every layer. 

 

Layer Number: Layer Type: Explanation: 

1 CPU Upper Component Layer 

2 SIG Signal Layer 1 

3 PW1 Power Layer 1 

4 PS1 Splits from Power Layer 1 

5 SIG Signal Layer 2 

6 GD1 Ground Layer 2 

7 GS1 Splits from Ground Layer 2 

8 SIG Signal Layer 3 

9 CPL Lower Component Layer 

10 PAD or DRI Padmaster or Drill file  
(Connects all Layers) 



 Chapter 12 Netlist Extraction 

 433 

Buried Vias 

 
This example has buried vias (VIA layers) stacked with signal layers (SIG). Each via layer defines the 
conductivity for the preceding and following layers in the stack. All layers are drilled by the padmaster 
(PAD), including layers that are not stacked before or after a via layer. 

 

Layer Number: Layer Type: Explanation: 

1 PAD Padmaster 
(Connects all layers) 

2 CPU Upper Component Layer 
(Connected by padmaster to all) 

3 SIG Signal Layer 1 
(Connected by padmaster to all) 

4 GD1 Ground Layer 1 
(Connected by padmaster to all) 

5 PW1 Power Layer 1 
(Connected by padmaster to all) 

6 SIG Signal Layer 2 
(Connected by Padmaster to all and 
connected to Signal 3 by Via 1) 

7 VIA Buried Via Layer 1 
(Connects Signal 2 to Signal 3) 

8 SIG Signal Layer 3 
(Connected by Padmaster to all and 
connected to Signal 2 by Via 1 and 
connected to Signal 4 by via 2) 

9 VIA Buried Via Layer 2 
(Connects Signal 3 to Signal 4) 

10 SIG Signal Layer 4 
(Connected by Padmaster to all and 
connected to Signal 3 by Via 2) 

11 SIG Signal Layer 5 
(Connected by padmaster to all) 

12 CPL Lower Component layer  
(Connected by padmaster to all) 
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No Through-Hole Padmaster 

 
This example is a surface mount board with no padmaster. Instead the example has a via layer 
containing main pads and via holes shared by each working layer and the next. 

 

Layer Number: Layer Type: Explanation: 

1 CPU Upper component layer 

2 VIA Blind common via layer 1 
(Connects Upper Comp. To Signal 1) 

3 SIG Signal layer 1 

4 VIA Buried common via layer 2 
(Connects Signal 1 to Signal 2) 

5 SIG Signal layer 2 

6 VIA Buried common via layer 3 
(Connects Signal 2 to Signal 3) 

7 SIG Signal layer 3 

8 VIA Buried common via layer 4 
(Connects Signal 3 to Signal 4) 

9 SIG Signal layer 4 

10 VIA Blind common via layer 5 
(Connects Signal 4 to Lower Comp.) 

11 CPL Lower component layer  
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Run the Vector Netlist Extraction 

 

To Run the Vector Netlist Extraction: 
1. After you have prepared the data for Vector Netlist Extraction, go to the Tools menu and click 

Netlist-Extract Vector. 

2. On the File Type tab, select the types of netlist files and reports to generate. Click the types of 
files you want to generate so that there is a check mark next to the ones you want. For the 
types of files you do not want, click so that there is no check mark. 

 

Vector Netlist File Type Tab 
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3. In the Netlist File Name box, enter the prefix of the files to be generated. The system supplies 
the appropriate suffix. If you want for browse for directories or file names click the Browse 
button. 

4. On the Extraction Options tab, select the options you want. 

 

Vector Netlist Extraction Options Tab 

Endpoint Options: This option determines whether and how endpoints are distinguished from 
midpoints. If midpoints are distinguished from endpoints, then Format 2 and Format 4 netlists 
include both types of points and a special record to indicate which are which; for all other netlist 
formats, the output is limited to endpoints only. If endpoints are not distinguished from endpoints, 
then the Format 2 and Format 4 netlists do not include a special record to indicate which are 
which, and the other formats are not limited to endpoints only. 
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• Do Not Distinguish Endpoints and Midpoints: If this option is selected, midpoints are 
not distinguished from endpoints. All other options indicate that endpoints are 
distinguished from midpoints and designate the method used to distinguish between the 
two.  

• Conservative: The system requires at least two endpoints per net per layer before 
designating any points as midpoints. This conservative approach to identifying midpoints 
results in more endpoints. For example, every point on a ring net or loop would be tested 
as an endpoint. 

• Liberal: Pads with more than one trace coming in are marked as midpoints, as are vias 
that are part of plane layers. This liberal approach to midpoint identification results in 
fewer endpoints. For example, every point on a ring net or loop would be a midpoint, and 
there would be no endpoints. 

• CPU Layer Only: Looking at only the CPU layer results in vias which would normally 
be midpoints being selected and tested as endpoints. 

• CPL Layer Only : Looking at only the CPL layer results in vias which would normally 
be midpoints being selected and tested as endpoints. 

Alternate Test Points Options: This options tells the system how to deal with filter layer (SPU, 
SPL) points, if any. To include only SPU and SPL points in the netlist output, ignoring all other 
extracted test points, check Output SPU and SPL Layer Points Only. To include SPU and SPL 
points in addition to the other extracted test points, check the Output SPU and SPL Points in 
Addition to Extracted Points.  

Alternate Test Points Options: This option is for Format 2 and 4 reports, a check here turns on 
the Alternate Test Point field and causes the system to match the closest through hole with a 
surface mount pad if possible; no check disables Alternate Test Points. 

Check Traces Intersections: To consider crossed traces as making electrical connection, select 
this option with a check mark. When this option is selected, the system also uses information from 
the Filled column on the Layers Table to process the netlist. Without a check mark, the system 
does not recognize crossed traces as making electrical connection, and entries in the Filled column 
are ignored. 

Check Inside Frame Only: To use the Reference Frame to define the Vector Netlist Extraction 
area, select the Check Inside Frame Only option with a check mark. Otherwise, turn the option off, 
by clicking so that there is no check mark. 

5. At the bottom of the Netlist Setup dialog, click OK. 

The system displays a progress dialog so you can keep track of the process. The extracted netlist 
database is added to the current Job and the netlist file is exported. 

To load the extracted netlist file into the job file, import the netlist file. See Import Netlist Data on 
page 55. 
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Net Numbering Conventions in Lavenir Software 
Nets are extracted arbitrarily and numbered according to the following table: 

Net Number: Type of Net: 

-1 Power to Ground shorts 

0 Isolated points in the padmaster 

1 to 5 Points connected to unsplit power planes 

6 to 10 Points connected to unsplit ground planes 

11 to 199 Points connected to split power and ground planes 

200 and above Connected points not part of power or ground plane nets. 

Layer Numbering Conventions in Lavenir Software 
Layers are numbered by the operation according to the order in which they are listed on the Layers 
Table. Any point with a layer numbered 0 (zero) is a via. Any point with a non-zero layer number is a 
surface mount pad on that layer. 
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View Netlist Data 

 

View the Netlist Extraction Gerber Reference Plot 

 
The system generates several Gerber files for referencing net data: 

• Gerber Reference Plot (.GNT)  

• Short Circuit Gerber Plot (.VGD)  

To view these files, import them just as you would any other plot data. See Import Basic Gerber on 
page 29. 

View the Netlist Reports 

 
The system generates several ASCII text reports: 

• Net Count Report (.REP)  

• Short Circuit Report (.SCT)  

• Split Plane Error Report (.SPT)  

To View the Netlist Reports: 
1. On the File Menu, click a Report-View. 

2. In the Files of Type list, select All Files (*.*). 

3. In the Look in box, click the drive, folder, or network location that contains the report. 

4. In the folder list, double-click folders until you open the folder that contains the report you 
want. 

5. Double-click the Report. 

 If you want to rename the file, then while you are viewing the file in the text editor, save it out 
under a new name by using the Save As command. 
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View Netlist Data On Screen 

 
When netlist information is present in the currently loaded Job File database, either by Raster Netlist 
extraction or by importing a netlist file, each element is identified with a particular net code that 
indicates what net it is in, if any. Here are some suggestions for visually inspecting the netlist data on 
screen. 

To Find Out What Net a Particular Element Is In: 
Ø Query the properties of that element. See Query Element on page 103. 

To Step Through All Elements in the Same Net: 
Ø Set the selection criteria to search for only that particular net, and use the First Element and 

Next Element commands. 

To Select the Entire Net: 
Ø Set the selection criteria to search for only that particular net, and use the Global Select 

command. 

To Clearly See Only the Selected Net: 
Ø After selecting the net, shut off the visibility of unselected elements, leaving only the selected 

net visible. See Element Visibility on page 84. 

 Some netlist databases, such as those extracted using the CAMMaster Raster Netlist 
Extraction routine, flag single-point nets as “N/C” and flag elements which cause short 
circuits between different types of plane layers as “S/C.” For these types of netlist databases, 
you may also select single point nets elements or short circuit elements by entering a net 
number of “N/C” or “S/C”, respectively, into the Current Net field. 
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Chapter 13 
Scripting 

 
CAMMaster incorporates the Sax Basic Editor, an interactive design environment for developing, 
testing and executing Sax Basic scripts. The Sax Basic Language provides the core language definition 
and is Visual Basic for Applications compatible. The program also has a macro recorder for capturing 
macros and recording them as Sax Basic scripts which can be saved, edited and executed. 

The Sax Basic Engine and Sax Basic Language are a full-featured development environment and 
programming language. Instead of just playing back a recorded list of commands, you can program 
using variables, math and flow control. This script development system can also make use of the 
functions of other programs whose methods and properties are available to you as automation object 
libraries. 

Most major CAMMaster functions are provided in the CAMMaster Automation Object Library of 
properties and methods. This means you can easily insert and use CAMMaster functions in your scripts 
and you can also have your scripts get values from the currently loaded Job File.  

Use Macros 

 

The CAMMaster Macro Interface 

 
The Macro Menu and the Macro Toolbar contain the CAMMaster commands for controlling macros.  

 

Macro Toolbar 

To Display the Macro Toolbar: 
Ø On the View menu, look at Toolbars-Macro. 

• If Macro has a checkmark next to it, then the Macro Toolbar is displayed. 

• If Macro does not have a checkmark next to it, then the Macro Toolbar is not displayed. 

To change the display of the Macro Toolbar, click Macro. 
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Record a Macro 

 
CAMMaster has a macro recorder that allows you to record CAMMaster Automation methods and 
properties as Sax Basic scripts. 

To Record a Macro: 
1. Click Macro-Record. 

2. Do the CAMMaster operations that you want to record as part of the macro. 

The Macro Recorder records the CAMMaster Automation methods and properties that correspond 
to the operations you activate.  

 Not all CAMMaster operations have a corresponding CAMMaster Automation object, 
and likewise, not all CAMMaster Automation objects correspond exactly to a 
CAMMaster operation that you can activate manually. But macro recording is still a 
good way to capture scripts of commonly used CAMMaster operations. 

3. When you are done recording the macro, stop the macro recording by clicking Macro-
Record a second time. 

  

Pause Macro Recording 

 
Pausing a macro allows you to perform a CAMMaster operation that you do not want recorded when 
the Macro Recorder is running. 

To Pause a Macro: 
Ø Click Macro-Pause. When you want to resume recording, click Macro-Pause again to 

release the pause. 
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Load and Run a Macro 

 
The Load and Run command loads a macro into the system and runs it in one step. 

To Load and Run a Macro: 
1. Click Macro-Load and Run. 

2. In the Look in box, click the drive, folder, or network location that contains the macro file. 

3. In the folder list, double-click folders until you open the folder that contains the macro file. 

4. Double-click the macro file. 

 The four most recently used macro files are listed on the Recent Macro list at the bottom of 
the Macro menu, and can be loaded and run by clicking on them. 

 Macros can also be dragged and dropped into the system.  
You can also load a macro and run it in two separate steps. See Load a Macro on page 444 
and Run a Macro on page 445. 
You can also run a macro by opening it and running it from within the Sax Basic Editor. See 
Sax Basic Editor on page 447. 

Drag and Drop a Macro into the System 

 
You can load a macro by dragging and dropping it into the system. 

To Drag and Drop a Macro into the System: 
1. Open the Lavenir program and a file browser such as Windows Explorer or My Computer 

so that they are side by side on the desktop. 

2. In the file browser, select the macro file that you want to drag into the Lavenir program: 

3. Click on the selected macro file, hold down the mouse, and drag the selected macro file over 
to the Lavenir program. 

4. Release the mouse button over the viewing area or the program icon. 

The macro is loaded into the program. 

 You can also load and run a macro using the command menus rather than drag and drop. See 
Load and Run a Macro above. 
You can also run a macro by opening it and running it from within the Sax Basic Editor. See 
Sax Basic Editor on page 447. 
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Load a Macro 

 
Before a macro can be run from the CAMMaster Macro menu, it needs to be loaded into the system.  

 Macros are automatically loaded after they are recorded.  

To Load a Macro: 
1. Click Macro-Load. 

2. In the Look in box, click the drive, folder, or network location that contains the macro file. 

3. In the folder list, double-click folders until you open the folder that contains the macro file 
you want. 

4. Double-click the macro file. 

  

 You can also run a macro by opening it and running it from within the Sax Basic Editor. See 
Sax Basic Editor on page 447. 

Unload a Macro 

 
Unloading a macro removes the macro from the system, meaning that it cannot be run again until it is 
loaded again. 

To Unload a Macro: 
Ø Click Macro-Unload. 
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Run a Macro 

 
After you load a macro, you can run the macro from the Macro Menu. 

To Run a Macro from the Macro Menu: 
Ø After you load a macro, you can run the macro by clicking Macro-Run. 

  

You can also run the macro at the cursor location using the Macro Tool. This is useful if you want to 
run a macro on a particular element or location. 

To Run the Macro at the Cursor Location Using the Macro Tool: 
1. After you load a macro, click Macro-Tool. 

2. Position the cursor where you want the macro to run. 

3. Click the mouse or press Enter. 

  

 You can also run a macro by opening it and running it from within the Sax Basic Editor. See 
Sax Basic Editor on page 447. 

Stop a Macro 

 
You can stop a macro that is currently running. The primary use for this command is when a macro has 
failed but is still running. 

To Stop a Macro that is Running: 
Ø Click Macro-Stop.  

  

 You can also stop a macro from within the Sax Basic Editor. See Sax Basic Editor on page 
447. 
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Edit a Macro 

 
You can edit a macro in the Sax Basic Editor. 

To Edit a Macro: 
Ø Click Macro-Editor. 

This opens the Sax Basic Editor, where you can edit macros of the Sax Basic Language. See Sax 
Basic Editor on page 447. 

  

Save a Macro 

 
You can save a macro from within the Sax Basic Editor.  

To Save a Macro Captured with the Macro Recorder: 
When you stop the Macro Recorder, the macro will be automatically loaded into the system. 

1. Click Macro-Editor. 

The Sax Editor opens, and the macro that was loaded into CAMMaster is open within the Editor. 

2. On the Sax Editor menu bar, click File-Save. 

3. To save the macro file in a different folder, click a different drive in the Save in box, or 
double-click a different folder in the folder list. 

4. To save the macro file in a new folder, click Create New Folder. 

5. In the File Name box, type a name for the macro file. 



 Chapter 13 Scripting 

 447 

Sax Basic Editor 

 
The Sax Basic Editor is an editing and development environment for macros and scripts written in the 
Sax Basic Language. It has specialized tools for editing, running, and debugging Sax Basic scripts. 

To Display the Sax Basic Editor: 
Ø Click on Macro-Editor.  

  

To Display On-Line Help for the Sax Basic Editor: 
Ø Go to the Sax Basic Editor menu bar, and click on Help-Editor Help. 

 

Sax Basic Editor 
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Sax Basic Language 

 
The Sax Basic Language provides the core language definition for scripting in Lavenir products. The 
Sax Basic Language is Visual Basic for Applications™ compatible. The two languages are almost 
identical languages, but there are a few things in VBA that are not in Sax Basic and vice versa. 

To Display On-Line Help for the Sax Basic Language: 
Ø Go to the Sax Basic Editor menu bar, and click on Help-Language Help. 

What is in VBA but not in Sax Basic 

 

Collection 
• Add 

• Count 

• ItemRemove 

Conditional Compilation  
• #Const 

• #If…Then…#Else…#EndIf 

Control Flow  
• GoSub…Return 

• On…GoSub 

• On…GoTo 

Line Numbers  
• All line numbers 

DDE  
• LinkExecute 

• LinkPoke 

• LinkRequest 

• LinkSend 
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Error Handling  
• Erl 

• Resume ‘ current line 

Financial  
• All financial functions 

Objects  
• Clipboard 

• Collection 

• LoadPicture 

Options  
• Option Compare 
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What is in Sax Basic but not in VBA 

 

Clipboard  
• Clipboard 

DDE  
• DDEExecute 

• DDEInitiate 

• DDEPoke 

• DDERequest 

• DDETerminate 

• DDETerminateAll 

Dialogs  
• Dialog 

• DlgControlId 

• DlgCount 

• DlgEnable 

• DlgEnd 

• DlgFocus 

• DlgListBoxArray 

• DlgName 

• DlgNumber 

• DlgSetPicture 

• DlgText 

• DlgType 

• DlgValue 

• DlgVisible 

• CancelButton 

• CheckBox 

• ComboBox 

• DropListBox 

• GroupBox 



 Chapter 13 Scripting 

 451 

• ListBox 

• OKButton 

• OptionGroup 

• Picture 

• PushButton 

• Text 

• TextBox 

• UserDialog 

Execution  
• MacroDir 

• MacroRun 

• MacroRunThis 

Miscellaneous  
• CallersLine 

• PortInt 

• Wait 

String  
• InStrRev 

• Replace 
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CAMMaster Automation Object Library 

 
The CAMMaster Automation Object Library is a library of CAMMaster methods and properties that 
you can include in your scripts. Using these methods and properties (objects), you can easily insert and 
use CAMMaster functions in your scripts, and you can also have your scripts get values from the 
currently loaded Job File. 

The macro recorder operates by capturing CAMMaster objects as you activate the corresponding 
operations in CAMMaster and recording the objects in a Sax Basic script. 

Use a CAMMaster Automation Object in a Script 

 
The CAMMaster objects are identified as the object type CAMMaster.Tool 

To use the CAMMaster Automation Object Library, include a line such as the one below in your 
scripts: 

Dim LTI As New CAMMaster.Tool 

This line declares that LTI is a variable that identifies a CAMMaster object. In this example, LTI is 
just an arbitrary variable name, and you can use any other variable name in the declaration as long as 
you use it thereafter in that macro to refer to CAMMaster objects. For example, if you wanted to use 
LAV as the variable, the declaration would be as follows: 

Dim LAV As New CAMMaster.Tool 

In the above example, which uses LAV as the variable to identify CAMMaster objects, subsequent 
lines that use CAMMaster objects would appear as follows: 

LAV.ClearSelection 

LAV.OnlyCurrentLayer = True 

LAV.CursorY = 0 

In these examples, the variable LAV identifies the objects ClearSelection, OnlyCurrentLayer, and 
CursorY as CAMMaster objects. 
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Property Strings 

 
Some CAMMaster properties and arguments of methods take a string as input to set various 
subproperties. This method minimizes the number of properties needed in the CAMMaster Automation 
Object Library. For example: 

LTI.GerberDataFormat=”Left=2, Right=3, Leading, Absolute, 
English, 360-Degree, ASCII” 

In this example, the property GerberDataFormat takes the string “Left=2, Right=3, Leading, 
Absolute, English, 360-Degree, ASCII” to set seven subproperties.  

When you want to change any of the subproperties, you don’t need to include all of them in the 
subproperties string, only the ones you want to change. All the non-specified subproperties will remain 
unmodified. For example: 

LTI.GerberDataFormat=”Right=4” 

In this example the subproperty “Right=4” is set, while the other six subproperties of 
GerberDataFormat remain the same. 

Also, for any text in the subproperties string, any non-ambiguous prefix is enough to set the 
subproperty. For example: 

LTI.GerberDataFormat=”Le=2, Eng” 

is the same as: 

LTI.GerberDataFormat=”Left=2, English” 

because the only GerberDataFormat subproperty to begin with Le is Left, and the only subproperty 
to begin with Eng is English.  
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Browse the CAMMaster Automation Object Library 

 
You can browse the CAMMaster Automation Object Library in the Sax Basic Editor. 

To Browse the CAMMaster Automation Object Library: 
1. In the CAMMaster menu bar, click Macro-Editor. 

2. In the Sax Editor menu bar, click Edit-References. 

3. In the References dialog, click Lavenir CAMMaster Type Library (1.0) so that it has a 
check mark. 

4. In the References dialog, click OK. 

5. In the Sax Editor toolbar, click the Browse Object button. 

6. In the ActiveX Automation Members dialog, go to the Library drop down list and select 
CAMMaster. 

7. In the ActiveX Automation Members dialog, go to the Data Type drop down list and select 
Tool. 

The ActiveX Automation Members dialog shows the methods and properties of the CAMMaster 
Automation Object Library in the Methods/Properties list. 

8. In the ActiveX Automation Members dialog, click on a method or property in the 
Methods/Properties list to see additional information about that method or property. 

 For Help on the Sax Editor, go to the Sax Basic Editor menu bar, and click on Help-Editor 
Help. 
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Chapter 14 
AutoPanel Script 

 
CAMMaster comes with the AutoPanel.BAS script as way to demonstrate the power of Sax Basic 
scripting in CAMMaster. 

What the AutoPanel Script Does 

 
The CAMMaster AutoPanel script automatically processes a prepared one-up .BIN file into panelized 
layer files ready for output. 

Steps and Repeats the Prepared One-up File 

 
The AutoPanel script steps and repeats the prepared one-up file within an area that you define. 
AutoPanel determines the size of the one-up file from the board outline layer (.OLN). AutoPanel 
prompts you for the size of the area within which you want to step and repeat the file and for the 
distance you want between stepped images. Then AutoPanel determines the orientations that will yield 
the most stepped images within the area you defined. When AutoPanel determines the best orientation 
and position for the stepped pattern, the script shows a preview of what the step pattern will look like. 
You can select whether to accept the pattern or decline the pattern and try again with different 
steppable area dimensions and different clearance values. When you accept the previewed step pattern, 
AutoPanel steps and repeats the file to match the preview. 
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Imports Predefined Panel Data 

 
AutoPanel includes panel data files for three sizes of panels: 

• 12” x 18” 

• 16” x 18” 

• 18” x 24” 

The predefined panel files have: 

• Robber bars 

• Boundaries for venting and thieving fill 

• Targets for optical inspection and registration 

• Areas defined for title blocks, drill final hits, layer number blocks. 

The predefined panel files are located in the  
C:\Lavenir\CAMMaster 6.0\Sample Scripts\Panel directory.  

After AutoPanel steps and repeats the file, the script determines which panel sizes will fit the 
dimensions of the steppable area that you defined. AutoPanel prompts you to pick a panel size, and 
then it imports the predefined panel data and merges it into the proper layers. 

Generates Venting and Thieving Patterns 

 
The AutoPanel script generates venting and thieving patterns for inner and outer layers. The script 
prompts you for which types of patterns to use for inner and outer layers. When you have selected the 
parameters, AutoPanel automatically generates the venting and thieving patterns for each layer type. 
The system automatically handles positive and negative data, drawn and flashed planes, paint and 
scratch layers.  
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Adds Job Information to the Panel as Text 

 
AutoPanel gathers information about the job and adds it to the panel as text: 

• Adds the one-up file name as text to a title block. 

• Drills the one-up file name into the drill layer. 

• Runs a copper area calculation and adds the results as text to a title block. 

• Prompts for mask type and silkscreen color and adds the information as text to the appropriate 
layers. 

• Numbers each layer in a layer number block. 

• Adds scale factors as text to each inner layer. 

Optimizes Drill Data and Adds Final Hits 

 
AutoPanel optimizes the stepped drill data and adds final hits for each tool. 

Scales and Flips Layers for Output 

 
AutoPanel prompts for scale factors for each layer and prompts for the construction type, cap or foil. 
Then AutoPanel scales each layer as you specified and flips layers to match the construction type. 
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File Preparation 

 
The CAMMaster AutoPanel script requires that the one-up .BIN file be prepared in a particular way. In 
addition to the CAM work that you would normally do prior to panelization, the script requires an 
outline layer, a labeled solder side layer, an NC drill layer, and a particular layer naming convention in 
order to run properly. All prepared one-up data must be saved in a single .BIN file prior to starting the 
AutoPanel script. 

Outline Layer 

 
AutoPanel requires an outline layer. The script uses the outline layer to determine the dimensions of 
the one-up part for stepping and repeating and also to determine the board profile for the venting and 
thieving operations. The outline layer must contain a polygon that encloses all data of the one-up part. 
The outline layer must be named with the extension “.OLN” as described in the Naming Convention. 
See Naming Convention on page 460. 

Solder Side Layer 

 
AutoPanel requires that you label the solder side layer. The script uses the solder side layer to 
determine the number of layers in the part. The solder side layer must be named with the extension that 
contains “SS” as described in the Naming Convention. See Naming Convention on page 460. 

Drill Layer 

 
AutoPanel requires a drill layer defined in a particular way: 

• The drill layer must have the layer type DRI in the Layers Menu. 

• The drill layer must contain only D Codes of type N mapped to Tool Codes. The system will 
not work with a Gerber layer for the drill layer.  

• The drill layer must only use Tool Codes 3 and higher. The AutoPanel script reserves Tool 
Codes 1 and 2 for it’s own standard tooling. 

• The drill layer must be named with the extension that contains “DRI” as described in the 
Naming Convention. See Naming Convention on page 460. 
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Maximum Layer Count 

 
The AutoPanel script can only process files that have 20 layers or fewer. 

Directory Structure 

 
The AutoPanel script requires the Panel directory containing the predefined panel files to be inside the 
same directory that contains the AutoPanel.BAS script. Also, the PlotOut.BAS script must be in the 
same directory that contains the AutoPanel.BAS script. By default this is how the AutoPanel directory 
structure is installed on your system by the Setup program.  
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Naming Convention 

 
The AutoPanel script requires that layer names in the one-up file follow a standard Naming 
Convention for layer name extensions. The layer name prefix must be the same as the one-up .BIN file 
prefix, and the extension must come from the following table.  

 The NameExtension.BAS script can help you apply this naming convention to the layers in 
your job. See Naming Convention Script on page 477. 

 

Layer Name Extension: Layer Type: 

“1” Component layer 1 

“1d” Component layer 1 Drawn Plane 

“1f” Component layer 1 Flashed Plane 

“1s” Component layer 1 First Scratch  

“1p” Component layer 1 First Paint  

“1s1” Component layer 1 Second Scratch  

“1p1” Component layer 1 Second Paint  

“s1” Component Silkscreen 

“s1s” Component Silkscreen Scratch 

“m1” Component Soldermask 

“m1s” Component Soldermask Scratch 

“p1” Component Paste Mask 

“#ss” Solder Side 

“#ssd” Solder Side Drawn Plane 

“#ssf” Solder Side Flashed Plane 

“#sss” Solder Side First Scratch 

“#ssp” Solder Side First Paint 

“#sss1” Solder Side Second Scratch 

“#ssp1” Solder Side Second Paint 

“#” Internal Signal  
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Layer Name Extension: Layer Type: 

“g#f” Internal Ground Flash  

“p#f” Internal Power Flash  

“g#d” Internal Ground Drawn 

“p#d” Internal Power Drawn 

“#s” First Scratch  

“#p” First Paint   

“#s1” Second Scratch  

“#p1” Second Paint 

“#s2” Third Scratch  

“#p2” Third Paint 

“s#” Silkscreen 

“s#s” Silkscreen Scratch 

“m#” Soldermask 

“m#s” Soldermask Scratch 

“p#” Paste Mask 

“oln” Board Outline 

“pol” Array Outline 

“dri” Primary Drill 

“dri#” Drill 2nd, 3rd, 4th, etc. 

“bv#” Blind/Buried Via (bv1-5, bv5-6, etc) 

“rt” Primary Rout Profile 

“#rt” Rout Profile 2nd, 3rd, 4th, etc. 

“fab” Fab Drawing 

“fab#” Fab Drawing 2nd, 3rd, 4th, etc. 

“oth” Other 

“oth#” Other 2nd, 3rd, etc. 
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Use the AutoPanel Script 

 
The following are step-by-step instructions for using the AutoPanel script. AutoPanel comes with a 
prepared sample one-up file, so you can try out the script without preparing your own Job File. To use 
the AutoPanel script on your own files, first prepare your files as described in the File Preparation 
section on page 458. 

Load and Run the AutoPanel Script 

 
1. Start in CAMMaster, with no data loaded. 

2. On the Macro menu, click Load. 

3. On the Open dialog, navigate to  
C:\Lavenir\CAMMaster 6.0\Sample Scripts\AutoPanel.BAS 

4. Click on AutoPanel.BAS so that it appears in the File Name field. 

5. Click OK. 

The AutoPanel script is loaded into the system. 

6. On the Macro menu, click Run. 

The system prompts you to “Select the Edited job.bin.” 

Example:  
AutoPanel comes with a sample prepared Job File called  
C:\Lavenir\CAMMaster 6.0\Sample Scripts\Sample1up\Sample1up.BIN.  
If you are just trying out AutoPanel, click on this file. Otherwise use your own prepared 
Job File. 

7. On the Select the Edited job.bin dialog, navigate to the directory that contain the prepared 
Job File that you want to panelize and click on the prepared Job File that you want to 
panelize so that its name appears in the File Name field. 

8. Click Save. 
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Step and Repeat inside the Panel Area 

 
The system prompts you for the panel area and spacing. 

 

Layout Calculator 

9. In the Panel Area X and Y fields of the Layout Calculator dialog, enter the X and Y 
dimensions of the area in which you want the script to step and repeat the Job File. 

 Because of the panel features outside of the steppable area (i.e. coupons, targets, title 
blocks, etc.), the finished panel size is going to be larger than the area you specify here 
as the steppable area.  

10. In the Spacing X and Y fields of the Layout Calculator dialog, enter the X and Y distance 
you want between the repeated images of the Job File. 

The system calculates the most efficient step pattern and previews it on screen along with a yield 
analysis dialog. The system uses the dimensions of the board outline layer and the Panel X and Y 
and the Spacing X and Y dimensions to determine how many stepped images can fit in both 
horizontal and vertical orientations, and then the system displays the orientation that yields the 
most images.  
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Step Pattern Preview 

11. If you like the pattern preview, then click Accept on the Yield Analysis dialog. 
If you do not like the pattern preview, then click Decline on the Yield Analysis dialog and 
change the Panel X and Y and the Spacing X and Y dimensions until you get a pattern you 
like. 

After you click Accept, the system steps and repeats the job to match the previewed image.  
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If the Panel X and Y dimensions that you specified earlier will fit on more than one predetermined 
panel size, the system prompts you to select a panel size. 

 If the specified Panel X and Y dimensions will only fit on the largest panel size, then the 
system will skip this step. 

 

Select Panel Size 

12. On the Select Panel Size dialog, click on the panel size that you want to use. 

13. Click OK. 

After you select the panel size, the system imports the files for the predetermined panel size.  



Lavenir CAM Software User’s Guide 

466 

Add Venting and Thieving Patterns 

 
The system prompts you to select options for the thieving pattern to be used on the outer layers. 

 

Outer Layer Thieving Options 
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14. On the Outer Layer Thieving Options dialog set the options for the thieving pattern that you 
want to use on the outer layers. 

Solid Fill: The Solid Fill option adds a solid fill of traces between the profile of the stepped 
boards and the inner profile of the panel. If you want a solid fill for the outer layer thieving 
pattern: 

• Click Solid Fill. 

• In the Keep Away field, enter the distance you want between the fill pattern and the 
stepped images. 

• Click OK. 

Fill with Dots: The Fill with Dots option adds an alternating dot pattern between the profile of the 
stepped boards and the inner profile of the panel. If you want a dot fill for the outer layer thieving 
pattern: 

• Click Fill with Dots. 

• In the Keep Away field, enter the distance you want between the fill pattern and the 
stepped images. 

• In the Dot Size field, enter the size of the D Code to use for the dot pattern. 

• In the Dot Shape field, enter shape of the D Code to use for the dot pattern. 

• In the Dot Spacing field, enter the distance you want between dots on a layer. 

• Click OK. 

Fill with Board Profile: The Fill with Board Profile option adds a trace of specified width around 
the profile of the stepped boards. If you want a board profile fill for the outer layer thieving 
pattern: 

• Click Fill with Board Profile. 

• In the Keep Away field, enter the distance you want between the board profile trace and 
the stepped images. 

• In the Thief Width field, enter the size of the D Code to use for the board profile trace. 

• Click OK. 

After you specify the options to use for the outer layer thieving, the system generates the fill 
pattern you specified.  
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The system prompts you to select options for the thieving pattern to be used on the inner layers. 

 

Inner Layer Thieving Options 



 Chapter 14 AutoPanel Script 

 469 

15. On the Inner Layer Thieving Options dialog set the options for the thieving pattern that you 
want to use on the inner layers. 

Fill with Dots: The Fill with Dots option adds an alternating dot pattern between the profile of the 
stepped boards and the inner profile of the panel. If you want a dot fill for the inner layer thieving 
pattern: 

• Click Fill with Dots. 

• In the Keep Away field, enter the distance you want between the fill pattern and the 
stepped images. 

• In the Dot Size field, enter the size of the D Code to use for the dot pattern. 

• In the Dot Shape field, enter shape of the D Code to use for the dot pattern. 

• In the Dot Spacing field, enter the distance you want between dots on a layer. 

• Click OK. 

Fill with Starburst: The Fill with Starburst draws a starburst pattern with traces between the 
profile of the stepped boards and the inner profile of the panel. If you want a starburst fill for the 
inner layer thieving pattern: 

• Click Fill with Starburst. 

• In the Angle field, enter the angle you want between rays of the starburst pattern. 

• Click OK. 

After you specify the options to use for the inner layer thieving, the system generates the fill 
pattern you specified.  
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Add Job Info to the Panel as Text 

 
The system prompts for the type of solder mask that is going to be used for the job. 

 AutoPanel adds the mask type to the soldermask layers as text. 

 

Soldermask Type 

16. On the Mask Type dialog, click on the type of solder mask that is going to be used for the 
job, either LPI or Dry Film. 

17. Click OK. 

The system prompts for the color of silkscreen that is to be used for the job. 

 AutoPanel adds the silk color to the silkscreen layers as text. 

 

Silkscreen Color 

18. In the Silk Color dialog, click on the color of the silkscreen to be used for the job. 

19. Click OK. 



 Chapter 14 AutoPanel Script 

 471 

The system prompts for options to be used in the copper area calculation.  

 The system puts the calculated copper area on the layer as text in a title block and also 
exports a report file with the calculated copper area. 

 

Copper Area Calculation Options 

20. In the Copper Area Calculation Options dialog, select the options you want for copper area 
calculation. 

Outer Layers with Hole Wall: Click this option if you want to calculate the copper area for the 
outer layers only and include the copper area of plated through holes. 

Outer Layer with Hole Wall and Inner Layer Surface: Click this option if you want to 
calculate the copper area for the outer layers, including the copper area of plated through holes, 
and also calculate the copper area of the inner layer surfaces. 

Skip Cu Area Calc.: Click this option if you do not want to do a copper area calculation on the 
panel. 

21. Click OK. 

The system calculates the copper area and inserts the results as text on the layers. 

Next, the system optimizes the drill data and reports the shortened path length. 

 

Path length of optimized drill path 

22. Click OK. 
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The system reports that the panelization is complete. 

 The macro still has more scaling and mirroring for output to do, but the macro pauses at 
this point for you to inspect the data. The data at this point represents the board as it will 
be built. You should thoroughly inspect the data before resuming the macro.  

 

Panelization Complete 

23. Click OK. 

The AutoPanel macro is paused, and you can operate CAMMaster normally at this point. 

24. Thoroughly inspect the panelized plot. 

 The system places any scratch layers that it needs to generate into the layers 31 and 
higher. To view these layers as composites you need to turn on visibility for both the 
original layer and the generated scratch layer.  

 For example the sample file, Sample1up.BIN, contains flashed ground and power 
planes. The venting patterns generated for these flashed plane layers require the system 
to generate scratch layers. To view the composite for the ground plane layer, turn on 
visibility for layer 3 (Sample1up.g3f) and layer 33 (Sample1up.3scratch). To view the 
power plane composite, turn on 4 and 34. 

Save a Copy of the Panelized Files 
While the macro is paused, you can save a copy of the file at this point before mirroring and 
scaling for output. 

25. Click Save As. 

26. Enter the new file name. 

Example: 
If you are trying out the AutoPanel script with the sample file Sample1up.BIN, you could 
rename the file Sample Panel.BIN to avoid inadvertently overwriting the original sample 
file. 

27. Click OK. 
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Scale and Flip the Data for Output 

 
28. On the Macro menu, click Resume. 

The system prompts for an X and Y scale factor for each layer. 

 In addition to using this information to actually scale the data, AutoPanel also adds the 
scale factors to the layers as text. 

 

Scale Factor 

29. For each layer enter X and Y scale factors into the Scaling dialog. 

30. Click OK. 
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The system prompts for the type of construction for this job. 

 AutoPanel uses this information to determine how to flip the data for output. Depending 
on cap or foil construction, text on alternating layers is flipped to read right from the top 
or bottom, and data is flipped to have the correct emulsion side up or down. 

 

Construction 

31. In the Stackup dialog, click on the type of construction to be used for the job, cap or foil. 

32. Click OK. 

AutoPanel scales and flips that data as you specified and adds the scale factor to the layers as text.  

The system indicates that the data have been scaled and flipped. 

 

Scaled and Flipped 

33. Click OK. 

This is the end of the AutoPanel script, but there are a few more manual steps to the procedure. 
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Save a Copy of the Output Files 

 
34. Thoroughly inspect the data before output. 

35. Click Save As. 

36. Enter the new file name. 

Example: 
If you are trying out the AutoPanel script with the sample file Sample1up.BIN, you could 
rename the file Sample Output.BIN to avoid inadvertently overwriting the original 
sample file. 

37. Click OK. 

38. Export the data for photoplotting as usual using the File-Export menu command and the 
format and options you usually use. 
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Troubleshoot AutoPanel Error Messages 

 
Most problems that have been encountered with the AutoPanel script have been related to improper 
setup of the one-up file. Here are some of the more common error messages and what to check for. 

Can’t Find #SS 

 
This error message happens when the script is having trouble locating and classifying the layers that it 
needs. This could be due to several reasons: 

• Be sure the one-up .BIN file contains a solder side layer with the extension containing “SS”. 
See Solder Side Layer on page 458. 

• Be sure the one-up .BIN file contains an outline layer with the extension .OLN. See Outline 
Layer on page 458. 

• Be sure the one-up .BIN file contains a drill layer with the extension .DRI and the layer type 
DRI, and be sure the drill layer does not use tool codes 1-3. See Drill Layer on page 458. 

• Be sure all layer name extensions in the one-up .BIN file are correct as specified in the 
naming convention. See Naming Convention on page 460. 

• Be sure all layer names in the one-up .BIN file have the same prefix as the .BIN file. See 
Naming Convention on page 460. 

Floating Point Error 

 
This error message happens when the script encounters a math error. This could be due to several 
reasons: 

• Be sure the outline layer with the extension .OLN contains a complete, closed polygon. See 
Outline Layer on page 458. 

• Be sure the outline layer with the extension .OLN does not contain a double-drawn polygon. 
See Outline Layer on page 458. 

• Be sure all layer name extensions in the one-up .BIN file are correct as specified in the 
naming convention. See Naming Convention on page 460. 
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Chapter 15 
Sample Scripts 

 
In addition to the AutoPanel script CAMMaster contains several other sample scripts. 

Naming Convention Script 

 
The NameExtension.BAS script assists you in applying the Lavenir layer naming convention used by 
the AutoPanel.BAS script and other Lavenir scripts. You can use the script to prepare your own files 
for automatic panelization. 

To Apply the Lavenir Naming Convention with the NameExtension.BAS Script: 
1. Begin with the files you want to rename open in CAMMaster. 

2. If you want to save the files with their original names before applying the naming convention, 
go to the Files menu and click Save. 

3. On the Macro menu, click Load. 

4. On the Open dialog, navigate to  
C:\Lavenir\CAMMaster 6.0\Sample Scripts\NameExtension.BAS. 

5. Double-click NameExtension.BAS. 

6. On the Macro menu, click Run. 

7. On the Job Number dialog, enter the name or number you want to use for this job. 

 The script uses the name or number you enter here as the name for a new directory 
containing the new .BIN file, the prefix for the new .BIN file, the prefix for the individual 
layer names, and the prefix for a report file containing the name changes. 
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Job Number or Name 

8. Click OK. 
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The script displays the Layer Identification dialog. The dialog shows the name of the first layer 
in the currently loaded files, and the layer is also displayed in the CAMMaster viewing area. The 
dialog prompts you to enter the new layer extension from the naming convention for the layer 
shown. 

 

Layer Identification 

9. If you don’t know what the correct extension should be, click Naming Convention Example.  

The script displays a text file in Notepad. The file explains the naming convention extensions. You 
may want to print the file from Notepad if you think you will need to refer to it frequently. 

 The naming convention extensions are also listed in this document.  
See Naming Convention on page 460. 

10. In the Layer Identification dialog, enter the new layer extension from the naming convention 
for the layer shown. 

11. Click OK. 

The script renames the current layer using the new job name prefix and naming convention 
extension. In the Assigned Names section, the Layer Identification dialog displays a history of the 
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layers that have been renamed during the current session. Then the script displays the next layer in 
the Layer Identification dialog and the CAMMaster viewing area.  

12. If you need to go back to rename a layer that you have already passed, click Previous. 

13. Continue renaming layers until you have processed all the loaded layers. 

When you have processed all the loaded layers, the script displays the Layer Naming Process 
Complete dialog that shows the history of all name changes during the current session. 

 

History of Changes 

14. Review the name changes to be sure all are correct. 

15. If you need to change anything in the list, click Reassign. 

16. When all the layer names are correct on the Layer Naming Process Complete dialog, click 
OK. 

The system displays a dialog that indicates all layer name extensions have been changed and 
reviewed and prompts whether you want to view a layer name text document. The document 
contains the history of all name changes during the current session 



 Chapter 15 Sample Scripts 

 481 

17. To view the text document, click Yes. 
To skip the text document, click No. 

The script creates a directory with the job name. Inside that directory, the script saves the new 
.BIN with the layer name changes and gives that .BIN file the job name prefix. The script also 
saves a text report with a history of the layer name changes in that directory. 

The system displays a dialog indicating that the directory and .BIN file have been saved. 

18. Click OK. 

The script is done.  
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Location Marker Script 

 
The Location.BAS script marks the cursor location and inserts the cursor coordinates as text. This is 
useful for verifying data against fab drawings. You can use the script to mark locations and elements 
on the data that you want to compare to the drawings and then print out or plot the file with the marked 
locations. The script is run from the Macro Tool, so it can demonstrate the usefulness of the Macro 
Tool Feature. 

To Mark a Location with the Location.BAS Script: 
1. On the Macro menu, click Load. 

2. On the Open dialog, navigate to  
C:\Lavenir\CAMMaster 6.0\Sample Scripts\Location.BAS. 

3. Double-click Location.BAS. 

4. On the Macro menu, click Tool. 

5. Position the cursor at the point you want to mark. 

 For precision, use the Align and Go To Coordinate commands when setting the cursor 
position. 

6. Click the mouse or press Enter. 

The Location script inserts a mark at the cursor location and inserts the coordinates of the mark as 
text. 

The Macro Tool remains selected with the Location.BAS macro loaded, so you can mark one 
location after another. 

 

Location Marked in File 
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Padstack Selection Script 

 
The StackSelect.BAS script allows you to select entire padstacks in all visible layers with a mouse 
click, just like you would use the selection tool to select single pads in a single layer. The script 
displays the properties of the selected pads in the stack. Once the stack is selected, it can be copied, 
moved or edited in any other way. The script is run from the Macro Tool, so it can demonstrate the 
usefulness of the Macro Tool Feature. 

To Select a Padstack with the StackSelect.BAS Script: 
1. Begin with all layers that you want to select from active and visible. See Select from the 

Active Layers on page 152. 

2. On the Macro menu, click Load. 

3. On the Open dialog, navigate to  
C:\Lavenir\CAMMaster 6.0\Sample Scripts\StackSelect.BAS. 

4. Double-click StackSelect.BAS. 

5. On the Macro menu, click Tool. 

6. Position the cursor near the padstack that you want to select. 

7. Click the mouse or press Enter. 

The cursor snaps to the nearest pad and selects all flashed pads in the active visible layers within 
.001 inch of the first pad. The script pops up the properties dialog for selected elements to indicate 
what was selected. 

8. To dismiss the properties dialog, click OK. 

The selected padstack can be copied, moved or edited in any other way. 

The Macro Tool remains selected with the StackSelect.BAS macro loaded, so you can select one 
stack after another. 
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Chapter 16 
Key Commands 

To support power users and speed operation, the program has accelerator keys for almost every 
function. The accelerator keys for the new Lavenir line of View Editors for Windows are in many 
cases different than those in the DOS View2001 and View+386 editors.  

New Key Commands Listed by Function 

 
This is a list of all of the new key commands, broken out by function. The table includes the equivalent 
key commands in the old DOS View2001 and View+386 software. 

Selection Commands 
Function New Key Old DOS Key 

Selection Tool S  
Enter for single 
Tab to start area 
Tab again to end 

-- 

Global Selection Shift+V -- 

Select All Data Ctrl+A -- 

Invert Selection Ctrl+I -- 

Clear Selection Ctrl+U -- 

Select Inside/Outside Selection Frame I Alt+I 

Select Any Element Class U -- 

Select Only from Current Layer 0 (Zero) Alt+L 

Select Only Elements of Current D Code Ctrl+D -- 

Set the Current D Code Shift+D Shift+D 

Select Only Elements of Current Net Ctrl+F -- 

Set the Current Net Ctrl+Shift+N -- 

Select Only Pads P P 

Select Only Traces  T T 

View Properties of Selected Elements Alt+Shift+Enter -- 
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Editing Commands 
Function New Key Old DOS Key 

Activate Selected Editing Tool Enter -- 

Turn Off Selected Editing Tool Escape Slash 

Undo Editing Command Ctrl+Z U 

Delete Selected Elements Delete Delete, 
Alt+D, 
Ctrl+D, 
Shift+Delete 

Copy Selected Elements K K, 
Ctrl+K 

Move Selected Elements Shift+M Tab, 
Shift+Tab 

Rotate Selected Elements Ctrl+R Alt+Q 

Mirror Selected Elements Horizontal, Vertical Shift+X, Shift+Y Alt+X, Alt+Y 

Transfer Selected Elements to New layer J J, 
Alt+J, 
Ctrl+J 

Replicate Selected Elements to New layer Ctrl+J Alt+R, 
Ctrl+R 

Step and Repeat Selected Elements Shift+K Alt+K 

Snap Selected Elements to Grid Ctrl+M Alt+M, 
Ctrl+M 

Transcode Selected Elements Ctrl+T Alt+T, 
Ctrl+T 

Insert Element Insert 
Key for element 
Enter to Activate 

Insert 

Insert Rectangular Polygon at Frame Shift+B Shift+B 

Break Traces Ctrl+B 
Enter for Single 
Tab to start area 
Tab again to end 

Ctrl+B 
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Function New Key Old DOS Key 

Stretch Traces Ctrl+Shift+M 
Enter for Single 
Tab to start area 
Tab again to end 

-- 

Convert Drawn Pads to Flashed Ctrl+Shift+P Alt-P 

 

Layer Editing Commands 
Function New Key Old DOS Key 

Align Layers Ctrl+Q Ctrl+Q 

Move Layers Q Q 

Center Layer in other Layers Shift+Q Shift+Q 

Center Layer to Frame Shift+C Shift+C 

Swap Layers Shift+J -- 

 



Lavenir CAM Software User’s Guide 

488 

Layer Commands 
Function New Key Old DOS Key 

Layers Table F10 F10 

Layers Toolbar Ctrl+Shft+L 
Arrow to Layers 
Enter for Visibility 
Space for Menu 
Escape to Exit 

-- 

Make Only Single Layer Active L Alt+L 

Make All Layers Active 0 (Zero) Alt+A 

Make Next Layer Active Equals Equals 

Make Previous Layer Active Backspace -- 

Toggle Single Layer Visibility Shift+L -- 

Toggle Visibility of All Layers Shift+0 (Zero)  -- 

Toggle Visibility of Current Layer Ctrl+Shift+0(Zero) -- 

Make All Layers Visible Ctrl+0 (Zero) -- 

Make Only Next Layer Active and Visible Shift+Equals Shift+O 

Make Only Previous Layer Active and Visible Shift+Backspace Shift+Backspace 

Make Only Single Layer Active and Visible Ctrl+L -- 

Quick Access Active 1-9 1-8 

Quick Access Visible Shift+1-9 -- 

Quick Access Single Layer Active and Visible Ctrl+1-9 -- 

Quick Access Set Color Ctrl+Shift+1-9 -- 
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Reference Frame Commands 
Function New Key Old DOS Key 

Frame Around All Data  Ctrl+W Ctrl+W, 
Shift+W 

Draw New Frame Shift+W 
Enter to activate 

-- 

Move Frame at Same Size W  
Press once to grab 
corner and again to 
release 

0 (Zero) 

Resize Frame Ctrl+Shift+W  
Press once to grab 
corner and again to 
release 

9 

Zoom Commands 
Function New Key Old DOS Key 

Zoom Tool Z 
Enter for Up 
Shift+Enter Down 
Tab to start area 
Tab again to end 

-- 

Zoom Up Page Up Page Up 

Zoom Down Page Down Page Down 

Set Zoom Level Shift+Z Alt+Z 

Zoom on Frame Shift+Home W 

Zoom to Show All Data Home Home 

Zoom to Reference Zoom Level Minus Minus 

Set Reference Zoom Level Shift+Minus Plus 
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Distance Measurement Commands 
Function New Key Old DOS Key 

Distance Measurement D D 

Switch Coordinates between Relative/Absolute R R 

Set Relative Origin Shift+R 
Enter to activate 

R 

Mark Location M M 

Visibility Commands 
Function New Key Old DOS Key 

Pads Switch between Visible/Not Visible Shift+P Shift+P 

Traces Switch between Visible/Not Visible Shift+T Shift+T 

Selected Elements Switch btw. Visible/Not Visible Shift+S Ctrl+I 

Unselected Elements Switch btw. Visible/Not Vis. Shift+U Shift+I 

Trace Width Switch btw Full Width/Centerline O Ctrl+Z 

Pad Outline Switch betw. Full Width/Outline Shift+O -- 

Pad Contrast Switch betw. Same Color/Contrast V Alt+C 

D Code Switch between Blank and Shape Shift+H Shift+H 

Redraw Viewing Area  End Enter 

Redraw Viewing Area at Cursor Shift+End End 
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Go To Commands 
Function New Key Old DOS Key 

Align Cursor to Element A A 

Align Cursor to Element and Query Properties Shift+A S 

Move Cursor Arrow Keys Arrow Keys 

Move Cursor Slowly Shift+Arrows Shift+Arrows 

Pan Screen Ctrl+Arrows Ctrl+Arrows 

Pan to First Screenful Shift+F Shift+F 

Pan to Next Screenful Shift+N Shift+N 

Go To X, Y Coordinate X, Y X, Y 

Go to Origin Ctrl+Home Z 

Go To Center of Data in Frame C C 

Go To Center of Arc Shift+E Shift+E 

Go to Trace Ends E E 

Go To Frame Corner Ctrl+E Alt+W 

Go To Marker H H 

Mark Location M M 

Go To First Element F F 

Go To Next Element N N 

Go To Previous Element B Ctrl+N 

Separate Pointer and Crosshair Spacebar Spacebar 

Grid Commands 
Function New Key Old DOS Key 

Turn Grid On/Off G G 

Switch Grid between Variable and Fixed Ctrl+G Ctrl+G 

Switch Grid between Anchored and Dragged Shift+G Alt+G 
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Setup Commands 
Function New Key Old DOS Key 

Layers Table F10 F10 

D Code Table F5 F5 

Set Current D Code Shift+D Shift+D 

Tool Code Table Shift+F5 Alt+F5 

Set Current Net Ctrl+Shift+N -- 

File Commands 
Function New Key Old DOS Key 

Import Layer Files Ctrl+F2 Ctrl+F2 

Import Gerber F2 F2 

Import Gerber (options only) F3 -- 

New Job File Ctrl+N -- 

Open Job File Ctrl+O -- 

Print Job File Ctrl+P -- 

Save Job File Ctrl+S -- 

Job File Properties Alt+Enter -- 

Help Commands 
Function New Key Old DOS Key 

Help Topics F1 F9 

Context Sensitive Help Shift+F1 -- 

System Commands 
Function New Key Old DOS Key 

Abort Operation Ctrl+Break Ctrl+Break 

Exit Program Alt+F4 Escape 
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DOS Key Commands and Equivalent New Keys 
This is a list of all the old DOS key commands and their equivalent new keys. The equivalent new keys 
are for new functions that are similar to the old DOS functions, but the exact operation of the new 
function may be different than the old function. For Instance, the new command may require you to 
select data before activating the command, or the new command may select an editing tool that you 
need to activate by pressing Enter. The table is sorted alphabetically by the old DOS key command. 

Old DOS Key New Key Function 

0 (Zero) W Move Frame at Same Size 

0 and then 9  Shift+W  
Enter to Activate 

Draw New Frame 

1-8 1-9 Quick Access Make Layer Active 

9 Ctrl+Shift+W Resize Frame 

A A Align Cursor to Element 

Alt+A 0 (Zero) Make all Layers Active 

Ctrl+A -- Arc Insertion Direction 

Arrow Key Arrow Key Move Cursor 

Ctrl+Arrow Key Ctrl+Arrow Key Pan Screen 

Shift+Arrow Key Shift+Arrow Key Move Cursor Slowly 

Asterisk (Shift+8) -- Toggle Cursor Resolution for Arrow Keys 

B -- Toggle Blinking Cursor 

Alt+B -- Program Mouse Buttons 

Ctrl+B Ctrl+B Break Trace 

Shift+B Shift+B Insert Rectangular Polygon 

Shift+Backspace Shift+Backspace Make Only Previous Layer Active and Visible 

Ctrl+Break Ctrl+Break Abort Operation 

C C Go To Center 

Alt+C V Toggle Pad Contrast 

Ctrl+C -- Toggle Full-Screen Cursor 

Shift+C Shift+C Center Layer to Frame 

D D Distance Measurement 
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Old DOS Key New Key Function 

Alt+D Delete Delete Group 

Ctrl+D Delete Delete Group 

Shift+D Shift+D Set Current D Code 

Delete Delete Delete Element 

Shift+Delete Delete Delete Group 

E E Go to Trace Ends 

Alt+E -- Draw Polygon from Chain of Traces 

Ctrl+E -- Draw Polygon from Chain of Traces 

Shift+E Shift+E Go To Center of Arc 

End Shift+End Redraw Graphics at Cursor 

Enter End Redraw Graphics  

Ctrl+Enter -- Start DOS Shell 

Equals Equals Make Next Layer Active 

Escape Alt+F4 Exit Program 

F F Go To First Element 

Shift+F Shift+F Pan to First Screenful 

F10 F10 Layers Menu 

F12 Enter Simulate Left Mouse Click 

Shift+F12 -- Simulate Right Mouse Click 

F2 F2 Import File 

Alt+F2 -- Import Environment 

Ctrl+F2 Ctrl+F2 Import Layers 

F4 -- Clear and Load File 

Alt+F4 -- Clear 

Ctrl+F4 -- Clear and Load Layers 

F5 F5 D Code Table 

Alt+F5 Shift+F5 Tool Code Table 

F7 -- Design Rule Check 
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Old DOS Key New Key Function 

F9 F1 Help 

G G Toggle Grid On/Off 

Alt+G Shift+G Toggle Grid Anchored/Dragged 

Ctrl+G Ctrl+G Toggle Grid Variable/Fixed 

H H Go To Marker 

Alt+H S Highlight Group 

Ctrl+H S Highlight Group 

Shift+H Shift+H Blank/Unblank D Code 

Home Home Zoom to show all data 

Alt+I I Toggle Inside/Outside Frame Selection 

Ctrl+I Shift+S Toggle Visibility of Highlighted Elements 

Shift+I Shift+U Toggle Visibility Highlighted Elements 

Ctrl+Ins -- Insert Rectangular Pad 

Insert Insert Insert Element 

J J Transfer  

Alt+J J Transfer Group 

Ctrl+J J Transfer Group 

Shift+J -- Set Destination Layer 

K K Copy Element 

Alt+K Shift+K Step and Repeat 

Ctrl+K K Copy Group 

L -- Text Entry 

Alt+L L Make Layer Active 

Ctrl+L -- Text Entry with New Parameters 

Shift+L -- Text Entry at Window Size 

M M Mark Location 

Alt+M Ctrl+M Snap Group to Grid 

Ctrl+M Ctrl+M Snap Group to Grid 
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Old DOS Key New Key Function 

Minus Minus Zoom to Reference Zoom 

Alt+Minus -- Transfer Chain 

Ctrl+Minus -- Transfer Chain 

N N Go To Next Element 

Alt+N -- Highlight Net 

Ctrl+N B Go To Previous Element 

Shift+N Shift+N Pan to Next Screenful 

Alt+O -- Toggle Constrain/Redraw Cursor 

Ctrl+O -- Toggle Visibility of Active Layer 

Shift+O Shift+Equals Make Only Next Layer Active/Visible 

P P Pad Editing Mode 

Shift+P Shift+P Toggle Visibility of Pads 

Page Down Page Down Zoom Down 

Page Up Page Up Zoom Up 

Plus Shift+Minus Set Reference Zoom Level 

Q Q Move Layers 

Alt+Q Ctrl+R Rotate Elements 

Ctrl+Q Ctrl+Q Align Layers 

Shift+Q Shift+Q Center Layer in other Layers 

R R, 
Shift+R 

Toggle Relative/Absolute Coordinate and 
Set Relative Origin 

Alt+R Ctrl+J Replicate Group 

Ctrl+R Ctrl+J Replicate Group 

Shift+R -- Swap Group 

S Shift+A Select Nearest Element and 
Query Nearest Element Properties 

Alt+S -- Scale Elements 

Ctrl+S S Highlight Nearest Element 

Shift+S -- Unhighlight Nearest Element 
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Old DOS Key New Key Function 

Slash Escape Turn Trace insert off 

Spacebar Spacebar Separate Pointer and Crosshair Cursor 

T T Trace Editing Mode 

Alt+T Ctrl+T Transcode Current D Code 

Ctrl+T Ctrl+T Transcode Element 

Shift+T Shift+T Toggle Trace Visibility 

Tab Shift+M Move Element 

Shift+Tab Shift+M Move Group 

U Ctrl+Z Undo 

Alt+U -- Unhighlight Group 

Ctrl+U -- Unhighlight Group 

V -- Transfer Traces of Special Types 

Alt+V -- Show D Code Values 

Ctrl+V -- Select D Code by Size 

W Shift+Home Zoom on Frame 

Alt+W Ctrl+E Go To Frame Corner 

Ctrl+W Ctrl+W Insert Frame Around Data 

Shift+W Ctrl+W Insert Frame Around Data with Margin 

X X Go To X 

Alt+X Shift+X Mirror Horizontal 

Y Y Go To Y 

Alt+Y Shift+Y Mirror Vertical 

Z Ctrl+Home Go to Origin 

Alt+Z Shift+Z Set Zoom Level 

Ctrl+Z O Toggle Display of Traces at Zero Width 
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Why Did Lavenir Change the Key Commands? 
The key commands in the new Lavenir line of View Editors for Windows are different than those in 
the old DOS View+386 and View2001 editors. The key commands needed to change for several 
reasons: 

• In Windows, some key combinations are reserved for special Windows functions. For 
instance the Alt key is reserved for accessing the menus from the keyboard. This eliminated 
many of the key commands that were used in the DOS software. 

• In Windows, some key commands are standardized for certain operations. For instance, 
Ctrl+S for Save file, Ctrl+N for New file, Ctrl+P for Print, and Ctrl+Z for Undo. The desire to 
support the standards of the platform eliminated a number of other key commands that were 
used in the DOS software. 

• The new selection method does away with some of the redundancy of key commands required 
for similar operations. For instance the old J, Ctrl+J, Alt+J commands are now all handled by 
one command, J, which transfers selected elements. Fortunately, the new selection system 
freed up a wealth of key combinations that we were able to use for the old commands 
displaced by the needs of Windows. 

• Because of the need to change so many commands we took the opportunity to rethink some 
combinations to make more sense. For instance the old visibility commands Shift+P, Shift+T, 
Ctrl+I, Shift+I are now Shift+P, Shift+T, Shift+S, Shift+U for Pad, Trace, Selected, 
Unselected. 

These changes are not going to be popular with established users of the Lavenir DOS editors that are 
trying to adapt to the new Windows products. Nobody likes change, especially when they have work to 
do. But considering the changes required to bring the old features to the new platform, there really was 
very little choice. Established users will find that the new accelerator key list is as usable as the old. 
We tried to keep as much the same as was possible, and gave the rest a lot of thought.  
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Index 
 

A 

Absolute Origin 
Absolute Origin, 95 
Distance Measurement and Coordinate System Overview, 93 

Active Layer 
Active Layer on Layer Toolbar, 350 
Select by Active Layer, 152 

Add to a Selection, 161 
Address 

Lavenir Technical Support, 19 
Send Us Your Comments, 18 

Align 
Align Cursor to Element, 102 
Align Layers, 167 
Query Element Properties, 103 

All Data 
Select All Data, 158 
Zoom To Show All Data, 91 

Anchored or Dragged Grid, 108 
Aperture File 

D Code Table Overview, 313 
Export Aperture Data from the Job, 79 
Import an Aperture List into the Job, 43 
Import Aperture Information into the Job Overview, 43 
Import Basic Gerber into the Job Using a .ENV File, 36 
Merge Aperture Information into Job, 34 
Use the Aperture File Wizard, 45 
VIEW Environment Files (.ENV), 79 

Append 
Append Files to Gerber Extended Headers, 68 
Append Files to MDA Autoplot Headers, 72 

Arc 
Convert 360-Degree Arcs into Quadrants, 185 
Convert Arcs to Chords, 183 
Go To Arc Center, 104 
Insert 3-Point Arc, 125 
Insert Center and Chord Arc, 128 
Insert Chord and Point Arc, 127 
Insert Chord and Tangent Arc, 126 
Insert Circular Arc, 124 
Select by Special Class of Element, 155 
Set Arc Direction - Clockwise/Counterclockwise, 129 

Array 
Select and Edit Entire Array of a Coded Step and Repeat 

Block, 160 
Step and Repeat Selected Elements, 144 
Step and Repeat Selected Elements, Overview, 143 

Autoblob, Consolidate Soldermask Data, 308 
Automation 

AutoPanel Script Overview, 455 
Browse the CAMMaster Automation Object Library, 454 

CAMMaster Automation Object Library, 452 
Drag and Drop a Macro into the System, 443 
Edit a Macro, 446 
Load a Macro, 444 
Load and Run a Macro, 443 
Location Marker Script, 482 
Macro Toolbar, 441 
Naming Convention Script, 477 
Padstack Selection Script, 483 
Pause Macro Recording, 442 
Property Strings, 453 
Record a Macro, 442 
Run a Macro, 445 
Save a Macro, 446 
Sax Basic Editor, 447 
Sax Basic Language, 448 
Scripting, Overview, 441 
Stop a Macro, 445 
Unload a Macro, 444 
Use a CAMMaster Automation Object in a Script, 452 
What is in Sax Basic but not in VBA, 450 
What is in VBA but not in Sax Basic, 448 

AutoPanel Script Overview, 455 

B 

BIN File 
Close a Job File, 26 
Import a Job File, 27 
Job File Overview, 21 
Open a Job File, 22 
Revert to a Saved Job File, 26 
Save a Copy of a Job File, 25 
Save a New Unnamed Job File, 23 
Save Work in Progress, 24 
Start a New Job, 22 

Blank D Code Type B 
Blank D Code Type B Command, 86 
Blank D Code Type B on D Code Table, 322 

Board Layer 
Board Layer on Layers Table, 351 
Board Layer on Layers Toolbar, 351 
Board Layer, Overview, 351 
Raster Netlist Board Layer Stacking Examples, 418 

Break 
Clip Traces, 172 
Clip Traces and Replace with a Pad, 173 

B-Type Blank D Code 
Blank D Code Type B Command, 86 
Blank D Code Type B on D Code Table, 322 

C 

CAMMaster Overview, 16 
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Capture Custom Aperture, 334 
Center 

Center Layer to Layers, 167 
Center Layers to Frame, 168 
Center Selected Elements to the Frame, 134 
Center View on Cursor, 100 
Go To Arc Center, 104 
Pan Screen to Center, 99 

Centerline, View Zero-Width Elements, 87 
Centroid Data 

Generating Centroid Data Overview, 280 
Preparing a Componenet Footprint File, 280 
Running the Centroid Data Operation, 284 
Viewing and Editing a Centroid Report File, 287 

Chain, Select a Chain of Traces, 159 
Chord 

Convert Arcs to Chords, 184 
Insert Center and Chord Arc, 128 
Insert Chord and Point Arc, 127 
Insert Chord and Tangent Arc, 126 

Circle D Code Type C, 315 
Circular Arc, Insert Circular Arc, 124 
Clear the Selection, 163 
Clip 

Clip Traces, 172 
Clip Traces and Replace with a Pad, 173 
Clipping Silkscreen Traces for Padmaster Clearance, 253 

Close a Job File, 26 
Color 

Layer Color on Layer Toolbar, 361 
Layer Color on Layers Table Overview, 357 
Layer Color Overview, 357 

Combine Files 
Combine Paint & Scratch and Positive & Negative Layers in 

Extended Gerber, 67 
Combine Paint & Scratch and Positive & Negative Layers in 

MDA Autoplot, 71 
Export Basic Gerber Combined Files, 64 
Export Drill Data Combined Files, 78 
Export Gerber Extended Combined Files, 67 
Export MDA Autoplot Combined Files, 71 

Comments, Send Us Your Comments, 18 
Compare 

Inspect Netlist Comparison Discrepancies, 294 
Lavenir CAM Software Feature Comparison, 11 
Make Net Numbers in the NUT Match Net Numbers in the 

REF, 296 
Netlist Comparison, Overview, 291 
Prepare Data for Netlist Comparison, 291 
Run the Netlist Comparison, 292 

Compare Layers 
Inspecting the Layer Differences, 290 
Overview of Layer Comparison, 288 
Running the Layer Comparison, 288 

Consolidate Soldermask Data, 308 
Contour, Generate Contour Polygon from Exisitng Trace 

Contours, 303 

Contrast 
Pad and Trace Contrast, 87 
View Selected Elements in White or Contrasting Color, 86 

Conventions Used in this User's Guide, 20 
Convert 

Convert 360-Degree Arcs into Quadrants, 185 
Convert Aperture File Using the Aperture File Wizard, 45 
Convert Arcs to Chords, 183 
Convert Coded Step and Repeat Blocks to Copied Step and 

Repeat Data, 146 
Convert Drawn Pads, Overview, 227 
Convert Elements of Custom Aperture D Codes to 

Primitives, 340 
Convert Libraries of Shapes, 232 
Convert Netlist Format, 57 
Convert Single Drawn Pads, 227 

Coordinates 
Absolute Origin, 95 
Distance Measurement and Coordinate System Overview, 93 
Go To Coordinates, 101 
Go To Marked Position, 106 
Mark a Location, 106 
Measure Distance, 93 
Polar Coordinates, 94 
Rectangular Coordinates, 94 
Relative Origin, 95 
Set Relative Origin, 96 

Copper Area 
Calculating Copper Area, 242 
Copper Area Calculation, Overview, 242 
Viewing a Copper Area Report, 244 

Copper Pouring 
Defining the Polygon Areas for Filling, 186 
Drawing Fill Polygons with Traces, 187 
Filling Around Pads and Traces, 193 
Filling Inside Elements, 202 
Generating a Crosshatched Fill, 198 
Generating a Hatched Fill, 196 
Generating a Solid Fill, 194 
Generating Outlines Only with the Fill Feature, 200 
Nested Polygons for Filling, 186 
Polygon Filling, Overview, 186 
Selecting the Layers for the Fill Operation, 190 
Setting the General Fill Options, 191 
Setting the Polygon Options for the Fill Operation, 188 
Using the Reference Frame as a Boundary for a Fill, 186 

Copy Selected Elements, 134 
Corner, Go To Reference Frame Corners, 105 
Counts 

Layer Element Counts on Layers Table, 368 
Number of Occurrences of each Tool Code in the Loaded 

Data, 342 
Crosshair 

Full-Screen Cursor, 112 
Separate the Crosshair and Mouse Cursor, 112 

Crosshair D Code Type Y, 322 
Crosshatch 
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Generating a Crosshatch Venting Pattern, 224 
Generating a Crosshatched Fill, 198 

C-Type Circle/Round D Code, 315 
Current D Code, 314 
Current Element Toolbar, 151 
Cursor 

Align Cursor to Element, 102 
Center View on Cursor, 100 
Full-Screen Cursor, 112 
Separate the Crosshair and Mouse Cursor, 112 

Custom Aperture 
Capture a Custom Aperture, 334 
Convert Elements of Custom Aperture D Codes to 

Primitives, 340 
Custom Aperture D Code Type M, Description, 317 
Custom Aperture D Code Type M, Overview, 334 
Export a Custom Aperture File, 336 
If You See an M in a Square in the Viewing Area, 340 
Import a Custom Aperture File into the D Code Table, 338 
Recreate Primitives Used in a Custom Aperture, 339 

D 

D Code 
Blank D Code Type B Command, 86 
Blank D Code Type B on D Code Table, 322 
B-Type Blank D Code Command, 86 
B-Type Blank D Code on D Code Table, 322 
Capture a Custom Aperture, 334 
Change D Code Dimensions on the D Code Table, 325 
Change D Code Shapes on the D Code Table, 325 
Circle D Code Type C, 315 
Convert Elements of Custom Aperture D Codes to 

Primitives, 340 
Crosshair D Code Type Y, 322 
C-Type Circle/Round D Code, 315 
Current D Code, 314 
Custom Aperture D Code Type M, Description, 317 
Custom Aperture D Code Type M, Overview, 334 
D Code Shape and Dimension Descriptions, 315 
D Code Table Overview, 313 
Delete D Code on the D Code Table, 327 
Diamond D Code Type D, 315 
Drawn Crosshair D Code Type Y, 322 
Drawn Obround D Code Type X, 321 
Drill Hole D Code Type N, 318 
D-Type Diamond D Code, 315 
E-Type Octagon D Code, 315 
Export a Custom Aperture File, 336 
F-Type Polygon Trace D Code, 316 
Grow D Code on the D Code Table, 331 
Heat Relief D Code Type H, 316 
H-Type Thermal/Heat Relief D Code, 316 
If You See an M in a Square in the Viewing Area, 340 
Import a Custom Aperture File into the D Code Table, 338 
Insert D Code on the D Code Table, 326 
Invert the Selected D Codes on the D Code Table, 324 

M-Type Custom Aperture D Code, Description, 317 
M-Type Custom Aperture D Code, Overview, 334 
NC Drill Hole D Code Type N, 318 
N-Type NC Drill Hole D Code, 318 
Obround D Code Type O, 318 
Octagon D Code Type E, 315 
O-Type Obround D Code, 318 
Polygon Trace D Code Type F, 316 
Q-Type Rounded Rectangle D Code, 319 
Query Element Properties, 103 
Recreate Primitives Used in a Custom Aperture, 339 
Rectangle D Code Type R, 319 
Rotate D Codes on the D Code Table 90 Degrees, 329 
Rotate D Codes on the D Code Table, Overview, 329 
Round D Code Type C, 315 
Round Off D Code Dimensions on the D Code Table, 333 
Rounded Rectangle D Code Type Q, 319 
R-Type Rectangle D Code, 319 
Scale D Code Area on the D Code Table, 333 
Scale D Code Dimensions on the D Code Table, 332 
Select All D Codes on the D Code Table, 323 
Select by Current D Code, 153 
Select D Codes by Size, Largest Shape D Code on the D 

Code Table, 324 
Select D Codes by Size, Next Larger Shape D Code on the D 

Code Table, 324 
Select D Codes by Size, Next Smaller Shape D Code on the 

D Code Table, 324 
Select D Codes by Size, Smallest Shape D Code on the D 

Code Table, 324 
Select D Codes of the Same Shape on the D Code Table, 323 
Select D Codes on the D Code Table Manually, 323 
Select D Codes on the D Code Table, Overview, 323 
Select Used D Codes on the D Code Table, 323 
Set Up Tool Codes In the D Code Table, 345 
Square D Code Type S, 319 
S-Type Square D Code, 319 
Swell D Code on the D Code Table, 330 
Target D Code Type T, 320 
Thermal D Code Type H, 316 
Transcode D Codes on the D Code Table, Overview, 327 
Transcode Elements of the Selected D Code on the D Code 

Table, 327 
Transcode Selected Elements, 141 
Transcode to Unique Shapes on the D Code Table, 328 
T-Type Target D Code, 320 
Undefined D Code Type ?, 320 
View Selected Element D Code Properties, 110 
X-Type Drawn Obround D Code, 321 
Y-Type Drawn Crosshair D Code, 322 

Delete 
Delete D Code on the D Code Table, 327 
Delete Layers Command, 171 
Delete Layers on the Layers Table, 371 
Delete Layers on the Layers Toolbar, 371 
Delete Selected Elements, 133 
Deleting Non-Functional Pads, 245 
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Diameter 
Change Tool Type and Tool Diameter on the Tool Table, 

343 
Tool Diameter, 342 

Diamond D Code Type D, 315 
Directory 

Browse the Directories for File Names on Layers Table, 352 
Set Current Directory, 81 
Toggle Display of the Path Portion of the Layer Name on 

Layers Table, 353 
Distance 

Absolute Origin, 95 
Distance Measurement and Coordinate System Overview, 93 
Go To Marked Position, 106 
Mark a Location, 106 
Measure Distance, 93 
Polar Coordinates, 94 
Rectangular Coordinates, 94 
Relative Origin, 95 
Set Relative Origin, 96 

Distance Histogram 
Distance Histogram Overview, 409 
Generating the Distance Histogram Report, 409 

Dot, Generating a Pad Venting Pattern, 211 
Download Software Updates, 18 
Drag and Drop a Macro into the System, 443 
Drag, Anchored or Dragged Grid, 108 
Drag-and-Drop File Import, 28 
Drawn Crosshair D Code Type Y, 322 
Drawn Obround D Code Type X, 321 
Drawn Pads 

Consolidate Soldermask Data, 308 
Convert Drawn Pads, Overview, 227 
Convert Libraries of Shapes, 232 
Convert Single Drawn Pads, 227 
Import Library Parameter Files, 241 
Import Shape Files, 239 
Save Library Parameter Files, 240 
Save Shape Files, 238 
Shape Files, Overview, 238 

DRC 
Design Rule Checking Routines Overview, 385 
Distance Histogram Overview, 409 
Generating the Distance Histogram Report, 409 
Preparing Plot Data for the Raster Design Rule Check, 387 
Preparing Plot Data for the Vector Design Rule Check, 399 
Raster Design Rule Checking, Overview, 386 
Raster DRC Advantages, 386 
Raster vs. Vector DRC Error Inspection Method, 385 
Raster vs. Vector DRC Technique, 385 
Removing Vector Design Rule Check Errors Flags from the 

Plot, 408 
Running the Raster Design Rule Check, 389 
Running the Vector Design Rule Check, 401 
Vector Design Rule Checking Overview, 399 
Vector DRC Advantages, 386 
View the Design Rule Check Error Report, 412 

View Vector Design Rule Check Errors on Screen, 407 
Viewing Raster DRC Errors on Screen, 396 

Drill Data 
Change Tool Type and Tool Diameter on the Tool Table, 

343 
Drill Data Format Options, Export, 75 
Drill Data Format Options, Import, 41 
Drill Export Options, 77 
Drill Hole D Code Type N, 318 
Excellon Drilled Slot Pattern, 78 
Export Drill Data from the Job Overview, 73 
Import Drill Data into the Job, 40 
Number of Occurrences of each Tool Code in the Loaded 

Data, 342 
Select Tool Codes, 343 
Set Up Tool Codes In the D Code Table, 345 
Sort the Tool Code Table, 344 
Tool Code Table Overview, 341 
Tool Diameter, 342 
Tool Type, 342 
View Selected Element Drill Properties, 111 

D-Type Diamond D Code, 315 

E 

Edit 
Align Layers, 167 
Break Traces, 172 
Break Traces and Replace with a Pad, 173 
Center Layer to Layers, 167 
Center Layers to Frame, 168 
Center Selected Elements to the Frame, 134 
Change Step and Repeat Parameters of a Coded Step and 

Repeat Block, 147 
Clip Traces, 172 
Clip Traces and Replace with a Pad, 173 
Copy Selected Elements, 134 
Current Element Toolbar, 151 
Delete Layers Command, 171 
Delete Layers on the Layers Table, 371 
Delete Layers on the Layers Toolbar, 371 
Delete Selected Elements, 133 
Differences Between Coded Step and Repeat and Copied 

Step and Repeat, 143 
Edit a Macro, 446 
Edit Entire Layers, Overview, 164 
Edit Plot Data, Overview, 115 
Edit Selected Data, Overview, 132 
Edit Toolbar, 132 
Flip Selected Elements, 137 
Insert 3-Point Arc, 125 
Insert 90-Degree Elbow in Existing Trace, 121 
Insert 90-Degree Trace Pair, 119 
Insert Center and Chord Arc, 128 
Insert Chord and Point Arc, 127 
Insert Chord and Tangent Arc, 126 
Insert Circular Arc, 124 
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Insert Drawn Rectangle, 122 
Insert Elbow in Existing Trace, 120 
Insert Frame-Sized Pad, 123 
Insert Frame-Sized Rectangular Polygon, 123 
Insert Orthogonal Trace, 118 
Insert Pad, 116 
Insert Text, 130 
Insert Toolbar, 115 
Insert Trace, 117 
Memory Allocated for the Undo Feature, 176 
Mirror Selected Elements, 137 
Move Active Layers, 164 
Move Chosen Layers, 165 
Move Layers by Displacement, 166 
Move Selected Elements, 133 
Replicate Layers Command, 170 
Replicate Layers on the Layers Table, 372 
Replicate Layers on the Layers Toolbar, 373 
Replicate Selected Elements, 136 
Rotate Selected Elements, 138 
Scale Selected Elements, 140 
Select and Edit Entire Array of a Coded Step and Repeat 

Block, 160 
Select and Edit One-Up Image of a Coded Step and Repeat 

Block, 149 
Select Elements for Editing Overview, 150 
Selection Toolbar, 150 
Set Arc Direction - Clockwise/Counterclockwise, 129 
Snap Selected Elements to the Grid, 142 
Step and Repeat Selected Elements, 145 
Stretch Traces, 174 
Swap Layers Command, 171 
Swap Layers on the Layers Table, 376 
Swap Layers on the Layers Toolbar, 377 
Transcode Selected Elements, 141 
Transfer Layers Command, 169 
Transfer Layers on the Layers Table, 374 
Transfer Layers on the Layers Toolbar, 375 
Transfer Selected Elements, 135 
Undo an Editing Action, 176 

Elbow 
Insert 90-Degree Elbow in Existing Trace, 121 
Insert Elbow in Existing Trace, 120 

E-Mail 
Lavenir Technical Support, 19 
Send Us Your Comments, 18 

Endpoint, Go To Endpoint of Trace, 104 
ENV File 

Import Basic Gerber into the Job Using a .ENV File, 36 
VIEW Environment Files (.ENV), 79 

E-Type Octagon D Code, 315 
Excellon Drilled Slot Pattern, 78 
Export 

Append Files to Gerber Extended Headers, 68 
Append Files to MDA Autoplot Headers, 72 
Combine Paint & Scratch and Positive & Negative Layers in 

Extended Gerber, 67 

Combine Paint & Scratch and Positive & Negative Layers in 
MDA Autoplot, 71 

Drill Export Options, 77 
Export a Custom Aperture File, 336 
Export Aperture Data from the Job, 79 
Export Basic Gerber Combined Files, 64 
Export Basic Gerber from the Job, 63 
Export Basic Gerber Layer-by-Layer Files, 64 
Export Drill Data Combined Files, 78 
Export Drill Data from the Job Overview, 73 
Export Drill Data Layer-by-Layer Files, 77 
Export Gerber Extended Combined Files, 67 
Export Gerber Extended from the Job, 64 
Export Gerber Extended Layer-by-Layer Files, 67 
Export Gerber Files from the Job, Overview, 59 
Export MDA Autoplot Combined Files, 71 
Export MDA Autoplot from the Job, 68 
Export MDA Autoplot Layer-by-Layer Files, 71 
Export Raster Netlist Files, 80 
Gerber Export Fields Options, 60 
Gerber Export Fields Options, Gerber Extended, 66 
MDA Export Options, 70 
Photoplotting Multiple Layers on a Single Piece of Film, 72 
Set Current Directory, 81 

F 

Feedback, Send Us Your Comments, 18 
File Handling Overview, 21 
Fill 

Defining the Polygon Areas for Filling, 186 
Defining the Polygon Areas for Venting, 204 
Drawing Fill Polygons with Traces, 187 
Drawing Venting Polygons with Traces, 204 
Filling Around Pads and Traces, 193 
Filling Inside Elements, 202 
Generating a Crosshatch Venting Pattern, 224 
Generating a Crosshatched Fill, 198 
Generating a Hatch Venting Pattern, 221 
Generating a Hatched Fill, 196 
Generating a Negative VPI Venting Pattern, 215 
Generating a Pad Venting Pattern, 211 
Generating a Positive VPI Venting Pattern, 213 
Generating a Solid Fill, 194 
Generating a Solid Venting Pattern, 219 
Generating a Starburst Venting Pattern, 217 
Generating Outlines Only with the Fill Feature, 200 
Nested Polygons for Filling, 186 
Nested Polygons for Venting, 204 
Polygon Filling, Overview, 186 
Selecting the Layers for the Fill Operation, 190 
Selecting the Layers for the Venting Operation, 208 
Setting the General Fill Options, 191 
Setting the Polygon Options for the Fill Operation, 188 
Setting the Polygon Options for the Venting Operation, 206 
Using the Reference Frame as a Boundary for a Fill, 186 
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Using the Reference Frame as a Boundary for a Venting 
Area, 204 

Venting Around Pads and Traces, 210 
Venting Pattern, Overview, 204 

Fill Layer on Layers Table, 368 
Filleting 

Generate Pad Filleting, 270 
Snowman Fillet Options, 274 
Teardrop Fillet Options, 279 

First, Pan Screen to First Screenful, 99 
Fixed or Variable Grid, 109 
Flip Selected Elements, 137 
Folder 

Browse the Directories for File Names on Layers Table, 352 
Set Current Directory, 81 
Toggle Display of the Path Portion of the Layer Name on 

Layers Table, 353 
Frame 

Center Layers to Frame, 168 
Center Selected Elements to the Frame, 134 
Draw a New Reference Frame, 177 
Go To Reference Frame Corners, 105 
Insert a Reference Frame Around All Data, 180 
Insert a Reference Frame Around Workspace, 179 
Insert Frame-Sized Pad, 123 
Insert Frame-Sized Rectangular Polygon, 123 
Move a Reference Frame, 181 
Reference Frame Overview, 177 
Resize a Reference Frame, 181 
Set Exact Reference Frame Corners, 178 
Zoom On Reference Frame, 92 

F-Type Polygon Trace D Code, 316 
Full-Screen Cursor, 112 

G 

Gerber Data 
Append Files to Gerber Extended Headers, 68 
Combine Paint & Scratch and Positive & Negative Layers in 

Extended Gerber, 67 
Export Basic Gerber from the Job, 63 
Export Gerber Extended from the Job, 64 
Export Gerber Files from the Job, Overview, 59 
Export MDA Autoplot from the Job, 68 
Gerber Auto Features, 33 
Gerber Data Format Options, Export, 61 
Gerber Data Format Options, Import, 29 
Gerber Export Fields Options, 60 
Gerber Extended Export Options, Gerber Extended, 66 
Gerber File Interpretation Options, 31 
Import Basic Gerber Files into the Job, 35 
Import Basic Gerber into the Job Using a .ENV File, 36 
Import Gerber Directly into the Layers Table, 37 
Import Gerber Extended and MDA Autoplot into the Job, 39 
Import Gerber Files into the Job, Overview, 29 
Set the Gerber Import Options without Importing, 38 
Vector Netlist Gerber Reference Plot (.GNT), 428 

Vector Netlist Short Circuit Gerber Plot (.VGD), 428 
View the Vector Netlist Gerber Reference Plot, 439 

Global, Select Globally from the Entire Database, 158 
Go To 

Align Cursor to Element, 102 
Go To Arc Center, 104 
Go To Coordinates, 101 
Go To Endpoint of Trace, 104 
Go To Marked Position, 106 
Go To Reference Frame Corners, 105 

Grid 
Anchored or Dragged Grid, 108 
Fixed or Variable Grid, 109 
Grid Units, 109 
Screen Grid Overview, 107 
Snap Selected Elements to the Grid, 142 
Turn the Screen Grid On and Off, 107 

Ground Planes, Vector Netlist Split Plane Error Report (.SPT), 
428 

Grow D Code on the D Code Table, 331 

H 

Hatch 
Generating a Hatch Venting Pattern, 221 
Generating a Hatched Fill, 196 

Header 
Append Files to Gerber Extended Headers, 68 
Append Files to MDA Autoplot Headers, 72 

Heat Relief D Code Type H, 316 
Highlight 

Add to a Selection, 161 
Clear the Selection, 163 
Invert the Selection, 163 
Remove from a Selection, 162 
Select a Chain of Traces, 159 
Select a Group of Elements, 157 
Select a Single Element, 156 
Select All Data, 158 
Select and Edit Entire Array of a Coded Step and Repeat 

Block, 160 
Select by Active Layer, 152 
Select by Current D Code, 153 
Select by Current Net, 154 
Select by Special Class of Element, 155 
Select Elements for Editing Overview, 150 
Select Globally from the Entire Database, 158 

Histogram 
Distance Histogram Overview, 409 
Generating the Distance Histogram Report, 409 

Home, Zoom To Show All Data, 91 
Hotkeys 

Accelerator Keys Overview, 485 
DOS Key Commands and Equivalent New Keys, 493 
New Key Commands Listed by Function, 485 
Why Did Lavenir Change the Key Commands?, 498 

HPGL 
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Import HPGL into the Job, 54 
H-Type Thermal/Heat Relief D Code, 316 

I 
Icons Used in this User's Guide, 20 
Import 

Convert Netlist Format, 57 
Drag-and-Drop File Import, 28 
Gerber Auto Features, 33 
Gerber Data Format Options, 29 
Gerber File Interpretation Options, 31 
Import a Custom Aperture File into the D Code Table, 338 
Import a Job File, 27 
Import an Aperture List into the Job, 43 
Import Aperture Information into the Job Overview, 43 
Import Basic Gerber Files into the Job, 35 
Import Basic Gerber into the Job Using a .ENV File, 36 
Import Drawn Pads Library Parameter Files, 241 
Import Drill Data into the Job, 40 
Import Gerber Directly into the Layers Table, 37 
Import Gerber Extended and MDA Autoplot into the Job, 39 
Import Gerber Files into the Job, Overview, 29 
Import HPGL into the Job, 54 
Import Netlist Data into the Job, 55 
Import Shape Files, 239 
Merge Aperture Information into Job, 34 
Set Current Directory, 81 
Set the Gerber Import Options without Importing, 38 
Use the Aperture File Wizard, 45 

In-Circuit Thieving, Venting Around Pads and Traces, 210 
Insert 

Insert 3-Point Arc, 125 
Insert 90-Degree Elbow in Existing Trace, 121 
Insert 90-Degree Trace Pair, 119 
Insert Center and Chord Arc, 128 
Insert Chord and Point Arc, 127 
Insert Chord and Tangent Arc, 126 
Insert Circular Arc, 124 
Insert D Code on the D Code Table, 326 
Insert Drawn Rectangle, 122 
Insert Elbow in Existing Trace, 120 
Insert Frame-Sized Pad, 123 
Insert Frame-Sized Rectangular Polygon, 123 
Insert Orthogonal Trace, 118 
Insert Pad, 116 
Insert Text, 130 
Insert Toolbar, 115 
Insert Trace, 117 

Inside Fill, Filling Inside Elements, 202 
Interval, Grid Units, 109 
Invert the Selection, 163 

J 

Job File 

Close a Job File, 26 
Import a Job File, 27 
Job File Overview, 21 
Open a Job File, 22 
Revert to a Saved Job File, 26 
Save a Copy of a Job File, 25 
Save a New Unnamed Job File, 23 
Save Work in Progress, 24 
Start a New Job, 22 

K 

Key Commands 
Accelerator Keys Overview, 485 
DOS Key Commands and Equivalent New Keys, 493 
New Key Commands Listed by Function, 485 
Why Did Lavenir Change the Key Commands?, 498 

L 

Lavenir 
Download Software Updates, 18 
Lavenir Technical Support, 19 
Send Us Your Comments, 18 

Lavenir Format 
Convert Netlist Format, 57 
Lavenir Format 0 Netlist (.F00), 427 
Lavenir Format 1 Netlist (.F01), 427 
Lavenir Format 2 Netlist (.F02), 427 
Lavenir Format 3 Netlist (.F03), 427 
Lavenir Format 4 Netlist (.F04), 427 
VIEW Environment Files (.ENV), 79 

Layer 
Active Layer on Layer Toolbar, 350 
Align Layers, 167 
Board Layer on Layers Table, 351 
Board Layer on Layers Toolbar, 351 
Board Layer, Overview, 351 
Browse the Directories for File Names on Layers Table, 352 
Center Layer to Layers, 167 
Center Layers to Frame, 168 
Combine Paint & Scratch and Positive & Negative Layers in 

Extended Gerber, 67 
Combine Paint & Scratch and Positive & Negative Layers in 

MDA Autoplot, 71 
Compare Layers, 288 
Delete Layers Command, 171 
Delete Layers on the Layers Table, 371 
Delete Layers on the Layers Toolbar, 371 
Edit Entire Layers, Overview, 164 
Enter a New Layer Name on Layers Table, 352 
Export Basic Gerber Layer-by-Layer Files, 64 
Export Drill Data Layer-by-Layer Files, 77 
Export Gerber Extended Layer-by-Layer Files, 67 
Export MDA Autoplot Layer-by-Layer Files, 71 
Fill Layer on Layers Table, 368 
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Import Gerber Directly into the Layers Table, 37 
Invert Selected Layers on the Layers Table, 370 
Layer Color on Layer Toolbar, 361 
Layer Color on Layers Table Overview, 357 
Layer Color Overview, 357 
Layer Element Counts on Layers Table, 368 
Layer Name on Layers Table Overview, 352 
Layer Name on the Layers Toolbar, 354 
Layer Name Overview, 352 
Layer Number Conventions in Lavenir Software, 438 
Layer Number on Layer Toolbar, 350 
Layer Number on Layers Table, 350 
Layer Number Overview, 350 
Layer Stacking Examples for Vector Netlist Extraction, 432 
Layer Toolbar, 349 
Layer Type on Layers Table, 356 
Layer Type on the Layers Toolbar, 356 
Layer Type Overview, 355 
Layer Visibility on Layer Toolbar, 365 
Layer Visibility on Layers Table, 364 
Layer Visibility Overview, 88 
Layers Table Overview, 348 
Loaded Data on Layer Toolbar, 368 
Make a Range of Layers the Only Visible Layers, Command, 

89 
Make All Layers Visible on the Layers Table, 364 
Make All Layers Visible on the Layers Toolbar, 365 
Make All Layers Visible, Command, 89 
Make Any Single Layer Visible, Command, 88 
Make Layers Visible with Quick Keys, 89 
Make Next Layer Visible, Command, 88 
Make Previous Layer Visible, Command, 88 
Manually Select Single or Multiple Layers on the Layers 

Table, 369 
Move Active Layers, 164 
Move Chosen Layers, 165 
Move Layers by Displacement, 166 
Paint and Scratch Layers Overview, 367 
Paint and Scratch on Layers Table, 367 
Paint and Scratch on the Layers Toolbar, 367 
Photoplotting Multiple Layers on a Single Piece of Film, 72 
Positive and Negative Layers Overview, 366 
Positive and Negative on Layers Table, 366 
Positive and Negative on the Layers Toolbar, 366 
Query Element Properties, 103 
Raster Netlist Board Layer Stacking Examples, 418 
Rename Multiple Files Using Wildcards on Layers Table, 

352 
Replicate Layers Command, 170 
Replicate Layers on the Layers Table, 372 
Replicate Layers on the Layers Toolbar, 373 
Replicate Selected Elements, 136 
Select All Layers on the Layers Table, 369 
Select by Active Layer, 152 
Select Layers on Layers Table Overview, 369 
Select Loaded Layers on the Layers Table, 370 
Select None on the Layers Table, 369 

Selecting the Layers for the Fill Operation, 190 
Selecting the Layers for the Venting Operation, 208 
Swap Layers Command, 171 
Swap Layers on the Layers Table, 376 
Swap Layers on the Layers Toolbar, 377 
Toggle Display of the Path Portion of the Layer Name on 

Layers Table, 353 
Toggle Layer Visibility, Command, 89 
Toggle the Visibility of All Layers on the Layers Table, 364 
Toggle the Visibility of All Layers on the Layers Toolbar, 

365 
Toggle the Visiblity of a Single Layer on the Layers Table, 

364 
Toggle the Visiblity of a Single Layer on the Layers Toolbar, 

365 
Transfer Layers Command, 169 
Transfer Layers on the Layers Table, 374 
Transfer Layers on the Layers Toolbar, 375 
Transfer Selected Elements, 135 
Working with Layers Overview, 347 

Load a Macro, 444 
Load and Run a Macro, 443 
Location Marker Script, 482 

M 

M in a Square in the Viewing Area, 340 
Macro 

AutoPanel Script Overview, 455 
Browse the CAMMaster Automation Object Library, 454 
CAMMaster Automation Object Library, 452 
Drag and Drop a Macro into the System, 443 
Edit a Macro, 446 
Load a Macro, 444 
Load and Run a Macro, 443 
Location Marker Script, 482 
Macro Toolbar, 441 
Naming Convention Script, 477 
Padstack Selection Script, 483 
Pause Macro Recording, 442 
Property Strings, 453 
Record a Macro, 442 
Run a Macro, 445 
Save a Macro, 446 
Sax Basic Editor, 447 
Sax Basic Language, 448 
Scripting, Overview, 441 
Stop a Macro, 445 
Unload a Macro, 444 
Use a CAMMaster Automation Object in a Script, 452 
What is in Sax Basic but not in VBA, 450 
What is in VBA but not in Sax Basic, 448 

Main Toolbar, 21 
Maintenance Contract, Lavenir Technical Support, 19 
Mark 

Go To Marked Position, 106 
Mark a Location, 106 
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MDA Autoplot 
Append Files to MDA Autoplot Headers, 72 
Combine Paint & Scratch and Positive & Negative Layers in 

MDA Autoplot, 71 
Export MDA Autoplot from the Job, 68 
Import Gerber Extended and MDA Autoplot into the Job, 39 
MDA Export Options, 70 

Measurement 
Absolute Origin, 95 
Distance Measurement and Coordinate System Overview, 93 
Go To Marked Position, 106 
Mark a Location, 106 
Measure Distance, 93 
Polar Coordinates, 94 
Rectangular Coordinates, 94 
Relative Origin, 95 
Set Relative Origin, 96 

Memory Allocated for the Undo Feature, 176 
Merge Aperture Information into Job, 34 
Milestone File, 81 
Mirror Selected Elements, 137 
Mouse, Separate the Crosshair and Mouse Cursor, 112 
Move 

Align Layers, 167 
Center Selected Elements to the Frame, 134 
Move a Reference Frame, 181 
Move Active Layers, 164 
Move Chosen Layers, 165 
Move Layers by Displacement, 166 
Move Selected Elements, 133 

M-Type D Code 
Capture a Custom Aperture, 334 
Convert Elements of Custom Aperture D Codes to 

Primitives, 340 
Custom Aperture D Code, Description, 317 
Custom Aperture D Code, Overview, 334 
Export a Custom Aperture File, 336 
If You See an M in a Square in the Viewing Area, 340 
Import a Custom Aperture File into the D Code Table, 338 
Recreate Primitives Used in a Custom Aperture, 339 

N 

Name 
Browse the Directories for File Names on Layers Table, 352 
Enter a New Layer Name on Layers Table, 352 
Layer Name on Layers Table Overview, 352 
Layer Name on the Layers Toolbar, 354 
Layer Name Overview, 352 
Rename Multiple Files Using Wildcards on Layers Table, 

352 
Toggle Display of the Path Portion of the Layer Name on 

Layers Table, 353 
Naming Convention Script, 477 
NC Drill Data 

Change Tool Type and Tool Diameter on the Tool Table, 
343 

Number of Occurrences of each Tool Code in the Loaded 
Data, 342 

Select Tool Codes, 343 
Set Up Tool Codes In the D Code Table, 345 
Sort the Tool Code Table, 344 
Tool Code Table Overview, 341 
Tool Diameter, 342 
Tool Type, 342 
View Selected Element Drill Properties, 111 

NC Drill Hole D Code Type N, 318 
Negative VPI, Generating a Negative VPI Venting Pattern, 215 
Netlist 

Convert Netlist Format, 57 
Export Raster Netlist Files, 80 
Import Netlist Data into the Job, 55 
Inspect Netlist Comparison Discrepancies, 294 
Lavenir Format 0 Netlist (.F00), 427 
Lavenir Format 1 Netlist (.F01), 427 
Lavenir Format 2 Netlist (.F02), 427 
Lavenir Format 3 Netlist (.F03), 427 
Lavenir Format 4 Netlist (.F04), 427 
Layer Number Conventions in Lavenir Software, 438 
Layer Stacking Examples for Vector Netlist Extraction, 432 
Make Net Numbers in the NUT Match Net Numbers in the 

REF, 296 
Net Numbering Conventions in Lavenir Software, 438 
Netlist Comparison, Overview, 291 
Netlist Extraction Routines, 413 
Prepare Data for Netlist Comparison, 291 
Preparing Plot Data for Raster Netlist Extraction, 415 
Preparing Plot Data for Vector Netlist Extraction, 429 
Query Element Properties, 103 
Raster Netlist Board Layer Stacking Examples, 418 
Raster Netlist Extraction Advantages, 414 
Raster Netlist Extraction, Overview, 415 
Raster Tools Resolution, 425 
Raster vs. Vector Netlist Extraction Output, 413 
Raster vs. Vector Netlist Extraction Technique, 413 
Run the Netlist Comparison, 292 
Running the Raster Netlist Extraction, 422 
Running the Vector Netlist Extraction, 435 
Select by Current Net, 154 
Short Circuits in Raster Netlist Extraction, 426 
Types of Netlist Files and Reports Extracted by Vector 

Netlist, 427 
Vector Net Count Report (.REP), 428 
Vector Netlist Extraction Advantages, 414 
Vector Netlist Extraction Overview, 427 
Vector Netlist Gerber Reference Plot (.GNT), 428 
Vector Netlist Short Circuit Gerber Plot (.VGD), 428 
Vector Netlist Short Circuit Report (.SCT), 428 
Vector Netlist Split Plane Error Report (.SPT), 428 
View Netlist Data On Screen, 440 
View the Netlist Reports, 439 
View the Vector Netlist Gerber Reference Plot, 439 

New, Start a New Job, 22 
Next, Pan Screen to Next Screenful, 100 
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Non-Functional Pads, Deleting Non-Functional Pads, 245 
Non-Plated 

Change Tool Type and Tool Diameter on the Tool Table, 
343 

Tool Type, 342 
N-Type NC Drill Hole D Code, 318 
Number 

Layer Number Conventions in Lavenir Software, 438 
Layer Number on Layer Toolbar, 350 
Layer Number on Layers Table, 350 
Layer Number Overview, 350 

O 

Object 
Browse the CAMMaster Automation Object Library, 454 
CAMMaster Automation Object Library, 452 
Property Strings, 453 
Use a CAMMaster Automation Object in a Script, 452 

Obround D Code Type O, 318 
Octagon D Code Type E, 315 
One-up Image, Select and Edit One-Up Image of a Coded Step 

and Repeat Block, 149 
Open a Job File, 22 
Origin 

Absolute Origin, 95 
Distance Measurement and Coordinate System Overview, 93 
Pan Screen to Origin, 99 
Polar Coordinates, 94 
Rectangular Coordinates, 94 
Relative Origin, 95 
Set Relative Origin, 96 

Orthogonal 
Insert 90-Degree Elbow in Existing Trace, 121 
Insert 90-Degree Trace Pair, 119 
Insert Orthogonal Trace, 118 
Select by Special Class of Element, 155 

O-Type Obround D Code, 318 
Outline 

Generating Element Outlines, Differnece between Vector 
and Raster, 262 

Generating Element Outlines, Overview, 262 
Generating Element Outlines, Raster, 267 
Generating Element Outlines, Vector, 263 
Generating Outlines Only with the Fill Feature, 200 
View Zero-Width Elements, 87 

Overlap, Correcting Trace Overlap Problems, 298 

P 

Pad 
Correcting Trace Overlap Problems, 298 
Deleting Non-Functional Pads, 245 
Generating a Pad Venting Pattern, 211 
Insert Frame-Sized Pad, 123 
Insert Pad, 116 

Layer Element Counts on Layers Table, 368 
Pad and Trace Contrast, 87 
Query Element Properties, 103 
Select by Special Class of Element, 155 
Toggle Pad Visibility, 84 
Venting Around Pads and Traces, 210 
View Zero-Width Elements, 87 

Padmaster 
Clipping Silkscreen Traces for Padmaster Clearance, 253 
Snapping Data to the Padmaster, 249 

Padstack Selection Script, 483 
Paint and Scratch Data 

Combine Paint & Scratch and Positive & Negative Layers in 
Extended Gerber, 67 

Combine Paint & Scratch and Positive & Negative Layers in 
MDA Autoplot, 71 

Paint and Scratch Layers Overview, 367 
Paint and Scratch on Layers Table, 367 
Paint and Scratch on the Layers Toolbar, 367 

Pan 
Center View on Cursor, 100 
Pan Screen Automatically at Viewing Area Edges, 98 
Pan Screen to Center, 99 
Pan Screen to First Screenful, 99 
Pan Screen to Next Screenful, 100 
Pan Screen to Origin, 99 
Pan Screen Up/Down/Left/Right, 98 
Scroll the Screen, 97 

Panelization, AutoPanel Script Overview, 455 
Path 

Browse the Directories for File Names on Layers Table, 352 
Toggle Display of the Path Portion of the Layer Name on 

Layers Table, 353 
Pause Macro Recording, 442 
Phone Number 

Lavenir Technical Support, 19 
Send Us Your Comments, 18 

Photoplotting Multiple Layers on a Single Piece of Film, 72 
Planes, Vector Netlist Split Plane Error Report (.SPT), 428 
Plated 

Change Tool Type and Tool Diameter on the Tool Table, 
343 

Tool Type, 342 
Polar Coordinates 

Distance Measurement and Coordinate System Overview, 93 
Measure Distance, 93 
Polar Coordinates, 94 

Polygon 
Defining the Polygon Areas for Filling, 186 
Defining the Polygon Areas for Venting, 204 
Drawing Fill Polygons with Traces, 187 
Drawing Venting Polygons with Traces, 204 
Generate Contour Polygon from Exisitng Trace Contours, 

303 
Generating Element Outlines, Differnece between Vector 

and Raster, 262 
Generating Element Outlines, Overview, 262 



 Index 

 509 

Generating Element Outlines, Raster, 267 
Generating Element Outlines, Vector, 263 
Insert Drawn Rectangle, 122 
Insert Frame-Sized Rectangular Polygon, 123 
Nested Polygons for Filling, 186 
Nested Polygons for Venting, 204 
Polygon Filling, Overview, 186 
Setting the Polygon Options for the Fill Operation, 188 
Setting the Polygon Options for the Venting Operation, 206 
Using the Reference Frame as a Boundary for a Fill, 186 
Using the Reference Frame as a Boundary for a Venting 

Area, 204 
Polygon Trace D Code Type F, 316 
Positive and Negative Data 

Combine Paint & Scratch and Positive & Negative Layers in 
Extended Gerber, 67 

Combine Paint & Scratch and Positive & Negative Layers in 
MDA Autoplot, 71 

Positive and Negative Layers Overview, 366 
Positive and Negative on Layers Table, 366 
Positive and Negative on the Layers Toolbar, 366 

Positive VPI, Generating a Positive VPI Venting Pattern, 213 
Power Planes, Vector Netlist Split Plane Error Report (.SPT), 

428 
Primitives 

Convert Elements of Custom Aperture D Codes to 
Primitives, 340 

Recreate Primitives Used in a Custom Aperture, 339 
Print 

If you get a Black Rectangle, 381 
Previewing a Print, 380 
Printing a Plot, 379 

Problems, Lavenir Technical Support, 19 
Properties 

Generate a Report File, 384 
Layer Element Counts on Layers Table, 368 
Number of Occurrences of each Tool Code in the Loaded 

Data, 342 
Query Element Properties, 103 
Report File Overview, 383 
View a Report File, 384 
View Selected Element D Code Properties, 110 
View Selected Element Drill Properties, 111 
View Selected Element Properties, 110 

Property Strings, 453 
Proximity, Sort by Proximity, 185 

Q 

Q-Type Rounded Rectangle D Code, 319 
Quadrant Arcs, Convert 360-Degree Arcs into Quadrants, 185 

R 

Raster DRC 
Design Rule Checking Routines Overview, 385 

Preparing Plot Data for the Raster Design Rule Check, 387 
Raster Design Rule Checking, Overview, 386 
Raster DRC Advantages, 386 
Raster Tools Resolution, 425 
Raster vs. Vector DRC Error Inspection Method, 385 
Raster vs. Vector DRC Technique, 385 
Running the Raster Design Rule Check, 389 
Vector DRC Advantages, 386 
Viewing Raster DRC Errors on Screen, 396 

Raster Netlist 
Export Raster Netlist Files, 80 
Layer Number Conventions in Lavenir Software, 438 
Net Numbering Conventions in Lavenir Software, 438 
Netlist Extraction Routines, 413 
Preparing Plot Data for Raster Netlist Extraction, 415 
Raster Netlist Board Layer Stacking Examples, 418 
Raster Netlist Extraction Advantages, 414 
Raster Netlist Extraction, Overview, 415 
Raster Tools Resolution, 425 
Raster vs. Vector Netlist Extraction Output, 413 
Raster vs. Vector Netlist Extraction Technique, 413 
Running the Raster Netlist Extraction, 422 
Short Circuits in Raster Netlist Extraction, 426 
Vector Netlist Extraction Advantages, 414 
View Netlist Data On Screen, 440 
View the Netlist Reports, 439 

Record a Macro, 442 
Rectangle 

Insert Drawn Rectangle, 122 
Insert Frame-Sized Rectangular Polygon, 123 

Rectangle D Code Type R, 319 
Rectangular Coordinates 

Distance Measurement and Coordinate System Overview, 93 
Rectangular Coordinates, 94 

Reference Frame 
Center Layers to Frame, 168 
Center Selected Elements to the Frame, 134 
Draw a New Reference Frame, 177 
Go To Reference Frame Corners, 105 
Insert a Reference Frame Around All Data, 180 
Insert a Reference Frame Around Workspace, 179 
Insert Frame-Sized Pad, 123 
Insert Frame-Sized Rectangular Polygon, 123 
Move a Reference Frame, 181 
Reference Frame Overview, 177 
Resize a Reference Frame, 181 
Set Exact Reference Frame Corners, 178 
Using the Reference Frame as a Boundary for a Fill, 186 
Using the Reference Frame as a Boundary for a Venting 

Area, 204 
Zoom On Reference Frame, 92 

Refresh Screen, 113 
Relative Origin 

Distance Measurement and Coordinate System Overview, 93 
Measure Distance, 93 
Relative Origin, 95 
Set Relative Origin, 96 
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Remove from a Selection, 162 
Replicate 

Replicate Layers Command, 170 
Replicate Layers on the Layers Table, 372 
Replicate Layers on the Layers Toolbar, 373 
Replicate Selected Elements, 136 

Report 
Generate a Report File, 384 
Generating the Distance Histogram Report, 409 
Report File Overview, 383 
Vector Net Count Report (.REP), 428 
View a Report File, 384 
View the Design Rule Check Error Report, 412 
View the Netlist Reports, 439 

Resolution, Raster Tools Resolution, 425 
Revert to a Saved Job File, 26 
Rotate 

Rotate D Codes on the D Code Table 90 Degrees, 329 
Rotate D Codes on the D Code Table, Overview, 329 
Rotate Selected Elements, 138 

Round D Code Type C, 315 
Round Off D Code Dimensions on the D Code Table, 333 
Rounded Rectangle D Code Type Q, 319 
R-Type Rectangle D Code, 319 
Run a Macro, 445 

S 

Sample Scripts 
Location Marker Script, 482 
Naming Convention Script, 477 
Padstack Selection Script, 483 

Save 
Milestone File, 81 
Revert to a Saved Job File, 26 
Save a Copy of a Job File, 25 
Save a Macro, 446 
Save a New Unnamed Job File, 23 
Save Drawn Pads Library Parameter Files, 240 
Save Shape Files, 238 
Save Work in Progress, 24 

Sax Basic 
AutoPanel Script Overview, 455 
Browse the CAMMaster Automation Object Library, 454 
CAMMaster Automation Object Library, 452 
Drag and Drop a Macro into the System, 443 
Edit a Macro, 446 
Load a Macro, 444 
Load and Run a Macro, 443 
Location Marker Script, 482 
Macro Toolbar, 441 
Naming Convention Script, 477 
Padstack Selection Script, 483 
Pause Macro Recording, 442 
Property Strings, 453 
Record a Macro, 442 
Run a Macro, 445 

Save a Macro, 446 
Sax Basic Editor, 447 
Sax Basic Language, 448 
Scripting, Overview, 441 
Stop a Macro, 445 
Unload a Macro, 444 
Use a CAMMaster Automation Object in a Script, 452 
What is in Sax Basic but not in VBA, 450 

Scale 
Scale D Code Area on the D Code Table, 333 
Scale D Code Dimensions on the D Code Table, 332 
Scale Selected Elements, 140 

Screen Grid 
Anchored or Dragged Grid, 108 
Fixed or Variable Grid, 109 
Grid Units, 109 
Screen Grid Overview, 107 
Turn the Screen Grid On and Off, 107 

Screen View Toolbar, 83 
Scripting 

AutoPanel Script Overview, 455 
Browse the CAMMaster Automation Object Library, 454 
CAMMaster Automation Object Library, 452 
Drag and Drop a Macro into the System, 443 
Edit a Macro, 446 
Load a Macro, 444 
Load and Run a Macro, 443 
Location Marker Script, 482 
Macro Toolbar, 441 
Naming Convention Script, 477 
Padstack Selection Script, 483 
Pause Macro Recording, 442 
Property Strings, 453 
Record a Macro, 442 
Run a Macro, 445 
Save a Macro, 446 
Sax Basic Editor, 447 
Sax Basic Language, 448 
Scripting, Overview, 441 
Stop a Macro, 445 
Unload a Macro, 444 
Use a CAMMaster Automation Object in a Script, 452 
What is in Sax Basic but not in VBA, 450 
What is in VBA but not in Sax Basic, 448 

Scroll 
Scroll the Screen, 97 
Set the Workspace Dimensions, 97 

Selection 
Add to a Selection, 161 
Clear the Selection, 163 
Current Element Toolbar, 151 
Edit Selected Data, Overview, 132 
Invert the Selection, 163 
Remove from a Selection, 162 
Select a Chain of Traces, 159 
Select a Group of Elements, 157 
Select a Single Element, 156 
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Select All Data, 158 
Select and Edit Entire Array of a Coded Step and Repeat 

Block, 160 
Select and Edit One-Up Image of a Coded Step and Repeat 

Block, 149 
Select by Active Layer, 152 
Select by Current D Code, 153 
Select by Current Net, 154 
Select by Special Class of Element, 155 
Select D Codes on the D Code Table, Overview, 323 
Select Elements for Editing Overview, 150 
Select Globally from the Entire Database, 158 
Selection Toolbar, 150 
Toggle Selected Element Visibility, 85 
Toggle Unselected Element Visibility, 85 
View Selected Element D Code Properties, 110 
View Selected Element Drill Properties, 111 
View Selected Element Properties, 110 
View Selected Elements in White or Contrasting Color, 86 

Separate the Crosshair and Mouse Cursor, 112 
Shape Files 

Import Shape Files, 239 
Save Shape Files, 238 
Shape Files, Overview, 238 

Short Circuit 
Short Circuits in Raster Netlist Extraction, 426 
Vector Netlist Short Circuit Gerber Plot (.VGD), 428 
Vector Netlist Short Circuit Report (.SCT), 428 

Silkscreen, Clipping Silkscreen Traces for Padmaster Clearance, 
253 

Size, Change Tool Type and Tool Diameter on the Tool Table, 
343 

Slot, Excellon Drilled Slot Pattern, 78 
Snap 

Align Cursor to Element, 102 
Snap Selected Elements to the Grid, 142 
Snapping Data to the Padmaster, 249 

Snowman Filleting 
Generate Pad Filleting, 270 
Snowman Fillet Options, 274 

Software 
CAMMaster Overview, 16 
Download Software Updates, 18 
Lavenir CAM Software Feature Comparison, 11 
ViewMaster Overview, 12 
ViewMaster PRO Overview, 15 
ViewMate Overview, 12 

Soldermask 
Consolidate Soldermask Data, 308 
Generating a Soldermask Layer, 257 

Solid 
Generating a Solid Fill, 194 
Generating a Solid Venting Pattern, 219 

Sort 
Sort by Proximity, 185 
Sort the Tool Code Table, 344 

Split Planes, Vector Netlist Split Plane Error Report (.SPT), 428 

Square D Code Type S, 319 
Stackup 

Layer Stacking Examples for Vector Netlist Extraction, 432 
Raster Netlist Board Layer Stacking Examples, 418 

Starburst, Generating a Starburst Venting Pattern, 217 
Start a New Job, 22 
Step and Repeat 

AutoPanel Script Overview, 455 
Change Step and Repeat Parameters of a Coded Step and 

Repeat Block, 147 
Convert Coded Step and Repeat Blocks to Copied Step and 

Repeat Data, 146 
Differences Between Coded Step and Repeat and Copied 

Step and Repeat, 143 
Select and Edit Entire Array of a Coded Step and Repeat 

Block, 160 
Select and Edit One-Up Image of a Coded Step and Repeat 

Block, 149 
Step and Repeat Selected Elements, 144 
Step and Repeat Selected Elements, Overview, 143 

Stop a Macro, 445 
Stretch Traces, 174 
S-Type Square D Code, 319 
Support, Lavenir Technical Support, 19 
Swap 

Swap Layers Command, 171 
Swap Layers on the Layers Table, 376 
Swap Layers on the Layers Toolbar, 377 

Swell D Code on the D Code Table, 330 

T 

Table 
D Code Table Overview, 313 
Layers Table Overview, 348 
Tool Code Table Overview, 341 

Target D Code Type T, 320 
Teardrop Filleting 

Generate Pad Filleting, 270 
Teardrop Fillet Options, 279 

Technical Support, 19 
Text, Insert Text, 130 
Thermal D Code Type H, 316 
Thieving 

Defining the Polygon Areas for Venting, 204 
Drawing Venting Polygons with Traces, 204 
Generating a Crosshatch Venting Pattern, 224 
Generating a Hatch Venting Pattern, 221 
Generating a Negative VPI Venting Pattern, 215 
Generating a Pad Venting Pattern, 211 
Generating a Positive VPI Venting Pattern, 213 
Generating a Solid Venting Pattern, 219 
Generating a Starburst Venting Pattern, 217 
Nested Polygons for Venting, 204 
Selecting the Layers for the Venting Operation, 208 
Setting the Polygon Options for the Venting Operation, 206 
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Using the Reference Frame as a Boundary for a Venting 
Area, 204 

Venting Around Pads and Traces, 210 
Venting Pattern, Overview, 204 

Tool Code 
Change Tool Type and Tool Diameter on the Tool Table, 

343 
Number of Occurrences of each Tool Code in the Loaded 

Data, 342 
Select Tool Codes, 343 
Set Up Tool Codes In the D Code Table, 345 
Sort the Tool Code Table, 344 
Tool Code Table Overview, 341 
Tool Diameter, 342 
Tool Type, 342 

Toolbar 
Current Element Toolbar, 151 
Edit Toolbar, 132 
Insert Toolbar, 115 
Layer Toolbar, 349 
Macro Toolbar, 441 
Main Toolbar, 21 
Screen View Toolbar, 83 
Selection Toolbar, 150 
Visibility Toolbar, 83 

Tooling Hole 
Change Tool Type and Tool Diameter on the Tool Table, 

343 
Tool Type, 342 

Trace 
Break Traces, 172 
Break Traces and Replace with a Pad, 173 
Clip Traces, 172 
Clip Traces and Replace with a Pad, 173 
Clipping Silkscreen Traces for Padmaster Clearance, 253 
Correcting Trace Overlap Problems, 298 
Go To Endpoint of Trace, 104 
Insert 90-Degree Trace Pair, 119 
Insert Elbow in Existing Trace, 120 
Insert Orthogonal Trace, 118 
Insert Trace, 117 
Layer Element Counts on Layers Table, 368 
Pad and Trace Contrast, 87 
Query Element Properties, 103 
Select a Chain of Traces, 159 
Select by Special Class of Element, 155 
Stretch Traces, 174 
Toggle Trace Visibility, 84 
Venting Around Pads and Traces, 210 
View Zero-Width Elements, 87 

Transcode 
Transcode D Codes on the D Code Table, Overview, 327 
Transcode Elements of the Selected D Code on the D Code 

Table, 327 
Transcode Selected Elements, 141 
Transcode to Unique Shapes on the D Code Table, 328 

Transfer 

Transfer Layers Command, 169 
Transfer Layers on the Layers Table, 374 
Transfer Layers on the Layers Toolbar, 375 
Transfer Selected Elements, 135 

Troubleshooting, Lavenir Technical Support, 19 
T-Type Target D Code, 320 
Type 

Change Tool Type and Tool Diameter on the Tool Table, 
343 

Tool Type, 342 

U 

Undefined D Code Type ?, 320 
Undo 

Clear the Selection, 163 
Memory Allocated for the Undo Feature, 176 
Milestone File, 81 
Revert to a Saved Job File, 26 
Undo an Editing Action, 176 

Unique Shapes on the D Code Table, 328 
Unload a Macro, 444 
Update, Download Software Updates, 18 

V 

Variable, Fixed or Variable Grid, 109 
VBA 

AutoPanel Script Overview, 455 
Browse the CAMMaster Automation Object Library, 454 
CAMMaster Automation Object Library, 452 
Drag and Drop a Macro into the System, 443 
Edit a Macro, 446 
Load a Macro, 444 
Load and Run a Macro, 443 
Location Marker Script, 482 
Macro Toolbar, 441 
Naming Convention Script, 477 
Padstack Selection Script, 483 
Pause Macro Recording, 442 
Property Strings, 453 
Record a Macro, 442 
Run a Macro, 445 
Save a Macro, 446 
Sax Basic Editor, 447 
Sax Basic Language, 448 
Scripting, Overview, 441 
Stop a Macro, 445 
Unload a Macro, 444 
Use a CAMMaster Automation Object in a Script, 452 
What is in Sax Basic but not in VBA, 450 
What is in VBA but not in Sax Basic, 448 

Vector DRC 
Design Rule Checking Routines Overview, 385 
Distance Histogram Overview, 409 
Generating the Distance Histogram Report, 409 
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Preparing Plot Data for the Vector Design Rule Check, 399 
Raster DRC Advantages, 386 
Raster vs. Vector DRC Error Inspection Method, 385 
Raster vs. Vector DRC Technique, 385 
Removing Vector Design Rule Check Errors Flags from the 

Plot, 408 
Running the Vector Design Rule Check, 401 
Vector Design Rule Checking Overview, 399 
Vector DRC Advantages, 386 
View the Design Rule Check Error Report, 412 
View Vector Design Rule Check Errors on Screen, 407 

Vector Netlist 
Layer Number Conventions in Lavenir Software, 438 
Layer Stacking Examples for Vector Netlist Extraction, 432 
Net Numbering Conventions in Lavenir Software, 438 
Netlist Extraction Routines, 413 
Preparing Plot Data for Vector Netlist Extraction, 429 
Raster Netlist Extraction Advantages, 414 
Raster vs. Vector Netlist Extraction Output, 413 
Raster vs. Vector Netlist Extraction Technique, 413 
Running the Vector Netlist Extraction, 435 
Types of Netlist Files and Reports Extracted by Vector 

Netlist, 427 
Vector Net Count Report (.REP), 428 
Vector Netlist Extraction Advantages, 414 
Vector Netlist Extraction Overview, 427 
Vector Netlist Gerber Reference Plot (.GNT), 428 
Vector Netlist Short Circuit Gerber Plot (.VGD), 428 
Vector Netlist Short Circuit Report (.SCT), 428 
Vector Netlist Split Plane Error Report (.SPT), 428 
View Netlist Data On Screen, 440 
View the Netlist Reports, 439 
View the Vector Netlist Gerber Reference Plot, 439 

Venting 
Defining the Polygon Areas for Venting, 204 
Drawing Venting Polygons with Traces, 204 
Generating a Crosshatch Venting Pattern, 224 
Generating a Hatch Venting Pattern, 221 
Generating a Negative VPI Venting Pattern, 215 
Generating a Pad Venting Pattern, 211 
Generating a Positive VPI Venting Pattern, 213 
Generating a Solid Venting Pattern, 219 
Generating a Starburst Venting Pattern, 217 
Nested Polygons for Venting, 204 
Selecting the Layers for the Venting Operation, 208 
Setting the Polygon Options for the Venting Operation, 206 
Using the Reference Frame as a Boundary for a Venting 

Area, 204 
Venting Around Pads and Traces, 210 
Venting Pattern, Overview, 204 

Via 
Change Tool Type and Tool Diameter on the Tool Table, 

343 
Tool Type, 342 

View 
Align Cursor to Element, 102 
Center View on Cursor, 100 

Layer Visibility on Layer Toolbar, 365 
Layer Visibility on Layers Table, 364 
Layer Visibility Overview, 88 
Make a Range of Layers the Only Visible Layers, Command, 

89 
Make All Layers Visible on the Layers Table, 364 
Make All Layers Visible on the Layers Toolbar, 365 
Make All Layers Visible, Command, 89 
Make Any Single Layer Visible, Command, 88 
Make Layers Visible with Quick Keys, 89 
Make Next Layer Visible, Command, 88 
Make Previous Layer Visible, Command, 88 
Pad and Trace Contrast, 87 
Pan Screen Automatically at Viewing Area Edges, 98 
Pan Screen to Center, 99 
Pan Screen to First Screenful, 99 
Pan Screen to Next Screenful, 100 
Pan Screen to Origin, 99 
Pan Screen Up/Down/Left/Right, 98 
Query Element Properties, 103 
Refresh Screen, 113 
Screen View Toolbar, 83 
Scroll the Screen, 97 
Toggle Layer Visibility, Command, 89 
Toggle Pad Visibility, 84 
Toggle Selected Element Visibility, 85 
Toggle the Visibility of All Layers on the Layers Table, 364 
Toggle the Visibility of All Layers on the Layers Toolbar, 

365 
Toggle the Visiblity of a Single Layer on the Layers Table, 

364 
Toggle the Visiblity of a Single Layer on the Layers Toolbar, 

365 
Toggle Trace Visibility, 84 
Toggle Unselected Element Visibility, 85 
View a Report File, 384 
View Data, Overview, 83 
View Netlist Data On Screen, 440 
View Raster DRC Errors on Screen, 396 
View Selected Element D Code Properties, 110 
View Selected Element Drill Properties, 111 
View Selected Element Properties, 110 
View Selected Elements in White or Contrasting Color, 86 
View the Design Rule Check Error Report, 412 
View the Netlist Reports, 439 
View the Vector Netlist Gerber Reference Plot, 439 
View Vector Design Rule Check Errors on Screen, 407 
View Zero-Width Elements, 87 
Visibility Toolbar, 83 
Zoom Level, Overview, 90 
Zoom On Reference Frame, 92 
Zoom To Exact Zoom Level, 92 
Zoom To Show All Data, 91 
Zoom Tool, 90 
Zoom Up or Down, 91 

ViewMaster Overview, 12 
ViewMaster PRO Overview, 15 
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ViewMate Overview, 12 
Visibility Toolbar, 83 
Visual Basic 

AutoPanel Script Overview, 455 
Browse the CAMMaster Automation Object Library, 454 
CAMMaster Automation Object Library, 452 
Drag and Drop a Macro into the System, 443 
Edit a Macro, 446 
Load a Macro, 444 
Load and Run a Macro, 443 
Location Marker Script, 482 
Macro Toolbar, 441 
Naming Convention Script, 477 
Padstack Selection Script, 483 
Pause Macro Recording, 442 
Property Strings, 453 
Record a Macro, 442 
Run a Macro, 445 
Save a Macro, 446 
Sax Basic Editor, 447 
Sax Basic Language, 448 
Scripting, Overview, 441 
Stop a Macro, 445 
Unload a Macro, 444 
Use a CAMMaster Automation Object in a Script, 452 
What is in Sax Basic but not in VBA, 450 
What is in VBA but not in Sax Basic, 448 

VPI 
Generating a Negative VPI Venting Pattern, 215 
Generating a Positive VPI Venting Pattern, 213 

W 

Warrantee, Lavenir Technical Support, 19 
Web Site 

Download Software Updates, 18 
Lavenir Technical Support, 19 
Send Us Your Comments, 18 

Wildcards, Rename Multiple Files Using Wildcards on Layers 
Table, 352 

Window 
Center Layers to Frame, 168 
Center Selected Elements to the Frame, 134 
Draw a New Reference Frame, 177 
Go To Reference Frame Corners, 105 
Insert a Reference Frame Around All Data, 180 
Insert a Reference Frame Around Workspace, 179 
Insert Frame-Sized Pad, 123 
Insert Frame-Sized Rectangular Polygon, 123 
Move a Reference Frame, 181 
Reference Frame Overview, 177 
Resize a Reference Frame, 181 
Set Exact Reference Frame Corners, 178 
Zoom On Reference Frame, 92 

Wizard, Use the Aperture File Wizard, 45 
Workspace 

Insert a Reference Frame Around Workspace, 179 

Scroll the Screen, 97 
Set the Workspace Dimensions, 97 

X 

X-Type Drawn Obround D Code, 321 
XY Coordinates 

Distance Measurement and Coordinate System Overview, 93 
Rectangular Coordinates, 94 

Y 

Y-Type Drawn Crosshair D Code, 322 

Z 

Zero Width, View Zero-Width Elements, 87 
Zoom 

Zoom Level, Overview, 90 
Zoom On Reference Frame, 92 
Zoom To Exact Zoom Level, 92 
Zoom To Show All Data, 91 
Zoom Tool, 90 
Zoom Up or Down, 91 

 


